16:01:14 <schwicke> #startmeeting hierarchical_multitenancy
16:01:15 <openstack> Meeting started Fri Sep 26 16:01:14 2014 UTC and is due to finish in 60 minutes.  The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:19 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:01:23 <schwicke> so let's go
16:01:44 <schwicke> First of all: I'm sorry that I apparently mis-named the meeting last week:(
16:02:03 <schwicke> somehow an additional _ ended up at the end of the meeting name
16:03:04 <schwicke> #topic: test installation on the VM
16:03:45 <VINOD_> The quota code has been successfully put up in the VM provided by Raildo with his Hierarchical Multitenancy keystone code
16:03:48 <schwicke> Sajeesh sent me an e-mail as he cannot connect today
16:04:01 <VINOD_> and also preliminary tests were successful.
16:04:10 <schwicke> "Regarding the integration of nova and keystone,it is successful.Both are communicating.I will do a detailed testing in the weekend,and will send you the report."
16:04:24 <VINOD_> I and sajeesh will check with more complex example of project hierarchy
16:04:51 <schwicke> great!
16:05:23 <schwicke> I also went through some user stories with Nirupma to be tested
16:05:28 <VINOD_> The only change we could see is that, i think Raildo has changed the parent project id attribute in the keystone as "parent_id" (earlier it was parent_project_id)
16:05:43 <schwicke> ok
16:06:27 <schwicke> Hi, Nirupma
16:06:29 <VINOD_> Also, the nova specs is still not opened for Kilo
16:06:34 <nirupma> hello
16:06:50 <VINOD_> so as agreed, the quota blueprint will be uploaded to Kilo as soon as it opens
16:06:52 <schwicke> nirupma: did you manage to go through some user stories as we discussed ?
16:07:06 <schwicke> Vinod: I'll come back to that in a moment
16:07:13 <VINOD_> schwicke: o
16:07:19 <VINOD_> schwicke: ok
16:07:26 <nirupma> the dashboard has been changed
16:07:36 <schwicke> ok
16:07:40 <nirupma> i am not able to login to the m/c
16:07:44 <schwicke> haven't check in the last 2 days.
16:07:54 <nirupma> it now has an extra feild for domain name
16:07:59 <nirupma> which is compulsary
16:08:56 <VINOD_> nirupma: i didn't get you..could you please tell me about the problem
16:09:22 <nirupma> thiago's m/c's dashboard has changed
16:09:36 <nirupma> earlier it was just user name and password
16:09:41 <VINOD_> nirupma: ok..i got you..i had check it now
16:09:53 <nirupma> now it has an added field for domain name which is compulsary
16:10:29 <schwicke> ok
16:10:36 <VINOD_> ok
16:10:53 <nirupma> i assume that he is testing some new code
16:11:34 <schwicke> Thiago does not seem to be connected, is he ?
16:12:08 <VINOD_> schwicke: I also think that he is not connected (and neither raildo)
16:13:05 <schwicke> Nirumpa: contact him by e-mail
16:13:10 <nirupma> ok
16:13:15 <nirupma> mailing him now
16:13:36 <schwicke> #action: Nirupma will ask Thiago about the changed horizon interface
16:13:52 <schwicke> #topic Horizon dashboard feedback
16:14:10 <schwicke> I had sent a bit of feedback for the GUI during the week.
16:14:20 <schwicke> was hoping we could discuss today.
16:14:30 <schwicke> I was thinking of ways on how to implement the delegation stuff
16:15:04 <schwicke> I think that part is easy: when editing a project there could be another tab which defines the list of admin users
16:15:17 <schwicke> in the same way as there is now a tab to define the users
16:15:30 <schwicke> The more tricky bit is setting quota
16:16:33 <schwicke> Not sure how this works. If you login to horizon, and you are member of several projects, I suspect you first only get an unscoped token. Is that assumption correct ?
16:17:09 <schwicke> The tricky bit is that when you select a project you authenticate to that.
16:17:53 <VINOD_> schwicke: I am not sure on this..but...i also think the same way
16:18:00 <schwicke> At that point we'd need dialog showing the children you own along with their quotas
16:18:42 <schwicke> thiagop: is that assumption correct ?
16:19:12 <VINOD_> probably, it can first the quota for that project in detail (like available, allocated etc)
16:19:27 <VINOD_> and by expanding it, then it can show the quota details of its child projects
16:19:56 <schwicke> which requires some calls to the nova api
16:20:38 <schwicke> we should check that offline with Thiago
16:20:51 <VINOD_> yes, nova for quota and keystone for child projects list
16:21:35 <VINOD_> For some reason (unknown), the login to the VM has also been stopped
16:22:16 <schwicke> you mean via ssh ?
16:22:24 <VINOD_> yes
16:23:07 <VINOD_> A wild guess, may be to solve "shellshock bash" bug
16:23:21 <schwicke> I was thinking the same way
16:23:30 <VINOD_> yesterday it was working...now its not allowing
16:24:00 <schwicke> we should come back to the clients
16:24:18 <schwicke> Sajeesh says, not much has been done yet with python-openstackclient
16:24:24 <VINOD_> yes
16:24:34 <schwicke> #topic nova client support
16:24:54 <VINOD_> he believes that the python-openstackclient may not require changes with respect to the quota code...as the API's will remain same
16:24:56 <schwicke> he mentions that he has some doubts
16:25:05 <VINOD_> but yet to be checked to be more sure
16:25:10 <schwicke> that's good news
16:25:45 <schwicke> did you manage to test python-novalclient on the VM with the quota code ?
16:25:56 <VINOD_> not yet...
16:26:18 <VINOD_> yesterday, i could complete the integration and tested few commands..
16:26:27 <schwicke> #action Vinod or Sajeesh should test nova clients with quota code
16:26:43 <schwicke> ok, that's a very good start
16:26:45 <VINOD_> i thought of testing it today...but i could see now that the login to the VM is not working
16:27:10 <VINOD_> i mean testing the command with more complex examples today..
16:27:54 <schwicke> ok
16:28:06 <schwicke> I just sent a mail to Thiago about the login issues
16:28:48 <schwicke> not much we can do now. Let's wait for them
16:28:54 <schwicke> Let'
16:28:57 <VINOD_> +1
16:28:59 <schwicke> Let's move on
16:29:09 <schwicke> #topic KILO
16:29:44 <schwicke> first thing to note is that the keystone code will only be in KILO as well
16:29:52 <schwicke> as I understand it
16:29:57 <morganfainberg> schwicke, correct
16:30:37 <schwicke> hmm ... too bad
16:30:59 <schwicke> for the submissions for nova: something seems to be happening
16:31:04 <schwicke> #link https://blueprints.launchpad.net/nova/kilo
16:31:39 <schwicke> there is a link to register a new blueprint
16:32:26 <schwicke> I'd be able to submit a blue print it seems
16:33:13 <schwicke> vinod: can you check ?
16:33:22 <VINOD_> yes, i am checking...but it is just with launchpad
16:33:39 <schwicke> and I see there are already 3
16:33:57 <VINOD_> In juno i cam to know that, in addition to launch pad, the blueprint has to be submitted to gerrit as well..to nova-specs
16:34:49 <schwicke> Please register it in launch pad already
16:35:00 <VINOD_> may be launch pad is open to submit for blueprint in kilo, but yet to open for nova-specs...it seems vishy is online..
16:35:05 <VINOD_> vishy: can you comment on this?
16:35:43 <VINOD_> schwicke: I will dol the blueprint registration for quota code in launchpad
16:35:57 <schwicke> great!
16:36:22 <schwicke> #action Vinod will register the hierarchical projects nova parts in launchpad
16:36:31 <VINOD_> I think vishy is busy
16:36:52 <schwicke> I also see raildo online but he's apparently busy as well
16:37:05 <schwicke> Thiago as well
16:37:10 <VINOD_> yes
16:38:21 <schwicke> #link https://blueprints.launchpad.net/keystone/kilo
16:38:25 <schwicke> same thing it seems
16:38:51 <VINOD_> ok
16:39:16 <schwicke> seems that for keystone nothing has been submitted so far
16:39:40 <VINOD_> the keystone-specs link of keystone for Kilo is open..
16:39:47 <VINOD_> #link https://github.com/openstack/keystone-specs/tree/master/specs
16:40:08 <VINOD_> so i guess keystone is already allowing the blueprints through launchpad as well as through keystone-specs
16:40:10 <morganfainberg> VINOD_, those were re-targeted specs mostly
16:40:20 <VINOD_> morganfainberg: ok
16:40:24 <morganfainberg> VINOD_, ones we knew were falling to kilo
16:40:37 <morganfainberg> VINOD_, feel free to submit a spec to kilo though
16:40:49 <morganfainberg> we may not approve it till we get RC1 juno cut though.
16:40:57 <morganfainberg> but no harm in proposing it
16:41:10 <morganfainberg> even if it's just retargeting the current spec to kilo
16:41:12 <VINOD_> morganfainberg: We have the blueprint for nova...as we are doing the nova quota stuff.
16:41:19 <morganfainberg> for keystone that is.
16:41:39 <VINOD_> morganfainberg: Thanks
16:42:17 <schwicke> thanks for the info!
16:42:21 <VINOD_> schwicke: So, i guess we need to wait a little bit for blueprint upload to nova-specs...but any way i will do it on launchpad
16:42:54 <schwicke> yes, let's keep an eye on it when it opens
16:43:06 <VINOD_> ok
16:43:42 <schwicke> anything else we need to discuss today ?
16:43:51 <schwicke> #topic AOB
16:44:04 <VINOD_> schwicke: Any thing on the topics for summit?
16:44:11 <VINOD_> otherwise nothing more from my side
16:44:26 <schwicke> nothing special from my side.
16:44:38 <VINOD_> ok
16:44:43 <schwicke> Nirupma is preparing herself
16:44:48 <VINOD_> ok
16:44:50 <schwicke> as she'll represent us
16:45:04 <schwicke> a pity I can't go as well :'(
16:45:29 <VINOD_> Next week, both Sajeesh and myself will not be available for the meeting...as its a long weekend holiday here...and we are on holiday
16:45:31 <nirupma> i've prepared a tentative list of lectures that might be interesting. I'll mail it by tonight.
16:45:45 <VINOD_> but before that we will complete the testing and send you the report
16:45:49 <VINOD_> ok
16:45:56 <nirupma> We can refine it further later
16:45:57 <VINOD_> nirupma: ok
16:46:36 <VINOD_> schwicke: Is bemiro going for the summit?
16:46:55 <schwicke> I think so
16:47:07 <VINOD_> great!!
16:47:27 <schwicke> Tim will be definitely there as well, and some other people from the cloud operations team.
16:48:12 <schwicke> for the summit details we can also discuss on Wednesday in our phone meeting.
16:48:22 <VINOD_> ok
16:48:23 <schwicke> so for today we can close early I think :)
16:48:30 <schwicke> #endmeeting