16:05:07 <raildo> #startmeeting Hierarchical Multitenancy
16:05:07 <thiagop> it's been a while
16:05:07 <openstack> Meeting started Fri Oct 10 16:05:07 2014 UTC and is due to finish in 60 minutes.  The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:08 <nirupma> hi thiago
16:05:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:12 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:05:19 <raildo> #topic quota management
16:06:03 <raildo> sajeesh, maybe you can lead this point?
16:06:10 <sajeesh> ok...
16:06:36 <sajeesh> raildo,I think there was a discussion on moving quota management to keystone...
16:06:45 <sajeesh> can you please eloborate it
16:08:40 <sajeesh> I am telling about the mail that you have forwarded to us
16:09:04 <raildo> I still do not know everything about it, but I believe the proposal is send the quotas implementation for the Keystone or a new service
16:09:20 <sajeesh> ok
16:09:31 <raildo> I saw that email and thought you would be interesting to discuss
16:09:41 <sajeesh> yes
16:09:58 <raildo> #link https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg36883.html
16:10:27 <sajeesh> what I had understood was that,quota management would be moved towards keystone
16:10:40 <raildo> #link https://wiki.openstack.org/wiki/Blazar
16:10:55 <raildo> maybe this Blazar can control quotas?
16:11:15 <raildo> i don't know, i have to investigate more
16:11:21 <sajeesh> ok
16:12:04 <sajeesh> there were some comments from vishy as well
16:12:19 <raildo> #action Raildo (and others) understand more about Quota management and enforcement across projects
16:12:56 <vishy> the discussion on the mailing list is to try to move the quota limits into keystone
16:13:04 <vishy> but do enforcement via a shared library in oslo
16:13:18 <sajeesh> ok..
16:13:18 <raildo> vishy, nice
16:13:23 <raildo> thank you
16:13:29 <sajeesh> thanks vishy for joining
16:14:17 <raildo> vishy, This may affect the current implementation of quotas in Nova, right?
16:14:48 <vishy> yes but the library will most likely be taken with some nova with some modifications
16:14:51 <vishy> i would think
16:15:03 <sajeesh> ok
16:15:35 <sajeesh> vishy,do you expect these changes to go in kilo ?
16:16:14 <vishy> i don’t know
16:16:20 <sajeesh> ok
16:16:22 <vishy> no one has officially signed up to do them yet
16:16:27 <sajeesh> ok
16:16:49 <thiagop> so, you don't think it's too much a breakthrough regarding the hierarchical quotas?
16:18:10 <sajeesh> vishy, regarding nested quota driver in nova,the development is over and I am testing it now.Do I need to go ahead with it ?
16:19:56 <vishy> sajeesh: yes
16:20:05 <vishy> the shared library needs nested quotas too
16:20:07 <sajeesh> ok,vishy
16:20:21 <raildo> vishy, Thanks for the explanation
16:20:30 <sajeesh> vishy ,thanks a lot
16:20:34 <tsv> vishy, i started looking at quota support for barbican by looking at nova impl as example. could you please give some pointers to the shared library wiki ?
16:21:26 <raildo> next topic?
16:21:38 <sajeesh> ok
16:21:51 <sajeesh> raildo,any updates from keystone side ?
16:22:28 <raildo> sajeesh, we are receiving some reviews, but not critical :)
16:22:35 <sajeesh> ok
16:22:43 <raildo> #topic Hierarchical Projects in Keystone - Reviews
16:22:44 <sajeesh> :-)
16:23:15 <thiagop> nirupma: what are your thoughts so far?
16:23:52 <raildo> sajeesh, If you want to review:
16:24:00 <raildo> #link http://paste.openstack.org/raw/120195/
16:24:02 <nirupma> if i create a new project and assign no members to it
16:24:19 <sajeesh> raildo,I will do
16:24:27 <raildo> we have a lot os patches hahaha
16:24:30 <nirupma> then even the admin cannot create new sub-projects.
16:24:33 <raildo> of*
16:24:57 <vishy> tsv: I don’t think it exists yet
16:24:58 <sajeesh> thiago,have you seen the feedback of vinod ?
16:25:01 <nirupma> now if i assign him the admin role then he can create sub-projecta'
16:25:38 <nirupma> but if i assign him the member role, he is still able to create sub-projects.
16:25:47 <nirupma> I am not sure if its correct
16:26:18 <nirupma> thiago: what do u think?
16:26:29 <tsv> vishy, thanks. will look forward for it
16:28:04 <thiagop> sajeesh: yes. I had also worked on it but some changes had no effect when I tested on Apache
16:28:17 <sajeesh> ok
16:28:52 <sajeesh> main issue was that parent was not coming in the list after it is created
16:29:22 <thiagop> sajeesh: it's a session problem
16:29:29 <sajeesh> ok
16:29:34 <nirupma> adding to sajeesh's comment
16:29:48 <nirupma> that issue is met even when we delete a project
16:29:55 <thiagop> I'll work on it as soon as I can
16:30:30 <sajeesh> ok,thanks thiago
16:30:36 <thiagop> #action fix token renewal on creating/deleting projects
16:31:01 <thiagop> nirupma: the deleted project is still being shown on the list, right?
16:31:12 <nirupma> yes
16:31:49 <raildo> #topic Design Session Summit
16:31:54 <raildo> #link https://etherpad.openstack.org/p/kilo-crossproject-summit-topics
16:33:03 <thiagop> nirupma: I'll take a look on the roles problems also. I'll give you some feedback next week.
16:33:16 <raildo> I talked with morganfainberg  and david-lyle , we are well nearby to get a space to discuss our features :)
16:33:28 <nirupma> Thanks thiago
16:33:41 <sajeesh> ok
16:35:13 <raildo> So we have to be all prepared to advance in this session
16:35:33 <sajeesh> ok
16:35:36 <raildo> nirupma, You'll be there, right?
16:36:04 <nirupma> yes
16:36:31 <raildo> great :)
16:36:41 <nirupma> raildo: What all should I prepare for the summit?
16:37:04 <nirupma> i mean what all should i read and understand well
16:37:11 <raildo> So far we have three main topics: New features in Keystone, Horizon Implementation, and quota support for hierarchical projects in Nova and other services
16:37:23 <raildo> nirupma, #link https://etherpad.openstack.org/p/kilo-crossproject-summit-topics
16:37:38 <nirupma> yeh i have read the etherpad
16:37:44 <raildo> You can look for Hierarchical Project in cross-projects ( Raildo Mascena 'raildo')
16:38:24 <nirupma> ok
16:38:45 <raildo> nirupma, I intend to discuss this and anything else that we can think to the summit
16:39:01 <nirupma> ok
16:39:46 <sajeesh> raildo,any update is available regarding python-openstackclient ?
16:39:59 <raildo> nirupma, I believe that you may be more concerned with the quota support for hierarchical projects in Nova and other services
16:40:00 <sajeesh> I mean the unified client ?
16:40:20 <nirupma> yes
16:40:22 <raildo> sajeesh, implementation is ready and is under review
16:40:28 <sajeesh> ok
16:40:33 <raildo> the implementation*
16:40:41 <nirupma> sajeesh has worked a lot on it
16:40:52 <sajeesh> hi shwicke
16:41:09 <raildo> #link https://review.openstack.org/#/c/123539
16:41:16 <raildo> hi schwicke
16:41:21 <nirupma> hi shwicke
16:41:42 <raildo> #link https://review.openstack.org/#/c/121101
16:42:15 <thiagop> hi schwicke
16:44:38 <raildo> Something else to be discussed?
16:45:25 <sajeesh> nothing from my side
16:46:37 <thiagop> just a question: sajeesh nirupma , what are your thoughts about the interface? Is it too ugly? Difficult to use?
16:47:06 <nirupma> i think its rather very easy to understand
16:47:12 <sajeesh> Thiago,the interface is good
16:47:37 <nirupma> and the tree structure of project is clearly visible
16:47:42 <sajeesh> yes
16:47:51 <raildo> great :)
16:48:02 <thiagop> we made a proposal to change the role assignment experience
16:48:12 <sajeesh> ok
16:48:15 <thiagop> we need to give it a way to set it as inherited or not
16:48:25 <thiagop> I'll send it to you by email ASAP
16:48:37 <sajeesh> ok,thanks thiago
16:48:42 <nirupma> ok
16:49:40 <raildo> so until next week
16:49:53 <raildo> #endmeeting