16:01:54 <schwicke> #startmeeting hierarchical_multitenancy
16:01:55 <openstack> Meeting started Fri Oct 17 16:01:54 2014 UTC and is due to finish in 60 minutes. The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:56 <sajeesh> schwicke
16:01:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:59 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:02:06 <schwicke> sorry again for last Friday.
16:02:15 <schwicke> Our internet connection broke down right in time ...
16:02:16 <sajeesh> no problem
16:03:01 <schwicke> #topic quota blue print
16:03:09 <sajeesh> I have been asked to upload the bp in gerrit.
16:03:13 <sajeesh> https://blueprints.launchpad.net/nova/+spec/nested-quota-driver-api
16:03:34 <schwicke> great
16:03:42 <schwicke> #link https://blueprints.launchpad.net/nova/+spec/nested-quota-driver-api
16:03:46 <schwicke> here we go
16:03:48 <sajeesh> I will upload it today
16:04:38 <schwicke> #action Sajeesh will upload the quote driver to gerrit today
16:05:10 <schwicke> I think it is important to do that asap so that people can have a look before the summit
16:05:31 <sajeesh> +1
16:05:51 <schwicke> Any issues so far ?
16:06:02 <sajeesh> nothing
16:06:22 <schwicke> ok
16:06:23 <sajeesh> testing is progressing well
16:06:54 <schwicke> I've been pretty stuck with other stuff during the last 2 weeks. Sorry about that.
16:07:03 <sajeesh> no problem
16:07:13 <VINOD_> schwicke: Sajeesh has integrated the code with Keystone hierarchical code and its working well
16:07:20 <sajeesh> yes
16:07:49 <schwicke> testeed on the VM ?
16:08:02 <sajeesh> yes...I have created a VM for that
16:08:06 <VINOD_> The VM provided by Raildo is closed
16:08:20 <VINOD_> and so sajeesh created a VM and had taken the latest hierarchical code from github
16:08:22 <sajeesh> I have taken Raildo's code from gerrit
16:08:45 <schwicke> that's good news!
16:09:41 <schwicke> We still had a question if we need client tool support to set the quota.
16:09:46 <schwicke> #topic client tool support
16:10:19 <sajeesh> schwicke ,since the api calls remains the same,nova client will be essentially the same
16:10:44 <schwicke> needs testing anyway.
16:10:49 <sajeesh> sure
16:10:50 <schwicke> I'm also referring to this:
16:10:58 <schwicke> #link https://review.openstack.org/#/c/121101
16:11:04 <schwicke> posted by raildo last Friday
16:12:10 <VINOD_> schwicke: But this code is for V3....
16:13:00 <schwicke> right
16:13:22 <sajeesh> shwicke,what I mean is that nova client remains the same no matter whether the projects are nested or not
16:13:22 <VINOD_> schwicke: I didn't get how it is related to quota code for nova client
16:14:33 <VINOD_> sajeesh: Its fine. I think what schwicke was trying to say is that, we have to test it to be sure
16:14:48 <VINOD_> otherwise the link will break between nova client and its api's
16:14:51 <sajeesh> sure,that will be dobe
16:15:00 <schwicke> VINOD_: even if we think there is nothing to do this should be confirmed by testing
16:15:03 <sajeesh> that will be done
16:15:16 <VINOD_> yes, exactly
16:15:22 <sajeesh> +1
16:15:34 <schwicke> +1
16:15:45 <schwicke> #topic summit preparation
16:16:35 <schwicke> I was scanning through the design summit stuff
16:16:39 <schwicke> #link http://kilodesignsummit.sched.org/
16:18:08 <schwicke> #link http://kilodesignsummit.sched.org/event/bd8c499d6087ca672f0dd6b496ffb3d7#.VEFA1YUicWM
16:19:19 <schwicke> Niru-mpa: please sign up to taht
16:19:31 <schwicke> (I think she's not there, is she ?)
16:19:44 <VINOD_> i think she is there
16:19:48 <sajeesh> she is there
16:19:52 <VINOD_> Nirupma: Are you there?
16:19:53 <nirupma> yes i am here
16:20:10 <nirupma> the connection is not very gud today and is breaking in between
16:20:42 <nirupma> i'll sign up for the session
16:20:59 <schwicke> ok.
16:21:28 <schwicke> #action: Nirupma should sign up for the hierarchical multi-tenancy session
16:21:40 <schwicke> I see Tim already signed up for it as well.
16:21:50 <VINOD_> yes
16:22:13 <schwicke> Nirupma: you should of course also go to the cross-project workshop.
16:22:19 <morganfainberg> That session is closely related to the other policy session(s) we're having
16:22:33 <morganfainberg> just as a heads up... there is a lot of policy talk this summit
16:22:52 <sajeesh> hi morganfainberg
16:23:00 <morganfainberg> hi :)
16:23:06 <nirupma> ok
16:23:15 <schwicke> Hi morganfainberg
16:23:20 <morganfainberg> The other policy discussion that *could* be interesting to HM topics is
16:23:25 <morganfainberg> #link http://kilodesignsummit.sched.org/event/061876b56285e8a46443bc3bf730031b
16:23:43 <schwicke> yep
16:24:07 <schwicke> #action Nirupma should sign up to http://kilodesignsummit.sched.org/event/061876b56285e8a46443bc3bf730031b as well
16:24:26 <nirupma> done
16:24:38 <schwicke> (again, Tiim has signed up for that already :-) )
16:24:57 <nirupma> yes
16:25:40 <schwicke> any special session on Quota management and store? I saw the remarks von vish in the last meeting ...
16:25:55 <schwicke> That is another thing we need to keep an eye on but where will that be discussed ?
16:26:01 <sajeesh> exactly
16:26:29 <schwicke> possibly in the corss project workshop but maybe there is something else
16:26:53 <VINOD_> I didn't any session on this...as for lot of sessions (in nova), it is mentioned that topic is yet to be decided
16:27:08 <schwicke> Currently there are quite some session topics in tbd
16:27:34 <schwicke> #action scan http://kilodesignsummit.sched.org/ for possible interesting new topics
16:27:34 <VINOD_> #link http://kilodesignsummit.sched.org/event/8df02f751841faa1cee7e4f1de1450f1#.VEFDV1f4LEo
16:28:10 <VINOD_> sorry wrongly posted....i thought it is openstack-client...but it is keystone-client
16:28:27 <schwicke> yep
16:31:02 <schwicke> not sure if this one might be interesting:
16:31:05 <schwicke> #link http://kilodesignsummit.sched.org/event/336040396ada6a1101ada03c7693f9f8#.VEFD9oUicWM
16:32:12 <schwicke> otherwise I don't have anything else which needs to be urgently discussed
16:32:32 <sajeesh> I also think so
16:32:46 <sajeesh> hi raildo
16:32:47 <raildo> hi all
16:32:51 <schwicke> hi raildo
16:32:56 <VINOD_> nothing more from my side as well...
16:32:58 <raildo> sorry for the delay
16:33:04 <nirupma> hi raildo
16:33:11 <sajeesh> no problem..raildo
16:33:25 <raildo> i'll read the log
16:33:25 <sajeesh> raildo,any updates
16:34:41 <schwicke> Raildo: I have a question for you
16:34:57 <schwicke> do you happen to know how the cross project workshop is organized
16:35:10 <schwicke> it seems to me as if there are 3 sessions in parallel
16:35:13 <schwicke> is that correct?
16:35:26 <schwicke> If so, how to decide to which one to sign up?
16:36:29 <raildo> hum... that is a good question
16:37:52 <schwicke> can check here with people who have been there last time maybe
16:38:04 <nirupma> just a thought
16:38:39 <nirupma> may be we can decide after further details are provided
16:38:59 <schwicke> yes, I think we have to wait longer to see how this evolves.
16:39:00 <nirupma> right now very few sessions have been disclosed
16:39:10 <raildo> I believe it depends on the content of each meeting.
16:40:22 <schwicke> yes.
16:40:41 <schwicke> Let's see when they come up with some more detailed topics. Its probably simply to early.
16:40:45 <raildo> I do not have an answer to this question . :P
16:41:21 <schwicke> #topic AOB
16:41:34 <schwicke> nothing else from my side for today
16:42:06 <sajeesh> from my side as well,raildo are there any updates from your side ?
16:43:02 <schwicke> ok
16:43:08 <VINOD_> nothing else from my side as well
16:43:10 <raildo> just that the design session was confirmed, as you have seen.
16:43:17 <sajeesh> ok
16:43:25 <schwicke> yes, that's good!
16:43:37 <raildo> and we are having several reviews of our patches, which is very good
16:43:41 <schwicke> I put a link earlier.
16:43:46 <sajeesh> great
16:43:49 <schwicke> +1
16:43:55 <raildo> including some +2
16:44:02 <sajeesh> great
16:44:16 <schwicke> hope we'll be as successful for the quota parts ;-)
16:44:27 <sajeesh> :-)
16:45:07 <raildo> me too :)
16:45:57 <VINOD_> Bye all for now...have a great weekend
16:46:10 <schwicke> yes, buy everybody!
16:46:12 <VINOD_> I have to go...so bye all
16:46:20 <schwicke> Sajeesh: keep us informed !
16:46:22 <sajeesh> Good bye all :-) Nice weekend
16:46:34 <schwicke> #endmeeting