#openstack-meeting: hierarchical_multitenancy

Meeting started by schwicke at 16:01:09 UTC (full logs).

Meeting summary

  1. Default quota patch - root level project gets default values set in cinder.conf (schwicke, 16:03:32)
    1. https://review.openstack.org/151677 (vilobhmm, 16:05:04)
    2. https://review.openstack.org/#/c/149828/ (sajeesh, 16:06:07)
    3. AGREED: : the root project should have default quota values and children set the default quota to zero (schwicke, 16:21:46)
    4. AGREED: : we take the same approach for cinder and for nova (schwicke, 16:22:09)

  2. : writing unit tests (schwicke, 16:22:40)
    1. ACTION: write unit tests for cinder (schwicke, 16:24:59)

  3. mocking keystone call (schwicke, 16:26:20)
    1. AGREED: Sajeesh will contact the mailing list to get advice on the keystone call (schwicke, 16:36:23)
    2. ACTION: Sajeesh contact the mailing list to get advice on the keystone call (schwicke, 16:36:46)

  4. code availability and merging of patches (schwicke, 16:37:55)
    1. ACTION: ericksonsantos will test the code (schwicke, 16:39:52)
    2. ACTION: vilobhmm will update cinder code with agreed items from this meeting (schwicke, 16:41:36)
    3. ACTION: all: review next update of https://review.openstack.org/#/c/185704/ asap (schwicke, 16:44:48)

  5. AOB (schwicke, 16:47:41)
    1. https://github.com/openstack/nova/blob/master/etc/nova/policy.json#L108 (raildo, 16:51:52)
    2. https://review.openstack.org/#/c/182522/ (sajeesh, 16:54:35)


Meeting ended at 16:56:06 UTC (full logs).

Action items

  1. write unit tests for cinder
  2. Sajeesh contact the mailing list to get advice on the keystone call
  3. ericksonsantos will test the code
  4. vilobhmm will update cinder code with agreed items from this meeting
  5. all: review next update of https://review.openstack.org/#/c/185704/ asap


Action items, by person

  1. ericksonsantos
    1. ericksonsantos will test the code
  2. openstack
    1. all: review next update of https://review.openstack.org/#/c/185704/ asap
  3. sajeesh
    1. Sajeesh contact the mailing list to get advice on the keystone call
  4. vilobhmm
    1. vilobhmm will update cinder code with agreed items from this meeting


People present (lines said)

  1. vilobhmm (83)
  2. schwicke (61)
  3. sajeesh (60)
  4. ericksonsantos (32)
  5. raildo (17)
  6. belmoreira (5)
  7. openstack (3)


Generated by MeetBot 0.1.4.