16:02:18 <schwicke> #startmeeting hierarchical_multitenancy
16:02:19 <openstack> Meeting started Fri Jun 26 16:02:18 2015 UTC and is due to finish in 60 minutes.  The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:22 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:02:25 <schwicke> better now :)
16:02:30 <schwicke> So who's there /
16:02:31 <schwicke> ?
16:02:42 <sajeesh> Hi schwicke
16:02:45 <rodrigods> o/
16:03:27 <schwicke> I suggest we first go through the action items from last friday
16:03:37 <sajeesh> ok
16:03:55 <schwicke> #topic review of action items from last meeting
16:04:08 <schwicke> We had:  ericksonsantos will test the code
16:05:03 <schwicke> does anybody have an update on this ?
16:05:04 <rodrigods> schwicke, he is currently applying sajeesh code into devstack
16:05:10 <rodrigods> in order to test it
16:05:14 <sajeesh> ok
16:05:14 <schwicke> OK
16:05:16 <schwicke> great!
16:05:50 <schwicke> I understand that Sajeesh did that already so maybe if there are problems Sajeesh could help ?
16:06:04 <sajeesh> I can help
16:06:15 <rodrigods> schwicke, he hasn't reported any issues yet. But sure, will let him know
16:06:18 <sajeesh> actually testing is very time consuming
16:06:28 <schwicke> sure
16:06:36 <sajeesh> it is not that difficult...but takes lot of time
16:06:50 <schwicke> not surprising :)
16:06:51 <rodrigods> sajeesh, yes, thanks for volunteering to help :)
16:07:00 <sajeesh> no problem :-)
16:07:48 <schwicke> Let's try to use the skype forum for fast response where possible, keeping in mind that Sajeesh unfortunatly can't use it during working hours so here you need to fall back to e-mail
16:08:03 <sajeesh> yes
16:08:20 <schwicke> #action Sajeesh can help on testing if need be. Corrdinate via e-mail or skype
16:08:43 <schwicke> all: review next update of https://review.openstack.org/#/c/185704/
16:08:48 <schwicke> I see that this is merged
16:08:58 <schwicke> So we can tick that off I suppose
16:09:05 <schwicke> correct ?
16:09:05 <rodrigods> schwicke, yes... the follow up patch is not currently passing tests
16:09:30 <rodrigods> ericksonssantos can definitely take care of it while vilobh is not present
16:09:39 <rodrigods> #link https://review.openstack.org/#/c/194406/
16:09:55 <schwicke> rodrigods: thanks for the link!
16:10:08 <sajeesh> thanks
16:10:48 <schwicke> #action: ericksonssantos can help on tests for https://review.openstack.org/#/c/194406/ after finishing the tests
16:11:09 <schwicke> lets move on: Sajeesh contact the mailing list to get advice on the keystone call
16:11:28 <sajeesh> yes...I have contacted them
16:11:40 <sajeesh> there are two methods
16:12:07 <sajeesh> 1. monkey patch the two methods only
16:12:23 <sajeesh> or keystoneclient as a whole
16:12:42 <rodrigods> don't like the option of doing unnecessary work
16:12:44 <rodrigods> would go with 1
16:12:54 <sajeesh> ++1
16:12:56 <raildo> sajeesh, do you have the link of this email?
16:13:04 <sajeesh> I will send you
16:13:10 <raildo> sajeesh, thanks
16:13:15 <raildo> rodrigods, ++
16:14:30 <schwicke> there was a comment from ayoung: "A worst case approach is to monkey patch the Keystoneclient.  Please don't do that if you can avoid it;  better to provide a mock alternative."
16:15:13 <sajeesh> but in the second mail he wrote something different
16:15:17 <schwicke> #action: sajeesh send link to mail thread
16:15:22 <sajeesh> ok
16:15:47 <sajeesh> sorry ..I thought you all might have seen
16:15:58 <sajeesh> seen the mail
16:16:08 <schwicke> indeed: "Its not great, but not horrible.  It seems to match the scope of what you are testing.  However, you might want to consider doing a mock for the whole Keystoneclient call, as that really should beo utside of the unit test for the Nova code.
16:16:09 <schwicke> "
16:16:09 <raildo> #link https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg56439.html
16:16:25 <sajeesh> yes
16:16:58 <sajeesh> thanks raildo
16:17:13 <schwicke> I'm not deep enough inside the code to really judge but there seems to be some consensus to go for the monkey patch thing
16:17:36 <schwicke> raildo: thanks a lot for the link!
16:17:55 <sajeesh> yes , we have to do that....only the scope needs to decided
16:18:48 <sajeesh> raildo, rodrigo...any links of monkey patching done in keystone..It will be helpful to me
16:19:02 <sajeesh> I mean the way
16:19:03 <rodrigods> sajeesh, I believe we have something in Horizon
16:19:05 <rodrigods> just a sec
16:19:22 <sajeesh> ok
16:19:49 <rodrigods> #link https://github.com/openstack/horizon/blob/master/openstack_dashboard/test/api_tests/keystone_tests.py
16:20:04 <rodrigods> in those tests, Horizon is mocking the return of keystone calls
16:20:05 <sajeesh> rodrigo, thanks a lot
16:21:00 <sajeesh> ok
16:21:16 <schwicke> #agreed go for a monkey patch as proposed in the mail thread
16:21:43 <schwicke> sajeesh: when do you think you can start to work on this ?
16:22:07 <sajeesh> schwicke ...I will start as soon as possible
16:23:07 <schwicke> #action sajeesh will work on implementing monkey patching the keystone calls
16:23:13 <schwicke> great!
16:23:33 <schwicke> finally we had: vilobhmm will update cinder code with agreed items from this meeting
16:23:57 <sajeesh> shwcicke planning start working on that by this weeked
16:24:02 <sajeesh> weekend
16:24:05 <schwicke> well, not very well phased this action item, sorry for that :)
16:24:24 <schwicke> sajeesh: cool!
16:24:26 <rodrigods> I believe vilobhm is on vacation? erickdonsantos can do that
16:24:34 <rodrigods> (as I said in a previous topic)
16:24:39 <schwicke> poor erickdonsantos :)
16:24:44 <sajeesh> ok
16:24:46 <rodrigods> haha :)
16:24:53 <raildo> lol
16:24:55 <sajeesh> :)
16:25:22 <schwicke> erickdonsantos: is that ok for you ?
16:25:50 <rodrigods> schwicke, he is in a poor 3g connection
16:26:03 <rodrigods> in a mobile
16:26:05 <erickdonsantos> I lost the beginning of the meeting :(
16:26:19 <sajeesh> hi erickson
16:26:25 <schwicke> hi!
16:26:38 <erickdonsantos> Hi :)
16:26:51 <rodrigods> hey erickdonsantos, said that you started the devstack deploy with sajeesh's code
16:27:13 <schwicke> erickdonsantos: we've action itemed you on: testing of Sajeeshs code and taking over from vilobhmm while he's on vacation
16:27:13 <rodrigods> and that you are going to fix vilobhm change (set default values to 0) since he is out
16:27:24 <rodrigods> schwicke, ++
16:27:45 <erickdonsantos> I'm from a mobile using 3g net, it's being difficult to follow up the discussion, sorry
16:28:18 <erickdonsantos> I'm ok with that
16:28:19 <schwicke> no problem, you'll be able to read the missing bits from the logs
16:28:22 <erickdonsantos> :)
16:28:23 <schwicke> great!
16:28:26 <sajeesh> :)
16:28:49 <schwicke> #action: erickdonsantos will take over from vilobhmm while he's on vacation
16:29:09 <schwicke> let's move on
16:29:12 <schwicke> #topic nova code feedback
16:29:33 <schwicke> Sajeesh, any special thing that you want to discuss here ?
16:29:38 <rodrigods> I have...
16:29:49 <rodrigods> the whole patch chain is not passing tests, starting from https://review.openstack.org/#/c/182140/
16:29:49 <schwicke> go ahead!
16:29:54 <sajeesh> I want feedback
16:30:14 <rodrigods> this needs special attention because the nova cores won't review it until they are passing the tests
16:30:35 <rodrigods> maybe you've seen some thoughts I had about it in the mail thread?
16:30:36 <erickdonsantos> As soon as I've done the scripts to test sajeesh' patches on devstack, I'll sent a code review
16:30:38 <sajeesh> yes..I know
16:30:58 <sajeesh> thanks erickson
16:31:20 <sajeesh> rodrigo...I have seen your mail
16:31:27 <sajeesh> I am working on that...
16:31:34 <rodrigods> sajeesh, sure :)
16:31:42 <rodrigods> I believe you may need to ask feedback from nova cores
16:31:45 <sajeesh> If am not able to ,I will take help from the community
16:32:06 <rodrigods> because you may have two options: fix the tests somehow or just drop the tests
16:32:10 <sajeesh> rodrigo, I am also thinking so
16:32:25 <rodrigods> their feedback can speed up things
16:32:28 <sajeesh> I am planning for fixing the tests
16:32:44 <sajeesh> anyway , I will ask them
16:32:50 <erickdonsantos> Sajeesh, I think you can start addressing our previous reviews
16:32:57 <rodrigods> sajeesh, I mean... only fixing the tests without the feedback about the approach can be harmful
16:33:22 <sajeesh> ok...then I will ask their feedback
16:33:32 <rodrigods> sajeesh, great!
16:33:46 <sajeesh> :-)
16:33:54 <rodrigods> :)
16:34:03 <schwicke> #action sajeesh will ask for feedback on failing tests for https://review.openstack.org/#/c/182140/
16:34:04 <erickdonsantos> rodrigods ++
16:34:15 <sajeesh> erickson..I had tried addressing the previous tests
16:34:24 <sajeesh> previous reviews
16:34:40 <schwicke> I suggest we do the same thing as last time: first send a draft of the mail, we iterate on it and then send it off ?
16:34:47 <sajeesh> let me know..if I had missed any
16:35:13 <rodrigods> schwicke, sajeesh would go for IRC discussions as well
16:35:24 <sajeesh> ++1
16:35:24 <schwicke> when contacting the community
16:35:28 <schwicke> good idea
16:35:39 <raildo> rodrigods, ++ it's easier to find the core team and get a quickly answers for this
16:35:41 <schwicke> in openstack-dev I suppose ?
16:35:48 <rodrigods> -nova
16:35:49 <raildo> #openstack-nova
16:35:54 <sajeesh> ok
16:36:02 <schwicke> ok
16:36:31 <schwicke> #action sajeesh will contact core developers on IRC in #openstack-nova
16:37:12 <schwicke> (hope I got the actions right :) )
16:37:13 <raildo> sajeesh, you can ping the nova cores: jogo, garyk, jaypipes, sdague and others
16:37:18 <sajeesh> :-)
16:37:26 <sajeesh> ok
16:38:24 <schwicke> probably to good to do that asap
16:38:29 <sajeesh> yes
16:38:46 <schwicke> lets move on
16:39:02 <schwicke> #topic unit testing method
16:39:14 <schwicke> not sure if we didn't already cover this
16:39:29 <rodrigods> schwicke, monkey patches :)
16:39:35 <sajeesh> :)
16:39:36 <schwicke> exactly :)
16:39:52 <schwicke> #agreed monkey patches
16:40:00 <schwicke> Only thing left is
16:40:05 <schwicke> #topic AOB
16:40:36 <schwicke> (didn't work it seems)
16:40:42 <schwicke> (did)
16:40:58 <rodrigods> who isn't in the skype group chat yet?
16:41:16 <schwicke> thanks! I was about to ask the same question
16:41:20 <schwicke> Sajeesh is not in yet
16:41:22 <sajeesh> I think ...I am :(
16:41:39 <ericksonsantos> Neither do I
16:42:01 <rodrigods> ericksonsantos, what is your skype ID?
16:42:04 <sajeesh> shwicke...I will check it
16:42:14 <rodrigods> schwicke, will add you as a contact and than add you to the group chat
16:42:20 <ericksonsantos> ericksonfilipe
16:42:46 <ericksonsantos> Ok, nice
16:43:03 <schwicke> ericksonsantos: I have sent you another contact request
16:43:09 <schwicke> same for sajeesh.
16:43:15 <sajeesh> thanks
16:43:23 <sajeesh> sajeesh-cs
16:43:24 <schwicke> If you could go online and accept it I can add you to the chat
16:43:52 <ericksonsantos> I'll accept as soon as I can, schwicke
16:44:12 <sajeesh> one more thing....before pinging the nova-core do we deed to send a mail to give a background info
16:44:36 <rodrigods> sajeesh, don't think it is necessary
16:44:45 <sajeesh> ok...
16:44:53 <rodrigods> think most of them are aware of the change (at least the spec)
16:44:56 <rodrigods> specially jogo
16:45:05 <rodrigods> that approved it
16:45:09 <sajeesh> yes..
16:45:18 <rodrigods> he might be your start point
16:45:28 <sajeesh> yes
16:45:39 <schwicke> +1
16:45:56 <ericksonsantos> rodrigods, good point
16:46:06 <schwicke> (btw for the record: my skype ID is "schwicke") :)
16:46:13 <sajeesh> ok
16:46:57 <schwicke> anything else to be discussed ?
16:47:24 <sajeesh> nothing from my side
16:47:30 <rodrigods> I'm good too
16:47:37 <rodrigods> please contact me via email, skype or IRC
16:47:41 <rodrigods> if you need anything
16:47:53 <sajeesh> ok..thanks
16:48:03 <schwicke> Great ! Thanks a lot
16:48:29 <schwicke> Let's meet again next week in any case to review the status of the various action items.
16:48:35 <schwicke> #endmeeting