16:02:26 <raildo> #startmeeting hierarchical_multitenancy
16:02:26 <openstack> Meeting started Fri Jul 10 16:02:26 2015 UTC and is due to finish in 60 minutes.  The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:29 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:02:45 <raildo> hi all
16:02:53 <ericksonsantos> Hi
16:03:00 <raildo> #topic review of action items
16:03:37 <raildo> i tought that we only have one action item in the last meeting
16:03:48 <sajeesh> yes
16:03:48 <raildo> "raildo will take a look in the patch and will fix it #link https://review.openstack.org/#/c/182140/"
16:03:54 <sajeesh> ok
16:04:21 <raildo> I take a look on this patch, the problem is not easy to solve.
16:04:31 <sajeesh> i know :-)
16:05:18 <raildo> me and rodrigods tested the nova behaviour and we see that in the nova site  works correctly with the tempest tests
16:05:58 <sajeesh> ok
16:06:24 <raildo> now, we are trying to figure out what is wrong in the tempest test and trying understand how to verify/change the project_id in the nova call
16:06:30 <raildo> and fix the test
16:06:49 <raildo> I think that we need one or two days to finish this
16:07:01 <vilobhmm> hi all
16:07:09 <sajeesh> ok
16:07:15 <raildo> hi vilobhmm
16:07:22 <ericksonsantos> hi, vilobhmm
16:07:30 <sajeesh> hi vilobh
16:07:34 <raildo> so I'll readd the action item, to keep with this for the next meeting
16:07:40 <sajeesh> ok
16:07:52 <vilobhmm> sorry raildo I missed but what is this action item about
16:08:02 <raildo> vilobhmm: raildo will take a look in the patch and will fix it #link https://review.openstack.org/#/c/182140/
16:08:24 <vilobhmm> raildo : ok thanks
16:08:34 <raildo> #action raildo wiil keep working to fix the #link https://review.openstack.org/#/c/182140/
16:09:19 <raildo> #topic nova code status
16:09:33 <raildo> sajeesh: - split of patches
16:09:44 <sajeesh> I have splited the code
16:10:08 <sajeesh> Now there are 7 patches
16:10:26 <sajeesh> I have to upload two more patches
16:10:37 <sajeesh> It is ready...I have to upload only
16:10:46 <ericksonsantos> what patches?
16:11:21 <vilobhmm> ericksonsantos : https://blueprints.launchpad.net/nova/+spec/nested-quota-driver-api
16:11:22 <sajeesh> api support for v3 and v2 calls
16:12:11 <sajeesh> presents everything is done in a single patches which makes the number of lines of code to more 1000
16:12:18 <sajeesh> more than 1000
16:12:19 <ericksonsantos> sajeesh, I mean... what are the patches you have to update?
16:13:17 <sajeesh> erickson: now lot of functionalites are in a single patch
16:13:47 <sajeesh> just splitting them into multple patches to ease the review process
16:13:56 <vilobhmm> sajeesh : do you mean to say are you breaking https://review.openstack.org/#/c/149828 into multiple patches
16:14:02 <ericksonsantos> sajeesh,  I saw you have updated some of them and I've started reviewing
16:14:21 <sajeesh> eirckson..you are right
16:14:44 <sajeesh> vilobh, yes
16:14:47 <vilobhmm> ok
16:14:55 <sajeesh> it is too big
16:15:14 <sajeesh> I will not change the code . just splitting only
16:15:19 <raildo> sajeesh: - avoiding code duplication
16:15:28 <ericksonsantos> sajeesh, ok
16:15:29 <sajeesh> yes...I am doing that
16:15:31 <vilobhmm> ok…
16:15:52 <raildo> sajeesh: What you are doing to avoinding this, when you are creating a new driver?
16:16:09 <sajeesh> ?
16:16:26 <vilobhmm> raildo : do you mean how do you avoid code duplication ?
16:16:30 <raildo> yes
16:16:41 <ericksonsantos> sajeesh, I have sent a review about code duplication
16:16:52 <sajeesh> raildo, inheritance I am using
16:17:03 <sajeesh> erickson, I have seen it
16:17:03 <raildo> I mean, now that we aren't the approach to create a hole new driver
16:17:29 <vilobhmm> raildo : one way would be that we have a common base class QuotaDriver from which class NestedQuotaDriver and class DbQuotaDriver will inherit
16:17:39 <sajeesh> new driver inherits from the old driver
16:18:05 <vilobhmm> since most of the functionality is shared between class NestedQuotaDriver and class DbQuotaDriver the common functionality can reside in base class QuotaDriver
16:18:06 <sajeesh> I have to override around 5 methods ..that is all
16:18:29 <raildo> vilobhmm: sajeesh great
16:19:06 <sajeesh> vilobh, I am keeping the DbQuotaDriver untouched
16:19:37 <raildo> sajeesh: and about tests for this new driver? Are you already implemented it?
16:19:42 <ericksonsantos> sajeesh, you can go this way, but make sure you will use inheritance power
16:19:49 <vilobhmm> sajeesh : I would say rather than going with olddriver—> new driver (new driver inheriting from old driver) we should go with olddriver and newdriver both inheriting from a common driver that way it will be good if we plan to add any more new drivers in future
16:20:21 <vilobhmm> anything is good i just feel 2nd approach is more scaalable…but up to you
16:20:26 <vilobhmm> you have a better idea
16:20:29 <sajeesh> raildo: I have implemented monkey patching in the existing test cases
16:20:44 <ericksonsantos> vilobhmm, I think that the common driver is already the DbQuotaDriver
16:20:50 <sajeesh> They are passing the tests
16:20:57 <sajeesh> erickson +1
16:21:18 <sajeesh> raildo, they are passing the tests
16:21:30 <sajeesh> now I have to add more uses cases
16:21:42 <vilobhmm> sajeesh : great!
16:21:51 <raildo> sajeesh: nice
16:22:07 <ericksonsantos> sajeesh, can you be more specific?
16:22:20 <sajeesh> raildo: I will upload the code with the modified test cases today
16:22:38 <raildo> #action sajeesh will upload the code with the modified test cases today
16:22:38 <sajeesh> erickson, can you plz make it clear
16:23:40 <sajeesh> erickson:  I have patched the existing test cases and they are passing the tests
16:23:52 <sajeesh> but they are meant for non-nested projects
16:24:02 <ericksonsantos> sajeesh, hmm... I see
16:24:08 <sajeesh> now more tests need to added for nested projects
16:24:14 <ericksonsantos> sure
16:24:58 <raildo> #topic implementation of monkey patches
16:24:59 <sajeesh> it is a bit time consuming thing ....since we need to have mock hierarchy with values
16:25:27 <raildo> sajeesh: so you probably will need help with this, right?
16:25:44 <sajeesh> yes....to make it faster
16:26:05 <ericksonsantos> sajeesh, how did you do in order to test keystone calls?
16:27:00 <sajeesh> I have patched it
16:27:39 <sajeesh> so that the existing tests will be passed
16:28:16 <ericksonsantos> ok
16:28:33 <sajeesh> I have patched  two methods only
16:28:43 <sajeesh> not ...keystone as a whole
16:29:44 <ericksonsantos> nice
16:30:13 <raildo> sajeesh: so, do you have a script or something in mind to create the use cases for the tests?
16:30:32 <raildo> sajeesh: something to make easier other people help you with this?
16:30:51 <sajeesh> I have made two test cases...for that I am following the existing method
16:31:00 <sajeesh> dummy values.
16:31:26 <sajeesh> but for the remaining , I am planning to have script
16:31:52 <sajeesh> I have something in my mind
16:32:19 <sajeesh> will communicate it by tomorrow
16:32:48 <raildo> sajeesh: great, I think that we can talk more about this in skype :)
16:32:55 <raildo> during the week
16:33:06 <sajeesh> means I will make a fake heirarchy...so that others can help me effectively
16:33:16 <sajeesh> raildo....thanks
16:34:05 <raildo> sajeesh: anything more about the nova side that you want to talk?
16:34:14 <sajeesh> we can contact through skype
16:34:26 <raildo> ok
16:34:35 <sajeesh> nothing more from my side
16:34:55 <raildo> #topic status of cinder code: what's left to be done?
16:35:01 <raildo> vilobhmm: ericksonsantos ^
16:35:18 <vilobhmm> For cinder https://review.openstack.org/#/c/194406/ and https://review.openstack.org/#/c/185704/ got merged....continue working on nested quota driver change that I left off before my vacation....started back with it...
16:35:53 <raildo> btw congrats for the merged patches :)
16:35:55 <vilobhmm> should have the changes ready by July 25th (including the unit test)
16:35:58 <ericksonsantos> I think the next step we have to do is to get informations from keystone (parent_id and childs) using keystoneclient and test it
16:36:33 <vilobhmm> raildo : thanks….ericsonsantos has been really helpful in pushing these patches when i was away…also thanks sajeesh for the reviews
16:36:45 <sajeesh> :-)
16:36:58 <ericksonsantos> vilobhmm, :)
16:37:09 <ericksonsantos> vilobhmm, when are you planning to upload the new patch?
16:37:13 <raildo> ericksonsantos: this is not already implemented, right?
16:37:15 <vilobhmm> yes once we figure out how the update path will work like scoping tokens etc…we should be good
16:37:47 <vilobhmm> ericksonsantos : end of coming week most prob
16:38:18 <ericksonsantos> raildo, not yet
16:38:22 <raildo> vilobhmm: ericksonsantos will keep working with you in the cinder side, right?
16:38:36 <vilobhmm> sure
16:38:41 <vilobhmm> more the better :)
16:38:57 <raildo> I think that the next steps can be understand if cinder make some similar keystone call
16:39:01 <ericksonsantos> vilobhmm, nice!
16:39:19 <ericksonsantos> raildo, no, it's not.
16:39:26 <raildo> hum
16:39:44 <ericksonsantos> raildo, I think the first patch wich is trying to do so is #link https://review.openstack.org/#/c/143645/
16:40:23 <ericksonsantos> raildo, so, we have a good start point.
16:40:33 <raildo> ericksonsantos: great :)
16:40:58 <vilobhmm> ericsonsantos, raildo : again how will this patch help us if you can shed some light
16:41:08 <vilobhmm> not able to get it from the description
16:41:29 <ericksonsantos> vilobhmm, this patch is making keystone call
16:41:47 <vilobhmm> right
16:41:49 <raildo> ericksonsantos: vilobhmm do you suggest some action point for your side for the next meeting?
16:41:52 <ericksonsantos> vilobhmm, so we can make our calls based on how they are doing it
16:42:11 * raildo need to goind deep more in the cinder code
16:42:18 <vilobhmm> raildo : we both can make sure this patch https://review.openstack.org/#/c/143645/ proceeds and gets merged
16:42:21 <vilobhmm> by coming week
16:42:40 <vilobhmm> as it will be helpful for our work
16:42:47 <raildo> sounds good to me :)
16:42:54 <ericksonsantos> raildo, vilobhmm yes
16:43:02 <vilobhmm> along with that vilobhmm will propose the initial patch for nested quota driver if possible
16:43:15 <raildo> #action vilobhmm and ericksonsantos will make sure this patch https://review.openstack.org/#/c/143645/ proceeds and gets merged
16:43:40 <vilobhmm> makes sense
16:44:09 <ericksonsantos> raildo, vilobhmm I think that I can send a patch with keystone calls to cinder, and you (vilobhmm) can send your patch above mine, what do you think?
16:44:54 <vilobhmm> ericksonsantos : works
16:44:55 <vilobhmm> for me
16:44:56 <ericksonsantos> since keystone calls will be needed anyway
16:45:00 <vilobhmm> sure
16:45:03 <ericksonsantos> vilobhmm, nice :)
16:45:04 <vilobhmm> lets do it !
16:45:20 <raildo> #action ericksonsantos will send a patch with keystone calls to cinder
16:45:30 <vilobhmm> raildo : cinder will also need policy.json changes right
16:45:37 <vilobhmm> for cloud admin and root adming
16:46:13 <raildo> vilobhmm: right...
16:46:15 <vilobhmm> since these are small steps better to finish them off before procedding to major chunks IMHO
16:46:25 <vilobhmm> so you can add that too in the action item
16:46:34 <vilobhmm> its a small change will finish that off as well
16:46:38 <raildo> the only problem that I see is that this roles needs to be created in the keystone side
16:46:56 <ericksonsantos> raildo, ++
16:47:00 <raildo> vilobhmm: to this works... so we are kind of creating a "role dependence"
16:47:09 <raildo> for the quota code
16:47:19 <sajeesh> yes
16:47:57 <vilobhmm> raildo, sajeesh, eriksonsantos : since these are small steps better to finish them off before procedding to major chunks IMHO
16:48:07 <raildo> I mean, if we don't have this exacly role, with this name in keystone, the nova/cinder doesn't work. I don't like this idea...
16:48:09 <vilobhmm> sorry pasted again
16:48:40 <vilobhmm> so why don't we have a common change in keystone so that both nova and cinder can benefit from it
16:49:05 <sajeesh> vilobh ++
16:49:12 <ericksonsantos> raildo, neither do I, maybe we have to think a bit more and try to come out with a better solution, if any
16:49:15 <raildo> vilobhmm: that something that I want to do, but this not be simple to make(for liberty)
16:49:33 <sajeesh> I know
16:50:16 <vilobhmm> raildo : lets jump of to keystone channel after our meeting or you can drop an email to openstack-dev and see if we can get this in…since from nova and cinder side people have commited for nested quota and will need help from keystone to get this going
16:50:49 <vilobhmm> raildo : requesting you since you have worked with keystone
16:50:55 <vilobhmm> and none of us have
16:51:09 <sajeesh> raildo: although I have more roles, role admin will work, even if others won't
16:51:26 <raildo> vilobhmm: I think that we can discuss a little more about this in the skype during a couple days, and we can talk in the keystone channel
16:51:41 <sajeesh> +1
16:51:42 <ericksonsantos> raildo, ++
16:51:51 <vilobhmm> sure raildo…
16:52:14 <raildo> just to trying find a better solution between us :)
16:52:20 <vilobhmm> Just that I don't want ericksonsantos or either of us to block because of this, so just being cautious :)
16:52:35 <vilobhmm> totally raildo
16:52:36 <raildo> vilobhmm: exactly
16:53:09 <vilobhmm> when do we have the skype meetings
16:53:18 <vilobhmm> i haven't attended one since i was away on vacations
16:53:20 <raildo> #action ALL discuss more about new roles in nova and cider, and try find a good solution to send for the keystone folks
16:53:25 <vilobhmm> ++
16:53:29 <ericksonsantos> vilobhmm, I think you are not in the skype group yet
16:54:06 <raildo> I will talk with schwicke to add you in the skype group
16:54:06 <vilobhmm> oh okay…
16:54:12 <raildo> vilobhmm: ^
16:54:13 <vilobhmm> please do
16:54:18 <raildo> great
16:54:19 <vilobhmm> thanks raildo
16:54:25 <raildo> we have 5 more minutes
16:54:35 <raildo> #topic AOB
16:55:01 <vilobhmm> nothing from my side
16:55:14 <sajeesh> nothing from my side too
16:55:25 <ericksonsantos> ^
16:55:36 <raildo> ok, so thank you guys and have a nice week :)
16:55:37 <vilobhmm> its great to work with all of you ! :) thanks again guys for all the help
16:55:39 <sajeesh> raildo...thanks a lot for conducting the meeting
16:55:41 <raildo> see you in the skype
16:55:45 <vilobhmm> you too raildo!
16:55:50 <raildo> sajeesh: np :)
16:55:51 <vilobhmm> and all
16:55:55 <raildo> #endmeeting