16:01:39 <schwicke> #startmeeting hierarchical_multitenancy
16:01:40 <openstack> Meeting started Fri Jul 31 16:01:39 2015 UTC and is due to finish in 60 minutes.  The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:44 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:02:27 <schwicke> whom do we have today ?
16:02:41 <sajeesh> Hi:-)
16:02:56 <schwicke> #topic review of action items
16:03:07 <schwicke> let's start with the actions from last meeting.
16:03:12 <ericksonfgds> ok
16:03:14 <schwicke> Thanks for running the meeting!
16:03:48 <raildo> #link http://eavesdrop.openstack.org/meetings/hierarchical_multitenancy/2015/hierarchical_multitenancy.2015-07-24-16.03.html
16:03:51 <schwicke> sajeesh, raildo in Nova side, try merge the initial patches related
16:03:51 <schwicke> to allocated column and setting default values to subprojects
16:04:23 <schwicke> how far are we with this ?
16:04:52 <sajeesh> Review is going on and we are making changes according to the review
16:05:04 <schwicke> ok
16:05:05 <raildo> in fact, sajeesh was most responsible for this, so this week I work in update the keystone calls code, and refactoring the last patches
16:05:22 <schwicke> ok, great !
16:05:22 <raildo> the good news that we we some nova cores looking in the code
16:05:30 <sajeesh> yes
16:06:24 <sajeesh> raildo..thanks a lot for your help :-)
16:06:39 <schwicke> +1
16:06:40 <raildo> sajeesh: you're welcome :)
16:07:57 <sajeesh> It is a big change and concentrating on multiple areas at the same time is difficult..so your help is really needed
16:08:58 <schwicke> There are still a few tests failing in the automatic build
16:09:03 <schwicke> are those understood ?
16:09:04 <raildo> sure.. I'm trying do my best with code... let's see if we can have this merge asap
16:09:36 <raildo> schwicke: yeap.. in this next week, my main goal is fix all the tempest/others test
16:09:38 <sajeesh> schwicke...I am planning to work on that in this weekend
16:09:57 <raildo> and finally have all the patches working nice with jenkins
16:10:08 <sajeesh> yes
16:10:11 <schwicke> ok. great!
16:10:52 <schwicke> #action raildo and sajeesh will work on the remaining tests which are still failing in the next days
16:11:00 <sajeesh> AFAIK there are no roadblocks ...It can be solved
16:11:11 <schwicke> what are the python errors about ?
16:12:16 <sajeesh> I think It is due to some quota dependency ...I need to patch it
16:12:35 <raildo> the last time that i saw the log, I found some errors to unrelated tests, probably some erros on rebase...
16:12:56 <raildo> I need to take a look on it, with more time.
16:12:56 <schwicke> #link http://logs.openstack.org/28/149828/36/check/gate-nova-python34/c098433/
16:13:05 <sajeesh> that is also a possibility
16:13:07 <schwicke> #link http://logs.openstack.org/28/149828/36/check/gate-nova-python27/cfcf9e7/
16:14:03 <raildo> something like that "AttributeError: 'module' object has no attribute 'MaxRetriesExceeded'"
16:14:25 <sajeesh> that may be a rebase error
16:14:36 <schwicke> I think that if we manage to pass jenkins tests it would put us into a better position to ask for a code freeze exception
16:14:42 <sajeesh> yes
16:14:50 <schwicke> if it is easy to rebase let's do it and see if that helps already
16:15:09 <sajeesh> we will try
16:15:21 <raildo> I have made a rebase/refactoring today... just waiting fot the jenkins response
16:15:29 <sajeesh> ok
16:15:43 <schwicke> ok
16:15:50 <sajeesh> schwicke....there are 5 changes and out of that 4 are fully under control....
16:16:27 <sajeesh> and final one is the one which is giving some errors
16:17:31 <schwicke> I see
16:17:41 <schwicke> I'd love to get this stuff into liberty still
16:17:52 <schwicke> #topic timelines
16:17:58 <sajeesh> we will try our level best
16:18:21 <schwicke> what is the dead line to ask for a code freeze exception ?
16:18:31 <schwicke> IMO we should do that asap and try to get it in
16:18:32 <sajeesh> there is still some hope left
16:18:41 <sajeesh> Aug-6
16:19:23 <sajeesh> I will request with in one or two days....I haven't seen any request yet
16:19:23 <schwicke> so let's try to get the jenkins stuff fixed asap and then file the request ?
16:19:42 <sajeesh> schwicke ++1
16:20:30 <schwicke> #agreed fix jenkins errors if possible then file a code freeze exception request well before 6/8
16:20:43 <schwicke> very good.
16:20:49 <raildo> btw, I think that we need to talk with the nova cores, to ask for this FFE
16:21:02 <raildo> talk before send it...
16:21:08 <schwicke> yes.
16:21:17 <raildo> just to try get some more support on it
16:21:23 <sajeesh> ++1
16:21:29 <schwicke> ++1
16:21:46 <ericksonfgds> sounds good
16:21:49 <schwicke> re-occuring question: what is the best way to do that ?
16:22:06 <raildo> irc channel :)
16:22:14 <vilobhmm> hi everyone
16:22:22 <raildo> just ping the guys and explain our view
16:22:28 <schwicke> I htink in the past we explicitly put some of them onto the code reviewer list as well
16:22:35 <vilobhmm> sorry got caught in the traffic and was delayed for the meeting
16:22:44 <raildo> hey vilobhmm
16:22:46 <schwicke> Hi, vilobhmm
16:22:57 <vilobhmm> hello schwicke, raildo
16:23:07 <vilobhmm> are we talking about the nova code and code exception
16:23:12 <ericksonfgds> I think that put it as a topic in the nova weekly meeting is a good idea as well
16:23:18 <ericksonfgds> Hi, vilobhmm
16:23:23 <vilobhmm> hello eric
16:23:29 <schwicke> +1
16:23:48 <sajeesh> hi vilobh
16:23:53 <raildo> sure, I can put this in the meeting and talk with the nova folks
16:24:05 <schwicke> ok great!
16:24:29 <schwicke> #action Raildo will add an entry on the nova meeting agenda and contact the nova core team
16:24:34 <sajeesh> raildo, will it be better to talk after  clearing the jenkin's test ?
16:24:36 <vilobhmm> https://wiki.openstack.org/wiki/Meetings/Nova
16:24:49 <vilobhmm> we all should try to be present
16:24:57 <vilobhmm> and show representation as a group
16:25:02 <sajeesh> ++1
16:25:03 <schwicke> sajeesh: if we manage I think that is the best strategy
16:25:15 <ericksonfgds> but to get a code exception it's good to have at least some of the patches with +1 from jenkins
16:25:33 <vilobhmm> yes
16:25:36 <vilobhmm> agree
16:25:48 <schwicke> +1
16:25:51 <sajeesh> ok.
16:25:52 <ericksonfgds> so, I think it is a must to test our code in our own environment, to check if the tests are passing, whenever possible, before upload  it to gerrit.
16:25:52 <sajeesh> +1
16:25:53 <raildo> If think this is important to the FFE email... I just to say "hey guys, we are working a lot with this... and this will be really important, please review"
16:25:59 <ericksonfgds> So we don't waste time  of reviewers with broken tests.
16:26:01 <schwicke> that is why I'm pushing so hard to have the remaining tests go through
16:26:09 <raildo> I just want*
16:26:32 <sajeesh> ++1
16:26:51 <schwicke> ++1
16:26:54 <vilobhmm> can someone work with sajeesh for next week or so….to help make sure that jenkins shows + 1
16:27:02 <ericksonfgds> raildo, ++
16:27:25 <ericksonfgds> raildo is already helping sajeesh
16:27:28 <sajeesh> ++1
16:27:30 <raildo> vilobhmm: We have a action added, I'll work with him
16:27:39 <vilobhmm> oh okay thats awesome !
16:27:49 <sajeesh> thanks a lot :-)
16:27:52 <schwicke> I can try to ping Tim to raise the importance of this for CERN
16:28:14 <vilobhmm> schwicke : that will really help…i will ask someone from yahoo to join
16:28:14 <sajeesh> schwicke ++1
16:28:23 <sajeesh> vilobh ++1
16:28:25 <schwicke> in case he's around maybe I could ask him to participate in the nova meeting
16:28:32 <vilobhmm> perfect
16:28:47 <schwicke> #action schwicke will talk to Tim and ask him to participate in the nova meeting
16:28:48 <sajeesh> I think Andrey can also help us
16:28:59 <raildo> sajeesh: sure
16:29:03 <raildo> I'll talk with him
16:29:14 <sajeesh> ok..thanks raildo
16:31:08 <vilobhmm> If we are done with this topic would like to give cinder update
16:31:16 <sajeesh> ok
16:31:28 <schwicke> #action raildo will contact Andrey asking for help as well
16:31:57 <sajeesh> vilobh..u  had told that cinder deadline is on August end ...what is the date ?
16:32:35 <ericksonfgds> the code freeze is in the first week of September
16:32:36 <schwicke> good point
16:32:45 <schwicke> so there we have a bit more time
16:32:48 <sajeesh> that is good
16:32:49 <vilobhmm> sajeesh : right as eric pointed
16:33:07 <sajeesh> ok..we have time
16:33:48 <vilobhmm> Needs Code Review :-
16:33:48 <vilobhmm> https://review.openstack.org/#/c/206171/ - Nested Quota Driver: Get Project Hierarchy
16:33:49 <vilobhmm> https://review.openstack.org/#/c/205369/ - Cinder Nested Quota Driver
16:33:49 <vilobhmm> https://review.openstack.org/#/c/206170/4 - Fix get default quota values for subprojects
16:33:49 <vilobhmm> Already Merged :-
16:33:50 <vilobhmm> https://review.openstack.org/#/c/185704/ - Nested Quota : Create allocated column in cinder.quotas
16:33:51 <vilobhmm> https://review.openstack.org/#/c/194406/ - Nested Quota: Set default values to subproject
16:34:03 <sajeesh> ok
16:34:27 <ericksonfgds> once vilobhmm and I have done with cinder, if there is still time, I can help with nova code.
16:34:33 <vilobhmm> out of the things that need review only https://review.openstack.org/#/c/205369/ - Cinder Nested Quota Driver has some jenkins problem but should be fixed soon….other than that we are in pretty good shape
16:34:50 <vilobhmm> i can also help sajeesh when done with cinder code
16:34:57 <schwicke> that's very good news!
16:35:05 <sajeesh> erickson, vilobh ...thanks a lot :-)
16:35:10 <ericksonfgds> np
16:35:12 <ericksonfgds> :)
16:35:16 <vilobhmm> i would appreciate if you all can chip in for the things that needs to be reviewed for cinder
16:35:45 <schwicke> I wonder if it would make sense to try to help sajeesh now and return to cinder after that is sorted out. Would that not make more sense ?
16:36:04 <schwicke> just because we still have a bit more time left for cinder
16:36:14 <ericksonfgds> vilobhmm, in fact, it is missing one +1 workflow in order to get this patch merged: https://review.openstack.org/#/c/206170/4
16:36:16 <vilobhmm> schwicke : we would loose focus IMHO…
16:36:40 <ericksonfgds> I agree with vilobhmm
16:36:54 <schwicke> maybe you are right
16:37:05 <vilobhmm> once we get a green signal from nova folks that nested quota can go in liberty
16:37:06 <sajeesh> I also think so
16:38:10 <vilobhmm> we all can work together if needed but for now I would prefer cinder going in first and then serving as a reference model for rest of the projects in openstack who want to incorporate nested quota driver
16:38:32 <vilobhmm> schwicke : ^^
16:38:42 <vilobhmm> aw thats it from me….and thats about cinder update
16:39:02 <vilobhmm> also I would like to appreciate the work done by ericsonfgds
16:39:09 <sajeesh> yes
16:39:26 <ericksonfgds> thanks :)
16:39:33 <vilobhmm> he has been very helpful and instrumental and we both have worked well as a team IMHO
16:40:12 <vilobhmm> schwicke, raildo, rodrigo : ^^
16:40:33 <sajeesh> ok..great
16:40:38 <ericksonfgds> vilobhmm, you too, the working is flowing and that's nice.
16:40:44 <ericksonfgds> work*
16:41:33 <raildo> so.. I think that we don't have to change this now.
16:42:01 <vilobhmm> change what raildo ?
16:42:16 <raildo> you and ericksonfgds working on cinder :)
16:43:22 <vilobhmm> ok..sounds good :) atleast till changes for cinder are in…
16:43:28 <schwicke> #link https://wiki.openstack.org/wiki/Meetings/Nova
16:43:41 <vilobhmm> also the thing is there is an operators midcycle in second week of august
16:43:49 <vilobhmm> in california
16:44:09 <vilobhmm> so there also nested quota will be raised as an enhancement by the operators
16:44:22 <vilobhmm> we can stress that as well if needed to get an exception
16:44:34 <schwicke> do you have a link ?
16:44:47 <vilobhmm> it will be in second week of august schwicke
16:45:27 <vilobhmm> because atleast the operators from yahoo are going to talk about that requirement for sure
16:45:34 <vilobhmm> i will send the etherpad link if i get some…
16:46:53 <vilobhmm> do we have anything else to discuss ?
16:47:10 <schwicke> #agreed developments teams are left as they are. No need to re-arrange priorities for now
16:47:11 <sajeesh> vilobh,erickson....if we are getting exception we will get free exception on August-6 and the code has to merged by Aug-10.It will be nice if we can get some help from you during that period without breaking your flow
16:48:06 <sajeesh> as we had agreed let us don't change the priorities now
16:48:14 <sajeesh> shwicke ++1
16:48:27 <vilobhmm> sajeesh : for sure
16:48:28 <ericksonfgds> sajeesh, sure! I'll try to help in that period.
16:48:37 <schwicke> we should have a checkpoint on skype eg on Monday
16:48:43 <sajeesh> thanks a lot :-)
16:48:58 <vilobhmm> meanwhile the changes that are done for cinder minimizes lot of code duplication
16:48:58 <schwicke> thanks ! ericksonfqds
16:49:20 <schwicke> That's all I wanted to discuss today
16:49:24 <schwicke> #topic AOB
16:49:25 <vilobhmm> and in-order to use similar changes for nova…will need to bring nova to that state IMHO…nova still has lot of code duplication
16:49:28 <ericksonfgds> sajeesh, schwicke: you're welcome :)
16:50:21 <sajeesh> vilobh ...it has not been decided whether to keep a separate class for nested quota or not
16:50:51 <sajeesh> if we are keeping a separate class there will be code duplication
16:50:54 <schwicke> can we try to get the code merged as it is now and then optimize ?
16:51:09 <sajeesh> shwicke ++1
16:51:39 <schwicke> I guess once the core team looks at the code they will come up with some suggestions
16:51:51 <ericksonfgds> schwicke, sure
16:52:14 <schwicke> time is almost up
16:52:21 <schwicke> I think we have a plan :)
16:52:26 <schwicke> Good luck to all of us!
16:52:33 <sajeesh> shwicke..I have told to the nova about the pros and cons of keeping a separate class
16:52:47 <sajeesh> *nova core
16:53:16 <schwicke> any conclusions from their side ?
16:53:25 <sajeesh> not yet
16:53:33 <schwicke> so ... let's go ahead
16:53:37 <sajeesh> ok
16:53:39 <schwicke> with what we have now
16:53:46 <sajeesh> +1
16:54:38 <ericksonfgds> see you, have a nice weekend!
16:54:54 <schwicke> have a nice weekend!
16:55:01 <schwicke> #endmeeting