16:00:40 <schwicke> #startmeeting hierarchical_multitenancy
16:00:41 <openstack> Meeting started Fri Sep 11 16:00:40 2015 UTC and is due to finish in 60 minutes.  The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:44 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:01:12 <schwicke> hi, sajeesh!
16:01:16 <schwicke> welcome back!
16:01:29 <sajeesh> hi, schwicke ..thanks :-)
16:02:00 <sajeesh> I have started making test cases
16:02:39 <schwicke> #topic test cases for MTsupport for Nova
16:03:21 <schwicke> New once or extending the once we had already ?
16:03:41 <sajeesh> I am extending
16:03:57 <sajeesh> to have more coverage
16:04:06 <sajeesh> the more the better
16:04:18 * geoffarnold lurking
16:04:25 <schwicke> +1
16:04:44 <schwicke> for the BP, it has been resubmitted already for liberty, right ?
16:04:52 <sajeesh> yes
16:05:41 <schwicke> not liberty, sorry :)
16:05:52 <sajeesh> :)
16:06:06 <sajeesh> mitaka
16:06:38 <sajeesh> hi vilobh
16:06:43 <schwicke> Hi, vilobh!
16:07:05 <schwicke> Sajeesh is resuming the work by extending the test cases.
16:08:28 <schwicke> I'm checking for the BP for Mitaka ...
16:10:02 <vilobhmm_11> hello all
16:10:15 <sajeesh> hi
16:10:33 <sajeesh> vilobh, if I am not wrong in cinder u have not included the parent_id in the url right ?
16:10:37 <vilobhmm_11> as i mentioned on skype if the nested quota spec needs to be re-approved again for mitaka we should start with it
16:10:46 <schwicke> #link  https://blueprints.launchpad.net/nova?searchtext=quota
16:11:05 <sajeesh> yes it needs to be re approved
16:11:44 <vilobhmm_11> sajeesh : https://github.com/openstack/nova-specsquick steps to do so
16:12:03 <vilobhmm_11> please check the steps under Previously approved specifications
16:12:07 <schwicke> There are a couple of others in the same state
16:12:18 <sajeesh> thanks..we have followed that
16:12:48 <sajeesh> same thing we had done for liberty....In fact this spec was first approved for kilo
16:13:10 <vilobhmm_11> sajeesh : ok
16:13:13 <schwicke> The link gives me a 404
16:13:30 <vilobhmm_11> schwicke : https://github.com/openstack/nova-specs
16:13:44 <vilobhmm_11> try this : ^^
16:14:33 <schwicke> priority is set to "low:
16:14:35 <schwicke> don't like that
16:14:36 <sajeesh> https://github.com/openstack/nova-specs#previously-approved-specifications
16:15:59 <schwicke> if that's correct we should get the approval soon.
16:16:06 <sajeesh> yes
16:17:09 <sajeesh> vilobh, if I am not wrong in cinder u have not included the parent_id in the url right ?
16:17:27 <schwicke> #topic treatment of parent_id
16:17:44 <vilobhmm_11> nope
16:17:52 <vilobhmm_11> we calculate parent id on the fly
16:17:54 <schwicke> (just to conclude on the previous topic we should be fine for Nova and Mitaka for now)
16:18:08 <vilobhmm_11> depinfing on the project id passed
16:18:16 <sajeesh> in nova , I am also doing the same thing
16:18:22 <schwicke> ok
16:18:22 <vilobhmm_11> cool
16:18:56 <sajeesh> schwicke vilobh , I would like to have parent_id in the keystone token
16:19:10 <vilobhmm_11> schwicke, sajeesh  : we @ yahoo have special interest in nested quota for nova and we will be happy to help in what it takes to get this in for mitaka
16:19:24 <sajeesh> thanks ...vilobh ?
16:19:48 <vilobhmm_11> we can ask keystone team to do so…btu need to open a blueprint/spec
16:19:51 <vilobhmm_11> beforehand
16:20:00 <vilobhmm_11> and we should start early IMHO
16:20:13 <sajeesh> yes...I will start then
16:20:22 <vilobhmm_11> cool
16:20:31 <sajeesh> or...do we need to ask the keystone team to do so ?
16:20:40 <schwicke> Sajeesh, will you file a BP for keystone for this ?
16:20:51 <sajeesh> I can do
16:21:17 <vilobhmm_11> cool
16:21:21 <sajeesh> +1
16:21:26 <schwicke> #action Sajeesh will open a BP in keystone to have the parent ID included in the token for hierarcical projects
16:21:36 <schwicke> Great!
16:21:51 <schwicke> The other thing into which we should look is horizon.
16:22:07 <schwicke> the BP needs to be resubmitted as well. Not sure though who's working on this
16:22:07 <sajeesh> vilobh, in cinder is there any context checking done before the api call
16:23:01 <vilobhmm_11> sajeesh : i don't think so
16:23:53 <sajeesh> in nova we are having ....for that parent_id in token is very much required
16:24:10 <vilobhmm_11> ok we should start talking to keystone ASAP then
16:24:18 <sajeesh> +1
16:24:20 <schwicke> +1
16:24:36 <schwicke> we may need to patch the cinder code once we have that
16:24:50 <vilobhmm_11> lets do one thing I can take ownership of https://review.openstack.org/151327 and https://review.openstack.org/151677 and work towards getting this merged…sajeesh can focus on other patches so that he don't have to do the follow up thing on these patches and saves his time...
16:25:24 <ericksonsantos> Hi
16:25:31 <vilobhmm_11> hi eric
16:25:32 <ericksonsantos> a little bit late here :/
16:25:40 <vilobhmm_11> np :) welcome
16:25:45 <ericksonsantos> thanks :)
16:25:47 <schwicke> hi, welcome anyway :)
16:25:51 <schwicke> np
16:26:17 <ericksonsantos> schwicke, thank you
16:26:30 <vilobhmm_11> sajeesh, schwicke : ^^ what you think of above proposal
16:27:01 <sajeesh> vilobh....it is fine with me
16:27:13 <schwicke> for me it is ok if it is ok with Sajeesh :)
16:27:28 <schwicke> I have no objections. Thanks for the proposal1
16:27:39 <schwicke> It's a good idea
16:28:02 <sajeesh> I can spend more time on the patches following that
16:28:23 <schwicke> #agreed Vilob will take owership of  https://review.openstack.org/151327 and https://review.openstack.org/151677 to allow Sajeesh to work on other patches
16:28:48 <schwicke> the first one is owned by Raildo it seesm
16:29:14 <sajeesh> yes
16:30:41 <sajeesh> vilobh...in cinder any changes you are making the current cycle
16:30:57 <sajeesh> in the current cycle
16:31:09 <sajeesh> you were talking abt concurrency
16:34:42 <sajeesh> shwicke...vilobh got disconnected from IRC ..
16:34:52 <schwicke> yes, just noticed.
16:35:39 <schwicke> let's wait a little to give him a chance to come back
16:36:56 <schwicke> OK, let's try to follow-up with him via skype which still works for him
16:37:52 <sajeesh> +1
16:39:08 <schwicke> Vilob says: " not planning to do so in this cycle ...will add it depending on the adoption of nested quota
16:39:08 <schwicke> [18:38:25] Vilobh  Meshram: plan to make it more stable
16:39:08 <schwicke> [18:38:31] Vilobh  Meshram: before adding more features
16:39:08 <schwicke> "
16:40:21 <schwicke> +1 from schwicke, Sajeesh and ericksonsantos
16:41:17 <schwicke> Anything else on this topic ?
16:41:49 <schwicke> #topic summit attendance
16:42:06 <schwicke> I guess from CERN there will be a couple of people. Probably not me though
16:43:11 <schwicke> Sajeesh cannot make it, nor Vilob
16:44:33 <schwicke> #topic: AOB
16:45:27 <schwicke> let's continue the discussion on skype
16:45:47 <schwicke> #endmeeting