16:19:22 <schwicke> #startmeeting hierarchical_multitenancy
16:19:23 <openstack> Meeting started Fri Oct 23 16:19:22 2015 UTC and is due to finish in 60 minutes.  The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:19:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:19:26 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:19:33 <schwicke> hi all,
16:19:56 <schwicke> some stuff to be discussed today.
16:20:09 <schwicke> #topic preparation of summit
16:20:21 <schwicke> so from our side Belmiro and Tim will go there
16:20:56 <schwicke> As discussed internally, Belmiro has proposed hierarchical quotas of the unconference
16:21:10 <schwicke> https://etherpad.openstack.org/p/mitaka-nova-unconference
16:21:15 <schwicke> #link https://etherpad.openstack.org/p/mitaka-nova-unconference
16:21:56 <schwicke> including the list to the latest patches
16:22:29 <schwicke> #link https://review.openstack.org/#/c/151327
16:22:41 <schwicke> #link https://review.openstack.org/#/c/151677
16:22:53 <schwicke> #link https://review.openstack.org/#/c/200342
16:23:03 <schwicke> #link https://review.openstack.org/#/c/200941
16:23:14 <schwicke> #link https://review.openstack.org/#/c/149828
16:23:44 <schwicke> I'd like to re-check where we are with the implementation compared to the BP
16:24:20 <sajeesh> ok
16:25:23 <schwicke> my understanding of the implementation is that
16:25:54 <schwicke> we are inline with what has been released for Cinder in liberty
16:26:03 <schwicke> Correct ?
16:26:17 <sajeesh> yes...AFAIK
16:26:33 <schwicke> In particular: for root projects there is no change in behaviour
16:26:39 <sajeesh> yes
16:26:47 <schwicke> for sub-projects default quotas are set to zero.
16:26:52 <sajeesh> yes
16:27:02 <schwicke> My understanding is that the latter is something people like to question.
16:27:18 <sajeesh> but that is same as that in Cinder
16:27:33 <schwicke> So we may have to explain better why we are doing that.
16:28:03 <schwicke> It seems to be something which is evident to all of us but not to many other people in the community
16:28:19 <sajeesh> I also think so
16:29:51 <schwicke> I think that we should not stress too much the technical reasons for the implementation but rather the conceptual reasons
16:30:22 <sajeesh> +1
16:30:35 <schwicke> that is that sub-projects must respect the quota of the parent
16:31:08 <schwicke> right ?
16:31:23 <sajeesh> that is very much essential for maintaining consistency across the tree
16:32:01 <schwicke> exactly.
16:32:40 <schwicke> I wonder if we are suffering from the fact that we've been mostly presenting a very basic use cases where you have a tree like a->b->c
16:33:09 <schwicke> giving a more complex example with several sub-projects at the same level may help to motivate that.
16:33:26 <vilobhmm11> schwicke : few thoughts
16:33:34 <schwicke> yes, go ahead
16:34:24 <vilobhmm11> rather than explaining the hierarchical model and the use cases in text in (A->B->C) format it would be nice to have a graphical/picture format
16:34:33 <vilobhmm11> it helps to make the people understand quicker
16:34:36 <schwicke> ++1
16:34:40 <sajeesh> +1
16:34:40 <vilobhmm11> when we have limited time
16:35:35 <vilobhmm11> so we should consider #1. simple treee and then #2. little bit complex tree with fanout factor of 3 and depth 3 where we can explain the problems which we are visualizing and expecting and no one else is seeing
16:35:44 <schwicke> that might also help also to distinguish the concept from other ideas like user quotas
16:35:52 <sajeesh> +1
16:36:13 <vilobhmm11> because #2 is more like a real world scenario and #1 will hardly a real world scenario
16:36:23 <schwicke> correct.
16:36:26 <sajeesh> yes
16:36:38 <vilobhmm11> so I feel in unconference session having some graphic picture helps to gets the message straighten out
16:36:38 <schwicke> and my fear is that #1 is causing quite some confusion
16:37:04 <vilobhmm11> schwicke : exactly…its not good enough to cover all the use cases we plan to address with nested quota
16:37:31 <sajeesh> I think #2 will be fine
16:37:43 <sajeesh> I mean more than enough
16:37:54 <schwicke> #action create a more complex graph for the session and provide it to people who are in the session to explain the ideas again
16:38:20 <schwicke> volunteers to do that ?
16:38:30 <sajeesh> I can
16:38:54 <schwicke> I think such a picture should also pass on the idea of delegation of rights.
16:39:37 <sajeesh> I will draft it tomorrow and circulate ...and changes can be made on that
16:39:46 <vilobhmm11> sajeesh : if you can create a diagram based of https://review.openstack.org/#/c/209969/6/specs/mitaka/approved/nested-quota-driver-api.rst
16:39:47 <schwicke> ok !
16:39:49 <vilobhmm11> it would be nice
16:39:56 <sajeesh> sure ++1
16:40:02 <vilobhmm11> so that people are in sync with the spec
16:40:19 <schwicke> #action Sajeesh will create a more complex graph based on https://review.openstack.org/#/c/209969/6/specs/mitaka/approved/nested-quota-driver-api.rst
16:40:35 <vilobhmm11> and they don't have to rub there head to understand somethig new and they can refer to spec for greater details
16:40:52 <schwicke> exactly
16:41:10 <sajeesh> +1
16:41:27 <schwicke> The other thing on the implementation I'd like to clarify is how the driver(s) are implemented right now
16:41:36 <schwicke> #topic current implemenation strategy
16:42:11 <schwicke> For cinder I understand that the existing driver has been updated while for nova we have a new driver which the service provider can select instead of the default one
16:42:14 <schwicke> is that correct ?
16:42:29 <sajeesh> yes
16:42:36 <schwicke> and the nova driver re-uses some parts of the old driver.
16:42:42 <sajeesh> yes
16:42:50 <schwicke> in order to avoid code doublication.
16:42:56 <sajeesh> yes
16:43:11 <sajeesh> the main difference comes in the calculation of settable quotas
16:43:17 <sajeesh> minimum and maximum quotas
16:43:23 <sajeesh> a project can have
16:43:33 <schwicke> I'm bringing this up because both Tim and Belmiro understood from our IRC meeting with John that we agreed to implement a new driver which supports hierarchical quotas.
16:44:02 <schwicke> This is what we did, didn't we ?
16:44:08 <sajeesh> yes
16:44:37 <sajeesh> also in the quotas table we added a column for allocated quota
16:44:51 <sajeesh> that is the only schema change
16:45:42 <schwicke> though we are extending the database schema of the old driver. So we somehow still depend on it.
16:46:01 <vilobhmm11> sajeesh : let me go through settable quotas code and see if we can avoid duplication by creating nestedquotadriver
16:46:26 <sajeesh> vilobh: thanks
16:46:35 <vilobhmm11> schwicke, sajeesh : I would prefer not going into too much details in the un-conference session on the implementation aspect...
16:46:48 <schwicke> true
16:46:58 <vilobhmm11> that can be sorted out as part of patch submission
16:47:06 <schwicke> I was now more aiming at the latest remarks we got from John ...
16:47:20 <vilobhmm11> schwicke, sajeesh : getting the idea accepted is what we should target
16:47:29 <schwicke> +1
16:47:34 <sajeesh> +1
16:48:03 <schwicke> as well as explaining the differences to other proposals.
16:48:12 <vilobhmm11> schwicke : i will look into nova code to see how we can avoid duplication of code
16:48:18 <sajeesh> but, we need to emphazise that not much changes have been done to the existing set up
16:49:19 <vilobhmm11> sajesh : ok
16:49:23 <vilobhmm11> sajeesh : ^^
16:49:33 <schwicke> and pass on the message that it is implemented and ready to be tested from now on
16:49:42 <sajeesh> yes
16:50:29 <schwicke> Belmiro asked me for this kind of detail for any discussions. So I will pass on the messages:
16:50:40 <sajeesh> ok
16:52:04 <schwicke> just to summerize: the code is ready including functional tests; the implementation is inline with what has been released for cinder; for nova we have a separate driver and the site admin can choose which one to use via a configuration option. In case of root projects only there is no change in behaviour
16:52:06 <schwicke> OK ?
16:52:35 <sajeesh> fine
16:52:36 <vilobhmm11> schwicke, sajeesh : so in short for the un-conference session  #1. prepare graphic picture based of spec (so that idea gets convinced clearly) . For more details people can refer to spec for details #2. Send out a msg that code is up and ready for reviews
16:52:55 <sajeesh> yes
16:53:01 <schwicke> correct.
16:53:32 <schwicke> and eventually add the more complex example to the BP as well.
16:54:24 <sajeesh> we have avoided that to avoid confusion
16:55:09 <schwicke> That was all I had on the agenda for today.
16:55:13 <schwicke> #topic AOB
16:55:24 <sajeesh> once it is discussed in the summit....we can add it to the spec
16:55:49 <schwicke> yes.
16:55:53 <vilobhmm11> yes
16:55:54 <sajeesh> nothing from my side
16:56:11 <schwicke> Also for the comments of John I think the best is to discuss directly with him at the summit.
16:57:06 <sajeesh> I have send one reply ..vilobh can you please check...some help is required
16:57:27 <vilobhmm11> sure
16:57:34 <sajeesh> thanks
16:57:37 <vilobhmm11> sajeesh : np
16:58:29 <schwicke> we could post a comment about the session.
16:58:44 <sajeesh> ?
16:59:12 <schwicke> The link to the notepad of the unconference
16:59:18 <sajeesh> ok
16:59:19 <schwicke> just a suggestion.
16:59:36 <schwicke> time is out :(
16:59:44 <schwicke> #endmeeting