16:11:35 <schwicke> #startmeeting hierarchical_multitenancy
16:11:36 <openstack> Meeting started Fri Oct 30 16:11:35 2015 UTC and is due to finish in 60 minutes.  The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:11:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:11:39 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:11:46 <schwicke> Hi all
16:11:52 <schwicke> sorry for being late.
16:12:40 <sajeesh> Hi
16:12:41 <schwicke> we had a time change on Sunday last week so now the meeting is one hour earlier for us ...
16:13:36 <vilobhmm11> okay
16:13:40 <schwicke> who's there ?
16:13:44 <sajeesh> Hi
16:13:53 <schwicke> ok, great
16:14:02 <vilobhmm11> so i dont see this being accepted yet
16:14:03 <vilobhmm11> https://review.openstack.org/#/c/209969/
16:14:09 <vilobhmm11> hopefully it will
16:14:15 <vilobhmm11> as per dicussion in the summit
16:14:15 <schwicke> me neither.
16:14:25 <sajeesh> I think it will be done after the summit
16:14:30 <vilobhmm11> so if it gets accepted
16:14:32 <schwicke> The summit just finished so I guess people are traveling. I'm not that worried about this
16:15:10 <schwicke> main topic of todays meeting is how we can get ready for the OK, aka what can we do now already.
16:15:11 <vilobhmm11> ok
16:15:29 <schwicke> #topic getting the code up to speed
16:15:33 <vilobhmm11> regarding patches we can divide the patches between us and focus on patch in hand rather than everyone looking at every other patch…"divide and conquer" will help IMHO
16:15:44 <sajeesh> +1
16:15:48 <vilobhmm11> what you guys think ?
16:15:49 <schwicke> +1
16:15:52 <vilobhmm11> cool
16:15:55 <schwicke> I think that is a very good idea.
16:16:13 <vilobhmm11> ok..then lets do that
16:16:32 <vilobhmm11> sajeesh : do you have the list of ptaches handy ?
16:16:45 <sajeesh> one second
16:16:53 <schwicke> #agreed divide patches so that people can focus on bits and pieces and maintain them rather than everybody looking at everything
16:16:58 <vilobhmm11> once raildo and eric are back we can distribute it amongst sajeesh, vilobh, eric and raildo
16:17:10 <schwicke> +1
16:17:14 <sajeesh> +1
16:17:44 <vilobhmm11> always we all can chip in for reviews for other patches
16:17:59 <schwicke> I think this is very important.
16:18:01 <sajeesh> vilobh once you have show interest on this 2.Set default values to sub-projects and users.
16:18:01 <sajeesh> https://review.openstack.org/#/c/151677/
16:18:10 <sajeesh> right ?
16:18:51 <vilobhmm11> yes
16:19:04 <vilobhmm11> i showed interest in https://review.openstack.org/#/c/151327/32 and https://review.openstack.org/#/c/151677/
16:19:14 <vilobhmm11> and i am ok to take them ahead if needed
16:19:49 <vilobhmm11> sajeesh, schwicke : will take care of these patches
16:19:56 <schwicke> #action vilobhmm11 signed up for #link  https://review.openstack.org/#/c/151327/32 and https://review.openstack.org/#/c/151677/
16:20:04 <vilobhmm11> cool
16:20:14 <schwicke> (not sure if that made it :) Hope it did
16:20:53 <sajeesh> i think 327 is owned by raildo
16:20:54 <schwicke> sajeesh: which one do you want to pick ?
16:21:23 <sajeesh> I can pick the remaining ones
16:21:50 <sajeesh> one second
16:21:52 <vilobhmm11> sajeesh , schwicke : https://etherpad.openstack.org/p/nova-nested-quota-pacthes
16:21:59 <sajeesh> https://review.openstack.org/#/c/149828/
16:22:12 <vilobhmm11> created a etherpad to track who is owning what
16:22:13 <sajeesh> and 3.Modification of settable quotas of nested projects
16:22:13 <sajeesh> https://review.openstack.org/#/c/200342
16:22:20 <schwicke> good initiative!
16:22:37 <sajeesh> https://review.openstack.org/#/c/149828/ and https://review.openstack.org/#/c/200342
16:23:04 <schwicke> sajeesh: I think it makes sense to leave something for raildo and eric
16:23:09 <vilobhmm11> sajeesh : there are lots of changes in these 2 patches
16:23:29 <vilobhmm11> I would request you to divide work between eric and raildo
16:23:31 <sajeesh> Then I will take https://review.openstack.org/#/c/149828/
16:23:38 <vilobhmm11> I agree with  schwicke
16:24:09 <sajeesh> is that OJK ? https://review.openstack.org/#/c/149828/
16:24:16 <schwicke> yes
16:24:23 <schwicke> added yours to the pad
16:24:37 <vilobhmm11> cool
16:24:38 <schwicke> #action sajeesh will take care of https://review.openstack.org/#/c/149828/
16:25:13 <schwicke> what's left ? We had the full list given to belmiro before the summit
16:25:37 <sajeesh> two more are there 3.Modification of settable quotas of nested projects
16:25:38 <sajeesh> https://review.openstack.org/#/c/200342
16:25:38 <sajeesh> 4.Nested Quota Driver: Finding parent_id and immediate child list
16:25:38 <sajeesh> https://review.openstack.org/#/c/200941/
16:26:09 <schwicke> Let's suggest them to Eric and Raido. They can trade them between themselves :)
16:26:15 <sajeesh> +1 :-)
16:27:04 <vilobhmm11> sounds ok to me
16:27:11 <schwicke> Added them to the pad
16:27:12 <vilobhmm11> lets get it done then ! :)
16:27:18 <schwicke> yeah!
16:27:22 <sajeesh> :-)
16:27:31 <schwicke> #topic absences
16:27:37 <vilobhmm11> we can take a treat from sajeesh when all is done :P
16:27:49 <sajeesh> surely :-)
16:28:06 <vilobhmm11> yes please update regarding absense or any blockers beforehand
16:28:08 <schwicke> I think it would be good if people could announce on skype if they are unavailable for some period
16:28:19 <vilobhmm11> so that we can load balance the patches between ourselves
16:28:22 <sajeesh> ++1
16:28:24 <schwicke> We could even nominate backups for the patches in the pad
16:29:05 <schwicke> shall we add backups to the pad ?
16:29:13 <vilobhmm11> schwicke : lets work with this model for a week or so and see if it works
16:29:18 <vilobhmm11> if not we can have backups
16:29:32 <schwicke> yeah, fine by me!
16:29:38 <sajeesh> +1
16:29:41 <schwicke> okidoki
16:29:51 <schwicke> #topic what can we do right from the start
16:30:02 <vilobhmm11> eric and i have worked closely on cinder and used the same model as i proposed above and it worked for us…lets try it for nova as well
16:30:05 <schwicke> I think we can start doing internal reviews as of now
16:30:14 <vilobhmm11> ok
16:30:18 <sajeesh> +1
16:30:20 <schwicke> +1
16:30:44 <schwicke> can we rebase already to make the tests more green even with the -2 on it ?
16:30:51 <vilobhmm11> yes
16:30:59 <vilobhmm11> that should be the first step
16:31:14 <sajeesh> schwicke I will start doing it
16:31:15 <schwicke> #action rebase the patches and make the tests green as first action
16:31:55 <schwicke> We should really avoid having failing tests when some of the cores get interested after the BP has been accepted.
16:32:16 <schwicke> passing tests will encourage them to review the code I hope.
16:32:21 <sajeesh> +1
16:32:23 <vilobhmm11> yup
16:32:32 <schwicke> I think we have a plan
16:32:44 <vilobhmm11> cool
16:33:24 <schwicke> One remaining thing: I will check with Tim and Belmiro as soon as they are back for details about the discussions they had.
16:33:46 <schwicke> What I have in mind is how useful the more complex examples were which we provided to them
16:33:57 <schwicke> I wonder if or not it is useful to add them to the BP
16:34:31 <vilobhmm11> not sure if bp accepts images to upload ; if they do we definately can
16:34:48 <vilobhmm11> also these images and diagrams can be later useful for us to write blog or something
16:34:56 <vilobhmm11> once nested quota for nova is merged in
16:35:10 <schwicke> Yes.
16:35:13 <vilobhmm11> those graphs ; figures are more real life scenario
16:35:27 <vilobhmm11> and longterm they will be useful
16:35:33 <schwicke> At some point we should create some documentation.
16:35:41 <sajeesh> yes
16:35:47 <vilobhmm11> yup!
16:36:29 <vilobhmm11> alrite then…I don't have anything else ; are we good then ?
16:36:31 <schwicke> #link https://wiki.openstack.org/wiki/HierarchicalMultitenancy
16:36:37 <schwicke> I think we shoudl review this
16:36:56 <vilobhmm11> schwicke : +!
16:36:58 <vilobhmm11> +1
16:37:01 <sajeesh> +1
16:37:02 <vilobhmm11> makes sense
16:37:09 <schwicke> there we can certainly add the new pictures
16:37:18 <schwicke> #action review https://wiki.openstack.org/wiki/HierarchicalMultitenancy
16:37:21 <vilobhmm11> sounds good idea
16:37:26 <sajeesh> +1
16:37:45 <schwicke> I'll open an internal ticket on myself to go through this ...
16:38:27 <schwicke> #topic availability
16:38:41 <schwicke> I'm not around next Friday. Will be away for a couple of weeks
16:38:48 <schwicke> /weeks/days/
16:39:05 <sajeesh> I am available
16:39:06 <vilobhmm11> schwicke : I can lead it if you want me to…
16:39:13 <schwicke> I'll be back the Friday after that, ie.13th
16:39:17 <vilobhmm11> ok
16:39:21 <sajeesh> ok
16:39:28 <schwicke> that would be great.
16:39:33 <vilobhmm11> i guess we will have raildo and eric back by then
16:39:38 <raildo> I think that I'm a little late :P
16:39:39 <sajeesh> that means you will miss one IRC meeting right ?
16:39:46 <schwicke> I will be traveling during the time of the meeting so no way I can connect
16:39:49 <sajeesh> raildo ...hi
16:39:54 <schwicke> hi raido
16:40:05 <vilobhmm11> hello raildo!
16:40:06 <raildo> hey guys, i'll read the log later
16:40:23 <sajeesh> raildo..there is some work for you :-)
16:40:30 <vilobhmm11> so in short we created this etherpad for patch distribution amongst ourselves https://etherpad.openstack.org/p/nova-nested-quota-pacthes
16:40:34 <vilobhmm11> raildo : ^^
16:40:42 <vilobhmm11> you can check it here :)
16:40:53 <raildo> vilobhmm11: thanks
16:41:01 <schwicke> and we decided to announce unavailabilites and review https://wiki.openstack.org/wiki/HierarchicalMultitenancy
16:41:14 <schwicke> Hope the assignement is OK for you
16:41:29 <schwicke> and Eric
16:42:00 <raildo> I think this wiki page are outdated...
16:42:32 <raildo> we need to rewrite this doc page
16:42:59 <raildo> and related to the patches, we just have to change the API v2.1 and not the API v2
16:43:09 <raildo> so we have to rewrite this part of the code
16:43:26 <sajeesh> +1
16:43:38 <schwicke> #action rewrite patches to change API v2.1 and not the API v2
16:43:41 <schwicke> +1
16:43:46 <sajeesh> +1
16:43:47 <vilobhmm11> ok
16:43:48 <raildo> and if we will follow the cinder concept
16:43:57 <raildo> we are change the dbquotadriver
16:44:21 <raildo> so basically we have to rewrite this last patch
16:44:54 <raildo> I have made part of this effort in a poc here, I can do this, if it's ok for everyone :)
16:45:21 <vilobhmm11> sounds gr8 to me
16:45:28 <sajeesh> +1
16:45:36 <schwicke> no objections from my side
16:45:52 <sajeesh> raildo ...on which patch you will be working ?
16:46:15 <sajeesh> just a clarification
16:46:55 <raildo> I improved the keystone calls patches, and I rewrote the API changes patch, to conform with cinder's behaviour
16:47:13 <sajeesh> ok
16:48:00 <raildo> and I made a lot of tests :D
16:48:08 <sajeesh> ok :-)
16:48:12 <vilobhmm11> cool
16:48:27 <schwicke> Just a clarification. In cinder the existing driver was extended, and for nova we have a different driver right now, correct ?
16:48:37 <raildo> schwicke: yes
16:49:01 <schwicke> do you propose to update the patches so that we extend the existing driver in nova and drop the idea of having an independent driver ?
16:49:26 <sajeesh> we have consult john regarding this
16:49:37 <sajeesh> I think...
16:49:45 <raildo> schwicke: ++ since we decided to follow the cinder concept, right?
16:50:23 <sajeesh> raildo...do we need to consult john regarding this ?
16:50:36 <schwicke> Hmm... I'm not a big friend of this approach. I think it is better for side admins to select what they want to use
16:51:05 <vilobhmm11> in cinder we did not create a a sepearet nested quotadriveråschwicke, sajeesh, raildo :
16:51:05 <raildo> schwicke: but it doesn't impact any admin that are not using HMT
16:51:42 <raildo> adn we don't need change anything in the nova.conf
16:51:46 <vilobhmm11> raildo : yes
16:51:46 <sajeesh> vilobh ...I know that....but I just want to take the opinion of john
16:51:47 <raildo> or something like that
16:52:09 <schwicke> I see your point.
16:52:19 <vilobhmm11> sajeesh : sure..you can ask john
16:52:28 <sajeesh> +1
16:52:32 <schwicke> it depends a bit on what exactly was decided in the unconference discussion
16:52:46 <sajeesh> I will ping john
16:52:54 <schwicke> Can we make the current version green again first while checking with the cores ?
16:52:59 <raildo> I think that we can wait for the summit end
16:53:06 <sajeesh> shwicke ++1
16:53:15 <raildo> talk with the erickson and belmiro
16:53:39 <schwicke> Will do that. I think Belmiro will still be away next week though, and the week after I'm away ...
16:53:42 <raildo> if john had agreed in implement as the cinder's behaviour
16:54:18 <schwicke> needs clarification.
16:54:21 <raildo> ok
16:54:53 <vilobhmm11> schwicke : may be lets confirm once more from people who were in conf
16:55:25 <schwicke> I suggest we rebase and update the current stuff to make everything pass all tests when the BP gets accepted, and verify in the mean time with the people who were there what was decided
16:56:00 <vilobhmm11> in progress…https://review.openstack.org/#/c/151327/ … rebased and uploaded new patch
16:56:12 <schwicke> cool :)
16:56:50 <sajeesh> schwicke ....regarding work division if raildo is interested in api calls , I will take care of https://review.openstack.org/#/c/200342
16:56:54 <schwicke> do we agree on this strategy ? Doesn't stop us to work in the background on a rewrite of the patch so that we can release it when people want it.
16:57:10 <vilobhmm11> i think we should have a quick conclusion on whether take cinder's approach or have seperate nested quota driver class
16:57:17 <vilobhmm11> as https://review.openstack.org/#/c/151677/42 will need a clarity
16:57:17 <schwicke> just change it in the pad so that we keep track of it.
16:57:31 <sajeesh> raildo ....what do you think ?
16:57:59 <raildo> sounds good for me :)
16:58:12 <sajeesh> :-)
16:59:04 <schwicke> vilobhmm11: I think we cannot decide on this right now. We need more feedback from the session. So let's first make the current stuff work again
16:59:35 <sajeesh> schwicke ++1
16:59:51 <vilobhmm11> schwicke : for https://review.openstack.org/#/c/151677/42 has lots of duplicated code
17:00:30 <vilobhmm11> because there is no clarity on using cinder approach or seperate class
17:00:36 <schwicke> ... which people will probably dislike ...
17:00:55 <vilobhmm11> just rebasing patch for the sake of it doesn;t seem right to me; we should do what is right
17:01:03 <raildo> we need finish the meeting...
17:01:04 <schwicke> I'll try to reach Belmiro and Tim
17:01:07 <schwicke> yes.
17:01:07 <vilobhmm11> ok
17:01:11 <sajeesh> pk
17:01:14 <sajeesh> ok
17:01:15 <vilobhmm11> thanks!
17:01:34 <schwicke> #endmeeting