03:01:17 <hongbin> #startmeeting higgins
03:01:18 <openstack> Meeting started Fri May 13 03:01:17 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:01:22 <openstack> The meeting name has been set to 'higgins'
03:01:27 <hongbin> #link https://wiki.openstack.org/wiki/Higgins#Agenda_for_2016-05-13_0300_UTC Today's agenda
03:01:28 <harlowja_at_home> yo yo
03:01:33 <dims> o/
03:01:33 <hongbin> #topic Roll Call
03:01:39 <mkrai> Madhuri Kumari
03:01:39 <Qiming_> o.
03:01:45 <yuanying_> o/
03:01:45 <harlowja_at_home> U can call me Mr. Josh
03:01:52 <hongbin> Hongbin Lu
03:01:55 <Qiming_> Mr. Josh, hi
03:01:58 <harlowja_at_home> lol
03:01:58 <shu-mutou> o/
03:01:59 <dims> Dims
03:01:59 <sheel> Sheel Rana
03:02:42 <hongbin> Pause a few minutes for other potential attendees
03:03:09 * harlowja_at_home holds my horses
03:03:16 * Qiming_ selling tickets at the door
03:03:24 <hongbin> haha
03:03:27 <hongbin> #topic Welcome
03:03:32 <yanyanhu> we also need beverage :)
03:03:37 <hongbin> Welcome to join the first Higgins team meeting.
03:03:47 <hongbin> The purpose of this meeting is to collect requirements from everyone and drive consensus on the project roadmap.
03:04:03 <hongbin> Thanks everyone for coming today to discuss the existing project with us.
03:04:07 <sheel> thanks hongbin for setting this all
03:04:17 <hongbin> #topic Introductions
03:04:30 <hongbin> In this section, I'd like to give everyone an opportunity to introduce themselves, and say what you work on and why you interest in the Higgins project.
03:04:44 <hongbin> I can start first.
03:04:53 <hongbin> My name is Hongbin Lu. I works for Huawei Canada, and I am the current Magnum PTL.
03:05:02 <hongbin> I want an OpenStack Container service that is integrable with different container technologies.
03:05:17 <hongbin> My role here is providing helps to create a new team (DONE), and then pass the responsibility to the new team.
03:05:26 <hongbin> That is all from me. Who would like to go next?
03:05:37 <sheel> Ok, I am Sheel Rana
03:05:48 <sheel> currently works with Cinder and Nova teams
03:05:56 <sheel> from NEC India
03:06:03 <mkrai> Madhuri Kumari, Magnum Core. I work with Intel, India.
03:06:36 <harlowja_at_home> I'm josh, current oslo ptl, core on many different things (in and outside of openstack), created multiple libraries used in different places, working at godaddy (previously yahoo), been in openstack for like 5 years, we are looking into the kube <-> openstack kind of integration but are also (personally and as a company interested in the general area here and ... TBD ...
03:07:23 <harlowja_at_home> I think therefore I am
03:07:24 <harlowja_at_home> and thats me
03:07:45 <mkrai> I have been working on containers for an year or so. So interested in enabling containers on Openstack. That's all from me
03:08:07 <hongbin> Thanks. Next?
03:08:09 <Qiming_> Qiming Teng, IBM, senlin PTL, heat core, based in Beijing, China
03:08:24 <dims> My nick name is Dims, just listening in. have helped with some related projects before.
03:08:37 <harlowja_at_home> dims, u are more than that!
03:08:39 <Qiming_> looking for a generalized abstraction of containers on openstack, so containers can be treated as first-class-citizen someday
03:08:39 <harlowja_at_home> :)
03:08:50 <haiwei_> I am xuhaiwei, from NEC, currently core of Senlin project, also focus on NFV
03:08:54 <dims> :)
03:09:08 <yanyanhu> I'm Yanyan Hu, from IBM China research lab, the same as Qiming. I'm from Senlin team. I also have worked on Mesos/Marathon scalability study for about half year.
03:09:15 <Namrata_> Namrata Sitlani based in India an individual contibutor.
03:09:41 <hongbin> Cool
03:09:42 <shu-mutou> I'm Shu Muto, Magnum-UI core, from NEC. I'd like to implement UI for Higgins. Thanks.
03:09:57 <haiwei_> UI man
03:10:05 <sheel> 👍
03:10:24 <yuanying_> I am OTSUKA, Yuanying from NEC. I want to use container technology without managing a lot of things.
03:10:37 <yanyanhu> :)
03:11:03 <hongbin> Seems that is all for everyone
03:11:09 <hongbin> #topic Announcements
03:11:14 <mkrai> Welcome everyone:)
03:11:18 <hongbin> #link https://review.openstack.org/#/admin/groups/1382,members Initial Higgins core team
03:11:41 <hongbin> The core team was created based on expressed interest in the etherpad
03:11:56 <sheel> fair enough
03:12:00 <hongbin> Anyone else want to join the core team? (or be removed)
03:12:12 * harlowja_at_home i can't say yet, perhaps in the future
03:12:18 <harlowja_at_home> need to see what this turns into first :-P
03:12:29 <hongbin> harlowja_at_home: ack
03:12:47 <hongbin> #topic Drive consensus on requirements
03:12:57 <hongbin> #link https://etherpad.openstack.org/p/container-management-service etherpad for collaborating on project requirements
03:13:11 <hongbin> In this section, I have the etherpad to record our requirements.
03:13:20 <hongbin> I will pause for a while to let everyone write down your opinions in the etherpad.
03:13:53 <mkrai> hongbin, Before we start I have some concerns.
03:14:05 <hongbin> mkrai: go ahead
03:14:19 <mkrai> Is openstack community accepting this project?
03:14:41 <mkrai> We have nova-docker also
03:14:45 <dims> mkrai : this is under big tent, we have all access as much as other projects
03:14:57 <harlowja_at_home> what means accepting in your mind mkrai ?
03:14:58 <yanyanhu> mkrai, the project has been accepted :)
03:15:12 <hongbin> Not for big tent yet
03:15:25 <hongbin> We need to have a working history to meet the 4 opens
03:15:35 <mkrai> Yes agree about that
03:15:35 <hongbin> Then, we are able to join the big tent
03:16:17 <hongbin> mkrai: any other concern?
03:17:09 <hongbin> From the comments on etherpad, it looks there is an argument about the scope of the project
03:17:17 <mkrai> No let's just kickstart things
03:17:58 <hongbin> Therefore, I summarize the proposed scopes in the last session
03:18:40 <hongbin> Obviously, there are many proposed ideas. It seems we cannot statisfy all of them
03:19:29 <hongbin> I am thinking if we could have everyone vote on the list
03:19:44 <harlowja_at_home> seems like there are as many ideas as people :-P
03:19:52 <harlowja_at_home> 1 vote for each, lol
03:20:14 <hongbin> harlowja_at_home: yes. That is allowed....
03:20:34 <harlowja_at_home> k
03:20:40 <Qiming_> I'm not gonna vote for Trump
03:21:05 <yanyanhu> lol
03:21:13 <dims> question is where do we start
03:21:40 <vivek_> Hi hongbin. I am Vivek Jain an Individual contributor from India. I am also interested in working on Higgins UI.
03:22:00 <hongbin> vivek_: hey
03:22:05 <hongbin> vivek_: welcome
03:22:13 <vivek_> hongbin: Thanks:)
03:22:15 <hongbin> vivek_: We are working on the etherpad
03:22:30 <hongbin> vivek_: https://etherpad.openstack.org/p/container-management-service
03:22:35 <vivek_> Thanks hongbin
03:27:21 <sheel> hongbin:  here i would like to ask on etherpad query - line 9 :  what is being abstracted?
03:27:45 <dims> here's looks like we are heading to consensus on initial tasks
03:27:49 <hongbin> sheel: The initial proposal is to abstract containers
03:28:21 <sheel> hongbin: ok
03:29:52 <hongbin> dims: Yes, some items get most votes, which is the good canadidate for initial implementation
03:30:02 <dims> wearing my TC Hat, we should NOT compete with container frameworks like Mesos or Kubernetes
03:30:32 <dims> over time may be, we should not start there
03:31:11 <harlowja_at_home> +1
03:31:39 <harlowja_at_home> that's why i still like the docker-compose-like thing still, but idk
03:31:49 <dims> this came up in the board/tc meeting fyi - https://etherpad.openstack.org/p/6PuSKyUOHk
03:32:00 <harlowja_at_home> holy crap
03:32:52 <dims> we need to co-exist and cooperate with others frameworks and foundations..not take over
03:33:49 <dims> if we do container composition, we should schedule to swarm, kubernetes, mesos etc. for example
03:34:06 <harlowja_at_home> that'd be fine with me (internal impl detail imho)
03:34:33 <hongbin> dims: you concern is the pod things?
03:35:29 <dims> hongbin : passing alone what was discussed whether i agree or not :)
03:35:30 <hongbin> dims: Or I might ask which proposed ideas that make you feel we are competing with COEs?
03:36:13 <dims> s/alone/along/
03:36:56 <hongbin> My feeling is that if we focus on abstracting different container technology, we won't compete with COEs
03:37:21 <hongbin> But if we want advanced features, like rolling upgrade, etc. then we are at risk
03:37:46 <yanyanhu> +1
03:37:52 <dims> hongbin : yep
03:38:01 <Qiming_> dims, could you pls shed us some lights on " we should NOT compete with container frameworks like Mesos or Kubernetes", why is that a big concern?
03:38:34 <gus> .. except the COEs do not offer identical features .. so are you proposing 3 (at least) different "container-ish things" that you can create?
03:38:42 <gus> .. or a lowest common denominator?
03:39:48 <hongbin> OK. It looks everyone finishes writing?
03:40:15 <dims> Qiming_ : long conversation will need folks like ttx and mordred about how to be a good citizen in the overall eco system
03:40:22 <dims> hey gus !
03:40:35 <Qiming_> I see
03:40:35 * gus stumbled into this meeting purely by accident
03:40:40 <gus> ;)
03:40:47 <harlowja_at_home> i'm a law-abiding citizen
03:40:50 <harlowja_at_home> and also good
03:40:53 <dims> Qiming_ : let me dig some info when i get a chance
03:41:32 <hongbin> From the etherpad, it looks most people like this idea: Basic container operations (i.e. CRUD)
03:41:42 <sheel> 👍
03:41:52 <Qiming_> yep, that is the core of the project
03:41:56 <yanyanhu> +1
03:41:58 <hongbin> I would suggest we start with that
03:42:00 <mkrai> Yeah +1
03:42:18 <mkrai> With docker intially?
03:42:19 <haiwei_> yes
03:42:23 <yanyanhu> agree
03:42:29 <sheel> +1
03:42:35 <hongbin> Sounds good
03:42:38 <flwang> hongbin: i'm interested in the relationship between magnum and higgins
03:42:51 <vivek_> +1
03:42:56 <dims> +1
03:43:01 <hongbin> flwang: you have specific question?
03:43:09 <flwang> that would be the 1st line of FAQ
03:43:28 <hongbin> flwang: sure I can fill that
03:43:40 <flwang> hongbin: since if we have Higgins, Heat can talk with Higgins directly
03:44:03 <hongbin> #action hongbin fill FAQ to explain the relationship between Magnum and Higgins
03:44:12 <flwang> hongbin: thanks :)
03:44:15 <dims> fyi, at https://github.com/dims/mincntr/tree/master/mincntr i have list and create operations for docker and k8s if we want to start there
03:44:33 <hongbin> flwang: Yes, Higgins should be independent of Magnum, with an option to integrate with Magnum
03:44:45 <dims> i maintain the python-k8sclient repo as well along with the magnum team
03:44:55 <hongbin> flwang: (that is my person oponions)
03:45:19 <hongbin> dims: thx
03:45:24 <mkrai> hongbin, mine too. Higgins should be independent of Magnum.
03:45:26 <flwang> dims: will the Higgins have to recreate all the wheels of Nova did?
03:45:33 <hongbin> #link https://github.com/dims/mincntr/tree/master/mincntr
03:45:45 <dims> flwang no. it will be a proxy/pass-through
03:46:18 <hongbin> We should avoid to duplicate with any other OpenStack project
03:46:18 <flwang> dims: like a client? instead of a service?
03:46:45 <hongbin> flwang: My understanding is like Ironic for baremetal
03:47:18 <dims> flwang . higgins CLI -> higgins REST API -> higgins API -> calls Docker API or K8S API
03:47:32 <harlowja_at_home> hmmmm, durn, i'd have liked a the docker-compose-like-service; aka, here is my docker-compose like yaml, go higgins make it happen (and user is done)
03:47:35 <dims> we start there
03:47:51 <sheel> dims: +1
03:47:53 <dims> harlowja_at_home : yep, that will call the higgins REST API
03:48:02 <gus> dims: In which case do we use magnum to provide the k8s api?
03:48:07 <dims> docker-compose-like-service can call higgins REST API
03:48:32 <dims> gus : this should work against k8s whether or not deployed by Magnum
03:48:35 <mkrai> gus,  We are removing all container related API from Magnum
03:48:35 <gus> In particular: what's the proposed strategy for multi-tenancy?
03:48:43 <harlowja_at_home> imho higgins would be the receiver of that yaml (and it would figure out how to do all the things) :-P
03:48:59 <harlowja_at_home> (but i do see the value of primitives and getting them working right)
03:49:00 <dims> harlowja_at_home : that's do able too. once we get past CRUD
03:49:15 <dims> y, stage 2
03:49:23 <flwang> dims: cool
03:49:35 <gus> so again: multi-tenancy.  k8s doesn't provide strongly isolated containers.
03:49:41 <hongbin> gus: There are two types of container (Clear Container/Hyper like, docker like). They might have differnet multi-tenancy strategy
03:49:55 <harlowja_at_home> i guess gus do we want to aim for the now, or for 6 months from now
03:50:17 <hongbin> #topic Open Discussion
03:50:20 <mkrai> I have heard that Kuryr provides multi-tenancy
03:50:39 <gus> well, if we're planning to build on k8s, then we might consider having "multiple" k8s APIs, for each tenant.  This is basically what magnum provides.
03:50:39 <harlowja_at_home> so depends on what variant of multi-tenancy that means :-P
03:50:47 <gus> mkrai: kuryr is only network (at least for now).
03:50:56 <dims> so, who has time for actual work? :)
03:51:05 <harlowja_at_home> dims,  i thought u had it all done already
03:51:05 <baohua> yes, kuryr guy here
03:51:28 <flwang> harlowja_at_home: +1 :)
03:51:28 <sheel> dims: i am in
03:51:48 <flwang> dims: count me
03:51:50 <mkrai> me too
03:51:54 <yuanying_> dims: me too
03:51:55 <hongbin> I will part-time contribute (full-time on Magnum)
03:52:04 <baohua> +1 in part-time
03:52:16 <haiwei_> part-time for me
03:52:21 <sheel> full time for me
03:52:23 <vivek_> I am in
03:52:24 <yuanying_> 50%
03:52:29 <dims> usual problem i see is (example kolla-k8s) is folks are very interested but have current obligations. hence the ask :)
03:52:36 <harlowja_at_home> to me thats in part why the API would be a docker-compose-like-thing vs the primitives, because u can basically say for v1 of this system, it will not be hardened multi-tenancy, but in the future u can just change out the backend implementation with one that is more hardened for multi-tenancy
03:52:40 <Namrata_> count me
03:52:45 <dims> very cool!
03:52:52 <yanyanhu> count me as well, although maybe not fulltime
03:53:06 <mkrai> Seems we have lots of contributor
03:53:15 <dims> looks like we can get cranking immediately
03:53:17 <harlowja_at_home> i can write some comments and such
03:53:18 <chandankumar> \o/
03:53:30 <hongbin> chandankumar: hey
03:53:32 <sheel> yes we can
03:53:34 <chandankumar> hongbin, Hello
03:53:40 <gus> harlowja_at_home: I think you're underestimating the differences between COEs (and rkt vs docker, etc)
03:53:41 <sheel> chandankumar:  hi
03:53:51 <hongbin> chandankumar: we are in open discussion
03:54:00 <harlowja_at_home> gus, well who said anything that the docker-compose-like-yaml would have to target them all initially ;)
03:54:17 <chandankumar> hongbin, i will take a look at the meeting minutes.
03:54:21 <hongbin> chandankumar: you can relay your inputs to https://etherpad.openstack.org/p/container-management-service later if you want
03:54:28 <chandankumar> sure
03:54:53 <mkrai> hongbin, How are we gonna distribute tasks?
03:54:59 <gus> just saying, fundamental things like pods and the network environment exposed to containers varies *greatly* between all the different things out there.
03:55:07 <hongbin> mkrai: use BP :)
03:55:10 <mkrai> I am afraid people might spend time working on same thing
03:55:31 <dims> +1 to BP
03:55:36 <Qiming_> gus +1
03:55:37 <mkrai> Works for me
03:55:53 <dims> mkrai : we can start weekly meetings to figure out who is doing what too right?
03:56:03 <chandankumar> BP will be a better option
03:56:14 <hongbin> Yes, the weekly meeting
03:56:19 <mkrai> Yes dims
03:56:33 <mkrai> hongbin, let's book a weekly slot for us
03:56:37 <gus> So .. what's a use-case for this project?
03:56:42 <harlowja_at_home> gus fair enough, let's see where stage1 here goes, maybe the more advanced thing is stage2, idk
03:56:53 <sheel> we are about to running out of time...3 more minutes left
03:56:56 <hongbin> Everyone want a weekly meeting?
03:57:00 <Qiming_> I usually don't attend meetings at 3am
03:57:03 <sheel> hongbin: yes
03:57:15 <hongbin> #action hongbin schedule a weekly meeting for Higgins
03:57:22 <dims> Qiming_ : almost midnight for me and hongbin
03:57:31 <gus> I see a whole lot of desired buzz words on the etherpad, but not any suggestion of what this offers to an end user.
03:57:42 <hongbin> I am thinking if we should have an alternate meeting biweekly
03:57:44 <Qiming_> try doodle then, :)
03:57:49 <harlowja_at_home> gus agreed
03:58:12 <hongbin> OK. Doodle will work
03:58:13 <sheel> gus +1
03:58:46 <dims> gus : it started from folks like trove wanting to use a single api to talk to anything deployed by magnum
03:58:46 <hongbin> gus: It offers a container abstraction backed by different container tech
03:58:53 <gus> .. and remember that the alternative that we need to compare ourselves against is doing something like a coreos VM with a few containers started via cloud-init.
03:59:21 <harlowja_at_home> go cloud-init!
03:59:22 <dims> gus : yep
03:59:23 <harlowja_at_home> lol
03:59:28 <gus> .. or just using the native k8s / swarm / mesos API directly.
03:59:44 <gus> I'm struggling to see what sort of user wouldn't already be satisfied with one of those.
03:59:49 <dims> trove will need 3 impls for same tasks...yes
04:00:09 <Qiming_> if people prefer k8s, then they should go k8s->magnum->openstack
04:00:29 <harlowja_at_home> orrrrr this group can focus on the k8s<->openstack integration parts
04:00:48 <harlowja_at_home> https://groups.google.com/forum/#!forum/kubernetes-sig-openstack ;)
04:01:02 <hongbin> OK, time is up
04:01:07 <Qiming_> thanks for the link, harlowja_at_home
04:01:11 <harlowja_at_home> np
04:01:15 <dims> harlowja_at_home : ha. nice try
04:01:16 <hongbin> All, thanks for joining hte meeting
04:01:20 <harlowja_at_home> dims, shhhh
04:01:21 <harlowja_at_home> lol
04:01:23 <mkrai> Thanks everyone!
04:01:23 <gus> dims: re the trove use case - they aren't going to get that.  If you want to install a multi-node (aka reliable) database then you need to configure your job differently for the different COEs in order to reach your peer servers.
04:01:24 <sheel> thanks
04:01:28 <hongbin> #endmeeting