21:59:43 <gabrielhurley> #startmeeting horizon
21:59:44 <openstack> Meeting started Tue Dec  4 21:59:43 2012 UTC.  The chair is gabrielhurley. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:59:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:59:48 <openstack> The meeting name has been set to 'horizon'
21:59:51 <gabrielhurley> huzzah
22:00:13 <gabrielhurley> No formal agenda today as it's the first meeting. I'll try and start publishing one regularly in th future.
22:00:27 <ttrifonov> Aloha
22:00:30 <gabrielhurley> can I get a quick show of hands from folks who are here for this meeting, just so I know who I might be talking to?
22:00:44 <gabrielhurley> hi ttrifonov, been a bit, glad you're here!
22:00:48 <ttrifonov> \m/
22:00:53 * mrunge is here
22:01:46 <ttrifonov> I've been off for a while, hope to be around for grizzly-2
22:01:55 <gabrielhurley> Cool. Well let's tentatively run the meeting this way: 1) general status, 2) blueprint/critical bug review, 3) open discussion/QA time.
22:02:13 <gabrielhurley> #topic General Horizon Status
22:03:00 <gabrielhurley> G1 wrapped up nicely, with only two possible bugs reported in the last couple days that I would deem "serious".
22:03:20 <gabrielhurley> G2 is off to a bit of a slow start (partly my fault for being sick and busy), but I expect it to pick up and I'm sure these meetings will help.
22:03:36 <mrunge> do you have a reference to those serious bugs?
22:03:49 <gabrielhurley> I'll bring 'em up in the next section ;-)
22:03:57 <mrunge> great
22:04:34 <gabrielhurley> I want to acknowledge that the pace of Gerrit reviews has also slowed. I need to be more vigilant, and I also intend to harass people with core review powers to do their jobs more often
22:04:42 <gabrielhurley> in a nice way, of course :-D
22:05:07 <ttrifonov> the dopenstack way
22:05:15 <mrunge> how many core reviewers are out there currently?
22:05:16 <gabrielhurley> of course
22:05:27 <gabrielhurley> there are ~5 that should be active including myself
22:05:32 <mrunge> in the last, I have only seen two or three
22:05:39 <gabrielhurley> hence the problem
22:05:40 <gabrielhurley> heh
22:05:48 <gabrielhurley> I've also started leaning towards taking multiple +1's from non-core reviewers whom I know/trust in place of additional +2's from core.
22:05:49 <mrunge> ;-)
22:05:58 <gabrielhurley> especially on smaller patches
22:06:03 <gabrielhurley> blueprints definitely need core reviewers
22:06:27 <gabrielhurley> anyhow, just a little added encouragement to keep people who may not be "core" active
22:06:33 <gabrielhurley> I think we can move to the next topic
22:06:41 <gabrielhurley> #topic Blueprints and Bugs
22:06:56 <gabrielhurley> as I mentioned, there are two bugs that came out of G1 that I want to look at ASAP
22:07:11 <gabrielhurley> https://bugs.launchpad.net/horizon/+bug/1086290
22:07:12 <uvirtbot> Launchpad bug 1086290 in horizon "Edit flavor with extra specs fails" [High,Confirmed]
22:07:45 <gabrielhurley> That one I thought we had tests for and had specifically addressed in the original patch, but there are reports of it not working, so it needs to be confirmed/fixed
22:08:05 * gabrielhurley needs a second to find the other one...
22:08:56 <gabrielhurley> here we go: https://bugs.launchpad.net/horizon/+bug/1084137
22:08:57 <uvirtbot> Launchpad bug 1084137 in horizon "login not possible if not service "volume" defined on keystone" [Undecided,Incomplete]
22:09:08 <gabrielhurley> I haven't confirmed that yet since I just triaged it this morning
22:09:27 <gabrielhurley> but given the reworkig we did of the quota/usage tabulation in G1 I want to make sure we didn't introduce a regression.
22:09:44 <gabrielhurley> I hesitate to confirm it outright because the same reporter filed another bug that was the result of a misconfigured keystone catalog
22:09:59 <gabrielhurley> so someone needs to try building out a devstack without cinder/n-vol and see if Horizon works
22:10:03 <mrunge> hasn't been there a patch to avoid that? one week ago?
22:10:10 <gabrielhurley> possibly
22:10:12 <gabrielhurley> needs confirmation
22:10:22 <gabrielhurley> that's why the bug is marked incomplete
22:10:27 <gabrielhurley> I just want to be sure we don't have a regression
22:10:48 <gabrielhurley> any takers for investigating?
22:11:01 <mrunge> I'll have a look on that
22:11:13 <mrunge> (the second one)
22:11:22 <gabrielhurley> awesome, thank you
22:11:55 <gabrielhurley> I'm not aware of any other new bugs that rank above a "medium" priority, and the bugs on the list are all pretty standard, so let's talk BPs for a minutes
22:11:58 <gabrielhurley> *minute
22:12:18 <ttrifonov> I'll volunteer for the Swift bug,
22:12:30 <gabrielhurley> excellent
22:12:37 <ttrifonov> in fact it should be fixed with the patch in swift-pythonclient
22:12:42 <gabrielhurley> even better
22:12:49 <ttrifonov> but there is some oboslete code that needs to be removed in api/nova
22:12:55 <ttrifonov> *obsolete
22:12:57 <gabrielhurley> gotcha
22:13:05 <gabrielhurley> hopefully not too hard to clean up
22:13:10 <ttrifonov> I just have to check if everything works now,
22:13:15 <ttrifonov> no, few lines with TODO
22:13:36 <gabrielhurley> cool
22:13:40 <gabrielhurley> anyhow, on the blueprints
22:13:42 <gabrielhurley> so, davidlenwell and his team are gona tackle most of the file upload work in G2/G3, and unless he wants to chime in now I'm gonna assume that's on track for the time being.
22:13:52 <davidlenwell> it is
22:13:56 <gabrielhurley> awesome
22:14:16 <davidlenwell> any day now actually if I can stop getting distracted by bare metal nova and other stuff hp is doing
22:14:25 <gabrielhurley> heh. no worries. You've stil lgot over a month
22:14:37 <davidlenwell> Yeah .. We'll hit it for sure
22:14:37 <gabrielhurley> and then G3 for implementing it everywhere
22:14:38 <ttrifonov> one question - https://bugs.launchpad.net/horizon/+bug/1065601 - as I've mentioned there - this looks like a blueprint, lot of work there
22:14:39 <uvirtbot> Launchpad bug 1065601 in horizon "no default templates for security rules" [Medium,Confirmed]
22:15:09 <gabrielhurley> ttrifonov: agreed. that will be addressed in https://blueprints.launchpad.net/horizon/+spec/security-group-rules
22:15:18 <gabrielhurley> and I've got good ideas there which I think will work really nicely
22:15:20 <ttrifonov> ah, nice
22:15:36 <gabrielhurley> It's on my "I really want to do this but it's not actually a high priority" list
22:16:03 <gabrielhurley> other BPs I have thoughts/questions on...
22:16:04 <gabrielhurley> https://blueprints.launchpad.net/horizon/+spec/orderable-mutiple-choice-field
22:16:21 <gabrielhurley> I'm hoping we can just find an off-the-shelf Django form field we can pull in there
22:16:26 <gabrielhurley> someone's got to have built one before
22:16:39 <gabrielhurley> the Quantum team needs it for ordering vnics
22:16:52 <gabrielhurley> I was hoping one of them might pick that up, but I haven't heard anything from them about it
22:17:09 <gabrielhurley> I can follow up with them on it, but I'll be the fallback for getting it done when they actually need it.
22:17:20 <gabrielhurley> same with https://blueprints.launchpad.net/horizon/+spec/nova-net-quantum-abstraction
22:17:28 <gabrielhurley> it's another one where the quantum team needs it
22:17:52 <gabrielhurley> I think I'll ask akihiro or dan to attend this meeting next week to talk about their plans
22:18:12 <gabrielhurley> #action gabrielhurley to follow up with quantum team about having a representative at horizon meeting
22:18:45 <gabrielhurley> I don't feel compelled to go into the other blueprints right now and would rather have plenty of time to let anyone else discuss topics of interest
22:18:54 <gabrielhurley> #topic General discussion
22:19:20 <gabrielhurley> I'm here to answer questions, offer advice, etc. so fire away
22:19:30 <davidlenwell> gabrielhurley: have you done anymore work building the spec for push notifications ?
22:19:41 <gabrielhurley> I knew somebody was gonna call me on that
22:19:45 <davidlenwell> ha ha
22:19:48 <gabrielhurley> no, I've been swamped since the summit
22:19:59 <gabrielhurley> I have the etherpads all bookmarked in my browser to follow up
22:20:09 <davidlenwell> the reason I call it out is that I was just considering doing some work on pythons web sockets
22:20:18 <gabrielhurley> gotcha
22:20:28 <davidlenwell> To negate the nead for node
22:20:32 <gabrielhurley> yeah
22:20:39 <gabrielhurley> If you beat me to the punch you're welcome to it
22:20:49 <gabrielhurley> first mover gets to define things by-and-large
22:20:54 <davidlenwell> We'll see .. I have a lot on my plate too .. but this is a pet project of mine
22:21:08 <gabrielhurley> yeah, for sure
22:21:12 <davidlenwell> (web sockets / python )
22:21:33 <gabrielhurley> I've been doing a lot of websocket work lately, so I definitely have opinions, but I don't think our protocol needs to be fancy at all
22:21:50 <gabrielhurley> in fact the simpler the better
22:21:57 <davidlenwell> ++
22:22:08 <davidlenwell> I'm a minimalist so yeah ..
22:22:24 <gabrielhurley> the biggest problem I've run into with socket communication involving openstack is actually the tremendous inconsistency in responses
22:22:44 <gabrielhurley> so we need https://etherpad.openstack.org/grizzly-signaling before we can do much for Horizon
22:23:12 <gabrielhurley> I need to follow up on that one too, but the Ceilometer team was very excited on working on that as well
22:23:18 <davidlenwell> It might be out of range for grizzly
22:23:23 <gabrielhurley> yeah, probably
22:23:28 <gabrielhurley> but worth getting started
22:23:34 <davidlenwell> agreed
22:23:58 <mrunge> +1
22:24:18 <davidlenwell> gabrielhurley do you kno cody-somerville ?
22:24:19 <gabrielhurley> #action gabrielhurley to follow up with ceilometer team on moving the message "subscription" code into common
22:24:27 <gabrielhurley> davidlenwell: I do not
22:24:35 <cody-somerville> Hi. :)
22:24:38 <davidlenwell> Cody .. Meat gabrielhurley
22:24:39 <gabrielhurley> hey
22:24:43 <davidlenwell> ha ha .. spelled that wrong
22:24:48 <davidlenwell> he's a new hp hire
22:24:56 <gabrielhurley> excellent. welcome to OpenStack
22:25:01 <davidlenwell> and has some django skills .. So he'll be helping out
22:25:28 <gabrielhurley> fantastic. feel free to start picking off bugs to get familiar, or if you've already got assignments we can coordinate on prioritizing them into Horizon's roadmap appropraitely
22:25:51 <cody-somerville> Sounds good.
22:26:10 <mrunge> are there any plans for ceilometer integration in horizon?
22:26:34 <gabrielhurley> hmmm
22:26:50 <gabrielhurley> not targeted for Grizzly right now 'cuz no one is chmpioning it
22:26:56 <gabrielhurley> *championing
22:27:01 <gabrielhurley> https://blueprints.launchpad.net/horizon/+spec/ceilometer
22:27:14 <gabrielhurley> needs somebody to envision what it would look like and then build it out
22:27:25 <mrunge> ah, I see
22:27:35 <mrunge> thanks
22:27:40 <ttrifonov> https://bugs.launchpad.net/horizon/+bug/1049161  - what's the status of this? The patch in pythonclient fixes the bug,   but I'm not sure if this needs some backport or else ..
22:27:41 <uvirtbot> Launchpad bug 1049161 in horizon "Cannot start instance when using non-ASCII chars in user data" [Low,Confirmed]
22:27:42 <gabrielhurley> I haven't spent enough time with ceilometer to even know exactly how I'd want to present that data
22:28:03 <gabrielhurley> ttrifonov: if it can be confirmed working then feel free to close the ticket as fixed
22:29:41 <gabrielhurley> Alright, well I'm in favor of keeping these meetings short. Let's try and grow the attendance for next week, and keep knocking out those bugs and blueprints!
22:29:55 <gabrielhurley> Thanks everyone!
22:30:03 <davidlenwell> ++
22:30:08 <mrunge> thank you Gabriel!
22:30:13 <gabrielhurley> #endmeeting