22:01:30 <gabrielhurley> #startmeeting horizon
22:01:31 <openstack> Meeting started Tue Dec 11 22:01:30 2012 UTC.  The chair is gabrielhurley. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:34 <openstack> The meeting name has been set to 'horizon'
22:01:49 <gabrielhurley> Hello folks. Welcome to the Horizon project meeting.
22:02:15 <gabrielhurley> If there are any quantum folks in the channel, I'd love it if you could stick around for a couple minutes.
22:03:21 <gabrielhurley> we'll do the same as last time, general status, blueprints and bugs, open discussion
22:03:32 <gabrielhurley> #topic General Horizon Status
22:03:44 <gabrielhurley> oh, this will serve as recap of actions from last meeting too
22:04:02 <gabrielhurley> so last meeting I was supposed to do two things: talk to ceilometer, and talk to quantum, I've done one of the two
22:04:14 <gabrielhurley> I haven't talked to ceilometer, so I need to carry that action forward
22:04:49 <gabrielhurley> #action gabrielhurley to talk to ceilometer team about moving message "subscription" code into oslo
22:05:24 <gabrielhurley> As far as Quantum goes, it looks like there hasn't been heavy priority from the Quantum team on Horizon/interface concerns in G2. Most of the blueprints in Quantum haven't been started.
22:05:37 <gabrielhurley> Consequently there's been little forward progress on my side as well.
22:06:00 <gabrielhurley> danwent: still around?
22:06:23 <mrunge> ... and how should an interface for quantum should look like?
22:06:44 <gabrielhurley> there's already support for basic management of networks, subnets and ports... lemme find the list of Quantum BPs
22:06:57 <mrunge> yes, that's right
22:07:20 <danwent> gabrielhurley: around
22:07:27 <gabrielhurley> ah, hi dan
22:07:44 <gabrielhurley> darnit, the list won't format nicely, but these are the ones Quantum has targeted:   ·         https://blueprints.launchpad.net/horizon/+spec/improve-quantum-summary-table  ·         https://blueprints.launchpad.net/horizon/+spec/quantum-floating-ip  ·         https://blueprints.launchpad.net/horizon/+spec/quantum-l3-support  ·         https://blueprints.launchpad.net/horizon/+spec/quantum-network-topology  ·
22:07:52 <gabrielhurley> there's 6 of them
22:08:12 <danwent> to me, the floatingips, l3-support, and interface ordering are the most important
22:08:17 <danwent> (I didn't see that last one posted)
22:08:33 <danwent> https://blueprints.launchpad.net/horizon/+spec/quantum-vnic-ordering
22:08:43 <danwent> https://blueprints.launchpad.net/horizon/+spec/quantum-security-group
22:08:55 <gabrielhurley> the vnic ordering https://blueprints.launchpad.net/horizon/+spec/quantum-vnic-ordering relies on https://blueprints.launchpad.net/horizon/+spec/orderable-mutiple-choice-field in horizon
22:09:23 <danwent> gabrielhurley: we are trying to hire someone to work on quantum + horizon stuff
22:09:33 <gabrielhurley> so those two may slip to G3 unless somebody from the Quantum team can champion that. Sadly there isn't a quick off-the-shelf django form widget that'll work for what we need there.
22:09:36 <danwent> if you know of any good leads, please have them contact me
22:09:47 <gabrielhurley> good to know. I'll let you know.
22:10:20 <gabrielhurley> The Quantum security groups one should be a much easier change provided the work there is done in quantum
22:10:24 <danwent> gabrielhurley: i am going to push amotoki and nati_ueno to give quantum + horizon some love in G-2, so you don't get dumped on by them in G-3 :)
22:10:41 <gabrielhurley> I'm perfectly happy to do the reviews whenever they've got the time to drop things in
22:10:49 <danwent> gabrielhurley: great, thanks.
22:11:14 <gabrielhurley> danwent: just keep in touch on how those are progressing.
22:11:26 <gabrielhurley> We've already talked about blueprints some, but moving on...
22:11:30 <gabrielhurley> #topic Blueprints and bugs
22:11:35 <danwent> gabrielhurley: will do.  i'm now going to have a weekly check-in from them during our team meeting on monday
22:11:39 <gabrielhurley> great
22:12:30 <gabrielhurley> I made some progress on the one-click "simple" floating IP management blueprint. there's a code review up for that. https://review.openstack.org/#/c/17772/
22:12:54 <gabrielhurley> I also investigated the work involved in an orderable multiple choice field for https://blueprints.launchpad.net/horizon/+spec/orderable-mutiple-choice-field
22:13:04 <gabrielhurley> and determined that it was gonna be a bit of a pain (moreso than expected)
22:13:12 <gabrielhurley> my notes/thoughts are on the whiteboard there
22:13:37 <gabrielhurley> I also talked to Ray Sun about the per-project flavors blueprint and he indicated it would likely land in G3 since he's been very busy lately.
22:13:41 <gabrielhurley> So I bumped that one forward.
22:13:52 <gabrielhurley> Otherwise there hasn't been any significant changes in the BPs that I'm aware of.
22:14:39 <gabrielhurley> jpich: any updates on the migrate instance blueprint? https://blueprints.launchpad.net/horizon/+spec/migrate-instance
22:15:03 <jpich> gabrielhurley: I have the functionality working, but need to polish the user experience
22:15:08 <gabrielhurley> awesome
22:15:11 <gabrielhurley> glad to hear it
22:15:21 <jpich> gabrielhurley: it should be all in time for g-2
22:15:26 <gabrielhurley> let me know if you need any advice, or feel free to push draft versions to github/gerrit
22:15:45 <jpich> gabrielhurley: Thanks, I will do that
22:15:47 <gabrielhurley> great
22:16:01 <gabrielhurley> so in terms of bugs, we had lots of good bugfix reviews this week, thanks everyone for that
22:16:08 <gabrielhurley> All the "high" bugs are either in progress or fixed
22:16:26 <gabrielhurley> nothing new of consequence
22:16:39 <mrunge> great to hear :D
22:17:13 <gabrielhurley> I know people are working on more fixes which will be proposed this week too... not that it applies to the peope who I know are listening, but don't forget to update the bug statuses in launchpad when you're working on something.
22:17:39 <gabrielhurley> Any other notes on bugs from folks?
22:17:54 <gabrielhurley> #topic General discussion
22:18:26 <gabrielhurley> I don't have a huge amount to discuss overall today, so questions and comments are welcome.
22:19:08 * gabrielhurley gives it a minute or two
22:19:13 <jpich> General FYI: we have an OpenStack intern for OPW who has been accepted and is interested in working on Horizon, Victory / vkmc - https://live.gnome.org/OutreachProgramForWomen
22:19:21 <zykes-> gabrielhurley: going to land reddwarf support or ?
22:19:21 <gabrielhurley> ah, very cool!
22:19:33 <gabrielhurley> zykes-: I don't know anything about it
22:19:39 <zykes-> awww
22:19:42 <gabrielhurley> I know what reddwarf is
22:19:51 <gabrielhurley> just not about work being done to integrate wiht horizon
22:19:55 <zykes-> :)
22:19:58 <gabrielhurley> do you have an update on that?
22:20:04 <zykes-> nopp
22:20:06 <zykes-> just wondering :)
22:20:06 <gabrielhurley> lol
22:20:08 <gabrielhurley> no worries
22:20:23 <gabrielhurley> It shouldn't be too hard, but since it's not even incubated yet I haven't been looking at it specifically
22:20:26 <jpich> (self-correction, "Victoria", not Victory, sorry)
22:20:38 <gabrielhurley> might be even easier if I can land https://blueprints.launchpad.net/horizon/+spec/resource-introspection
22:20:54 <zykes-> how come gabrielhurley ?
22:20:59 <gabrielhurley> jpich: is there anything I can do to help with the intern?
22:21:20 <gabrielhurley> zykes-: it'd just reduce the amount of code that'd need to be written to make reddwarf work for the basics
22:21:35 <zykes-> ah
22:21:49 <jpich> gabrielhurley: When you have time, I'd like to discuss with you and her what might be a nice blueprint for her to focus on during the 3 months she'll be with us
22:22:34 <gabrielhurley> great. will do.
22:22:40 <jpich> gabrielhurley: I thought perhaps https://blueprints.launchpad.net/horizon/+spec/tenant-deletion might fit, though there's a risk of it not making grizzly
22:22:47 <gabrielhurley> ah, yeah, that'd be good
22:23:40 <gabrielhurley> anything else from anybody?
22:24:15 <jpich> gabrielhurley: Cool, I'll catch you by email about it later
22:24:17 <gabrielhurley> great. I'll let y'all get back to your day, then. :-)
22:24:20 <gabrielhurley> #endmeeting