21:59:53 <gabrielhurley> #startmeeting horizon
21:59:53 <openstack> Meeting started Tue Jul 23 21:59:53 2013 UTC.  The chair is gabrielhurley. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:59:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:59:57 <openstack> The meeting name has been set to 'horizon'
22:00:02 <gabrielhurley> #topic overview
22:00:22 <gabrielhurley> Hello to those of you who are here. Thanks for being around.
22:00:27 <jcoufal> Hi all
22:00:30 <timductive1> o/
22:00:31 <gabrielhurley> Last week we cut the H2 milestone, that's awesome.
22:01:00 <gabrielhurley> this week is mostly a "get stuff done or go to OSCON" week, so a lot of people are out, and hopefully everyone's just working hard.
22:01:18 <gabrielhurley> #topic blueprints
22:01:46 <gabrielhurley> I've got nothing new to report for myself. I know there's been progress on the keystoneclient/client unpinning effort which I'll let others speak to, and anyone who wants to give an update is welcome to.
22:02:03 <gabrielhurley> david-lyle, lcheng: care to speak on the client stuff?
22:02:41 <lcheng> Still trying the get the latest openstack_auth consumed by horizon.
22:02:47 <david-lyle> I think the change that went in this morning was the last unpinning work, so we can adopt keystoneclient 0.3+ as desired
22:03:42 <jcoufal> about navigation enhancements - there is no more activity on mailing thread, so I am going to wrap up the discussion and start designing proposals to cover mentioned issues
22:03:43 <david-lyle> lcheng: that's unblocked by openstack/requirements right?
22:03:46 <gabrielhurley> did ceilometerclient get its update?
22:03:51 <gabrielhurley> that was the last blocker for the client stuff
22:03:53 <david-lyle> yes
22:03:58 <gabrielhurley> okay
22:04:00 <lcheng> There is a major bug fix made in https://review.openstack.org/#/c/37563/ for running openstack_auth in Keystone V3.
22:04:09 <david-lyle> yeah, we had to wait to everyone else got their changes in
22:04:20 <lcheng> We would need to release a new version of openstack_auth and use that version.
22:04:24 <gabrielhurley> david-lyle: then yeah, we should be unblocked on that.
22:04:37 <gabrielhurley> lcheng: I need to make sure I know the right way to do a release for that now that it's in gerrit
22:04:49 <gabrielhurley> I'll work on that ASAP
22:04:59 <gabrielhurley> jcoufal: sounds great
22:05:15 <lcheng> david-lyle: yes, that matches what's in openstack/requirements
22:06:03 <gabrielhurley> #action gabrielhurley to tag and release new openstack_auth version
22:06:22 <gabrielhurley> anybody else with blueprint updates?
22:06:23 <lcheng> Related to keystone-client, I'm keeping an eye on this: https://review.openstack.org/#/c/28043/
22:06:37 <gabrielhurley> ah, I hadn't seen that review
22:06:41 <gabrielhurley> that's good to know about
22:06:53 <jcoufal> david-lyle: last week you wanted to discuss something about nav enhancements, is that still on?
22:07:03 <timductive1> I've got a blueprint to update the Heat Topology now that a few features have been pushed through in Heat
22:07:04 <lcheng> There are some code changes that could break openstack_auth.
22:08:14 <david-lyle> jcoufal: we can do it in the blueprint I just wanted to mention that not a lot of input was coming in, hoping others would chime in
22:08:36 <gabrielhurley> lcheng: I'll be curious to see how that shakes out now that openstack_auth is also in the gating
22:08:51 <jcoufal> david-lyle: alright, we can continue there after I do the summary
22:08:54 <gabrielhurley> timductive1: yep. certainly looking forward to seeing that
22:09:10 <gabrielhurley> jcoufal, david-lyle: I'll probably have more input once I see some wireframes
22:09:33 <timductive1> gabrielhurley: Thanks I'm hoping to have a code review up this week
22:09:41 <gabrielhurley> even better :-)
22:09:49 <jcoufal> gabrielhurley: definitely, will be working on that and let you all know once they are out
22:09:54 <gabrielhurley> sweet
22:09:55 <gabrielhurley> #topic open discussion
22:10:03 <gabrielhurley> Let's just make this general talk time
22:10:09 <gabrielhurley> it's more for the logs than anything
22:10:52 <jcoufal> just quick reminder about UX discussions
22:11:05 <jcoufal> I would let people one last week for proposals
22:11:36 <jcoufal> and after that let vote for best tool from all proposals we have
22:12:05 <jcoufal> so I encourage everybody who has some suggestions, feel free to follow discussion in mailing list
22:12:23 <gabrielhurley> +1
22:13:57 <gabrielhurley> anybody else?
22:14:16 <lcheng> gabrielhurley: got a question on some hanging code
22:14:28 <gabrielhurley> oh?
22:14:34 <timductive1> is anyone actively working on wireframes for the nav enhancement?
22:14:40 <lcheng> Does anyone know if the code in https://github.com/openstack/horizon/blob/master/openstack_dashboard/dashboards/admin/projects/tables.py#L140 is still being used?
22:14:51 <lcheng> This is for the Project -> User assignment
22:15:33 <jcoufal> timductive1: working on that whenever I have some spare time
22:15:34 <lcheng> The implement for Project -> User assignment is mostly in javascript now (horizon.project.js).  Wondering if I should just clean this up.
22:16:21 <lcheng> There are also some leftover html template, url (not accessed) and view classes not used related to this functionality.
22:16:41 <gabrielhurley> hmmm... I suspect it may be orphaned, but I can't be 100% sure just at a glance
22:16:42 <david-lyle> timductive1: I posted am image of an accordion style nav that we are using: https://lh6.googleusercontent.com/-VQEiT33xj4o/UdwTp0llSPI/AAAAAAAAATs/kB7u3ZiMO44/w506-h281-o/Screenshot%2Bfrom%2B2013-07-08%2B15%25253A49%25253A36.png  but I would like to see what jcoufal comes up with
22:16:44 <lcheng> gabrielhurley: hanging -> leftover code
22:16:58 <jcoufal> timductive1: already have some ideas put on the paper, but I also wanted to wait for result of discussion about issues to be sure we cover as much as possible
22:17:42 <lcheng> Okay, I guess if the tests pass after cleanup I'll assume that cleanup is good. :-)
22:17:49 <david-lyle> what happens with the js implementation of adding/removing users if no js support?
22:17:50 <gabrielhurley> lcheng: I'd say so
22:18:16 <david-lyle> at the summit there was mention of primary use cases needing to work without js
22:18:21 <gabrielhurley> david-lyle: my recollection is that it originally had a NoJS fallback, but I'm blanking on it right now
22:18:24 <jcoufal> timductive1: however, I want to get out with something soon, so we can discuss and gather as much feedback, not wasting time on wrong ways
22:18:51 <gabrielhurley> david-lyle: I think the experience is quite janky but it ought to work. If not it's mostly a style problem as opposed to the capabilities existing vs. not
22:19:18 <timductive1> jcoufal: ok, I was just wondering what the scope was for the nav
22:19:20 <david-lyle> as long as there's a way, I'm good with it.
22:19:54 <timductive1> whether it is just a better left nav or reorganizing into horizontal tabs
22:21:19 <jcoufal> timductive1: I am trying to hit all possibilities I see
22:21:25 <david-lyle> I would assume all is on the table, but someone has to be willing to do the work if it's drastic
22:22:05 <david-lyle> modifying the left hand nav is not a large effort
22:22:19 <jcoufal> I will try also just to show options, even they might not be ideal, we can discuss
22:22:40 <jcoufal> I think seeing all possibilities will be helpful
22:22:44 <timductive1> ok, I'm curious to see the options, but yes its tough to make drastic changes
22:22:56 <gabrielhurley> the one thing to bear in mind (as far as when we try to land such a change) is that a lot of downstream distros and companies consume horizon and skin it, meaning we need to watch out for not surprising them with big changes at the end of a release cycle...
22:23:23 <david-lyle> that said, the current layout has fixed width items which obviously fit small screens poorly
22:23:30 <gabrielhurley> I would hate to have a navigation change be the reason people don't adopt the latest dashboard for months
22:23:32 <cody-somerville> making good use of CSS should help us avoid minimize that.
22:23:50 <gabrielhurley> yep, but any change is gonna affect those overlays/remixes
22:24:11 <david-lyle> yeah, I've played a lot in that code, lots of assumptions
22:24:25 <timductive1> yeah the main problem that seems hard to solve is having more than 3 dashboards with the fixed width left nav
22:24:28 <david-lyle> regarding width and float behavior
22:24:52 <david-lyle> the accordion works well for that which is why we adopted it
22:24:58 <jcoufal> gabrielhurley: agree
22:25:11 <david-lyle> we needed more than three tabs with really short non-translatable names
22:26:18 <timductive1> I like the accordion structure, maybe coupled with a good breadcrumb system would fix a lot of my nav issues
22:26:46 <jcoufal> timductive1: could you add your issues in the mailing thread?
22:27:02 <david-lyle> I agree about the breadcrumbs there are too many dead ends in the UI flow
22:27:17 <timductive1> jcoufal: sure thing
22:28:07 <jcoufal> timductive1: that would be great to have more information, thanks
22:28:21 <gabrielhurley> accordian is generally +1, though I find that project generally has to be surfaced as a top-level meta grouping. Project determines roles, and roles determine so much of what a user has access to... I'll be interesting to see what comes of it.
22:29:26 <jcoufal> timductive1: http://lists.openstack.org/pipermail/openstack-dev/2013-July/011509.html this one it is
22:29:45 <gabrielhurley> anyhow, I'm gonna head to another meeting. Feel free to keep discussing (obviously).
22:29:50 <gabrielhurley> I'll catch y'all next week.
22:30:00 <gabrielhurley> thanks for the good discussion today
22:30:02 <gabrielhurley> #endmeeting