16:02:12 <david-lyle> #startmeeting Horizon
16:02:13 <openstack> Meeting started Tue Apr 22 16:02:12 2014 UTC and is due to finish in 60 minutes. The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:17 <openstack> The meeting name has been set to 'horizon'
16:02:22 <akrivoka> hiya
16:02:26 <pbelanyi_> hi
16:02:33 <jcoufal> ahoy o/
16:02:38 <amotoki> hi
16:02:55 <absubram> hi
16:02:59 <david-lyle> Hello everyone
16:03:17 <SergeyLukjanov> o/ (lurking for Sahara related topics)
16:03:26 <lblanchard> hi all!
16:03:39 <clu_> hi!
16:03:41 <tqtran> hello
16:03:59 <david-lyle> Icehouse is officially release, on to Juno and backports to stable/icehouse.
16:04:18 <david-lyle> Thanks everyone for all you efforts on icehouse.
16:04:40 <david-lyle> Something we can all be proud of
16:05:08 <jcoufal> nice! great job to all
16:05:59 <david-lyle> The only topic I have for today regards design session topics, the proposal deadline is past, and I need to schedule the sessions. I want to have you help culling/combining topics.
16:06:38 <david-lyle> #link http://summit.openstack.org/
16:07:04 <david-lyle> 2x topics to slots
16:07:25 <jcoufal> How many slots do we have?
16:07:52 <david-lyle> I'm going to withdraw the node topic, I think we understand that one, and I just need to do the work. Or we can discuss the finer points in the hall.
16:07:57 <david-lyle> jcoufal: 8
16:08:13 <mrunge> we have lots of technical things to discuss
16:08:37 <david-lyle> mrunge, re: node or other items
16:08:59 <mrunge> david-lyle, well, I'd say, they might be connected
16:09:35 <jpich> http://summit.openstack.org/cfp/details/264 strikes me as not controversial, I'm not sure that a session is needed - someone just needs to do the work
16:09:50 <david-lyle> I could see that, but node/npm will be a means to an end here
16:10:35 <david-lyle> jpich, agreed, the only thing I could see for that would be a demo, but it doesn't sound to be that far along
16:10:40 <jcoufal> jpich: +1
16:10:52 <tqtran> is it too late to add topics?
16:11:09 <mrunge> jpich, I agree somehow. Although that proposal looks a bit empty
16:11:24 <mrunge> or cloudy, I'd say ;-)
16:11:30 <doug-fish> This seems like an easy +1 http://summit.openstack.org/cfp/details/32
16:11:31 <jpich> Re: Nodejs, there are people (Radomir?) who are investigating other alternatives for compiling CSS
16:12:14 <mrunge> yes, and discussed websockets, or discussed using marconi for websockets
16:12:44 <mrunge> node would be the other solution for async messaging
16:12:50 <jpich> tqtran: I'm afraid so, especially since we have way more sessions proposed than slots available. Though maybe exceptions can be made for a very important topics...
16:13:32 <jpich> mrunge: I'd prefer to see a Python solution, I think that's where we were going with the sockets
16:13:51 <lblanchard> doug-fish: thanks for the +1!!
16:14:37 <david-lyle> doug-fish: I think so too
16:14:37 <mrunge> jpich, me too, +1 for a python solution
16:14:44 <clu_> doug-fish lblanchard: +1, important
16:14:49 <tzumainn> do you guys think an etherpad might help to remember the +1s and the like?
16:15:22 <david-lyle> mrunge, jpich, the issue goes beyond mere compilation. It includes testing and development tools
16:15:41 <jpich> I agree UX is an important session, though it might still need to be combined with another one
16:16:00 <jcoufal> doug-fish: can we join http://summit.openstack.org/cfp/details/315 together with discussion about http://summit.openstack.org/cfp/details/32
16:16:21 <david-lyle> My question regarding UX is, there are two cross-project UX sessions, should that topic be addressed there?
16:16:48 <doug-fish> I'd expect UX and accessibility to have very little overlapping content
16:17:14 <jcoufal> david-lyle: it would be nice - is there enough space for cross-project sessions?
16:17:43 <doug-fish> david-lyle: can you link those sessions?
16:17:54 <david-lyle> jcoufal: 2 UX session are already scheduled
16:18:01 * david-lyle finding links
16:18:03 <jpich> doug-fish: Could you start the discussion on list about that topic either way? Not everything has to be decided within a 40 minutes face to face session
16:18:23 <doug-fish> jpich: great point. Will do that.
16:18:44 <david-lyle> http://junodesignsummit.sched.org/
16:19:12 <david-lyle> http://junodesignsummit.sched.org/event/e13c8775849567fe8576c16875d5c547#.U1aWfPldXoM
16:19:23 <tzumainn> david-lyle, would it make sense to have people put their input on an etherpad like https://etherpad.openstack.org/p/horizon-atlanta-summit , so it's easier to remember where people stand?
16:19:27 <jcoufal> david-lyle: found it, russel extended one for two slots
16:19:36 <lblanchard> david-lyle: yeah, I got notices about the UX off topic sessions…sounds like they thought we'd have a lot to cover so gave us two
16:19:38 <lblanchard> back to back
16:20:20 <david-lyle> lblanchard, the question is with those, should we put your Horizon content in there?
16:20:21 <jcoufal> lblanchard: though I think that the first one can be designers gathering and second can be more practical
16:20:48 <lblanchard> david-lyle: I think if the Horizon devs plan to be there, sure…I think it's important for the Horizon session to have the devs around
16:20:49 <david-lyle> or is the focus more APIs, or ?
16:21:10 <clu_> this session is user-feedback-centric, maybe we can combine as well? http://summit.openstack.org/cfp/details/175
16:21:27 <lblanchard> david-lyle: I think a lot of it will be process oriented…e.g. how do we work together, share, communicate, work with the teams…what are we working on today? type stuff
16:21:29 <jcoufal> tzumainn: the etherpad will be helpful, thanks
16:21:54 <jcoufal> lblanchard: but that can be covered in the first part
16:22:21 <david-lyle> thanks tzumainn
16:22:21 <lblanchard> clu_: I think this session will be very important for everyone to be at…sounds like we will have some ops in the room to discuss Horizon features needed for our users
16:22:30 <tzumainn> np!
16:22:31 * mattf waves
16:22:39 * mattf is a sahara lurker
16:22:56 <mattf> regret from chad
16:22:57 <jcoufal> lblanchard: I think we can use second part of the session to ease the load from Horizon to cover the usability feedback
16:23:00 <lblanchard> jcoufal: sure. I think it's just important to note that if it's not a Horizon specific session, we might not get Horizon devs there for their feedback on practical discussions
16:23:12 <lblanchard> jcoufal: I totally disagree.
16:23:26 <lblanchard> jcoufal: unless the devs are there :)
16:23:30 <david-lyle> mrunge, does separation have open questions, or just needing off ?
16:23:37 <david-lyle> s/off/effort/
16:23:38 <lblanchard> jcoufal: we have designs we will be showing and what to get dev feedback
16:24:24 <jcoufal> lblanchard: why not? I believe it will be interesting for people from all projects, since the UI covers majority of them
16:24:50 <jcoufal> and I am hoping that cross-project session will not overlap with Horizon's
16:24:52 <lblanchard> jcoufal: Yes, I think anyone who is interested in Usability Feedback on Horizon should attend
16:24:58 <lblanchard> jcoufal: but it should be on Horizon track
16:25:24 <lblanchard> jcoufal: so that there isn't another session overlapping potentially taking the Horizon devs away from that important discussion
16:26:25 <jcoufal> david-lyle: can we do voting for sessions in tzumainn's etherpad? https://etherpad.openstack.org/p/horizon-atlanta-summit
16:26:38 <jcoufal> I think that might help
16:26:48 <david-lyle> lblanchard, first UX session has a conflict for me, second UX session is good
16:27:31 <david-lyle> jcoufal, sure let's add a +1, -1 to topics on there, and maybe we can cull some obvious ones
16:27:39 * david-lyle wishfully thinking
16:28:02 <jcoufal> david-lyle: +1 from me
16:28:06 <doug-fish> What about identifying potential topics to combine? I'm looking at Do these 2 fit together into a single session? http://summit.openstack.org/cfp/details/117 http://summit.openstack.org/cfp/details/129
16:28:33 <doug-fish> they both seem closely tied and necessary for splitting horizon
16:28:44 <david-lyle> doug-fish, yes those two can combine
16:30:11 <jpich> I think a lot of the sessions should start on-list discussions, I'm sure a number of questions could be resolved without the need to wait for everyone to be in the same room
16:30:59 <jpich> It's a bit late to help a lot with the scheduling now but maybe it would reduce the scope of some discussions and make topics easier to combine
16:31:39 <tzumainn> jpich, +1, I think the same thing was suggested for tripleo
16:31:51 <lblanchard> jpich: +1, I will start discussions around the sessions I proposed
16:32:38 <jcoufal> david-lyle: modular widget based approach can be combined with Horizon pluggable content?
16:33:10 <david-lyle> certainly related
16:33:10 <amotoki> jpich: +1. totally agree.
16:34:24 <david-lyle> jpich: very much agree
16:34:30 <jpich> Great. We should ping the session owners who are not at this meeting and encourage them to do so soon
16:36:07 <jpich> I can do this and post a comment about this on all the proposals, if that sounds like a reasonable approach
16:36:44 <tzumainn> sounds reasonable to me!
16:37:32 <doug-fish> I love the idea of this session http://summit.openstack.org/cfp/details/175 but I'm concerned about getting participation from people who aren't Horizon developers.
16:37:33 <amotoki> +1. what we need to do first is to clarfiy the session owners want to discuss in the session and check if there is similar sessions.
16:37:43 <doug-fish> I haven't been to a summit before - is that a reasonable concern?
16:38:00 <jcoufal> doug-fish: I don't think so :)
16:38:15 <lblanchard> doug-fish: this will be the first time we are doing something like this. Operators haven't been allowed to attend design summit sessions in the past as far as I know.
16:38:30 <jpich> doug-fish: These are new, Tom is organising them for multiple projects and doing a lot of work advertising them to operators. It seems very much worth giving it a shot, to me
16:38:38 <lblanchard> doug-fish: Tom Fifield works closely with the user committee.
16:38:38 <doug-fish> cool!
16:38:50 <lblanchard> jpich: +1!!
16:38:52 <david-lyle> jcoufal: I think http://summit.openstack.org/cfp/details/175 may come out of your http://summit.openstack.org/cfp/details/356 naturally
16:38:55 <david-lyle> it did last time
16:39:05 <lblanchard> it's our best bet to get past devs and chat with ops IMO!
16:39:46 <lblanchard> david-lyle: operators attended the sessions?
16:40:05 <doug-fish> It has my +1. Like I said, I think its a good idea, was just concerned that maybe operators couldn't/wouldn't attend.
16:40:24 <david-lyle> those expressing operator type concerns, what their true role was, unsure
16:40:31 <jpich> lblanchard: I think a number of operators have a few contributions under their belt, so as ATC they can attend
16:40:42 <lblanchard> jpich: good point!
16:41:14 <lblanchard> I definitely think it's worth having a slot for. I'd be happy to use the 2nd UX slot for this…although it is very much Horizon focused.
16:41:14 <jcoufal> david-lyle: Probably, but I can't assure this :) But there definitely will be space for ask them questions
16:41:56 <david-lyle> Let's continue this on the etherpad: #link https://etherpad.openstack.org/p/horizon-atlanta-summit
16:42:07 <david-lyle> #topic Open Discussion
16:42:54 <david-lyle> want to leave a little time for this, if it devolves back to session planning, I'm ok with that, but others feel free to bring your topic up now
16:43:03 <mattf> SergeyLukjanov, NikitaKonovalov ^^ kick off some sahara discussion?
16:43:35 <mattf> SergeyLukjanov is our PTL and has a great handle on the topics like sahara v heat, which came up on the mailing list thread
16:44:07 <SergeyLukjanov> hey
16:44:26 <SergeyLukjanov> I'll send a response to jcoufal in ML
16:44:32 <david-lyle> as Sahara has graduated, I don't think Horizon makes the decision it should merge with Heat :)
16:44:37 <jcoufal> SergeyLukjanov: thanks
16:44:49 <SergeyLukjanov> in two words sahara isn't the part of orchestration, sahara use heat for it
16:45:06 <jcoufal> david-lyle: not proposing that, I am just trying to figure out the relationship :)
16:45:08 <SergeyLukjanov> example of existing projects with the same layout - trove
16:45:21 <david-lyle> jcoufal, sure
16:45:25 <SergeyLukjanov> trove has separated panel for their "cluster" (named databases)
16:45:53 <SergeyLukjanov> I'll try to explain the relations more detailed in ML
16:46:09 <SergeyLukjanov> re sahara dashboard merging into the horizon, I have a question
16:46:19 <SergeyLukjanov> do we need some time on summit to discuss it?
16:46:29 <mattf> i'll add that horizon integration has been a primary goal for sahara. we only grew a cli interface very recently.
16:46:48 <jpich> I don't think so, it doesn't seem controversial? We want you guys in :)
16:46:58 <jcoufal> SergeyLukjanov: sure thing, we can continue in the ML
16:47:14 <mattf> we want to make the workflow of cluster provisioning or data processing job execution very smooth and horizon first
16:47:34 <SergeyLukjanov> my init idea is to merge current state to the horizon during the J cycle and than iterate many times on UX
16:47:37 <jcoufal> SergeyLukjanov: agree with jpich, I am not disagreeing with merger, more trying to find the best place for it
16:47:44 <tzumainn> out of curiosity, is there a preferred workflow when a new project integrates with horizon?
16:47:59 <NikitaKonovalov> there is a change by crobertsrh adding a sahara-client
16:48:11 <NikitaKonovalov> this one https://review.openstack.org/#/c/86648/7
16:48:33 <NikitaKonovalov> so that's a good first step to start with I guess
16:48:41 <jpich> tzumainn: Not really so far: new project submits their code, we make it more horizony if required, then it gets merged
16:48:44 <lblanchard> SergeyLukjanov: +1 to it being in Horizon, agree with jcoufal it's just a matter of finding the right place and organization within the information architecture!
16:49:26 <jcoufal> SergeyLukjanov: we definitely should iterate in time, but I am afraid of OpenStack Dashboard to become unstable if project just merges in and then we try to re-organize things, which are already in master
16:50:25 <SergeyLukjanov> jcoufal, I'm not proposing to merge it as is, just to not change the overall approach
16:50:36 <jcoufal> therefore I would like to reduce this effect to minimum (not that the solution will be perfect final version which will have to take us 2 cycles to design)
16:50:49 <jcoufal> SergeyLukjanov: I think we are on the same page here
16:51:24 <SergeyLukjanov> jcoufal, my only concern is that we should merge it during the Juno or we need to supply it separately again and disable in horizon
16:51:29 <SergeyLukjanov> jcoufal, cool
16:51:38 <jpich> Horizon's always aimed to support new graduated projects out of the box, so let's make sure to find at least a temporary space so we have some sort of base to work from. The first patchset tends to be larger so it takes time to merge it as is
16:51:48 <david-lyle> I think with the newer panel, panel group and dashboard order management, reorganizing will be a lot simpler
16:51:49 <jcoufal> SergeyLukjanov: I think Juno is no problem here
16:52:09 <SergeyLukjanov> I hope ;)
16:52:24 <jcoufal> SergeyLukjanov: We will make it ;)
16:52:26 * mattf crosses fingers
16:53:01 <amotoki> from our past experience, we need to start tests a bit earlier. devstack integration or easy-setup-dev env really helps us.
16:53:51 <SergeyLukjanov> amotoki, sahara is in the integrated gate, there are not too many tests atm, but devstack integration should work ok
16:54:18 <amotoki> SergeyLukjanov: great. when I tried to run trove, it was a bit tricky and i need to explore more info...
16:54:19 <SergeyLukjanov> amotoki, I think that we could ask Chad (croberts) to make some short doc about how to test his patches
16:54:30 <tzumainn> SergeyLukjanov, that would be awesome : )
16:54:36 <jcoufal> need to run for today, but thanks guys, will continue this topic in ML
16:54:40 <jcoufal> have a great day all
16:54:43 <jpich> Yep, include the steps in the blueprint maybe
16:54:48 <mattf> jcoufal, thx
16:55:03 <SergeyLukjanov> we have a good docs for sahara re installation including our plugin for dashboard - http://docs.openstack.org/developer/sahara/#user-guide
16:55:13 <mattf> he's not here, you should #action chad for bp test docs
16:55:16 <SergeyLukjanov> jcoufal, thanks
16:55:52 <SergeyLukjanov> #action croberts to add doc re testing his changes for merging sahara-dashboard into the horizon
16:56:06 <amotoki> Sahara seems to have well-formed documents :)
16:57:14 <amotoki> /FYI/ I add the link of the etherpad page to horizon meeting page as well.
16:57:24 <amotoki> s/add/added/
16:57:27 <david-lyle> thanks amotoki
16:57:27 <jpich> Thanks amotoki!
16:58:21 <jpich> If I may provide some additional food for thought on the Summit: someone in a thread or other described the summit sessions as "the middle of a conversation" - I think that's important to keep in mind, the session shouldn't come out of nowhere (start on list discussions) and isn't the end of everything either, decisions can/should/will happen on list and outside of the Summit as well
16:58:59 <david-lyle> I need to have the schedule together by the end of the week, so I'll be acting on organizing/culling in the next couple of days. Make your opinions known.
16:59:27 <SergeyLukjanov> thank you, folks
16:59:36 <doug-fish> Thanks for soliciting input david-lyle! well handled.
17:00:16 <david-lyle> thanks, SergeyLukjanov, mattf, NikitaKonovalov, looking forward to adding Sahara support
17:00:24 <david-lyle> time's up
17:00:25 <mattf> pleasure
17:00:29 <david-lyle> #endmeeting