20:00:10 <robcresswell> #startmeeting horizon
20:00:11 <openstack> Meeting started Wed Jan 13 20:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is robcresswell. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:15 <openstack> The meeting name has been set to 'horizon'
20:00:28 <robcresswell> Hello
20:00:31 <neillc> o/
20:00:36 <itxaka> o/
20:00:40 <piet> o/
20:00:44 <rhagarty_> o/
20:00:49 <lhcheng> o/
20:00:51 <doug-fish> \o
20:00:51 <TravT> o/
20:00:59 <TravT> doug-fish: gotta be different
20:01:07 <doug-fish> :-)
20:01:12 <TravT> :)
20:01:14 <doug-fish> I'm special!
20:01:16 <robcresswell> He's that guy who stands at the front of the elevator and faces inwards
20:01:23 <neillc> doug-fish: that you are :)
20:01:26 <doug-fish> lol
20:01:29 <tsufiev> o/
20:01:43 <robcresswell> So, lets begin. Couple of notices first
20:02:06 <robcresswell> Firstly, M-2 is next week
20:02:15 <robcresswell> #link http://docs.openstack.org/releases/schedules/mitaka.html
20:02:51 <robcresswell> We still keep to the general openstack release cycle, so its worth keeping that in mind
20:03:15 <robcresswell> We need to keep moving on major blueprints for this cycle, and aim to avoid the RC-rush
20:03:36 <robcresswell> Next thing to mention is the mid-cycle
20:03:43 <robcresswell> #link https://wiki.openstack.org/wiki/Sprints/HorizonMitakaSprint
20:04:02 <robcresswell> Make sure to list attendance, and we need to start coming up with topics
20:04:31 <robcresswell> I think richard had some input on that, but he doesnt appear to be in the meeting
20:04:40 <mrunge> I'd have topics
20:04:48 <mrunge> even for mid-cycle
20:05:15 <tsufiev> if I get an approve (still in process), I�m going to discuss Horizon profiling
20:05:20 <robcresswell> Whats the preferred platform for topic discussion, etherpad?
20:05:50 <mrunge> I'm quite concerned about our angular status
20:05:54 <hurgleburgler> richard's out through friday
20:06:08 <robcresswell> hurgleburgler: Ah, I see
20:06:19 <tsufiev> +1 for etherpad (it worked before)
20:06:25 <hurgleburgler> +1
20:06:27 <matt-borland> +1/etherpad
20:06:46 <mrunge> +1 for etherpad
20:06:53 <robcresswell> #link https://etherpad.openstack.org/p/horizon-mitaka-midcycle
20:07:11 <robcresswell> List topics/discussion points
20:07:18 <TravT> i liked david-lyles idea for this midcycle which basically was rapid iterations on reviews and coding
20:07:38 <TravT> to help finish out the release
20:08:19 <tsufiev> oh yes, finally merge all integration tests :)
20:08:30 <robcresswell> Heh, its more like an "endofcycle" sprint
20:08:38 <hurgleburgler> would be nice
20:08:43 <hurgleburgler> how much time would we spend on that?
20:08:46 <robcresswell> Put names next to topics btw
20:08:54 <lhcheng> it could be pre-planning for the next cycle :)
20:08:57 <robcresswell> Because I dont think etherpad stores names after you drop..?
20:09:43 <robcresswell> Okay, I've updated the wiki to add the etherpad link as well
20:10:45 <robcresswell> I can see that rapidly filling up, so thats good
20:11:06 <TravT> i suspect that closer to the date we'll have a bit more items.
20:11:12 <mrunge> yes, names might be missing after you disconnect
20:11:23 <mrunge> and names are missing, if not logged in on etherpad
20:11:34 <robcresswell> Yep, good to get content down though, so we can see
20:11:42 <robcresswell> Lets move on to the agenda
20:11:49 <robcresswell> #link https://wiki.openstack.org/wiki/Meetings/Horizon#Agenda_for_2016-01-13_2000_UTC
20:12:37 <robcresswell> We've discussed the midcycle already, so we can look at the django release item
20:12:59 <robcresswell> #topic Django and backports
20:13:12 <robcresswell> #link http://lists.openstack.org/pipermail/openstack-dev/2016-January/083701.html
20:13:29 <robcresswell> zigo: If you're around, you may have some input here
20:14:06 <mrunge> that has been briefly discussed in this weeks stable meeting
20:14:28 <robcresswell> As far as I can tell this is mainly a packaging related issue that arises from a disconnect between our release cycle and Djangos
20:14:35 <tsufiev> mrunge, what was the conclusion?
20:14:59 <mrunge> heh, to discuss in #openstack-horizon
20:15:08 <mrunge> somehow we all agreed, it's a good idea
20:15:12 <robcresswell> The thread seemed to indicate that backports would be acceptable
20:15:16 <mrunge> I was looking for logs right now
20:15:38 <mrunge> zigo got the recommendation to stick with django-1.8
20:15:40 <robcresswell> The idea being that we backport django version fixes, so that older versions of Horizon can run on newer versions of Django
20:15:47 <mrunge> and to fix mitaka first
20:15:50 <robcresswell> In this case, Liberty and Django 1.9
20:16:00 <robcresswell> heh, yep. I'm working on it
20:16:07 <tsufiev> +1 for fixing Mitaka first
20:16:20 <mrunge> ah, and we agreed to disagree on need of filing bugs or a blueprint
20:16:35 <robcresswell> I have a couple more issues to fix, and the infra patches to enable dj19 tests both have a +2
20:16:35 <mrunge> I asked to file, zigo wanted fixes first
20:16:45 <mrunge> congrats robcresswell
20:17:00 <TravT> robcresswell: that was record time
20:17:11 <mrunge> oh, wait, do we want to force django-1.9 tests on liberty too?
20:17:27 <tsufiev> TravT, infra guys seem to be very responsive these days
20:17:27 <robcresswell> mrunge: Not yet. Mitaka first.
20:17:28 <doug-fish> mrunge: wouldn't that be expected?
20:17:44 <robcresswell> Then we can enabled the tests for Liberty too
20:17:46 <doug-fish> isn't that was zigo is asking for?
20:17:49 <robcresswell> enable*
20:18:29 <mrunge> doug-fish, /me would think, django-1.9 is out of support while liberty is still supported
20:18:50 <mrunge> logs of that stable session are here: http://eavesdrop.openstack.org/meetings/stable/2016/stable.2016-01-12-15.01.log.html
20:18:53 <mrunge> #link http://eavesdrop.openstack.org/meetings/stable/2016/stable.2016-01-12-15.01.log.html
20:19:22 <mrunge> doug-fish, zigo is asking us to support django-1.9 for liberty, yes
20:19:40 <mrunge> but that's not: we're gating on django-1.8 and django-1.9 for liberty
20:20:01 <robcresswell> If its supported, it needs to be tested
20:20:13 <doug-fish> yeah, I'd agree robcresswell
20:20:33 <robcresswell> The question is whether we want to backport the dj19 fixes
20:20:39 <robcresswell> As well as any others that may be Liberty specific
20:21:19 <robcresswell> mrunge: Is this issue in other distros too?
20:21:37 <mrunge> robcresswell, we don't have django-1.9 for liberty
20:21:46 <ducttape_> it seems weird to go back for a previous release an add support for a non LTS version
20:21:51 <robcresswell> All I've heard so far is that it breaks in Sid, and I don't consider Debians "unstable" distro to exactly be high priority
20:21:53 <mrunge> we might have django 1.9 for mitaka
20:22:35 <mrunge> especially since django-1.9 is a release living for another 6 months
20:22:59 <ducttape_> Liberty supports django 1.8 (LTS) right?
20:23:09 <doug-fish> yep
20:23:13 <ducttape_> good enough
20:23:22 <mrunge> yes, that's right
20:23:51 <doug-fish> I think zigo would disagree
20:23:51 <mrunge> but if zigo wants to support horizon on django-19 for debian and is providing patches?
20:24:09 <mrunge> we can only win here
20:24:11 <tsufiev> mrunge, he still needs our help in fixing remaining issues
20:24:19 <mrunge> yes
20:24:36 <tsufiev> I think if we finalize django19 support in Mitaka, he could backport it to Liberty on his own
20:24:41 <ducttape_> openstatck projects are careful to backport features.  and previous releases seem like they should focus support on LTS packages.  my $.02
20:24:43 <tsufiev> I mean, in form of custom patches
20:24:47 <doug-fish> It's hard to take a position on Liberty support without knowing how much we are talking backporting
20:25:25 <mrunge> doug-fish, zigo had 3-4 patches already
20:25:29 <robcresswell> doug-fish: https://blueprints.launchpad.net/horizon/+spec/drop-dj17
20:25:42 <mrunge> there were about 9 tests failing now
20:25:52 <mrunge> it doesn't seem to be that much
20:25:59 <doug-fish> mrunge: thx - but I haven't evaluated their scariness index yet.
20:26:03 <robcresswell> I wrapped dj17 drop and dj19 into one bp, since thats the deprecation period
20:26:13 <tsufiev> zigo said an interesting thing: a lot of messages about �undefined ngusers namespace� may also exist in django18, they were just silenced
20:26:15 <robcresswell> There's likely to be one more patch to get it all running
20:26:23 <robcresswell> tsufiev: I don't have that issue on my local patch
20:26:29 <tsufiev> hm...
20:26:32 <tsufiev> weird
20:26:56 <tsufiev> robcresswell, I confirm the problem in debian, I chrooted to it in ubuntu and it was reproduced with zigo�s patches
20:27:08 <mrunge> tsufiev, yes, that scared me as well, but one would need to look at that
20:27:40 <robcresswell> I would be surprised if there is an issue specific to one ng panel and not the other two (I think its two) that are currently in Horizon
20:28:13 <mrunge> it might be, there is a different order on loading panels (or so)
20:28:32 <mrunge> iirc, we had that on django-1.8 too
20:28:45 <mrunge> but I may be wrong
20:29:07 <mrunge> it would be good to see actual patches to play with them
20:29:13 <robcresswell> Overall, we need to think about whether as a community we want to work on the effort of supporting current django versions on stable branches, or whether we cap it
20:29:37 <robcresswell> Thats the high level issue, I think
20:29:57 <mrunge> it's like: do we backport features to stable branches?
20:29:57 <tsufiev> what are the benefits (besides making zigo happy)?
20:30:35 <ducttape_> there is a chart with the dates for django support, about halfway down on https://www.djangoproject.com/download/
20:31:26 <ducttape_> tsufiev - it's about supporting customers with latest and greatest stuff, less bugs, more secure etc.  from a horizon point of view it should be 0 difference
20:32:11 <ducttape_> but this gets into why LTS releases exist, in my mind
20:32:40 <robcresswell> LTS is generally for security backports, unless django is different somehow
20:32:51 <robcresswell> So security shouldnt be an issue really
20:32:57 <mrunge> exactly robcresswell
20:33:30 <mrunge> but operators don't upgrade their installation every 6 month
20:33:40 <robcresswell> But so far we've capped Django at the highest supported version when we release Horizon
20:33:46 <mrunge> openstack is infrastructure
20:33:48 <robcresswell> So it'll be 1.9 for Mitaka
20:33:52 <TravT> unless you r ducttape_, then you do it "whenever you really want something"
20:34:14 <ducttape_> correct.  I pay a high price for the bleeding edge
20:34:19 <mrunge> yepp, robcresswell
20:34:34 <david-lyle> I think backporting will start to get messy and potentially not possible especially crossing the LTS boundaries
20:35:45 <mrunge> we don't support django-1.7 anymore no?
20:36:00 <david-lyle> liberty is >= 1.7 < 1.9
20:36:18 <mrunge> uh oh
20:36:29 <mrunge> 1.7 is not supported any more by upstream
20:36:29 <david-lyle> yeah
20:36:43 <ducttape_> so you get 1.8.  that choice is easy
20:36:48 <ducttape_> ;)
20:37:02 <david-lyle> but the code still has to work with 1.7
20:37:05 <mrunge> but in theory, we should still be supporting 1.7
20:37:09 <mrunge> yes
20:37:23 <robcresswell> Interesting. We would have to drop 1.7 to support 1.9.
20:37:37 <mrunge> can we do that?
20:37:42 <david-lyle> right which seems like a poor trade
20:37:56 <mrunge> I mean, doesn't zigo has liberty on django-1.7?
20:37:56 <david-lyle> I'm not sure we should
20:38:09 <mrunge> ... on current debian?
20:38:19 <mrunge> I may be wrong here
20:38:21 <mrunge> anyone?
20:38:33 <david-lyle> I think liberty on 1.9
20:38:34 <ducttape_> I would think apt would install 1.8, if that is in a repo
20:38:46 <r1chardj0n3s> hi, sorry I'm late
20:38:49 <robcresswell> Sid is 1.9, but I've no idea what Jessie is on
20:39:06 <robcresswell> r1chardj0n3s: No problem, we're discussing the django backport thing
20:39:15 <mrunge> but sid is not released yet
20:39:20 <david-lyle> but we can't break existing installs for liberty with 1.7 by supporting 1.9
20:39:25 <robcresswell> Sid never releases
20:39:59 <mrunge> jessie has django-1.7
20:40:00 <mrunge> https://packages.debian.org/jessie/python-django
20:40:06 <robcresswell> It looks like Jessie is on 1.7 and Stretch on 1.9 from what I can tell
20:40:09 <robcresswell> Yep
20:40:10 <david-lyle> I think non-backward incompatible fixes are fine to merge on liberty, but anything that breaks 1.7 support will have to be downstream
20:40:22 <robcresswell> So supporting Sid means breaking stable, which is silly.
20:40:30 <mrunge> sounds good to me
20:40:47 <mrunge> (to what david said)
20:41:09 <TravT> david-lyle: the voice of reason
20:41:11 <robcresswell> I agree too, I think. It's a shame zigo isn't here.
20:41:28 <robcresswell> Anyone against what david said?
20:42:27 <mrunge> as a break-down: as long as patches support both django-1.7 and 1.8 and 1.9, everything is fine
20:42:32 <TravT> you can do an actual vote robcresswell
20:42:56 <TravT> if needed
20:42:59 <TravT> #startvote (question) ? choice1, choice2
20:43:00 <openstack> Only the meeting chair may start a vote.
20:43:03 <TravT> #endvote
20:43:06 <TravT> FYI
20:43:25 <robcresswell> Just looking for discussion, thats all, but it seems we're okay
20:43:28 <mrunge> do we need to vote? is this controversial?
20:43:41 <TravT> doesn't seem like it
20:43:46 <neillc> I don't think so
20:44:21 <robcresswell> #agreed We shouldn't be backporting changes that break django compatibility at the time of release. So no 1.9 update for Liberty.
20:44:25 <tsufiev> the only person who could vote against is not here
20:44:31 <robcresswell> (I think thats the format for that :p )
20:44:45 <robcresswell> There are no more agenda items
20:44:52 <robcresswell> #topic Open Discussion
20:45:23 <robcresswell> #chair david-lyle
20:45:25 <openstack> Current chairs: david-lyle robcresswell
20:45:32 <robcresswell> Sorry, forgot to do that earlier.
20:45:35 <TravT> i thought i'd mention that Piet is running some UX meetings on Friday of the week of the mid-cycle
20:45:49 <TravT> not sure exactly the topics
20:45:57 <piet> Working on topics
20:46:02 <david-lyle> in addition to London?
20:46:07 <piet> Yeah
20:46:29 <piet> I happened to be in the Northwest to visit family, so thought I would spend a day in Portland.
20:46:47 <david-lyle> so we're all visiting your family?
20:46:58 <david-lyle> )
20:47:00 <robcresswell> That's very generous of them
20:47:05 <tqtran> home cook food woot!
20:47:09 <piet> I wouldn't recommend it
20:47:21 <piet> I'm the sanest one
20:47:31 <rhagarty_> do we have a list of blueprints slated for mitaka?
20:47:32 <david-lyle> enough said
20:47:32 <ducttape_> so then drinks it is!
20:47:34 <mrunge> you're trying to scare us?
20:48:09 <mrunge> rhagarty_, isn't that a bit early?
20:48:20 <david-lyle> rhagarty_: we have https://etherpad.openstack.org/p/mitaka-horizon-priorities and launchpad
20:48:40 <rhagarty_> thanks...
20:49:02 <piet> Is it open dance?  I have an ask....
20:49:05 <david-lyle> the launchpad side is fluid and mostly for tracking what's done
20:49:40 <rhagarty_> I have a cinder blueprint I'm working on... https://blueprints.launchpad.net/horizon/+spec/cinder-consistency-groups
20:49:58 <rhagarty_> was hoping to see it on some prioprity list
20:50:28 <rhagarty_> patch is here (first of two) - https://review.openstack.org/#/c/257630/
20:52:31 <rhagarty_> I see next week is a Cinder blueprint freeze... not sure if mine made the cut list
20:52:33 <TravT> rhagarty_: i believe the correct process would be to send cash payments to a few people.
20:52:48 <rhagarty_> that can be arranged
20:52:48 <robcresswell> Or the promise of beer
20:52:53 <hurgleburgler> LOL
20:52:57 <tsufiev> just the promise )
20:53:02 <matt-borland> lol
20:53:10 <david-lyle> rhagarty_: didn't the bp state that the cinder side was in in Kilo?
20:53:15 <tsufiev> promise-driven development
20:53:36 <hurgleburgler> bribe-driven development
20:53:51 <r1chardj0n3s> tsufiev: that's angular, right?
20:53:57 <robcresswell> hahaha
20:54:07 <rhagarty_> david-lyle, yes, Cinder side done. Am I reading "Cinder freeze" wrong?
20:54:11 <tsufiev> r1chardj0n3s, pretty good term for it :)
20:54:16 <r1chardj0n3s> yeah
20:54:29 <david-lyle> cinder freeze is only for cinder projects
20:54:35 <rhagarty_> oh, ok.
20:54:39 <r1chardj0n3s> for what we are going through with angular we promise to drink more beer
20:54:51 <david-lyle> we tend to be less organized^H^H^H^H^H strict
20:54:54 <TravT> ++
20:55:20 <david-lyle> jquery is still available
20:55:25 <hurgleburgler> \o/
20:55:46 <neillc> r1chardj0n3s: +1
20:55:55 <TravT> libraries are for n00bs. i think we should go to straight javascript
20:56:11 <hurgleburgler> old school, i like it
20:56:18 <rhagarty_> I would have loved to use angular, but it was a new tab to an existing django panel, a I didn't feel that would be a good starting point for my first attempt at angular
20:56:27 <robcresswell> Python is fine
20:56:31 <tsufiev> TravT, DOM is for n00bs, we should use good old document.write()
20:56:33 <tsufiev> :)
20:56:34 <TravT> rhagarty_: i think that is a correct starting point
20:56:46 <TravT> tsufiev: nice
20:56:46 <david-lyle> rhagarty_: no need to do anything crazy
20:56:58 <r1chardj0n3s> agreed
20:57:01 <robcresswell> As for the bp, it looks like its already approved, just needs a new milestone target
20:57:29 <robcresswell> Now you just need to fight for reviews :D
20:57:56 <rhagarty_> robcresswell, yup... that's what my previous comments were for :)
20:58:05 <david-lyle> rhagarty_: set for m-
20:58:06 <david-lyle> 3
20:58:14 <rhagarty_> david-lyle, thanks
20:58:20 * TravT thinks rhagarty_ thinks we were all kidding about bribes
20:58:27 <TravT> ;)
20:58:41 <rhagarty_> TravT, I can't afford it... I work for HP
20:58:49 <TravT> yeah, that's hard
20:58:54 <hurgleburgler> rhagarty_ +1
20:59:46 <robcresswell> Right, thats it for this week :)
20:59:51 <robcresswell> Thanks all
20:59:54 <TravT> thanks!
20:59:57 <robcresswell> #endmeeting