20:00:04 <david-lyle> #startmeeting Horizon
20:00:06 <openstack> Meeting started Wed May 11 20:00:04 2016 UTC and is due to finish in 60 minutes.  The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:10 <openstack> The meeting name has been set to 'horizon'
20:00:24 <itxaka> o/
20:00:34 <david-lyle> robcresswell had other engagements so you're stuck with me
20:01:03 <tsufiev> o/
20:01:13 <hurgleburgler> (◠‿◠✿)ノ
20:01:43 <david-lyle> another large crowd ;)
20:02:02 <bpokorny> o/
20:02:20 <david-lyle> and two look familiar from 12 hours ago
20:02:39 <david-lyle> let's get started
20:02:57 <david-lyle> The agenda for today can be found at
20:03:00 <david-lyle> #link https://wiki.openstack.org/wiki/Meetings/Horizon#Agenda_for_2016-05-11_2000_UTC
20:03:17 <david-lyle> there are a couple of notices
20:03:30 <david-lyle> one the bug report is updated
20:03:38 <david-lyle> #link https://wiki.openstack.org/wiki/Horizon/WeeklyBugReport
20:04:03 <david-lyle> with some bugs and bps currently targeted
20:04:21 <david-lyle> so take a look and prioritize appropriately
20:04:44 <david-lyle> 2nd notice is about the midcycle
20:04:56 <david-lyle> a poll for dates is:
20:05:03 <david-lyle> #link http://doodle.com/poll/xvchsbbs4qz9tzr7
20:05:29 <david-lyle> if you plan on attending please vote with your availability
20:05:47 <david-lyle> I'm not entirely sure the where
20:06:12 <hurgleburgler> the where might dictate the ability to attend
20:06:21 <david-lyle> right
20:06:30 <david-lyle> it was not in the email to the ML either
20:06:35 <david-lyle> just checked
20:06:56 <david-lyle> #action robcresswell tells us where we're going for midcycle
20:06:56 <tsufiev> robcreswell mentioned that it may be San Francisco
20:07:28 <david-lyle> ok
20:07:52 <david-lyle> that's it for notices and agenda
20:07:59 <david-lyle> #topic Open Discussion
20:08:41 <bpokorny> Does anyone know what's going on with the integration tests lately?
20:08:56 <tsufiev> hopefully once https://review.openstack.org/#/c/315050/ is merged we should get much fewer failures
20:09:19 <bpokorny> Great. Thanks, tsufiev.
20:09:30 <tsufiev> but if it's not, here is an etherpad we're going to update to keep track of actual failures: https://etherpad.openstack.org/p/horizon-integration-tests-failures
20:09:41 <tsufiev> I find it easier to use than kibana
20:10:03 <tsufiev> categorize failures, see how frequent they are etc
20:10:03 <bpokorny> ok, good to know.
20:10:14 <david-lyle> tsufiev: what about elastic recheck?
20:10:19 <tsufiev> current form is not final, may adjust it to our needs
20:11:16 <tsufiev> david-lyle, what's the usual workflow with elastic recheck that may help us in navigating in different failures?
20:11:45 <david-lyle> if you put those signatures in elastic recheck, you would get a count on the failure numbers and the notice when it fails on the patch in gerrit
20:11:47 <tsufiev> I mean I'm not very familiar with ER facilities that really help finding out root causes...
20:12:10 <david-lyle> and an entry on here http://status.openstack.org//elastic-recheck/
20:12:25 <tsufiev> okay, I'll try it :)
20:12:44 <david-lyle> it's more about quantifying the failures and assess if they actually went away
20:13:15 <david-lyle> just something for the future
20:13:43 <tsufiev> thanks, I have to eventually get used to these big data helpers
20:14:02 <tsufiev> my first impression with kibana wasn't very... friendly
20:14:14 <david-lyle> the second thing to check is http://status.openstack.org//openstack-health/#/g/project/openstack~2Fhorizon?groupKey=project&resolutionKey=hour&end=2016-05-11T20:13:19.115Z
20:14:41 <david-lyle> but for some reason the failures are not showing up for integration jobs
20:15:00 <tsufiev> hehe
20:15:12 <tsufiev> you see, the job is fine :)
20:15:13 <david-lyle> so that might be worth checking into
20:15:25 <clarkb> kibana is a giant blobof js, I hear horizonay know how to workwith that >_>
20:16:12 <david-lyle> it's all an illusion clarkb
20:16:31 <tsufiev> being a developer doesn't mean we all know how to fix an electric kettle :)
20:16:35 <clarkb> kibana 3 is all client side and kibana 4 is node.js
20:16:48 <david-lyle> from bad to worse
20:16:51 <david-lyle> :)
20:16:57 <itxaka> lool
20:17:20 <clarkb> we currently run 3
20:17:29 <tsufiev> so the integration job fix just merged
20:17:52 <tsufiev> if you still encounter any failures in check job, just rebase your work onto latest master
20:18:03 <david-lyle> tsufiev: was it only failing in check?
20:18:07 * tsufiev crosses fingers
20:18:16 <david-lyle> that would explain health not showing failures
20:18:22 <hurgleburgler> thanks tsufiev
20:18:22 <david-lyle> but seems odd
20:18:50 <tsufiev> david-lyle, AFAIK, gate job always runs against latest master, but check is run for topic branches which may not be up to date
20:19:09 <tsufiev> no, failures were in both pipelines
20:19:17 <david-lyle> ok, that makes more sense
20:19:27 <david-lyle> your phrasing confused me
20:19:36 <david-lyle> but I started in that direction ;)
20:19:41 <tsufiev> yeah, I fancy being cryptic sometimes :)
20:20:21 <david-lyle> since we don't have a blueprint for this, as blueprints don't really track CP stuff
20:20:30 <david-lyle> I have created a tempest plugin for horizon
20:20:46 <david-lyle> it's merged and there is a new test job that runs on check which isn't voting
20:20:47 <tsufiev> btw, I've noticed that there were some tempest failures as well
20:21:12 <tsufiev> cannot give a specific link though
20:21:28 <david-lyle> I'm finalizing the job setup, once that's ready and passing, we can run that on gate as well
20:21:40 <david-lyle> and remove our test from integrated tempest
20:22:05 <david-lyle> then we can move forward with upper-constraints and new xstatic packages
20:22:22 <tsufiev> david-lyle, or the thing you're speaking about is not related to dsvm-tempest job?
20:22:35 <david-lyle> tsufiev: no
20:22:55 <tsufiev> :o
20:22:59 <david-lyle> well, gate-horizon-dsvm-tempest-plugin
20:23:01 <david-lyle> job
20:23:33 <david-lyle> is that what you're referring to?
20:24:01 <david-lyle> the job isn't doing much yet, I have another patch up that I am testing out
20:24:27 <david-lyle> https://review.openstack.org/#/c/314795/
20:24:36 <david-lyle> anyway, just a status report
20:24:42 <tsufiev> I think yes
20:25:25 <tsufiev> well, never mind, if it wasn't voting yet, then I most likely confused it with something else
20:25:32 <tsufiev> as that thing was voting
20:25:48 <david-lyle> ok
20:26:01 <tsufiev> when you look into many failures, they start looking into you :/
20:26:19 <itxaka> umm talking about failures and gate
20:26:45 <itxaka> did someone saw michael's email referring to npm mirrors?
20:26:47 <itxaka> http://lists.openstack.org/pipermail/openstack-dev/2016-May/094719.html
20:27:17 <itxaka> project I guess?
20:27:24 <itxaka> agh, cut phrase
20:27:38 <tsufiev> now I did :)
20:27:39 <itxaka> we are supposed to add the nam mirrors to the project I guess
20:28:20 <david-lyle> I tried it locally
20:28:31 <tsufiev> could we just change npm job builders?
20:29:01 <itxaka> ahh, now I am reading it properly lmao
20:29:17 <itxaka> its just to test it locally and report any errors, nothing to do with touching the project
20:29:20 <itxaka> sorry for the noise
20:29:27 * itxaka retreats
20:31:22 <david-lyle> any other items?
20:31:58 <ducttape_> so we get to ignore all test jobs, then?  great.  let's move forward  ;)
20:32:22 <tsufiev> wat :)?
20:32:31 <ducttape_> just trolling / kidding
20:32:31 * david-lyle thinks ducttape_ misread something
20:32:53 <TravT> david-lyle what's the net result of all this?
20:33:04 <david-lyle> TravT: this?
20:33:14 <TravT> ^^^
20:33:21 <TravT> last 15 mins
20:33:38 <david-lyle> status update
20:33:44 <ducttape_> that there are a lot of test jobs failing / getting fixed.  it's getting better very soon
20:33:53 <david-lyle> integration tests should be working better
20:34:04 <david-lyle> plans for xstatic upgrades moving forward
20:34:12 * TravT will send thank you card to david-lyle
20:34:48 <david-lyle> there is an npm mirror that will reduce failures and fragility in npm dependent tests
20:35:26 <tsufiev> one more reason to come by the end of meeting :)
20:36:30 <david-lyle> any other items?
20:37:03 <david-lyle> any hasty decisions to make?
20:37:10 <david-lyle> going twice
20:37:34 * TravT sold
20:37:39 <david-lyle> Have a banner week folks. Keep slinging that cloud.
20:37:43 <david-lyle> #endmeeting