20:00:57 <r1chardj0n3s> #startmeeting horizon
20:00:58 <openstack> Meeting started Wed Nov  2 20:00:57 2016 UTC and is due to finish in 60 minutes.  The chair is r1chardj0n3s. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:02 <openstack> The meeting name has been set to 'horizon'
20:01:03 <robcresswell> yeah bot must have disconnected
20:01:04 <r1chardj0n3s> \o/
20:01:06 <robcresswell> woohoo
20:01:11 <r1chardj0n3s> hello folks :-)
20:01:28 * ducttape_ better late than never
20:01:42 <r1chardj0n3s> OK, got a few things to mention
20:01:52 <r1chardj0n3s> #topic Selenium has been removed from the gate (was non-voting)
20:01:59 <r1chardj0n3s> #link https://review.openstack.org/#/c/391342/
20:02:11 <r1chardj0n3s> These jobs were a burden on the gate systems and since they are broken and not voting, there is no reason for them to run.
20:02:29 <r1chardj0n3s> We still have the non-voting check jobs to test out fixes.
20:02:39 <betherly> sounds good!
20:02:51 <tsufiev> +1
20:02:56 <r1chardj0n3s> I think I saw tsufiev already has a patch up to test out Firefox version shenanigans
20:03:40 <tsufiev> r1chardj0n3s, had a patch already for pinning marionette, and recently uploaded single browser fix
20:04:02 <r1chardj0n3s> cool, will keep an eye on them then
20:04:03 <tsufiev> now we've another occurrence of an old issue - mozilla ftp is not responding in time
20:04:13 <r1chardj0n3s> oh :-/
20:04:18 <tsufiev> thus our pinned firefox is unable to download
20:04:36 <tsufiev> will recheck it shortly after to see if it's a temporary issue
20:04:47 <tsufiev> but it still is downloadable by hand
20:05:02 <r1chardj0n3s> just like the phantomjs downloading, we need that thing to be cached or something.
20:05:13 <rdopiera> wait, we are downloading and installing firefox for every test?
20:05:25 <tsufiev> rdopiera, nope, just for the whole suite
20:05:34 <rdopiera> so for every patch
20:05:36 <tsufiev> doing it for every test would be too much even for us
20:05:42 <tsufiev> yep, that's true
20:05:49 <tsufiev> for every patch it is
20:06:24 <r1chardj0n3s> ok, well, we will keep an eye on it, and how about we talk to #infra about possible caching options for the firefox download?
20:06:28 <tsufiev> rdopiera, comparing to all the stuff happening during devstack deploy (for every patch) that's not a big dieal
20:06:42 <tsufiev> r1chardj0n3s, it would be awesome if they agreed
20:06:52 <ducttape_> if we could add it to the base image used for testing, that'd be nice
20:07:11 <r1chardj0n3s> #action Richard to talk to #openstack-infra about browser install file caching
20:07:20 <r1chardj0n3s> (I think #action is a thing ;-)
20:07:34 <robcresswell> Does infra have its own requirements mirror, or just use pypi?
20:07:44 <robcresswell> yup, it is
20:07:44 <r1chardj0n3s> robcresswell: yes, we mirror pypi
20:07:48 <tsufiev> r1chardj0n3s, well, may be we need a special builder macros, something like legacy-firefox
20:08:01 <tsufiev> there is already 'firefox' builder macro
20:08:10 <r1chardj0n3s> tsufiev: I'm sure we can sort out the detail with them :-)
20:08:20 <robcresswell> cool. I've been mirroring things locally too because otherwise testing out multiple tox things takes forveerrrr
20:08:35 * robcresswell is off topic
20:08:56 <r1chardj0n3s> robcresswell: oh, yes, definitely run your own local mirror, I shall provide clues for that later if you like :-)
20:08:59 <r1chardj0n3s> ok, moving on
20:09:02 <r1chardj0n3s> #topic Summit recap
20:09:03 * tsufiev thought for a moment about containers hotness
20:09:08 <r1chardj0n3s> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/106520.html
20:09:14 <r1chardj0n3s> Please have a read!
20:09:24 <r1chardj0n3s> And discuss, if you find anything controversial :-)
20:09:27 <tsufiev> r1chardj0n3s, that was a very nice recap :)
20:09:59 <r1chardj0n3s> thanks tsufiev, I also hope it was accurate :-)
20:10:30 <r1chardj0n3s> #topic New Keystone/Horizon meeting
20:10:39 <r1chardj0n3s> The kickoff for these meetings will be 8th November 2000UTC in #openstack-meeting-cp
20:10:47 <stevemar> \o/
20:10:50 <tsufiev> every week?
20:10:52 <r1chardj0n3s> ohai stevemar :-)
20:10:53 <rdopiera> -cp?
20:11:01 <tsufiev> cross-project?
20:11:02 <rdopiera> ah, x-project
20:11:18 <robcresswell> not openstack-meeting-copy
20:11:19 <tsufiev> yeah, should have named it *-xp :)
20:11:20 <robcresswell> :)
20:11:23 <r1chardj0n3s> It's a temporary channel until we agree on a more permanent meeting time/place
20:11:44 <robcresswell> :o need logs
20:11:52 <r1chardj0n3s> yes, it's a logged channel
20:12:00 <robcresswell> oh, neat
20:12:08 <robcresswell> TIL
20:12:13 <stevemar> tsufiev: r1chardj0n3s we ended up with a list of things that need to be fixed in keystone/horizon and i imagine the meetings will go on until we've got patches up for all the broken things :)
20:12:25 <r1chardj0n3s> yep, what stevemar said :-)
20:12:40 <ducttape_> they aren't broken, they are opportunities
20:12:50 <tsufiev> haha, I guess we're going to have these meeting for a long time ;)
20:12:51 <ducttape_> ;)
20:12:53 <robcresswell> newest d_o_a release has fixed token revocation btw.
20:12:58 <robcresswell> I've not tagged new stable yet.
20:13:57 <r1chardj0n3s> #topic Priority patches for review
20:14:28 <r1chardj0n3s> Our priorities discussion at the summit ended up with a number of patches already in-flight that would be super awesome to land by Ocata-1
20:14:37 <r1chardj0n3s> ... which is just under two weeks away :-)
20:14:47 <ducttape_> https://review.openstack.org/#/c/389866/   is a simple one, if I can advocate for ediardo
20:14:49 <betherly> wow that comes round fast
20:15:01 <r1chardj0n3s> For your convenience, I have tagged them in gerrit for you:
20:15:03 <r1chardj0n3s> #link https://review.openstack.org/#/q/starredby:r1chardj0n3s%20AND%20status:open
20:15:22 <ediardo> :)
20:15:30 * robcresswell feels the pressure
20:15:58 <ediardo> Guys, I'll need extra eyes on this patch that 'tries
20:16:18 <ediardo> to fix a few bugs in magicsearch
20:16:30 <ediardo> https://review.openstack.org/#/c/388200/
20:16:58 <r1chardj0n3s> Of course please do look at bug patches also, those ones I've starred are the features / ground work for the priorities we've tagged for Ocata goals
20:17:36 <r1chardj0n3s> There is also ui-router, which I need to get moving through the xstatic packaging machinery and into requirements
20:17:38 <r1chardj0n3s> #link https://blueprints.launchpad.net/horizon/+spec/ui-router
20:17:59 <r1chardj0n3s> (and I also need to update some POC code, I think)
20:18:23 <robcresswell> Made myself Approver so I can hassle you about its progress
20:18:30 <r1chardj0n3s> thanks robcresswell :-)
20:18:35 <ducttape_> would that help with extensibility issues ?
20:18:40 <ducttape_> seems like maybe
20:18:59 <r1chardj0n3s> If anyone has a patch that they feel is missing from the starred list please let me know.
20:19:23 <r1chardj0n3s> ducttape_: ui-router is necessary for more complex angularjs panels with nested information in them
20:19:38 <r1chardj0n3s> like Swift UI with container -> objects
20:19:46 <ducttape_> sure, I just didn't know if it might also provide extension hooks to change certain behaviors
20:20:07 <r1chardj0n3s> that's an interesting angle I hadn't considered
20:20:12 * ducttape_ needs to stay on topic, sorry
20:20:17 <lcastell> I have this one that's been around for a while https://review.openstack.org/327224 (server side filtering for swift)
20:20:33 <r1chardj0n3s> ducttape_: please do mumble such things in the BP whiteboard :-)
20:21:13 <r1chardj0n3s> lcastell: we will definitely be looking to land that in Ocata, though I have been talking to swift folks about getting more useful filtering than just prefix
20:21:33 <lcastell> yeah, right now is pretty lame :(
20:21:48 <r1chardj0n3s> still useful though
20:21:49 <betherly> r1chardj0n3s: I notice you said re panels again... is there any change to preference re people developing panels vs plugins?
20:22:16 <r1chardj0n3s> betherly: we still prefer for non-"core" services to be plugins
20:22:18 <ducttape_> you will get a mix of both betherly
20:22:41 <r1chardj0n3s> we definitely like people to be working on both
20:22:53 <betherly> ok cool. thanks! just wanted to check :)
20:23:06 <ducttape_> if you are doing a plugin, chances are high it also contains a panel or 2
20:23:22 <robcresswell> I smell sarcasm
20:23:39 <ducttape_> none from me
20:23:48 <robcresswell> :p
20:23:58 <r1chardj0n3s> never
20:24:00 <r1chardj0n3s> #topic Priority bugs
20:24:02 <betherly> nor me
20:24:08 <r1chardj0n3s> #link https://bugs.launchpad.net/horizon/+bug/1624743
20:24:08 <openstack> Launchpad bug 1624743 in OpenStack Dashboard (Horizon) "Project image table: admin user sees images which are not shared with me" [High,In progress] - Assigned to Brad Pokorny (bpokorny)
20:24:25 <robcresswell> Oh, we should remove bpokorny probably
20:24:38 <r1chardj0n3s> (this is a short list, because I ran out of time ;-)
20:24:43 <robcresswell> though it seems like he is lurking in the meeting if my autocomplete is right
20:25:01 <r1chardj0n3s> yep, this one needs more eyes/brains on it
20:25:14 <ducttape_> I think this is really a glance bug too
20:26:35 <robcresswell> I haven't looked yet, but will do
20:26:51 <r1chardj0n3s> I've also not had a chance to look into it in any detail
20:27:12 <robcresswell> Also we should really fix the default LI source, its changed to volume snapshot or something for some reason
20:27:29 <r1chardj0n3s> weird
20:28:39 <r1chardj0n3s> #topic Open Discussion
20:28:51 <r1chardj0n3s> robcresswell you wanted to have a local pypi mirror
20:29:01 <robcresswell> https://review.openstack.org/#/c/389352/ << Patch for Horizon 10.0.1
20:29:02 <r1chardj0n3s> I recommend http://doc.devpi.net/latest/quickstart-pypimirror.html
20:29:14 * ducttape_ if only anyone knew how to setup and run pypi
20:29:14 <robcresswell> r1chardj0n3s: Excellent, thats what I've been using
20:29:20 <robcresswell> hahaa
20:29:30 <ducttape_> :p
20:29:36 <r1chardj0n3s> that would be a handy person to have around, ducttape_
20:29:37 <rdopiera> there is also devpi
20:29:44 <rdopiera> by the author of tox and pytest
20:29:49 <r1chardj0n3s> rdopiera: that's what I linked ;-)
20:29:55 * robcresswell wonders if rdopiera can read
20:29:59 <r1chardj0n3s> ouch
20:30:01 <rdopiera> indeed
20:30:03 <rdopiera> I'm blind
20:30:07 <robcresswell> haha
20:30:13 <rdopiera> forgot to tell you
20:30:17 <r1chardj0n3s> :-)
20:30:35 <robcresswell> I've got post conference illness so I'm just grumpy
20:30:40 <r1chardj0n3s> :-(
20:30:49 <rdopiera> shows the advantage of js over python -- all those indentations are difficult to touch-read
20:30:51 <ducttape_> jamon-flu
20:31:08 <r1chardj0n3s> I'm having a long weekend this coming weekend, so I'm away from tomorrow on
20:31:16 <r1chardj0n3s> it's PAX AU weekend :-D
20:31:32 <rdopiera> I think I will have a long weekend due to a sick-leave, if this continues
20:31:41 <r1chardj0n3s> but it means I won't be around much after today until next week.
20:32:09 <robcresswell> I forsee many reviews ahead
20:32:10 <r1chardj0n3s> "today" being Thursday in my timezone
20:32:21 <robcresswell> ah, the future.
20:32:34 <rdopiera> good to know, let's prepare to merge all the stuff we don't want you to see
20:32:35 <r1chardj0n3s> in the future, breakfast is needed
20:32:37 <ducttape_> if you need anything done yesterday, lemme know
20:32:55 <robcresswell> quotas?
20:32:58 <r1chardj0n3s> heh
20:33:02 <ducttape_> touché
20:33:18 <rdopiera> incidentally, quotas planning has been postponed due to flu
20:33:19 <ducttape_> I think I will hack up the tests for those things more significantly
20:33:20 <ducttape_> btw
20:33:39 <rdopiera> I mean that landing page pagination stuff
20:33:53 <tsufiev> what's about throwing away all existing quota tests first, ducttape_?
20:33:55 <robcresswell> On a serious note, we really do need eyes on those XStatic updates. This cycle is short already, and for stability sake we cant really merge important libs past b2
20:34:08 <tsufiev> would be less work to do ;)
20:34:08 <r1chardj0n3s> yep, what robcresswell said
20:34:19 <ducttape_> yep, lets get those merged / in and find all the bugs
20:34:29 <rdopiera> https://review.openstack.org/#/q/project:^stackforge/xstatic.*+status:open,n,z
20:34:37 <rdopiera> ^-- useful link
20:34:47 <ducttape_> tsufiev: I will likely change the tests so they look like what our future vision would be, not the old confusing past with quotas
20:34:54 <robcresswell> rdopiera: stackforge?
20:35:02 <tsufiev> actually, if throwing them away allowed us to rewrite tests using mock instead of mox, that would be really good
20:35:05 <r1chardj0n3s> https://review.openstack.org/#/q/project:^openstack/xstatic.*+status:open,n,z is corrected link
20:35:10 <robcresswell> ohai 2014 :p
20:35:16 <rdopiera> argh
20:35:24 <rdopiera> explains why it was always empty
20:35:27 <r1chardj0n3s> :-D
20:35:35 <robcresswell> haha
20:35:49 <robcresswell> make typo. no reviews. job done.
20:35:52 * r1chardj0n3s notes those are already in the priorities starred list ;-)
20:36:11 <robcresswell> yeah, I was just emphasising the point
20:36:19 <robcresswell> emphasizing for those in the US
20:36:21 <r1chardj0n3s> that's cool :-)
20:36:39 <r1chardj0n3s> ok, any other business?
20:36:46 <r1chardj0n3s> or can I go have breakfast?
20:36:50 <robcresswell> most of them I've updated MAIN too, so we can steadily remove those hacks from our codebase
20:36:58 <robcresswell> I'm all done, you may eat
20:37:09 <r1chardj0n3s> \o/ robcresswell for more MAIN
20:37:24 <ducttape_> thanks all
20:37:30 <rdopiera> by the way, what is there to review in an xstatic
20:37:43 <rdopiera> other than metadata and comparing the files with the upstream repo?
20:37:54 <r1chardj0n3s> rdopiera: I tend to install it and make sure horizon doesn't fall about laughing, mostly
20:38:00 <ducttape_> I'd think you want to download patch and deploy it rdopiera
20:38:03 <r1chardj0n3s> and then double-check the metadata is sane
20:38:22 <rdopiera> r1chardj0n3s: how do you check horizon?
20:38:23 <ducttape_> reviewing line by line is going to be painful / not helpful I'd think
20:38:26 <rdopiera> r1chardj0n3s: smoke tests?
20:38:40 <rdopiera> grenade?
20:38:42 <robcresswell> install it locally and run tests, then just try it
20:38:49 <robcresswell> there's the JS unit tests for one
20:38:49 <tsufiev> rdopiera, that what some used integration tests for
20:38:57 <r1chardj0n3s> yep, what robcresswell said
20:39:09 <robcresswell> and any big JS like bootstrap, jquery, angular, will likely console log as soon as its evaluated
20:39:30 <rdopiera> ok, so check the logs
20:39:39 <rdopiera> by the way, we still have that compatibility layer in there?
20:39:42 <rdopiera> for jquery?
20:39:52 <robcresswell> if tests pass and there are no obvious breakages, i.e. workflows are okay, nothing visually catastrophic, then check metadata and content, merge away
20:40:01 <robcresswell> We do indeed
20:40:26 <robcresswell> We could probably go straightto jquery 3 without much trouble since we basically only use it for selectors and simple manipulation...
20:40:47 <rdopiera> but probably not in this release :)
20:41:22 <robcresswell> well, depends on workload. Also I think jquery is still owned by someone else iirc
20:41:30 <robcresswell> also depends on reviews :)
20:42:37 <robcresswell> anyway we can discuss this another time
20:42:42 <r1chardj0n3s> ok, I think we're done. thanks everyone for coming, and catch you in #openstack-horizon :-)
20:42:50 <rdopiera> good night
20:42:50 <robcresswell> \o thanks r1chardj0n3s
20:42:54 <r1chardj0n3s> #endmeeting