20:00:04 <r1chardj0n3s> #startmeeting horizon
20:00:05 <openstack> Meeting started Wed Nov 23 20:00:04 2016 UTC and is due to finish in 60 minutes.  The chair is r1chardj0n3s. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:09 <openstack> The meeting name has been set to 'horizon'
20:00:13 <r1chardj0n3s> hullo o/
20:00:44 <r1chardj0n3s> (I suspect a lower turnout today due to folks in the US talking vacation time)
20:01:11 <lcastell> o/
20:01:16 <betherly_> o/
20:01:28 <r1chardj0n3s> if all else fails I can sit in the corner and play Pokemon
20:01:35 <tqtran> [=_=]/
20:01:42 <betherly_> :D
20:01:53 <betherly_> I've got addicted to Ramsay dash
20:01:59 * betherly_ feels ashamed
20:01:59 <jlopezgu> o/
20:02:12 <tqtran> still playing pokemon? its been months!
20:02:15 <r1chardj0n3s> oh, betherly_ :-(
20:02:26 <r1chardj0n3s> tqtran: game came out last Friday :-P
20:02:27 <betherly_> r1chardj0n3s: I know, I know
20:02:30 <r1chardj0n3s> OK let's move on
20:02:38 <r1chardj0n3s> #topic Priority patches for review
20:02:43 <r1chardj0n3s> #link https://review.openstack.org/#/q/starredby:r1chardj0n3s%20AND%20status:open
20:03:04 <r1chardj0n3s> The list hasn't changed much in the last week, which is sad, because most of the things on the list were intended for Ocata-1 :-(
20:03:18 <tqtran> i added 2 recent items
20:03:36 <rdopiera> o/
20:03:59 <r1chardj0n3s> I'll add more of the Ocata-2 priority items (mostly angularja panel rewrites) once we get those out of the way.
20:04:06 <r1chardj0n3s> tqtran: which 2 items?
20:04:53 <tqtran> auto xstatic discovery and zaqar websocket
20:05:04 <r1chardj0n3s> oh, the agenda items, yep I have them noted thanks!
20:05:12 <r1chardj0n3s> #topic Reducing fragility of Horizon around release time?
20:05:13 <tqtran> was hoping more people are around....
20:05:25 <tqtran> since i wanted to get more opinions but sigh... its fine
20:05:38 <r1chardj0n3s> tqtran: yeah :-(
20:06:13 <r1chardj0n3s> Ocata-1 was a bit of a mess, we need to think about ways to tighten up the xstatic releases to try to avoid that again :-)
20:06:32 <r1chardj0n3s> I don't want to have to apologise to dhellmann too many more times ;-)
20:06:46 <r1chardj0n3s> I have some thoughts.
20:06:58 <r1chardj0n3s> How about no xstatic releases in release week? Ocata-1 was very short though :-(
20:07:15 <betherly_> It was that
20:07:20 <r1chardj0n3s> Regardless, I think better testing using the xstatic libraries before they’re released to expose issues would be good.
20:07:33 <tqtran> Im fine with that, we dont always have to use the latest and greatest (unless theres a feature we need)
20:07:41 <r1chardj0n3s> It can be tricky to test them, so maybe we could use some docs to help that?
20:08:15 <tqtran> if we had js integration tests, it would be easy to test
20:08:35 <r1chardj0n3s> tqtran: oh, did you just volunteer to fix our JS integration tests? :-)
20:08:42 <tqtran> we dont have any.....
20:08:42 <r1chardj0n3s> (read: selenium)
20:09:17 <tqtran> all it does is run jasmine and checks that the checksum all add up
20:09:41 <r1chardj0n3s> if you have thoughts about how to do non-selenium JS integration tests, I'd love to hear 'em!
20:10:21 <r1chardj0n3s> some things like the angular-bootstrap update definitely trigger test fails
20:10:38 <r1chardj0n3s> but a bunch of the xstatic libs aren't used by angular code
20:10:59 <r1chardj0n3s> or, in the case of roboto, you can't test using JS tests
20:11:28 <r1chardj0n3s> (I'm not sure our Selenium suite would've spotted that breakage either though)
20:11:54 <tqtran> one step at a time. i think what you suggested is reasonable. no releases during release week
20:12:33 <r1chardj0n3s> kinda like Horizon already feature freezes one week before other projects to allow knock-on effects in plugins to be discovered
20:13:26 <r1chardj0n3s> #agreed we should avoid releasing new xstatic library versions during release week
20:13:33 <r1chardj0n3s> moving on
20:13:38 <r1chardj0n3s> #topic ui-cookiecutter is now a project under Horizon
20:13:41 <r1chardj0n3s> \o/
20:13:43 <tqtran> yay!
20:13:46 <r1chardj0n3s> #link https://blueprints.launchpad.net/horizon/+spec/ui-cookiecutter
20:13:53 <r1chardj0n3s> It has its own core team as well, but Horizon cores are able to approve patches also.
20:14:32 <r1chardj0n3s> We can continue the discussion about retiring startpanel/startdash when the interested folks want to :-)
20:14:32 <tqtran> i thought its still going through gov? https://review.openstack.org/#/c/398785/
20:14:57 <tqtran> the repo and team are created, got an email on that
20:14:58 <r1chardj0n3s> hah, I thought I'd seen that merge. oh, they'll catch up ;-)
20:15:07 <r1chardj0n3s> gov always takes the longest
20:15:29 <r1chardj0n3s> #topic Auto static pathing of xstatic packages
20:15:35 <r1chardj0n3s> #link https://review.openstack.org/#/c/195371/
20:15:39 <r1chardj0n3s> tqtran ?
20:15:49 <tqtran> so rdopiera commented in there about security concerns
20:16:02 <tqtran> but we addressed at the midcycle and consensus was to allow it
20:16:02 <rdopiera> it's not just security
20:16:27 <tqtran> i left an explanation, is there anything else i missed?
20:17:11 <rdopiera> what that patch does, basically, is "import everything that is installed in the system that matches the name"
20:17:23 <rdopiera> we can't assume Horizon is the only installed application
20:17:30 <r1chardj0n3s> that's a very good point
20:18:03 <tqtran> hm....
20:18:07 <tqtran> i see what you're saying
20:18:23 <rdopiera> basically, horizon can stop working after the user installs something completely unrelated
20:18:39 <rdopiera> and the only fix would be either to uninstall it, or add to some kind of a blacklist
20:18:51 <rdopiera> but I think it's much better to have a whitelist instead
20:19:01 <r1chardj0n3s> I've been leaning towards the explicit listing instead of auto listing myself, and I think rdopiera is nicely articulating one of the things that's been troubling me about auto listing
20:19:20 <r1chardj0n3s> as rdopiera mentions, we don't change that whitelist that often
20:19:24 <tqtran> ok, im fine with that. we dont update that list that often anyhow.
20:19:44 <rdopiera> I would have nothing against a script that would check what we use and add that to requirements.txt, if we don't want to have it in two places
20:19:47 <r1chardj0n3s> and now that we're cleaning up the xstatic package metadata the amount of code change per xstatic package addition is being reduced to a single line.
20:19:50 <tqtran> well actually, i just remembered the use case
20:20:21 <tqtran> so kevin fox brought this up, he wanted to install an xstatic lib in his plugin
20:20:34 <tqtran> but theres no way to do that atm
20:20:38 <rdopiera> yes, we should have a way for the plugins to add to that list
20:20:48 <tqtran> he would have to package the lib into the plugin
20:21:03 <r1chardj0n3s> yes, the xstatic list should be exstensible
20:21:35 <tqtran> so if we are whitelisting, that list needs to be made available to plugins for extending
20:21:47 <tqtran> im thinking the enabled file is a good place
20:23:14 <tqtran> anyway, next topic. we can talk about it at a separate time.
20:24:16 <r1chardj0n3s> #topic Zaqar push-based communication via websocket (POC)
20:24:22 <r1chardj0n3s> #link https://review.openstack.org/#/c/246009/
20:24:53 <tqtran> so are there plans to work on the instances panel in P?
20:25:03 <tqtran> i believe we are going to tackle it yes?
20:25:55 <r1chardj0n3s> there's some instances work planned for O
20:26:10 <r1chardj0n3s> https://review.openstack.org/#/c/261376/
20:26:23 <r1chardj0n3s> https://review.openstack.org/#/c/316244/
20:26:27 <tqtran> er... are we going to realistic make it though?
20:26:37 <r1chardj0n3s> *shrug*
20:27:04 <tqtran> anyway, the reason i ask is because fei long (the zaqar PTL) has the linked patch
20:27:10 <tqtran> but its all written in legacy
20:27:40 <r1chardj0n3s> wow, that's an old patch :-(
20:27:52 <tqtran> so the question is (and maybe we should ask again when everyone is around) whether we let it in now, or rewrite it after angular instances panel land
20:28:17 <tqtran> since i have no idea whos going to be taking on the instances panel
20:28:33 <tqtran> its one of those cost vs benefits question (do it now with legacy, or do it right with angular)
20:28:44 <r1chardj0n3s> It clearly lacks a champion. I think it might be best to ask the broader group when folks are back next week.
20:28:53 <tqtran> yeah
20:29:15 <r1chardj0n3s> OK, one more week ain't gonna kill it.
20:29:32 <tqtran> right, its been there for ages anyhow
20:29:36 <r1chardj0n3s> Noting that O-2 is only a few weeks long itself because of this crazy cycle
20:30:18 <r1chardj0n3s> #topic Open Discussion
20:30:27 <tqtran> im gonna mark myself as approver for the ng-instances bp if thats ok
20:30:32 <tqtran> just so i can track it a bit better
20:30:34 <r1chardj0n3s> tqtran: thanks!
20:30:39 <tqtran> https://blueprints.launchpad.net/horizon/+spec/ng-instances
20:30:59 <r1chardj0n3s> Any other topics folks would like to bring up?
20:31:03 <betherly_> still working on pagination stuff - been a bit of a pig to get devstack and my env set up but nearly there now *facepalm*
20:31:14 <rdopiera> I'm rolling the first patch in the series for the settings cleanup
20:31:24 <betherly_> rdopiera: woot
20:31:38 <rdopiera> but I'm not yet entirely sure about the road to take exactly further down that
20:31:53 <rdopiera> I guess we will see when we get there
20:32:18 <r1chardj0n3s> betherly_: we have hidden knowledge in Horizon's docs to help devstack setup doc/source//ref/local_conf.rst
20:32:30 <rdopiera> one idea I have so far is to first tackle the django settings -- as those are relatively fixed
20:32:41 <r1chardj0n3s> one of these days I'll remember to get that better linked into the docs
20:33:02 <r1chardj0n3s> rdopiera: do you have a BP for that?
20:33:04 <betherly_> r1chardj0n3s: ye I'm normally ok with devstack but the bringing down of the nova and novaclient patches caused some pain. I'll definitely take a look though that's awesome thanks!
20:33:13 <r1chardj0n3s> betherly_: ah, right!
20:33:19 <rdopiera> https://blueprints.launchpad.net/horizon/+spec/ini-based-configuration
20:33:23 <rdopiera> it's still the same old bp
20:33:27 <rdopiera> but I filled some steps
20:33:40 <r1chardj0n3s> rdopiera: right, so it'd be good to update from the summit discussion about defaults perhaps?
20:33:45 <betherly_> r1chardj0n3s: when I say some pain, I under exaggerate ;)
20:34:02 <r1chardj0n3s> betherly_: I can only imagine
20:34:15 <rdopiera> r1chardj0n3s: not sure what you mean
20:34:23 <betherly_> in other news, I've put my name in to be considered to come to the meetup so hopefully see you all there
20:34:39 <rdopiera> r1chardj0n3s: we agreed to have them in one place, pretty much like in the original bp
20:35:00 <r1chardj0n3s> rdopiera: we discussed tying the ini changes to robcresswell's (IIRC) thoughts about having default setting values be more sensibly organised
20:35:09 <r1chardj0n3s> betherly_ \o/
20:35:38 <rdopiera> r1chardj0n3s: I will review the notes and upgrade
20:35:51 <r1chardj0n3s> rdopiera: thanks!
20:36:25 <r1chardj0n3s> right, so now onto the important Pokemon section of the meeting
20:36:56 <tqtran> haha
20:37:06 <tqtran> is it the new game for handheld?
20:37:27 <r1chardj0n3s> tqtran: yes. omg. your gamer cred is dying here
20:37:43 <rdopiera> it's been around since game boy...
20:37:50 <r1chardj0n3s> I think we might be done, thanks everyone for coming to this special Thanksgiving Vacation Time meeting! :-)
20:37:58 <r1chardj0n3s> #endmeeting