20:01:24 <e0ne> #startmeeting horizon
20:01:25 <openstack> Meeting started Wed Mar 21 20:01:24 2018 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:29 <openstack> The meeting name has been set to 'horizon'
20:01:45 <ying_zuo> o/
20:01:48 <vladiskuz> o/
20:02:08 <e0ne> hi
20:03:40 <e0ne> #topic Notices
20:04:03 <e0ne> so, there is only one month left until rocky-1 milestone
20:04:36 <e0ne> # link https://launchpad.net/horizon/+milestone/rocky-1
20:04:54 <dklyle> o/
20:05:01 <e0ne> dklyle: morning:)
20:05:03 <rdopiera> o/
20:05:34 <e0ne> I'm glad that we've good good team here
20:05:48 <e0ne> most of targeted bugs and blueprints are in progress or merged now
20:06:05 <e0ne> we're in a good shape of releasing rocky-1
20:06:48 <e0ne> there are some unassigned high priority bugs
20:06:51 <e0ne> #link https://bugs.launchpad.net/horizon/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.importance%3Alist=CRITICAL&field.importance%3Alist=HIGH&assignee_option=none&field.assignee=&field.bug_reporter=&field.b
20:06:51 <e0ne> ug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
20:07:04 <e0ne> it would be good to fix them too
20:07:26 <e0ne> ok, let's go throw our agenda
20:07:29 <e0ne> #link https://wiki.openstack.org/wiki/Meetings/Horizon
20:07:52 <e0ne> rdopiera: thanks for adding topics to the agenda.
20:08:16 <e0ne> rdopiera, I was  going to add xstacit topic too but you're faster:)
20:08:28 <e0ne> #topic XStatic packaging rights
20:08:56 <e0ne> link #http://lists.openstack.org/pipermail/openstack-dev/2018-March/128533.html - here is some background discussion about it
20:09:09 <e0ne> rdopiera: do you want to add something according this?
20:10:03 <rdopiera> no, I really don't have an opinion
20:10:24 <e0ne> ok
20:10:29 <rdopiera> I think that any solution we find will be good
20:11:09 <e0ne> so, heat-dashboard team wants to be able to merge patches to some xstatic repos
20:11:54 <e0ne> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128545.html
20:11:56 <dklyle> I'm confused, but what's new :)
20:12:02 <e0ne> ^^ now it works :)
20:12:24 <e0ne> dklyle: we've got new xstatic libs for heat-ui plugin
20:12:31 <dklyle> why do they need xstatic-core need to be involved with heat specific xstatic packages?
20:12:32 <rdopiera> dklyle: they basically want gerrit rights for +2
20:12:33 <e0ne> I mean heat-dashboard
20:13:19 <dklyle> what's the structure that is requiring xstatic-core as the approver?
20:13:51 <e0ne> #link https://review.openstack.org/#/admin/groups/385,members
20:14:37 <e0ne> dklyle: nothing I'm familiar with
20:15:04 <dklyle> e0ne, I understand the group is for our xstatic projects, why don't they have their own group for theirs?
20:15:44 <dklyle> ultimately I don't really mind the easiest solution, but it seems weird that it is the most obvious option
20:18:37 <e0ne> dklyle: we'd got this discussion at the PTG
20:19:12 <e0ne> and agreed to help heat team with their xstatic as they could be useful for other plugins too
20:19:22 <dklyle> ok, I'll trust that it's been worked through
20:22:10 <e0ne> so, how to we want to share responsibility with heat team on managing these projects?
20:22:42 <e0ne> it's about 8 new xstatic repos: https://review.openstack.org/#/c/551978/2/gerrit/projects.yaml
20:25:10 <rdopiera> I would trust that they won't go around merging things to the packages that they are not responsible for
20:25:40 <e0ne> rdopiera: +1
20:25:55 <rdopiera> but that may be my natural dislike of access restrictions
20:25:56 <dklyle> the only concern would be dependencies between the xstatic packages, but I doubt that's much of an issue
20:29:25 <e0ne> dklyle: good point. IMO, we can find a solution for this if the future if we meet issues with dependencies
20:29:51 <dklyle> works for me
20:30:27 <kazsh> hi, afaik the newly added repos don't have any dependencies to existing xstatic repos
20:30:57 <e0ne> what about "(2) Add specific members to xstatic-core" and see how it's going?
20:31:33 <e0ne> we can revisit our decision in the future and "Split core membership into per-repo basis" if it's really required
20:32:23 <e0ne> kazsh: thanks for the info
20:32:36 <kazsh> e0ne: NP:)
20:34:53 <e0ne> dklyle, rdopiera, ying_zuo : ^^ does it work for you?
20:35:50 <dklyle> yes
20:37:47 <e0ne> I suppose we've got agreement on this
20:38:43 <e0ne> I'll talk with kazsh and Rico to discuss who will be added to xstatic-core team from the heat-dashboard side
20:39:32 <e0ne> #action discuss xstatic permissions with heat team and send a result to the openstack-dev@ thread
20:39:46 <e0ne> I hope, it works for everyone
20:40:03 <kazsh> e0ne: thx mate, let's keep talking in the thread.
20:41:11 <e0ne> #topic Microsoft Edge support
20:41:50 <e0ne> rdopiera: do you want to add something?
20:42:51 <e0ne> I didn't find our previous discussion about MS browsers
20:43:30 <e0ne> afair, we didn't get volunteers to fix isses in IE11 and Edge
20:45:59 <e0ne> does anybody have something to add about this topic?
20:47:06 <e0ne> ok, let's move forward
20:47:30 <e0ne> rdopiera: please, add this topic to the next agenda again if you want to discuss it
20:47:36 <rdopiera> e0ne: sorry
20:47:43 <rdopiera> there was no previous discussion
20:47:52 <rdopiera> I just had some people ask me about the support
20:47:59 <rdopiera> so I thought I will start this
20:48:23 <e0ne> I remember some conversation with Rob in the past when I tried to fix some bugs
20:49:01 <e0ne> from my point of view, I'm ok to merge fixes for IE/Edge
20:49:25 <e0ne> I even could find env to test them if needed
20:49:42 <rdopiera> same here
20:50:00 <rdopiera> but no angular/edge experience to actually propose patches
20:50:05 <rdopiera> I can test them
20:50:22 <e0ne> we just said that 'horizon doesn't work with IE" to our customers
20:50:26 <rdopiera> I suppose pretty much everybody are in that situation
20:50:42 <rdopiera> it does work with IE, just not Edge
20:50:56 <e0ne> sorry, I mean IE/Edge
20:51:39 <rdopiera> so basically, if anyone wants it to work, they have to bring fixes themselves
20:51:57 <e0ne> rdopiera: +1
20:52:00 <dklyle> or at the minimum point out what doesn't work
20:52:37 <e0ne> from our side, it would be good to keep https://github.com/openstack/horizon/blob/master/doc/source/user/browser_support.rst up to date
20:52:44 <e0ne> dklyle: +1
20:53:47 <e0ne> #action e0ne to update to propose patch with update for  https://github.com/openstack/horizon/blob/master/doc/source/user/browser_support.rst
20:55:09 <e0ne> we can continue discuss it in the gerrit once I'll propose a patch
20:55:15 <e0ne> I'll to it later this week
20:55:30 <rdopiera> thanks!
20:55:35 <e0ne> np
20:55:50 <e0ne> #topic Open Discussion
20:55:59 <e0ne> one item for me
20:56:13 <e0ne> please, vote for meeting time http://lists.openstack.org/pipermail/openstack-dev/2018-March/128615.html if you want to change it
20:56:22 <e0ne> we discussed it at the PTG
20:57:38 <e0ne> for note: I'm not going to change meeting time until we'll get agreement on it'
20:57:59 <e0ne> that's all from my side
20:58:11 <e0ne> we still have ~2 mins left for the meeting
20:59:28 <e0ne> thanks everyone who joined meeting! see you next week
20:59:44 <vladiskuz> have a good one!
20:59:49 <e0ne> #endmeeting