15:01:15 <e0ne_> #startmeeting horizon
15:01:16 <openstack> Meeting started Wed Jun  6 15:01:15 2018 UTC and is due to finish in 60 minutes.  The chair is e0ne_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:20 <openstack> The meeting name has been set to 'horizon'
15:01:32 <e0ne_> hi everyone
15:01:47 <rdopiera> o/
15:03:04 <e0ne_> rdopiera: let's wait few minutes more
15:03:56 <david-lyle> o/
15:04:42 <e0ne_> david-lyle: hi. glad to see you around
15:04:57 <david-lyle> finally found the new time :)
15:05:02 <e0ne_> :)
15:05:19 <e0ne_> david-lyle: I know that you're busy with new Intel project
15:05:24 <e0ne_> #link https://wiki.openstack.org/wiki/Meetings/Horizon
15:05:50 <e0ne_> I've added our Rocky efforts to the meeting to track all items
15:06:39 <e0ne_> #topic Notices
15:07:13 <e0ne_> Rocky-2 milestone is on this week
15:07:15 <e0ne_> #link https://releases.openstack.org/rocky/schedule.html
15:07:40 <e0ne_> please, ping me if we need to have something important to land before I'll cut the release on Thursday
15:08:40 <e0ne_> we'll have one more milestone before feature freeze
15:09:03 <e0ne_> so no need to hurry with some features for rocky-2
15:09:25 <e0ne_> of course, it's better to merge something sooner than later
15:09:50 <e0ne_> that's all updates from my side
15:10:08 <e0ne_> #topic Community Goals
15:10:38 <e0ne_> IMO, we're in a good shape on mox=>mock migration
15:10:47 <e0ne_> #link https://etherpad.openstack.org/p/horizon-unittest-mock-migration
15:11:22 <e0ne_> we broke some plugins during this activity, but looks like they fix all issues pretty quick
15:12:00 <e0ne_> please, help with reviews for those patches if you have some time
15:12:27 <e0ne_> #topic
15:12:29 <e0ne_> #topic horizon release model
15:13:23 <e0ne_> david-lyle, rdopiera: do you have any input on this topic? Akihiro is an author of it, I don't have a lot to say about it
15:13:50 <amotoki> hi
15:13:57 <e0ne_> amotoki: hi
15:14:38 <amotoki> I am not sure what is the right direction on this....
15:14:42 <rdopiera> I think I missed the discussion
15:15:03 <rdopiera> is this about the requirements and syncing with plugins?
15:15:22 <e0ne_> rdopiera: it's one of the points on this discussion
15:15:42 <david-lyle> so release to PyPI mid-cycle milestones?
15:16:28 <amotoki> actually milestone releases are published to PyPI with beta version like 14.0.0.0b1
15:17:04 <amotoki> but if horizon plugins try to consume the master latest, it is not enough.
15:17:23 <david-lyle> so what are you proposing releasing?
15:17:44 <david-lyle> nightlies?
15:18:26 <david-lyle> honestly just trying to understand
15:19:10 <amotoki> In our CI, horizon plugins can consume the latest master easily
15:19:32 <amotoki> if we consume horizon mater in local test, the current process is a bit complicated.
15:19:56 <amotoki> something like tox -e py27 --notest; .tox/py27/bin/pip install -e ../horizon; tox -e py27
15:20:29 <amotoki> I don't have a strong opinion on this.
15:21:22 <amotoki> if horizon or dashboard plugin framework is a kind of library, it would be nice ot publish it to PyPI
15:21:39 <e0ne_> amotoki: +1
15:21:41 <amotoki> but horizon itself is an application so I am in a dillemma.
15:22:02 <david-lyle> would be nice, efforts to do that in the past proved difficult
15:22:24 <e0ne_> amotoki: but in such case, we have to split our releases to somehting like horizon-sdk and horizon dashboard
15:22:58 <e0ne_> david-lyle: I missed that releases.. why did we drop horizonlib in the past?
15:23:07 <amotoki> e0ne_: yeah, that is required.
15:23:27 <amotoki> david-lyle: what was the difficult point in the past effort?
15:23:41 <amotoki> I didn't tracked that effort carefully
15:23:50 <david-lyle> entanglements between horizon/horizon and horizon/openstack_dashboard
15:24:12 <david-lyle> there were app components in horizon/horizon
15:24:29 <e0ne_> the idea with horizon-lib/horizon-plugin-sdk (doesn't  meter how call name it)  sounds great from the plugins perspective
15:24:38 <david-lyle> there are probably ancient etherpads that mrunge created that I might be able to dig up
15:25:38 <david-lyle> my information could certainly be out of date too
15:26:17 <e0ne_> I've found some related ML conversation
15:26:19 <e0ne_> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/050043.html
15:26:22 <david-lyle> with the angular work and DOA import things have changed
15:26:28 <amotoki> horizon/horizon is a framework but now dashboard plugin is also a kind of library. it makes situation more complicated.
15:28:22 <e0ne_> I'm afraid, that I've got a bad news here
15:28:47 <e0ne_> some plugins imports something from openstack_dashboard too
15:29:43 <e0ne_> so it's not just about releasing current 'horizon' package to pypi
15:30:14 <e0ne_> what about creating something like horizon-sdk which will be used by all plugins?
15:30:15 <david-lyle> so even more complicated split?
15:30:26 <e0ne_> david-lyle: yep :(
15:30:56 <rdopiera> we should gradually move all things used by plugins into horizon then
15:31:02 <rdopiera> and then split
15:31:05 <e0ne_> my proposal is to extract everything what is used by plugins to horizon-sdk
15:31:08 <e0ne_> rdopiera: +1
15:31:10 <rdopiera> but that doesn't solve the immediate problem
15:31:16 <david-lyle> with angular that didn't make sense
15:31:28 <rdopiera> why not?
15:31:30 <e0ne_> it's a good topic for a PTG discussion
15:31:32 <amotoki> we also need to consider JS side...
15:31:40 <e0ne_> amotoki: +1
15:32:04 <rdopiera> does angular have a concept of a library?
15:32:06 <e0ne_> horizon-sdk can have both python and js stuff
15:32:44 <david-lyle> sadly I don't remember all the details, I'll try to recall the design decision motivations
15:33:37 <e0ne_> rdopiera, david-lyle: it has components and dependency injection mechanism which could cover our cases
15:34:20 <e0ne_> I can do some research and publish this proposal to openstack-dev ML
15:34:34 <e0ne_> so we can get more feedback and time to discuss it
15:34:38 <amotoki> while I don't know the detail, plugins already consume JS/angular stuffs so i think it is doable.
15:34:46 <e0ne_> amotoki: +1
15:35:14 <david-lyle> the angular work started in horizon/horizon/static and was moved because reasons is all I remember :)
15:35:45 <e0ne_> david-lyle: we can try to do it again in S release
15:36:05 <david-lyle> sure
15:36:45 <david-lyle> it might have to do with the REST endpoints
15:36:51 <e0ne_> so, does everybody agree to have horizonlib for plugins?
15:37:10 <amotoki> it would be nice
15:37:12 <david-lyle> in theory it sounds like a good idea
15:37:16 <e0ne_> david-lyle: good point
15:37:31 <rdopiera> yes, with documented API
15:37:37 <e0ne_> rdopiera: ++++
15:37:56 <david-lyle> then you have to version the API
15:38:01 <rdopiera> yes
15:38:01 <e0ne_> so, I'll collect what do we have now and send a note to openstack-dev ML
15:38:02 <david-lyle> and not break it
15:38:13 <e0ne_> so we can discuss it later with more details
15:38:15 <e0ne_> and on PTG
15:38:17 <rdopiera> or only break the parts that are not documented ;-)
15:38:22 <david-lyle> anyway, let's see what can be done
15:38:25 <e0ne_> rdopiera: :D
15:38:51 <e0ne_> it's really cool that we're all on the same page about this topic
15:40:04 <e0ne_> #agreed to try to propose horizonlib with stable API for plugins
15:40:36 <e0ne_> #action e0ne to collect all current information and send this proposal to ML
15:40:36 <rdopiera> the implementation may prove impossible, though
15:40:55 <e0ne_> rdopiera: we should to try
15:41:07 <rdopiera> definitely
15:41:25 <e0ne_> maybe we'll succeed with it :)
15:42:10 <e0ne_> can we move on to the next topic?
15:42:24 <e0ne_> or anybody have something to add?
15:43:23 <e0ne_> seems that we're done with this topic for today
15:43:38 <e0ne_> #topic Improve Horizon Testing
15:44:10 <e0ne_> so, we're close to drop nose from horizon and get back our selenium tests
15:44:22 <e0ne_> both functional and integrational
15:44:51 <e0ne_> #link https://review.openstack.org/#/q/status:open+branch:master+topic:bp/improve-horizon-testing
15:45:17 <e0ne_> I've filed blueprint for this effort
15:45:20 <e0ne_> #link https://blueprints.launchpad.net/horizon/+spec/improve-horizon-testing
15:45:27 <e0ne_> any feedback is welcome
15:46:15 <amotoki> when do we merge the initial test runner patch?
15:46:44 <e0ne_> I would like to wait for heat and searchlight plugins patches
15:47:25 <e0ne_> all other plugins won't be affected by this change
15:47:44 <amotoki> searchlight-ui seems inactive recently...
15:48:00 <e0ne_> you can approve https://review.openstack.org/#/c/544296/ - it has depends-on flag
15:48:27 <e0ne_> amotoki: I'm goinf to reach their PTL by email tonight
15:48:44 <amotoki> all non-trivial patches in searchlight-ui are unreviewed these several months...
15:48:53 <e0ne_> :(
15:49:27 <e0ne_> if we can get searchlight-ui patch merged  - it will be a good example of cross-project work
15:50:02 <e0ne_> anyway, we have +2 on searchlight-ui too
15:50:27 <e0ne_> so, I'm sure, we'll found the best approach how to get it merged
15:50:41 <e0ne_> I'll ask heat team to review patch to their plugin too
15:51:36 <amotoki> horizon-cores have +2 right on searchlight-ui, so it might not be a problem in this case :)
15:51:57 <e0ne_> amotoki: that what I'm talking about ;)
15:52:19 <e0ne_> let's wait for heat team until next week
15:52:31 <e0ne_> and merge https://review.openstack.org/#/c/544296/ this one
15:52:33 <amotoki> e0ne_: ah, +2 mean +2 right
15:53:10 <david-lyle> I'm not sure there are any searchlight devs left, probably should merge when ready
15:53:22 <e0ne_> :(
15:53:44 <e0ne_> #link https://review.openstack.org/572124 - searchlight-ui patch
15:54:08 <e0ne_> #link https://review.openstack.org/#/c/558467/ - fix current selenium job
15:55:29 <amotoki> regarding mox removal, some selenium tests still use mox. I didn't touch them because it is not easy to check it works.
15:55:45 <amotoki> I would like to convert them to mock after the selenium fix.
15:55:51 <e0ne_> amotoki: It's on my list to fix them
15:57:10 <e0ne_> I would like to get selenuim tests working with mox first
15:57:17 <e0ne_> to do it step by step
15:57:43 <amotoki> +1
15:57:53 <e0ne_> 3 mins reminder
15:59:01 <e0ne_> 1 commit = 1 fix ==> less work for commit author and reviewers
15:59:24 <e0ne_> we've got a productive meeting today! thanks everybody and see you next week!
15:59:41 <david-lyle> thanks e0ne_
15:59:52 <e0ne_> if you would like to discuss something more today - I'm all yours in #openstack-horizon
15:59:57 <e0ne_> #endmeeting