15:01:04 <e0ne> #startmeeting horizon
15:01:05 <openstack> Meeting started Wed Jul 18 15:01:04 2018 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:09 <openstack> The meeting name has been set to 'horizon'
15:01:29 <e0ne> hi everybody
15:01:47 <e0ne> let's wait minute or two to get people join us
15:01:55 <betherly> o/
15:03:10 <rdopiera> o/
15:03:42 <e0ne> I home amotoki will join us despite on Tour de France
15:03:55 <amotoki> hi
15:04:03 <amotoki> I am here as background of TDF broadcast :)
15:04:07 <e0ne> #link https://wiki.openstack.org/wiki/Meetings/Horizon
15:04:29 <e0ne> #topic Notices
15:04:54 <e0ne> we're one week before rocky-3 milestone and feature freeze
15:05:09 <e0ne> #link https://releases.openstack.org/rocky/schedule.html
15:05:15 <amotoki> this week is the non-client feature freeze but AFAIK we have no non-client libs
15:05:28 <amotoki> except xstatic repos
15:05:34 <betherly> thank you for merging the delete action for qos! i need to rebase my other patch that has +W so it merges.
15:05:48 <e0ne> amotoki: only this one https://review.openstack.org/#/c/581595/
15:06:30 <amotoki> e0ne: it has been merged. is there any problem?
15:06:30 <e0ne> I tried to add everything important to the etherpad
15:06:54 <e0ne> amotoki: no, just a notice that we've got one xtatic release this week
15:06:56 <e0ne> #link https://etherpad.openstack.org/p/horizon-reviews-priority
15:07:05 <amotoki> sounds nice!
15:07:36 <e0ne> if anybody wants to get some feature merged, please, add link to the etherpad
15:07:48 <e0ne> I'm reviewing it on daily basis
15:08:16 <amotoki> do we prioritize ng-groups/domains stuffs?
15:08:21 <amotoki> *this week?
15:09:29 <e0ne> amotoki: these patches was originally proposed last year and, IMO, are in good shape now
15:09:35 <amotoki> I have no strong opinion on them and would not like to block them. If we switch the default impl, we need to evaluate them during the RC period.
15:09:36 <e0ne> that's why I added them to the etherpad
15:09:52 <amotoki> it seems we are in the same page
15:09:57 <e0ne> good
15:10:29 <e0ne> thanks everybody who helped to get Generic Volumes feature landed!
15:10:59 <e0ne> #action e0ne to create release notes for generic volume groups feature
15:11:24 <e0ne> we're close to next PTG too
15:11:27 <amotoki> e0ne: thanks for taking care of it
15:11:28 <e0ne> #link https://etherpad.openstack.org/p/horizon-ptg-planning-denver-2018
15:11:55 <e0ne> I hope too see all of you in Denver
15:12:23 <amotoki> but regarding the generic group on cinder, have we implemented group type panel (in the admin dashboard?
15:12:41 <amotoki> this is the one I didn't post an initial work.
15:13:10 <e0ne> amotoki: unfortunately, not
15:13:27 <e0ne> I'll take a look on it if I can implement it before FF
15:13:36 <amotoki> e0ne: got it. this would be the one we need to follow up in Stein
15:13:46 <e0ne> amotoki: +1
15:14:17 <amotoki> it would be simple enough, so it might be a good candidate for FFE but I am not sure we have a volunteer
15:14:32 <amotoki> e0ne: +1
15:14:37 <amotoki> let's move on
15:14:40 <e0ne> that's all updates from me. let's switch to our agenda
15:14:58 <e0ne> #topic mox => mock migration
15:15:14 <e0ne> I'm working on openstack_auth patches
15:15:22 <e0ne> they'll be ready later this week
15:15:34 <amotoki> e0ne: thanks!!!
15:16:11 <e0ne> amotoki: you are welcome!
15:16:23 <amotoki> that's the last one. The other pending patch is https://review.openstack.org/563903 and I resolved the merge conflict this week
15:17:04 <e0ne> amotoki: great! will review it later tonight
15:17:37 <amotoki> I can explain our experience on mock migration (L.10-32 in the etherpad) in our documentation too.
15:18:06 <e0ne> #link https://etherpad.openstack.org/p/horizon-unittest-mock-migration
15:18:52 <e0ne> amotoki: maybe it's good add it to our docs for new contiburors
15:20:11 <e0ne> amotoki: argh... I want to see previous stage first
15:20:23 <amotoki> e0ne: we can add a note on mock migration and mox removal in Stein
15:20:34 <e0ne> +1
15:21:09 <amotoki> no worries. all the way of 7km is hill climb. it will take time :)
15:21:11 <e0ne> we did a great progress on it in Rocky
15:21:30 <e0ne> let's go on to the next stage
15:21:36 <amotoki> it is different from the horizon situation :)
15:21:39 <e0ne> I mean to the next topic :)
15:22:00 <e0ne> #topic Improve Horizon Testing
15:22:44 <e0ne> AFAIK, there are to plugins left with nose: sahara and murano dashboards
15:23:04 <e0ne> everybody else use django test runner
15:23:10 <amotoki> is it about unit tests?
15:23:15 <e0ne> yep
15:23:53 <e0ne> according to our functional tests, we've got few patches with fixes merged
15:24:04 <e0ne> #link https://review.openstack.org/#/q/status:open+branch:master+topic:bp/improve-horizon-testing
15:24:10 <amotoki> FYI, django20 support patches in tacker-horizon and murano-dashboard finally landed this week
15:24:23 <e0ne> great news!
15:24:51 <amotoki> we can finally drop horizon-openstack-tox-py35dj20 job from .zuul.yaml now :)
15:25:05 <e0ne> I didn't test and review last patch for functional tests yet
15:25:27 <e0ne> also I'm working on CI job with functional tests
15:25:33 <amotoki> how about the intgration tests and func tests?
15:25:37 <e0ne> it fails now:(
15:26:10 <amotoki> I'd just like to know the current status. what have we done and what not?
15:26:33 <amotoki> to refresh my memory :)
15:26:57 <e0ne> here is list of merged/fixed tests
15:26:59 <e0ne> #link https://review.openstack.org/#/q/owner:panneer.smn%2540outlook.com+status:merged
15:28:06 <amotoki> yeah, we had good progresses.
15:28:14 <e0ne> afair, about 60 tests are fixed and 20 still fails
15:28:27 <amotoki> what I am not sure is what are remaiing.
15:28:55 <e0ne> #link https://review.openstack.org/#/c/580469/ - my patch with CI job, it's still in progress
15:29:03 <amotoki> e0ne: it is same as my local testing results before +W
15:29:42 <e0ne> I tested all these patches on my fresh devstack before +2/+W
15:31:10 <e0ne> I hope to get non-voitng job with integration tests in Rocky
15:32:47 * e0ne is thinking about short bike trip right now
15:33:17 <e0ne> #topic Horizon feature gap
15:33:26 <e0ne> #link https://etherpad.openstack.org/p/horizon-feature-gap
15:33:36 <e0ne> we'ge good some list to start with
15:33:53 <e0ne> I'll send a link to the openstack-dev
15:34:22 <e0ne> just forgot to click 'send' button after the last meeting, it's in my drafts in gmail(
15:35:20 <e0ne> maybe it's a good idea to reach nova, cinder, keystone, glance, etc projects PTL to get more detailed lists
15:35:39 <amotoki> + neutron
15:35:40 <e0ne> so we can put this list as our features priority for Stein
15:35:45 <e0ne> amotoki: :)
15:35:57 <amotoki> betherly: do you see any feature gaps in neutron?
15:37:22 <e0ne> how can I kick off amotoki from this meeting? ;)
15:37:33 <amotoki> :)
15:38:10 <amotoki> ignore me
15:38:15 <e0ne> so the idea is to get feature gap list as a priority for new features
15:38:28 <e0ne> I hope we're all on the same page about it
15:39:19 <amotoki> I am not sure which are important between feature gaps and new features.
15:39:43 <amotoki> it depends on how the feature is important and useful to users
15:40:40 <amotoki> anyway, e0ne can cordinate cinder feature gaps and amotoki can work on neutron's ones
15:40:56 <e0ne> amotoki: sure, we can add every feature to the list and prioritize them
15:40:58 <amotoki> we are not sure on nova feature gaps at the moment
15:41:02 <e0ne> amotoki: good plan
15:41:13 <amotoki> + keystone
15:41:28 <e0ne> I'
15:41:35 <amotoki> I believe we are not behind glance features!
15:41:51 <amotoki> e0ne: russian character?
15:41:51 <e0ne> I'll tag all 'core' projects in the mail
15:42:09 <e0ne> amotoki: nope, just hit 'enter' too early :(
15:43:25 <amotoki> np
15:43:48 <e0ne> according to keystone
15:44:00 <e0ne> will be drop v2 support in Stein?
15:44:23 <e0ne> it's dropped since Pike release
15:44:59 <amotoki> keystone v2 API has been deprecated, so it would be nice to deprecate keystone v2 API  in horizon in rocky too
15:45:22 <e0ne> sounds good to me
15:45:23 <amotoki> has it been dropped in Pike?
15:45:32 <e0ne> yep
15:45:57 <amotoki> it has been deprecated too long, so I was not aware of being dropped.
15:46:31 <amotoki> so, there is no reason that we need to support keystone v2 :)
15:46:49 <e0ne> oh.. my fail
15:46:58 <e0ne> it's dropped in Queens only
15:47:09 <e0ne> https://docs.openstack.org/releasenotes/keystone/queens.html#other-notes
15:47:12 <amotoki> no worries
15:47:15 <e0ne> [blueprint removed-as-of-queens] Support for all Identity V2 APIs, with the exception of the EC2 v2 API, has been removed from keystone.
15:47:44 <e0ne> working actively on 3 releases at the same time is pretty hard
15:47:54 <amotoki> let's note it in the *horizon* release note too!
15:48:00 <e0ne> amotoki: +1
15:48:25 <e0ne> I'll propose a patch with keystone v2 deprecation
15:48:32 <amotoki> +1
15:49:18 <amotoki> we followed deprecations in back-end services in most features (like nova-net) but it would be nice if we can declare feature drops in advance).
15:49:36 <e0ne> I agree
15:50:05 <e0ne> #topic Open Discussion
15:50:12 <e0ne> anything else to discuss?
15:51:46 <e0ne> ok, let's wrap up the meeting
15:51:52 <e0ne> see you next week!
15:51:59 <e0ne> #endmeeting