15:00:53 <e0ne> #startmeeting horizon
15:00:54 <openstack> Meeting started Wed Oct  3 15:00:53 2018 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:58 <openstack> The meeting name has been set to 'horizon'
15:01:05 <rdopiera> o/
15:01:47 <e0ne> hi
15:02:05 <amotoki> ...hi....
15:02:12 <e0ne> hi
15:02:30 <e0ne> looks like we can start now :)
15:02:33 <e0ne> # link https://wiki.openstack.org/wiki/Meetings/Horizon
15:03:05 <e0ne> #topic Notices
15:03:29 <e0ne> I've updated our agenda as discussed at PTG
15:03:52 <e0ne> there is a list of our priorities for this cycle
15:04:07 <e0ne> feel free to add any topic you would like to discuss
15:04:32 <e0ne> #link https://releases.openstack.org/stein/schedule.html
15:04:47 <e0ne> we're about 3 weeks before stein-1 milstone
15:05:03 <amotoki> it seems to cover the PTG topics well
15:05:14 <amotoki> one question
15:05:17 <e0ne> nothing special for Horizon team just a friendly reminder
15:05:22 <e0ne> amotoki: sure
15:05:23 <amotoki> do we need to track action items from PTG?
15:05:24 <dklyle> o/
15:05:43 <e0ne> amotoki: I want to do it
15:06:09 <amotoki> I think it can be covered in "Action items from the previous meeting"
15:06:25 <e0ne> amotoki: TBH, I tried to get this list today in the etherpad, but etharpad was unavailable almost all day :(
15:06:36 <amotoki> ah...
15:06:49 <e0ne> I'm doing to do it tomorrow
15:07:29 <e0ne> finally finished with downstream work for our internal release, so I'll have more time for upstream at least next few months
15:07:33 <amotoki> I didn't review and do other things after PTG due to my internal stuffs and the vacation, so there seems what I haven't synced.
15:08:05 <e0ne> amotoki: I'll do it and send a mail to the openstack-dev@ ML
15:08:19 <amotoki> sounds fine
15:08:38 <e0ne> thanks
15:08:56 <e0ne> #help
15:09:41 <e0ne> #action e0ne to create 'Action Items from PTG' list
15:10:05 <e0ne> #topic Community Goals
15:10:33 <e0ne> I almost finished with openstack_auth tests. the patch will be proposed this week.
15:10:46 <e0ne> it's the last thing we should do with mox removal
15:11:06 <e0ne> #topic Python3 first
15:11:39 <e0ne> I didn't check the list, but it seems that we're in a good shape with this goal
15:12:25 <e0ne> #link https://storyboard.openstack.org/#!/story/2003227
15:13:04 <e0ne> #action e0ne to check what is the state with 'Python3 first' community goal
15:13:05 <amotoki> does everyone run devstack with python3 horizon?
15:13:39 <amotoki> I runs horizon with apache mod-wsgi python3 and runserver with python3.
15:13:51 <amotoki> I hope all developers try so.
15:13:56 <e0ne> cool. do you have any issues?
15:14:12 <amotoki> at least nothing serios hits me.
15:14:20 <e0ne> awesome!
15:14:38 <amotoki> I see many debug message which complains template rendering though
15:14:50 <amotoki> they are from django2.
15:15:05 <rdopiera> same here
15:15:06 <amotoki> we need to clean them up in this cycle.
15:15:07 <e0ne> amotoki: it would be great if you could file a bug for this
15:15:11 <e0ne> amotoki: +1
15:15:29 <amotoki> ack on filing a bug
15:15:40 <e0ne> amotoki: thanks
15:17:12 <e0ne> :(
15:17:30 <amotoki> let's move on
15:17:51 <e0ne> #topic Community Goals: pre-upgrade check
15:18:25 <e0ne> as discussed at PTG, we agreed to implement a command to check if we have any  deprecated options in the config
15:18:53 <e0ne> it would be great to have volunteer for this goal
15:19:40 <amotoki> do distros already have such kind of things internally?
15:20:04 <rdopiera> I don't know the details, but since I was working with the config a lot, I could tentatively look into it?
15:20:07 <e0ne> we don't have anything like this in our distro
15:20:23 <rdopiera> amotoki: I think it's too app-specific
15:20:35 <e0ne> rdopiera: sounds good
15:20:44 <amotoki> I mean OpenStack distributors by "distros"
15:21:19 <rdopiera> we just regenerate the config files from templates each time
15:21:19 <amotoki> the basic concept is defined in the TC page https://governance.openstack.org/tc/goals/stein/upgrade-checkers.html
15:21:25 <rdopiera> using configuration management tools
15:22:00 <rdopiera> people are not supposed to edit config files directly
15:22:30 <e0ne> rdopiera: good point
15:22:47 <amotoki> understandable
15:23:10 <e0ne> anyway, it's a good idea to have such checks
15:23:38 <amotoki> as my operator hat, we directly consume Ubuntu packages and have our own horizon settings.
15:24:44 <amotoki> In my understanding, what we need to check is just to alert them if local_settings contains deprecated settings.
15:24:58 <amotoki> we need to list deprecated settings
15:25:02 <e0ne> +1
15:25:42 <rdopiera> I would also alert about unknown settings
15:25:47 <rdopiera> once we are at it
15:25:57 <amotoki> +1
15:26:01 <rdopiera> you know, spelling mistakes and the like
15:26:11 <amotoki> but we need to take into account django options.
15:26:19 <rdopiera> yes
15:26:25 <amotoki> so it is not an easy thing.
15:26:34 <rdopiera> I will see if I can outomate it somehow
15:26:56 <amotoki> yeah, it is the right approach :)
15:27:08 <rdopiera> do we also need to list deprecated django settings?
15:27:24 <e0ne> yes
15:27:38 <amotoki> personally no
15:27:43 <e0ne> :)
15:27:54 <amotoki> because django version choice is up to deployers
15:27:55 <rdopiera> I wonder if I can reuse the mechanism that django uses for the warnings
15:28:18 <e0ne> it's less important than horizon settings but it would be good to have such optio
15:28:52 <amotoki> it sounds a thing we should explore as the second or optional step
15:29:03 <e0ne> +1
15:29:49 <amotoki> I am not sure whether we should focus on N to N+1 upgrade or we should cover more than +2 releases.
15:30:07 <amotoki> we can start from N to N+1 of course.
15:30:40 <e0ne> N+1 model is what we should start
15:31:13 <amotoki> totally agree
15:31:37 <e0ne> we can improve our solution in the future if needed
15:33:26 <e0ne> looks like we've agreed on this topic
15:33:30 <e0ne> let's move forward
15:33:44 <e0ne> #Bug status
15:34:21 <e0ne> not a big progress on bug triage for the last two weeks
15:34:50 <e0ne> we decreased a total number of 'New' bugs from 138 to 120
15:35:27 <amotoki> it looks like we receieved a number of new bugs :(
15:35:34 <e0ne> yes:(
15:35:40 <amotoki> e0ne seems to triage most of them :)
15:35:50 <e0ne> I do my best to do it
15:36:12 <e0ne> I do expect to have about ~80 bugs with New status until next meeting
15:36:14 <amotoki> I just checked the number of my new bug mails :p
15:36:22 <e0ne> :)
15:36:49 <e0ne> Also I added low-hang-fuits to few of them
15:37:00 <amotoki> feel free to tag 'neutron' if related to networking. I will check them.
15:37:14 <e0ne> ok, will do
15:37:26 <e0ne> we've got 38 low-hanging-fruit bugs
15:37:36 <e0ne> 120 New bugs
15:37:39 <e0ne> 463 Open bugs
15:37:45 <e0ne> #link https://bugs.launchpad.net/horizon
15:38:00 <e0ne> let's see what number will we have next week
15:38:09 <amotoki> what does 'low-hanging-fruit' mean? are they really low-hanging-frust or are they starter bugs?
15:38:19 <amotoki> s/frust/fruit/
15:38:37 <e0ne> amotoki: what do you mean by "starter bugs"?
15:39:06 <e0ne> I added this tag to bugs which should be easy to fix even for new contributors
15:39:10 <amotoki> sometimes 'low-hanging-fruit' tag is used as bugs for new contributors
15:39:22 <amotoki> but the actual meaning of low-hanging-fruit is different.
15:39:52 <amotoki> low-hanging-fruit actually means that we can get a bit even if we fix them
15:40:05 <e0ne> #link https://wiki.openstack.org/wiki/Bug_Tags
15:40:18 <e0ne> "low-hanging-fruit: Bugs that are easy to fix, ideal for beginners to get familiar with the workflow and to have their first contact with the code in OpenStack development.
15:40:18 <e0ne> "
15:40:57 <amotoki> okay. we OpenStack have our own definition of low-hanging-fruit. got it
15:41:03 <e0ne> :)
15:42:21 <amotoki> sometimes we added 'low-hanging-fruit' for bugs for which we can get a bit even if we fix.....
15:42:27 <rdopiera> it's just the style of my underwear
15:42:42 <amotoki> heh
15:42:54 <e0ne> #ation e0ne to update tags list at https://wiki.openstack.org/wiki/Bug_Tags#Horizon
15:42:59 <e0ne> #action e0ne to update tags list at https://wiki.openstack.org/wiki/Bug_Tags#Horizon
15:43:31 <e0ne> #topic Horizon feature gap
15:43:39 <amotoki> perhaps I am the original author of that page..... but I forgot it
15:43:42 <e0ne> it's a bit related to the previous topic
15:44:19 <e0ne> I'll file a bug and blueprint according to https://etherpad.openstack.org/p/horizon-feature-gap
15:44:21 <e0ne> #link https://etherpad.openstack.org/p/horizon-feature-gap
15:44:38 <e0ne> the some of features are easy to implement
15:45:00 <e0ne> we need to create low-hanging-fruit bugs for them
15:45:10 <amotoki> first of all, thanks e0ne for discussing this topic with various project teams in PTG
15:45:14 <e0ne> of course, it's not easy to implement all features
15:45:44 <e0ne> amotoki: np. now we're got some plan to work on with priorities from project teams
15:46:24 <e0ne> it was a good time at PTG discussion horizon stuff
15:47:21 <e0ne> also, I'll fill reviews priority list if we've got some feature gap fix proposal
15:47:29 <e0ne> that is my plan
15:48:12 <e0ne> #topic
15:48:14 <e0ne> #topic I don't have any updates about 'CI for plugins' topic
15:48:19 <e0ne> #topic CI for plugins
15:48:27 * e0ne hates copy&paste issues
15:48:35 <e0ne> I don't have a lot of updates about 'CI for plugins' topic
15:48:43 <amotoki> e0ne: '#undo' helps you :)
15:48:53 <e0ne> amotoki: thanks!
15:49:16 <e0ne> I'm working on manila and heat plugins to get basic tests up and working now
15:49:23 <amotoki> what was the problem on horizon plugi CI failures?
15:49:29 <e0ne> I hope to get it landed before stein-1
15:49:49 <e0ne> amotoki: xstatic-jquery 3 release
15:50:10 <amotoki> i see
15:50:28 <e0ne> we didn't have good solution now but workaround from Shu  helps to unblock gates
15:50:48 <amotoki> I think horizon plugins should have the consistent approach for running tests
15:50:55 <e0ne> we need to think on publishing horizon to npm as npm package
15:51:19 <amotoki> plugisn he maintains have some specific tricks which he thinks are good...
15:51:30 <e0ne> amotoki: +1
15:51:59 <amotoki> I sometimes try to convince him but I failed....
15:52:37 <e0ne> plugins CI is something I would like to improve this cycle
15:53:02 <amotoki> yeah
15:53:08 <e0ne> teams are interested on get this working
15:54:03 <e0ne> 6 minutes reminder
15:55:02 <e0ne> according to the new xstatic-jquery release
15:55:16 <e0ne> we need to cap it's version in stable/* branches too:(
15:55:24 <e0ne> I didn't have a time to do it yet
15:55:41 <rdopiera> we should probably cap all xstatic versions
15:55:48 <e0ne> rdopiera: +1
15:56:01 <rdopiera> at least to the major version
15:56:14 <e0ne> rdopiera: and try to get horizon working with new versions
15:56:20 <amotoki> for our CI on stable branches, we should use upper-constraints
15:56:32 <e0ne> amotoki: we use it
15:56:34 <amotoki> it is not easy to cap all cases
15:57:00 <amotoki> so what broke our CI?
15:57:01 <e0ne> https://github.com/openstack/requirements/blob/stable/rocky/upper-constraints.txt#L72
15:57:17 <e0ne> looks like stable branches are in safe now :)
15:57:28 <e0ne> I didn't check it befoew
15:57:56 <amotoki> perhaps it is because some installations do not honor u-c.
15:58:07 <e0ne> :(
15:58:21 <e0ne> we're almost out of time
15:58:52 <e0ne> we can continue in #openstack-horizon if needed
15:59:01 <e0ne> thanks for the great discussions! see you next week!
15:59:11 <amotoki> thanks
15:59:56 <e0ne> #endmeeting