15:01:25 <e0ne> #startmeeting horizon
15:01:26 <openstack> Meeting started Wed Nov 28 15:01:25 2018 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:30 <openstack> The meeting name has been set to 'horizon'
15:01:49 <e0ne> hi. is anybody around here for horizon meeting?
15:02:17 <vishalmanchanda> e0ne:
15:02:20 <vishalmanchanda> hi
15:02:59 <e0ne> vishalmanchanda: let's wait few minutes more
15:03:22 <vishalmanchanda> e0ne: yeah
15:07:30 <e0ne> vishalmanchanda: looks like nobody joins us. do you have anything to discuss?
15:12:16 <e0ne> I'll wrap up the meeting in 5 minutes if there is nothing to discuss
15:13:22 <vishalmanchanda> e0ne: I am trying to solve this bug: https://bugs.launchpad.net/horizon/+bug/1803486
15:13:23 <openstack> Launchpad bug 1803486 in OpenStack Dashboard (Horizon) "Floating and negative values accepted in volume size field." [Medium,Confirmed] - Assigned to Vishal Manchanda (vishalmanchanda)
15:14:06 <vishalmanchanda> If I want to use PositiveIntegerField() like IntegerFiled().how can i use it as it is not define here.https://github.com/openstack/horizon/blob/master/horizon/forms/__init__.py#L75 or i have to define a new filed like MACAddressField
15:14:06 <vishalmanchanda> https://github.com/openstack/horizon/blob/master/horizon/forms/fields.py#L134
15:16:20 <e0ne> according to https://docs.djangoproject.com/en/2.1/ref/forms/fields/#integerfield you can use IntegerField with min_value param
15:17:55 <amotoki> hi
15:18:30 <vishalmanchanda> amotoki: hi
15:19:09 <vishalmanchanda> e0ne: ok
15:19:15 <e0ne> amotoki: hi
15:19:31 <e0ne> amotoki: do you have anything to discuss?
15:19:51 <amotoki> e0ne: i have two things
15:20:05 <e0ne> #chair amotoki
15:20:06 <openstack> Current chairs: amotoki e0ne
15:20:18 <amotoki> the one is about Incomplete bug which you and I discussed a bit in email
15:20:27 <amotoki> the other is tox.ini in xstatic repos.
15:21:12 <amotoki> e0ne: what do you think about auto expiry of bugs?
15:21:36 <e0ne> amotoki: I'm OK to use this launchpad feature
15:21:52 <amotoki> IMHO we have 60(?) days before expiration so bug authors will have enough time
15:22:07 <e0ne> I'll add a note to the contributor documentation
15:22:16 <e0ne> amotoki: +1 sounds reasonable
15:22:17 <amotoki> in addition, bug authors will receive bug notifications they file
15:22:39 <amotoki> e0ne: thanks. +1 to the contributor docs
15:23:48 <amotoki> launchpad auto bug expiry is documented here https://help.launchpad.net/BugExpiry
15:24:20 <amotoki> let's move on next
15:24:31 <e0ne> #action e0ne to document Incomplete bugs workflow
15:25:09 <amotoki> I forgot to set a topic :(
15:25:22 <amotoki> #topic tox.ini in xstatic-* repos
15:25:26 <e0ne> #link https://review.openstack.org/#/q/project:%5Eopenstack/xstatic-.*%20status:open
15:25:59 <amotoki> thanks for the link
15:26:22 <amotoki> in xstatic-* repos, we have tox.ini but actually we don't use tox at all
15:26:22 <e0ne> removing tox.ini sounds reasonable for xstatic-* repos
15:26:42 <e0ne> e.g. https://github.com/openstack/xstatic-bootstrap-datepicker/blob/master/tox.ini
15:26:42 <amotoki> previously [venv] tox env was documented in PTI
15:26:53 <amotoki> but IIRC it is not a requirement now
15:27:07 <e0ne> let's try to remove
15:27:41 <amotoki> this is the current PTI https://governance.openstack.org/tc/reference/project-testing-interface.html
15:28:20 <amotoki> yeah, my voting is to drop tox.ini too
15:28:31 <amotoki> I would like to check my understanding is correct in the ML
15:28:40 <amotoki> because there are many xstatic-* repos
15:28:48 <e0ne> #agreed to remove tox.ini for xstatic repos
15:28:58 <e0ne> amotoki: +1
15:29:32 <amotoki> #action amotoki check our understanding on PTI is correct and we can drop tox.ini from xstatic-* repos
15:29:36 <e0ne> amotoki: would you like to send a mail to the openstack-dev@ ML yourself?
15:29:49 <amotoki> e0ne: sure s/-dev/-discuss/ :)
15:30:18 <e0ne> hm.. I didn't subscribe to openstack-discuss ML
15:30:29 <amotoki> e0ne: really?
15:30:32 <e0ne> yep
15:30:33 <amotoki> just a moment
15:30:45 <amotoki> I will find a mail post to switch to openstack-discuss
15:30:49 <e0ne> #link http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-discuss
15:31:25 <amotoki> #link http://lists.openstack.org/pipermail/openstack-dev/2018-November/136424.html
15:31:30 <amotoki> this is the final notice
15:31:45 <e0ne> thanks!
15:31:50 <amotoki> it was announced two or three months ago and the switch over happened
15:32:30 * e0ne subscribed
15:32:41 <amotoki> #link http://lists.openstack.org/pipermail/openstack-discuss/2018-November/000094.html
15:32:54 <amotoki> this is about tagging
15:33:07 <e0ne> amotoki: thanks for the notice
15:33:12 <e0ne> I missed it :(
15:34:03 <amotoki> this is really a good timing :)
15:34:26 <amotoki> #topic open discussion
15:34:38 <amotoki> any topic to discuss?
15:35:03 <amotoki> I recently noticed https://bugs.launchpad.net/bgpvpn/+bug/1805240
15:35:04 <openstack> Launchpad bug 1805240 in networking-bgpvpn "Unit tests fail with: 'AnonymousUser' object has no attribute 'token'" [Undecided,New]
15:35:04 <e0ne> nothing from me
15:35:18 <amotoki> some horizon change breaks bgpvpn-dashboard UTs :(
15:35:38 <e0ne> :(
15:35:46 <amotoki> if you have time it is appreciated to digging into it
15:36:36 <e0ne> amotoki: I'll take a look on it tomorrow morning
15:37:02 <amotoki> thanks
15:37:06 <amotoki> that's all from me
15:37:06 <e0ne> np
15:37:27 <e0ne> thanks for the participation! see you next week!
15:38:00 <e0ne> #endmeeting