15:00:38 <e0ne> #startmeeting horizon
15:00:39 <openstack> Meeting started Wed Dec 19 15:00:38 2018 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <openstack> The meeting name has been set to 'horizon'
15:02:26 <e0ne> is anybody around here for horizon meeting?
15:04:22 <e0ne> amotoki, rdopiera: are you around?
15:09:32 <e0ne> I have no notices this week, so I'll end the meeting in 5 minutes if nobody joins me
15:10:02 <e0ne> I'll probably skip the next meeting, I'll send a notification to the mailing list
15:12:37 <amotoki> hi
15:13:28 <amotoki> I'm on a train back to home from a party around the end of year which is so-called "bonenkai" in Japan
15:14:14 <amotoki> it seems I should be here 5 mins later :)
15:16:01 <e0ne> amotoki: no worries, I can wait:)
15:16:52 <amotoki> :)
15:17:16 <amotoki> I found a good explanation on bonenkai in Japan https://en.wikipedia.org/wiki/B%C5%8Dnenkai
15:17:33 <e0ne> https://en.wikipedia.org/wiki/B%C5%8Dnenkai
15:17:40 <e0ne> I like it :)
15:17:47 <amotoki> wikipedia gives us answers on most things :)
15:23:55 <amotoki> I noticed the meeting agenda is now relatively simple
15:24:36 <amotoki> e0ne: do we discuss some today?
15:25:20 <e0ne> amotoki: I moved old agenda to the etharad, so we can discuss it on demand
15:25:57 <amotoki> all may be moved to etherpad :)
15:26:13 <e0ne> amotoki: :)
15:26:32 <e0ne> #topic Notices
15:26:36 <amotoki> regarding discussion topics, apart from the topic I raised, I think we need to check the status of the community goals.
15:27:20 <e0ne> amotoki I won't attend the next meeting. we can skip it or you'll be a chair next time
15:27:59 <amotoki> e0ne: do you mean a meeting on Dec 26?
15:28:03 <e0ne> yes
15:28:28 <amotoki> My new-year vacation starts at Dec 28
15:28:35 <amotoki> perhaps we can skip next two meetings
15:29:18 <e0ne> sounds reasonable. I'll send a mail to openstack-discuss@ ML
15:29:26 <amotoki> +1
15:29:49 <e0ne> #agreed to skip next two meeting due to the Christmas holidays
15:30:12 <e0ne> #topic Community Goals
15:31:00 <e0ne> 'mox => mock migration' - I finished a patch, but have to fix few pep8 errors. finally, will do it this week
15:31:14 <amotoki> awesome!!
15:31:42 <e0ne> Python3 first
15:31:53 <e0ne> I think we're complete this goal
15:32:10 <amotoki> perhaps we need to use python3 by default in devstack
15:32:39 <e0ne> hm..
15:32:43 <amotoki> do we already use py3 in devstack?
15:32:52 <amotoki> or our gate?
15:33:01 <e0ne> I was thinking we do
15:33:07 <e0ne> but we don't :(
15:33:22 <e0ne> #action e0ne to propose a python3-based devstack job
15:33:31 <e0ne> I'll create a patch after the meeting
15:33:44 <amotoki> sounds fine! thanks
15:33:57 <e0ne> I'm pretty sure that it'll work without issues:)
15:34:04 <amotoki> generally speaking, I believe we don't have any issue on py3
15:34:06 <e0ne> I mean horizon, not my patch :)
15:34:12 <e0ne> amotoki: +1
15:34:17 <amotoki> :)
15:34:57 <e0ne> I use python3 on my env for horizon for the last few months without any issues
15:35:08 <e0ne> pre-upgrade check ("horizon-status upgrade check" command)
15:35:22 <e0ne> I don't know any progress on it from rdopiera
15:35:55 <amotoki> have rdopiera took this? I didn't know that
15:35:58 <e0ne> we agreed to have a check if we've got some outdated config options in the config
15:36:27 <e0ne> amotoki: he did it. I can find irc logs if needed
15:36:38 <amotoki> sounds nice :)
15:37:54 <e0ne> #topic Are there features we would like to drop in Stein and/or mark as deprecated?
15:38:25 <e0ne> it's safe to remove keystone v2 and glance v1
15:38:38 <amotoki> have we marked them as deprecated?
15:39:00 <e0ne> no
15:39:06 <amotoki> I think we have several approaches on feature removal
15:39:15 <e0ne> but technically, we can't use horizon with these features
15:39:16 <amotoki> horizon depends on back-end services
15:39:44 <amotoki> so we sometimes drop some feature in a shorter deprecation period compared to other back-end serivces
15:40:03 <amotoki> the reason is that we honor deprecations from back-end services.
15:40:19 <e0ne> +1
15:40:30 <amotoki> this is a good news, though we can follow the standard deprecation period :)
15:41:06 <e0ne> yes, I think it's OK to mark other APIs support as deprecated and remove in T release
15:41:11 <amotoki> it is related to our support policy for N-1 release
15:41:38 <e0ne> yes
15:42:43 <amotoki> so what soudns reasonable is to mark features which can be dropped in Train release as deprecated in Stein release
15:43:12 <amotoki> and to document our policy clearly
15:45:32 <e0ne> sounds good
15:46:35 <amotoki> i can take an action to propose deprecation notices
15:46:59 <amotoki> we can discuss which features should be deprecated in a review
15:47:45 <e0ne> it would be awewsome
15:49:54 <amotoki> that's all from me on the community goals
15:50:04 <amotoki> ah...
15:50:14 <amotoki> the topic is about feature deprecations
15:51:16 <e0ne> we covered both of them already
15:51:56 <amotoki> :)
15:52:17 <amotoki> are there anything to be discussed?
15:53:21 <amotoki> regarding open reviews, I would like to ask your opinions on https://review.openstack.org/#/c/623582/
15:53:23 <e0ne> nothing from my side
15:53:47 <e0ne> amotoki: I still don't understand the use case
15:54:07 <amotoki> as of now I am not so supportive to re-invent another solutions....
15:54:18 <amotoki> third eye would be appreciated
15:54:42 <e0ne> added to my TODOs list
15:54:59 <amotoki> thanks
15:55:34 <e0ne> you're welcome
15:55:47 <e0ne> amotoki: do you have anything more to discuss?
15:55:54 <amotoki> e0ne: nothing
15:56:00 <e0ne> ok
15:56:10 <e0ne> enjoy your vacation!
15:56:21 <amotoki> bye
15:56:33 <e0ne> see you after New Year
15:56:47 <e0ne> #endmeeting