15:01:02 <e0ne> #startmeeting horizon
15:01:03 <openstack> Meeting started Wed Feb 27 15:01:02 2019 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:06 <openstack> The meeting name has been set to 'horizon'
15:01:19 <e0ne> hi. is anybody here for Horizon meeting?
15:01:38 <vishalmanchanda> e0ne: hi
15:01:59 <e0ne> vishalmanchanda: hi
15:02:05 <e0ne> rdopiera: hi. are you around?
15:04:25 <e0ne> #topic Notices
15:04:32 <rdopiera> o/
15:05:03 <e0ne> 'Train' TC Election Voting Period Begins
15:05:30 <e0ne> you should receive  a link to vote via email
15:05:47 <e0ne> don't forget to vote for new TC members
15:05:56 <e0ne> #link https://releases.openstack.org/stein/schedule.html
15:06:30 <e0ne> We'll reach feature freeze with Stein-3 milestone next week
15:07:21 <e0ne> I'm looking for https://etherpad.openstack.org/p/horizon-release-priorities and https://etherpad.openstack.org/p/horizon-reviews-priority etherpads to review patches in the first priority
15:08:17 <e0ne> it would be great to reach Community Goals before feature freeze
15:08:33 <e0ne> I'm working on python3 support for integration tests now
15:09:02 <e0ne> rdopiera: is your patch https://review.openstack.org/#/c/631785/ ready for review?
15:09:31 <rdopiera> e0ne: I'm still working on a complete list of valid config options — I want a script for extracting that.
15:10:05 <rdopiera> e0ne: I should finish today.
15:11:02 <e0ne> rdopiera: we need to get it landed before March, 7th (next Thursday) or will postponed until the Train release
15:11:19 <rdopiera> roger
15:12:28 <e0ne> that's all updates from my side
15:13:03 <e0ne> #topic Gates are broken
15:13:28 <e0ne> openstack-tox-lower-constraints job fails on master branch
15:13:50 <e0ne> TBH, I didn't dig a lot on a root cause
15:14:15 <e0ne> but I found that we need to bump a min version of the appdirs
15:14:26 <e0ne> #link https://review.openstack.org/639636/
15:14:45 <e0ne> please, do not do rechecks until patch ^^ will be merged
15:15:01 <vishalmanchanda> e0ne: +1.
15:15:35 <e0ne> rdopiera: I appreciate if you can review my fix
15:15:53 <rdopiera> e0ne: will do
15:16:02 <e0ne> rdopiera: thanks
15:16:12 <e0ne> that's all I've got this week
15:16:18 <e0ne> #topic Open Discussion
15:16:31 <e0ne> vishalmanchanda, rdopiera: do you have anything to discuss?
15:16:45 <vishalmanchanda> e0ne: rdopiera :Can you help me in this patch https://review.openstack.org/#/c/638110/.
15:17:01 <vishalmanchanda> Acc. to this patch https://review.openstack.org/#/c/630790/ .I have
15:17:01 <vishalmanchanda> configure SESSION_ENGINE to django.contrib.sessions.backends.signed_cookies
15:17:01 <vishalmanchanda> which is fine.but when i run "tox -e runserver" command get a error no module name "memcache".
15:17:01 <vishalmanchanda> So i have install it by this command: 'pip install python-memcached' but still getting
15:17:01 <vishalmanchanda> same error.When i set it to 'LocMemCache' then "tox -e runserver" works fine.
15:17:20 <e0ne> vishalmanchanda: there is a -1 from Akihiro
15:17:40 <vishalmanchanda> e0ne: yeah.
15:18:39 <e0ne> vishalmanchanda: could you please share traceback with an exception?
15:19:07 <e0ne> vishalmanchanda: btw, you can ask such question anytime in #openstack-horizon, there is no need to wait for weekly meetings
15:19:14 <vishalmanchanda> e0ne: wait.
15:19:21 <vishalmanchanda> e0ne: ok.
15:20:35 <rdopiera> vishalmanchanda: I will test it in a moment
15:21:21 <rdopiera> e0ne: I noticed a problem today with the octavia plugin that may be widespread among other plugins
15:21:36 <e0ne> rdopiera: what problem?
15:21:57 <rdopiera> e0ne: we add /v3 to the keystone url in horizon when retrieving a token, however, many plugins have their own code for that, and they don't add it
15:22:10 <e0ne> :(
15:22:22 <e0ne> it's one more reason to add integration tests
15:22:39 <johnsom> rdopiera Did you open a story for the Octavia team to fix this?
15:22:41 <rdopiera> I wonder if it would make sense for me to review all the plugins and make sure they use horizon/openstack_auth functions for this
15:23:02 <e0ne> rdopiera: +1
15:23:05 <rdopiera> johnsom: it's being fixed by cgoncalves
15:23:23 <johnsom> rdopiera Ok, thanks.
15:23:55 <e0ne> rdopiera: could you please share a link to the patch?
15:24:18 <johnsom> I don't see one posted, that is why I asked about a story.
15:24:47 <rdopiera> we don't have a patch yet, only a bug in redhat's bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1593904
15:24:47 <openstack> bugzilla.redhat.com bug 1593904 in openstack-octavia-ui "TERMINATED_HTTPS Listener Type Unavailable due to Barbican 404" [Medium,Assigned] - Assigned to cgoncalves
15:25:17 <rdopiera> but it's this code: https://github.com/openstack/octavia-dashboard/blob/master/octavia_dashboard/api/rest/barbican.py#L37-L46
15:25:37 <e0ne> #action e0ne to review all the plugins and make sure they use horizon/openstack_auth for getting keystone URL
15:25:49 <e0ne> #link https://github.com/openstack/octavia-dashboard/blob/master/octavia_dashboard/api/rest/barbican.py#L37-L46
15:26:00 <e0ne> #link https://bugzilla.redhat.com/show_bug.cgi?id=1593904
15:26:01 <openstack> bugzilla.redhat.com bug 1593904 in openstack-octavia-ui "TERMINATED_HTTPS Listener Type Unavailable due to Barbican 404" [Medium,Assigned] - Assigned to cgoncalves
15:26:14 <johnsom> Do you have a link to an example for the horizon/openstack_auth?
15:26:34 <rdopiera> johnsom: https://github.com/openstack/horizon/blame/master/openstack_auth/utils.py#L355-L357
15:26:53 <johnsom> Or docs.  Cool, thanks I will open a story for this and include the links.
15:27:19 <rdopiera> and this: https://github.com/openstack/horizon/blame/master/openstack_auth/utils.py#L333
15:27:38 <rdopiera> I think we don't have it documented very well :(
15:29:01 <e0ne> https://github.com/openstack/horizon/blob/master/openstack_auth/utils.py#L333
15:29:45 <rdopiera> sorry, that was a blame url
15:30:43 <johnsom> It's all good. This will help us get this fixed. Do you happen to know how far back we should backport the fix?
15:31:01 <johnsom> I guess if it's in OSP13 at least queens
15:31:09 <rdopiera> well, that function was there 2 years ago...
15:31:23 <e0ne> johnsom: what is OSP13?
15:31:24 <rdopiera> so horizon has been fixing the urls at least for that long
15:31:40 <rdopiera> e0ne: open stack something 13
15:31:48 <e0ne> rdopiera: :D
15:32:05 <johnsom> Ok, thanks.  OpenStack Platform 13, Redhat's OpenStack offering.
15:32:33 <e0ne> johnsom:  it's a good time to add some integration tests for octavia-dashboard too
15:32:49 <johnsom> FYI: https://storyboard.openstack.org/#!/story/2005101
15:33:30 <rdopiera> johnsom: thank you!
15:33:31 <johnsom> Yeah, open to that.  Do you have links/info  for the approach on that?
15:34:17 <e0ne> johnsom: something like https://review.openstack.org/#/c/634487/ would be good for beginning
15:34:43 <e0ne> johnsom: I didn't finish official docs yet, but I've got few posts in my blog.
15:35:14 <johnsom> Ok, yeah, giving me some links and I can capture this as well.
15:35:24 <e0ne> we've got such tests for few plugins
15:35:56 <e0ne> these tests just verify that pages could be open. but project teams can add any tests they want
15:36:29 <e0ne> johnsom:https://blog.e0ne.info/tags/horizon/
15:36:39 <johnsom> Yeah, we had one a year or two ago, but we were advised to remove it as the approach was bad and wasn't really working well.
15:36:59 <e0ne> #action e0ne to add integration tests  documentation
15:37:26 <e0ne> johnsom: the idea is to have at lease smoke tests to verify that horizon changes don't break plugins
15:38:09 <johnsom> Yeah, I will take a look. I think the fact that we are Angular was an issue with the previous integration tests.
15:38:45 <e0ne> johnsom: feel free to ping me if any help is needed
15:38:58 <johnsom> Cool, thanks.
15:41:15 <e0ne> anything else to discuss today?
15:41:22 <johnsom> Please feel free to open stories for us if there are changes we need to  make in our dashboard.
15:42:12 <e0ne> johnsom: ok, will do if any
15:43:24 <e0ne> thanks everybody for productive discussion!
15:43:28 <e0ne> see you next week
15:43:47 <rdopiera> bye
15:43:54 <e0ne> #endmeeting