15:00:48 <e0ne> #startmeeting horizon
15:01:00 <openstack> Meeting started Wed May 29 15:00:48 2019 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:03 <openstack> The meeting name has been set to 'horizon'
15:01:10 <e0ne> hi
15:01:26 <e0ne> is anybody around for horizon meeting?
15:03:08 <vishalmanchanda> e0ne: hi
15:03:17 <e0ne> vishalmanchanda: hi
15:04:36 <e0ne> let't wait few minutes more if somebody joins us...
15:07:54 * e0ne is wondering if amotoki will join the meeting
15:09:07 <e0ne> I don't have updates this week
15:09:22 <e0ne> I had to work mostly on downstream release last week :(
15:09:32 <e0ne> vishalmanchanda, amotoki: do we have anything to discuss?
15:09:55 <amotoki> the next week is Train-1.
15:09:58 <e0ne> a localization issue is under discussion in #openstack-horizon
15:10:04 <amotoki> this is just a reminder.
15:10:35 <amotoki> I had two topics: volume API endpoint name and a translation issue
15:10:44 <e0ne> amotoki: I'm going to remove mox by that date and release horizon to be sure that no plugins are broken
15:10:50 <amotoki> but both of them have been discussed in #openstack-horizon.
15:10:58 <e0ne> #chair amotoki
15:10:59 <openstack> Current chairs: amotoki e0ne
15:11:13 <e0ne> amotoki: it's up to you to choose the first one :)
15:11:48 <amotoki> e0ne: I think we alreday clarify it regarding the endpoint name
15:12:44 <amotoki> resolving an endpoint name with version will take more time and openstacksdk migration (we discussed in the PTG) will help it a bit (or much)
15:13:16 <e0ne> +1
15:13:26 <amotoki> e0ne: btw, have we discussed the train prioties?
15:14:06 <vishalmanchanda> not yet
15:16:00 <e0ne> amotoki, vishalmanchanda: here is an etherpad based on PTG discussions
15:17:23 <e0ne> #link https://etherpad.openstack.org/p/horizon-release-priorities
15:19:11 <e0ne> I've added discussed topics to this etherpad
15:19:26 <amotoki> e0ne: I think we need owners for prioritized topics.
15:20:03 <amotoki> I can be an owner for ini-based-configuration
15:20:22 <e0ne> I've added myself for some of them
15:20:31 <amotoki> and e0ne is responsible for mox removal and more :)
15:20:38 <e0ne> yep
15:20:58 <e0ne> mox is my the biggest technical dept which I must to address
15:21:25 <amotoki> PDF generation would be easier and IPv6 testing affects less in horizon (as apache supports IPv6 :))
15:21:38 <e0ne> I agree
15:22:11 <amotoki> if you need owner, they can be in my radar for the train community goals.
15:22:12 <e0ne> #action e0ne to setup IPv6-based devstack job
15:22:48 <vishalmanchanda> amotoki: e0ne : Could you assign me some bps which are important from horizon point of view for train cycle.
15:22:52 <amotoki> for IPv6, we can follow up progresses in other projects :)
15:23:05 <e0ne> amotoki: it's something I'm personally interesting in. I'll be glad to test horizon with IPv6
15:23:21 <amotoki> e0ne: glad to hear that :)
15:24:06 <amotoki> e0ne: I already have experiences on running openstack with ipv6 envs (but it was not IPv6-only)
15:24:40 <e0ne> I did some testing in the past, but it was before I started contribution into horizon
15:24:57 <amotoki> :)
15:25:26 <e0ne> let's kill python2 and IPv4 ;)
15:25:56 <e0ne> vishalmanchanda: feel free to assign bugs to yourself in launchpad :)
15:26:28 <amotoki> vishalmanchanda: half (or less) of priorities are blueprints. Another important aspect is to address bugs which are important for operators. Such things cannot be seen via blueprints. Triaging and addressing bugs is more important to address (from my point of view)
15:26:43 <e0ne> amotoki: +1
15:27:17 <amotoki> vishalmanchanda: so, it is really really appreciated if you are involved in bug triaging.
15:27:36 <vishalmanchanda> amotoki: ok
15:27:51 <amotoki> The easiest way is to subscribe all horizon bugs in launchpad :)
15:28:25 <amotoki> as of now, e0ne and me are the only persons who triage horizon bugs.
15:29:51 <amotoki> if you would like to know how to subscribe bug mails, contact me.
15:30:32 <vishalmanchanda> i have already subscribed for bug mails
15:30:47 <amotoki> perhaps this "neutron" document helps you :) https://docs.openstack.org/neutron/latest/contributor/policies/bugs.html#getting-ready-to-serve-as-the-neutron-bug-deputy
15:31:07 <amotoki> I have no good pointer in horizon :p
15:31:42 <vishalmanchanda> amotoki: ok ,thanks for info will look into it
15:31:55 <amotoki> vishalmanchanda: thanks
15:32:49 <amotoki> regarding ini-based-configuation, it leads to >20 patches. I would like to have review sponsors.
15:34:19 <e0ne> amotoki: I'm one of them
15:34:31 <amotoki> vishalmanchanda: can you keep your eyes on ini-based-configurations reviews? e0ne already has steped it up :) if you have no bandwidth or have barriers, I will ask Radmir.
15:34:37 <e0ne> amotoki: just started to review your patches today
15:34:54 <amotoki> e0ne: thanks for your eyes.
15:35:14 <amotoki> I will resolve merge conflict once first two patches (without merge conflict) lands.
15:36:25 <vishalmanchanda> amotoki: added to my TODO list going to review after the meeting.
15:37:23 <amotoki> vishalmanchanda: good to heat that. I will add more handy URL to https://etherpad.openstack.org/p/horizon-release-priorities after the meeting
15:37:54 <vishalmanchanda> amotoki: +1
15:40:19 <e0ne> #action e0ne and amotoki to add gerrit links to the etherpad with current progress
15:40:30 <amotoki> +1
15:41:50 <amotoki> another question in bug triaging. Do we have more folks who are familiar areas around back-end service integration? e0ne is familiar with cinder and I am for neutron. we need some area owners. we don't need to be a specialist on a specific area but we need someone who is responsible for some area (e.g, bridging bugs to some familiar with a related project)
15:42:40 <e0ne> amotoki: I'll ask keystone and glance team to help... maybe the have some capacity to do it
15:43:26 <e0ne> I alway add related component tags during triage
15:43:39 <e0ne> even I can't confirm the bug it's useful
15:43:52 <amotoki> yeah. when I added keystone to keystone-related bugs recently, they made very quick feedback :)
15:44:31 <amotoki> it sounds a good practice for us.
15:45:02 <e0ne> :)
15:45:42 <e0ne> we've got 15 minutes more. do we have any more topic?
15:46:09 <vishalmanchanda> e0ne: amotoki : any input on this releasenote gate failure https://review.opendev.org/#/c/661526/
15:46:13 <amotoki> none from me :) I already discussed all I would like to raise.
15:46:34 <vishalmanchanda> getting this error http://logs.openstack.org/26/661526/2/check/build-openstack-releasenotes/e5e2f3f/job-output.txt.gz#_2019-05-29_10_57_21_408585
15:47:21 <amotoki> vishalmanchanda: is it a complicated thing?
15:47:25 <e0ne> vishalmanchanda: I've got few ideas.. let me check on my env
15:47:38 <amotoki> it is usually just a formatting issue around ReST
15:47:38 <vishalmanchanda> e0ne: thanks
15:47:45 <e0ne> looks like yaml syntax issue, but I'm not sure
15:47:49 <amotoki> I can check it.
15:48:55 <amotoki> let check the relnote job with the latest mater first.
15:49:10 <amotoki> if it does not fail, it is just a problem in a specific commit.
15:49:54 * e0ne is runnig `tox -e releasenotes` with that commit
15:50:11 <e0ne> ok. let's finish the meeting today
15:50:39 <e0ne> amotoki, vishalmanchanda: thanks for the interesting and productive discussions! I appreciate your contributions
15:50:54 <e0ne> see you next weel
15:51:00 <e0ne> s/weel/week
15:51:12 <amotoki> see you too!
15:51:43 <e0ne> #endmeeting