15:00:14 <e0ne> #startmeeting horizon
15:00:15 <openstack> Meeting started Wed Jun 12 15:00:14 2019 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <openstack> The meeting name has been set to 'horizon'
15:00:24 <e0ne> hi
15:01:07 <e0ne> is anybody around for horizon meeting?
15:01:38 <vishalmanchanda> e0ne: hi
15:02:04 <amotoki> o/
15:02:33 <e0ne> let's start
15:02:35 <e0ne> #topic Notices
15:03:07 <e0ne> we've got horizon train-1 released today
15:03:13 <e0ne> #link https://review.opendev.org/#/c/663961/
15:03:40 <e0ne> it's mostly needed for plugins
15:03:59 <e0ne> that's all updates from me
15:04:14 <e0ne> I had to work mostly on downstream tasks last week:(
15:04:42 <e0ne> vishalmanchanda, amotoki: do you have anything to discuss today?
15:05:24 <amotoki> e0ne: what is the highlight of Train-1 milestone? I am not sure what is for horizon plugins?
15:06:01 <amotoki> I didn't get it from the release commit...
15:06:04 <e0ne> amotoki: it's mostly useful to update requiremetns.txt
15:06:23 <e0ne> is somebody uses horizon as a library and don'
15:06:34 <e0ne> and doesn't consume the latest master
15:07:11 <amotoki> e0ne: do you mean something like horizon>=16.0.0.0b1?
15:07:15 <e0ne> yes
15:07:22 <amotoki> got it
15:07:49 <amotoki> I didn't see meaningful changes in 16.0.0.0b1 but it might be okay.
15:09:20 <e0ne> btw, I'll continue to work on assigned items to myself from https://etherpad.openstack.org/p/horizon-release-priorities starting tomorrow
15:10:54 <e0ne> #topic Open Discussion
15:12:39 <vishalmanchanda> amotoki: e0ne : Could you please review this patch https://review.opendev.org/#/c/661526/
15:13:27 <amotoki> e0ne: regarding https://bugs.launchpad.net/horizon/+bug/1821284, which is the preference from cinder team "group spec" and "group type spec"?
15:13:28 <openstack> Launchpad bug 1821284 in OpenStack Dashboard (Horizon) ""group type spec" and "group spec" are used inconsistently" [Low,In progress] - Assigned to Vishal Manchanda (vishalmanchanda)
15:13:47 <amotoki> e0ne: I cannot figure out which is a better terminology from the cinder API reference.
15:14:04 <amotoki> it uses "group spec for group type spec".......
15:14:49 <e0ne> I think we need to follow this https://developer.openstack.org/api-ref/block-storage/v3/index.html#group-type-specs
15:15:03 <amotoki> correction: "group specs for a group type"
15:15:19 <amotoki> does it mean "group spec" is the answer?
15:15:44 <e0ne> group type specs is cleaner
15:16:33 <amotoki> e0ne: thanks for clarification. let's go to that route :)
15:17:21 <e0ne> you're welcome
15:18:01 <amotoki> vishalmanchanda: re: https://review.opendev.org/#/c/661526/, I see no reason we need to prioritize it compared to others. we can review it as part of Train-2 as usual.
15:18:10 <vishalmanchanda> e0ne: so we don't need this patch https://review.opendev.org/#/c/664792
15:18:40 <amotoki> vishalmanchanda: is there no usage of "group specs"?
15:18:56 <amotoki> vishalmanchanda: if we use both, some fix is required anyway.
15:19:09 <e0ne> vishalmanchanda: what you you mean about patch #664792?
15:19:57 <amotoki> e0ne: I think vishalmanchanda thinks #664792 is unnecessary if we go to the route of "group type specs"
15:20:31 <amotoki> but when I filed the bug I saw both so the bug is still valid I think
15:20:37 <vishalmanchanda> e0ne: I mean we are already using "group type spec" .
15:21:29 <e0ne> vishalmanchanda: let's clarify that we use 'group type spec' everywhere
15:22:00 <vishalmanchanda> e0ne: +1
15:22:01 <amotoki> vishalmanchanda: if you are confident that we use "group type spec" consistently in the current codebase, could you mark the bug as Invalid with comment?
15:22:56 <amotoki> otherwise, #664792 can be used to close the bug for "group type spec" :)
15:23:41 <vishalmanchanda> amotoki: yeah sure.
15:28:50 <vishalmanchanda> Do we need to change this https://github.com/openstack/horizon/blob/master/openstack_dashboard/dashboards/admin/group_types/templates/group_types/specs/_create.html#L6  "group spec" to "group type spec" m?
15:29:53 <e0ne> I thinks we need
15:30:26 <amotoki> Wed seems our review day :)
15:30:56 <e0ne> amotoki: :)
15:31:35 <vishalmanchanda> e0ne: thanks will update it in next PS.
15:31:40 <amotoki> Mon and Thu are for me. I usually checks +2'ed reviews on Thu
15:32:01 <e0ne> amotoki: usually, I do bug triage on Wed
15:32:33 <amotoki> is anyone interested in a test coverage on https://review.opendev.org/#/c/663805/ ?
15:33:07 <amotoki> I am really surprised with the test coverage on this.
15:33:32 <amotoki> I had PTOs on Mon/Tue this week and it was merged before I left more comment.
15:35:05 <e0ne> amotoki: it's a good point. I +2'ed on it to fix broken code
15:35:43 <e0ne> tests coverage is really important but I think that's it's better to fix some issues asap and fix coverage in a follow up patch
15:37:26 <amotoki> e0ne: fair enough.
15:37:27 <amotoki> I am really worrying the code which is actually not used in horizon and is used only by plugins.
15:38:49 <amotoki> api/rest/*.py, especially for network.py and neutron.py, are a chaos zone..... the effort was stopped in the middle :-(
15:39:37 <amotoki> what we can do are (1) to improve the test coverage in horizon and (2) to clarify which plugins depend on them.
15:41:09 <amotoki> the third option might be to improve integration test coverage e0ne is working on a lot
15:41:25 <e0ne> honestly, I don't have any good ideas at the moment
15:42:06 <amotoki> e0ne: no problem. I am just saying irony :) and :(
15:44:29 <e0ne> amotokiL +1
15:44:32 <e0ne> amotoki: +1
15:44:53 <amotoki> another topic
15:44:59 <amotoki> what do you think about https://review.opendev.org/574310 ?
15:45:33 <amotoki> I raised a question on the upgrade path and it blocked the progress
15:45:52 <amotoki> but I still think this is an important change.
15:45:53 <e0ne> oh.. I almost forgot about that patch
15:46:12 <e0ne> I'll talk to Vadym tomorrow
15:46:46 <amotoki> if the upgrade impact is only once, IMHO we can accept it (with a release note)
15:47:33 <e0ne> I need to re-fresh my memory
15:47:35 <amotoki> it looks like it only affects session data and if a fallback works well the impact would be much smaller. "re-login" would solve the issue.
15:48:00 <amotoki> e0ne: that's my intention. I marked it as "starred" :)
15:48:39 <amotoki> that's all I have today.
15:48:40 <e0ne> amotoki: added to my list for tomorrow
15:48:53 <e0ne> thanks for raising this topic
15:49:55 <e0ne> #action e0ne to discuss https://review.opendev.org/574310
15:51:20 <e0ne> let's wrap up the meeting for today
15:51:36 <e0ne> we can still discuss anything in #openstack-horizon channel
15:51:46 <amotoki> :)
15:51:55 <e0ne> thanks everybody for participation an all your contributions!
15:52:29 <e0ne> #endmeeting