15:01:31 <amotoki> #startmeeting horizon
15:01:32 <openstack> Meeting started Wed Mar  4 15:01:31 2020 UTC and is due to finish in 60 minutes.  The chair is amotoki. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:36 <openstack> The meeting name has been set to 'horizon'
15:01:49 <e0ne> hi
15:01:52 <vishalmanchanda> hi
15:03:30 <amotoki> e0ne: vishalmanchanda: hi, lets wait for a while
15:04:47 <amotoki> okay, let's start
15:05:20 <amotoki> #topic notices/annoucements
15:05:47 <amotoki> as usual, the week of Apr 6 is ussuri-3 milestone.
15:06:01 <amotoki> it is a month away for the feature freeze.
15:07:11 <amotoki> that's all from me. anything else to be shared?
15:07:58 <amotoki> #topic general priotiries
15:08:59 <e0ne> #link https://etherpad.openstack.org/p/horizon-release-priorities
15:09:32 <amotoki> re the policy stuff, I have no good progress to be shared this week. I was busy as I was forced to change my dev env and needed to spend much time :(
15:10:24 <amotoki> re Django 1.11 drop, I sent a mail to the congress ptl to encourage reviews
15:10:32 <amotoki> but I see no progress so far.
15:10:36 <vishalmanchanda> amotoki: thanks.
15:11:00 <vishalmanchanda> #Error-messages-refactor
15:11:08 <amotoki> perhaps we no longer need to discuss the django 1.11 drop here.
15:11:30 <e0ne> amotoki: +1
15:11:34 <vishalmanchanda> I have corporate  radomir comments.
15:11:47 <vishalmanchanda> Now there is one issue i observed
15:12:23 <e0ne> vishalmanchanda: I just returned from the vacation. will review your patch asap
15:12:24 <vishalmanchanda> whenever we redirect to index view I think the control over details link(href) is no longer availble with us and js is not called .
15:12:53 <vishalmanchanda> the link and action on the link looks like not possible after redirect.
15:13:02 <vishalmanchanda> e0ne: thanks Ivan.
15:13:21 <amotoki> vishalmanchanda: is what you mentioned here covered by some comment in the review?
15:14:19 <vishalmanchanda> I mean radomir  give some comments on my patch
15:14:35 <vishalmanchanda> https://review.opendev.org/#/c/708069/
15:14:48 <vishalmanchanda> I have fixed all of them.
15:15:09 <rdopiera> vishalmanchanda: thanks, I will look later today too
15:15:21 <vishalmanchanda> rdopiera:ok.
15:15:56 <vishalmanchanda> If any scenario which didn't have redirect then my patch works fine.
15:16:15 <vishalmanchanda> I am looking into it how to fix it.
15:16:28 <amotoki> so do we still have an issue in cases where redirect is involved?
15:16:28 <rdopiera> vishalmanchanda: did it work before your patch?
15:16:48 <vishalmanchanda> amotoki: yeah:(
15:17:01 <vishalmanchanda> rdopiera: nope.
15:17:21 <rdopiera> vishalmanchanda: then it's something to be fixed separately I suppose
15:17:53 <vishalmanchanda> rdopiera: yeah. any suggestion?
15:19:01 <rdopiera> vishalmanchanda: I need to understand better what is happening, but since it's an existing problem, it should't be blocking your work on the message refactor
15:19:03 <amotoki> vishalmanchanda: to clarify, what doesn't work with 'redirect' before you patch? I am confused that it seems you are saying the current 'redirect' does not work.
15:20:55 <vishalmanchanda> amotoki: what i mean is this work fine https://review.opendev.org/#/c/708069/ if we are not passing redirect in handle.
15:21:28 <vishalmanchanda> amotoki: but that is wrong.
15:22:24 <amotoki> vishalmanchanda: so, the answer is 'yes' for rdopiera's question "did it work before your patch?", right?
15:24:04 <vishalmanchanda> amotoki: no what i mean if i redirect to index page then collapse  detail msg using 'href' not works.
15:24:29 <vishalmanchanda> but if i didn't redirect then it works.
15:24:57 <amotoki> vishalmanchanda: hmmm.... so you are always discussing a case with your patch, right?
15:25:06 <vishalmanchanda> yup.
15:25:31 <amotoki> the original question is what happens "before" your patch. that confuses me
15:26:08 <amotoki> anyway, we need to look into the detail on what happens in a vishalmanchanda's chane
15:26:30 <vishalmanchanda> waiting for your input....
15:26:33 <vishalmanchanda> https://review.opendev.org/#/c/708069/
15:28:46 <amotoki> apart from this, regarding mox removal, we see a great progress by stephenfin's patches.
15:28:47 <vishalmanchanda> :)
15:28:47 <amotoki> https://review.opendev.org/#/q/project:openstack/horizon+branch:master+topic:remove-mox
15:29:04 <e0ne> stephenfin: thanks for your hard work!
15:29:09 <amotoki> I confirmed this completes the mox removals
15:29:14 <stephenfin> no problem; happy to help
15:29:21 <amotoki> and I am doing a final cleanup
15:29:42 <amotoki> stephenfin: really appreciated!!!
15:29:59 <stephenfin> thanks to amotoki for reworking them to make more sense :)
15:29:59 <amotoki> I believe we can land them soon
15:30:00 <vishalmanchanda> stephenfin: cheers:)
15:30:10 <stephenfin> I think that's the last of the openstack/ projects using it too \o/
15:30:15 * stephenfin prepares the successbot message
15:30:26 <amotoki> :)
15:30:29 <e0ne> :)
15:31:25 <e0ne> hm... http://codesearch.openstack.org/?q=mox3&i=nope&files=&repos=
15:32:25 <e0ne> it's better http://codesearch.openstack.org/?q=mox3&i=nope&files=requirements.txt&repos=
15:33:05 <e0ne> anyway, it
15:33:25 <e0ne> anyway, it's great that we finanlly get rid of mox :)
15:34:01 <amotoki> yeah, perhaps horizon and congress are the last pieces who use mox3.
15:34:43 <amotoki> but horizon is the last piece which actually consumes it
15:35:27 <amotoki> regarding "Chinese translation handling", we landed https://review.opendev.org/#/c/708414/ today
15:36:06 <amotoki> I think the next step would be to test horizon with the new lang codes (zh_hans/hant)
15:36:08 <amotoki> right?
15:36:46 <e0ne> it should work without any issues
15:37:03 <amotoki> I hope so
15:37:48 <amotoki> once we confirmed they work, we need to decide (with the i18n team) whether we use zh_hans/hant or keep zh_ch/tw for Ussuri translations.
15:38:02 <e0ne> AFAIR, rdopiera's the first patch renamed current translations to the new names wich we abandoned
15:39:07 <amotoki> e0ne: do you mean https://review.opendev.org/#/c/640981/?
15:39:27 <e0ne> yes, this one
15:40:01 <amotoki> translations are automatically imported by the job, so the patch just reduces the diff for a new translation import.
15:40:07 <e0ne> rdopiera: are you going to restore and celebrate the Birthday of your patch tomorrow? :)
15:40:30 <e0ne> amotoki: sure, I don't propose to do it ourself in horizon repo
15:40:37 <rdopiera> it may require some coordination with the translations team
15:41:33 <rdopiera> I will restore it, and we can abandon it again in the worst case
15:42:39 <e0ne> rdopiera: I was joking.. but we can test how it works using your patch against the latest master
15:43:28 <amotoki> yeah what we need to do is to test horzon with rdopiera's patch to confirm it works well
15:43:56 <amotoki> it just helps us avoid doing it manually though :)
15:44:59 <amotoki> let's test zh_hans/hant in the coming one or two weeks (even though we cannot understand these languages) and discuss the next plan
15:45:22 <e0ne> #action e0ne to test  https://review.opendev.org/#/c/640981/?
15:46:01 <amotoki> e0ne: thanks. or you can just copy the existing zh_ch/tw to zh_hans/hant and test them :)
15:46:09 <e0ne> will do it
15:46:38 <amotoki> I am familiar with the job script so I can coordinate the further steps
15:47:29 <amotoki> anything to discuss more on the general priorities?
15:47:37 <e0ne> nothing from me
15:47:53 <vishalmanchanda> none from my side.
15:48:04 <amotoki> moving on
15:48:08 <amotoki> #topic bugs/reviews
15:48:31 <amotoki> I added two topics to "Reviews that need attentions" section in https://etherpad.openstack.org/p/horizon-release-priorities
15:48:49 <amotoki> the first one is https://review.opendev.org/#/c/705886/
15:49:06 <amotoki> which proposes a change to avoid stripping leading/traling spaces in password forms
15:49:25 <amotoki> e0ne shows a negative feedback on this but I am not sure the reason
15:49:25 <e0ne> I home vishalmanchanda and rdopiera will put +2 on it
15:49:47 <rdopiera> amotoki: there was some discussion on that on the mailing list I think
15:49:47 <amotoki> e0ne: what is your real concern on this?
15:49:47 <e0ne> I really don't want to block this patch because it fixes real issue
15:50:24 <e0ne> I prefer to strip spaces in passwords to not have issues with password copy-paste
15:50:43 <e0ne> but that's only my opinion
15:51:11 <e0ne> if community would like to have this merged - I won't block it
15:51:15 <amotoki> rdopiera: the mailing list discussion is found in the commit msg.
15:51:41 <rdopiera> great
15:52:30 <vishalmanchanda> I am fine with this patch.
15:53:23 <vishalmanchanda> or we can dicuss this more on the same thread.
15:53:34 <vishalmanchanda> discuss*
15:53:43 <amotoki> e0ne: thanks. I understand your point. perhaps it is a balance and it would be nice to show your opinions in the mailing list thread rather than the review. I was surprised what is a technical problem.
15:55:01 <e0ne> amotoki: ok, I'll post it to the mailing list too
15:56:09 <amotoki> e0ne: appreciated. it is really a problem where persons have different opinions and we need to find a balance/compromise.
15:56:45 <amotoki> I think it should put -1 to my patch as it lacks a release note at least :p
15:57:00 <rdopiera> and tests ;-)
15:57:13 <amotoki> hehe, of course
15:57:16 <amotoki> the second one is https://review.opendev.org/#/c/710174/
15:57:23 <vishalmanchanda> haha: )
15:57:23 <rdopiera> (just kidding, that should be covered by django's tests)
15:57:52 <amotoki> it is a variant of a fix in the master branch from e0ne https://review.opendev.org/#/c/675894/
15:58:01 <amotoki> but it requires cinderclient 5.0.0
15:58:11 <e0ne> that's was my question
15:58:39 <amotoki> e0ne: comment on which topic?
15:59:15 <e0ne> oh.. I see that your fix doesn't require a new cinderclient
15:59:26 <e0ne> I'll test it on my env
15:59:42 <amotoki> it just borrows a logic from cinderclient
15:59:50 <amotoki> so I would like to ask your opinionns
15:59:52 <vishalmanchanda> cool
16:00:45 <amotoki> we've passed the hour
16:00:52 <amotoki> thanks for joining all
16:00:55 <amotoki> #endmeeting