15:00:40 <vishalmanchanda> #startmeeting horizon
15:00:41 <openstack> Meeting started Wed Jul 22 15:00:40 2020 UTC and is due to finish in 60 minutes.  The chair is vishalmanchanda. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:44 <openstack> The meeting name has been set to 'horizon'
15:01:12 <vishalmanchanda> hi anyone around for horizon meeting.
15:01:51 <rdopiera> o/
15:02:05 <vishalmanchanda> rdopiera: hi.
15:02:47 <vishalmanchanda> e0ne: Ivan is going to join a little late.
15:03:16 <vishalmanchanda> let's wait for a few minutes if anyone joins.
15:03:45 <e0ne> hi
15:03:49 <amotoki> hi
15:03:59 <vishalmanchanda> #chair e0ne
15:04:00 <openstack> Current chairs: e0ne vishalmanchanda
15:05:21 <e0ne> let's start
15:05:35 <e0ne> #topic Notices
15:05:52 <e0ne> we'll reach Victoria-2 milestone next week
15:06:07 <e0ne> #link https://releases.openstack.org/victoria/schedule.html
15:06:14 <e0ne> nothing special for horizon
15:06:25 <e0ne> just FYI
15:06:45 <amotoki> have we dropped deprecated features we need to drop in victoria?
15:07:01 <e0ne> amotoki: I didn't check it yet
15:07:12 <e0ne> but it should be safe until FF
15:07:12 <amotoki> I haven't checked it yet, but perhaps it is better to drop them if any before milestone-2
15:07:26 <e0ne> sure, earlier is better
15:08:45 <e0ne> #action e0ne to check for deprecated features to drop in Victoria
15:09:24 <e0ne> Community goals for V release: https://governance.openstack.org/tc/goals/selected/victoria/index.html
15:09:49 <e0ne> nothing special for Horizon team to implement
15:10:57 <amotoki> is there no things we need to work explicitly?
15:11:37 <e0ne> need to check our zuul config once more
15:12:02 <rdopiera> I plan to check the alternate scss libraries, but that's more research than coding
15:12:03 <amotoki> yeah. let's check :)
15:12:34 <e0ne> amotoki:  I checked it few weeks ago and didn't find any legacy jobs there
15:12:36 <tosky> iirc there are no legacy zuul jobs for horizon, you should be fine
15:12:47 <e0ne> tosky: thanks!
15:12:52 <vishalmanchanda> I think we can test horizon on focal like others https://review.opendev.org/#/q/topic:migrate-to-focal
15:13:03 <e0ne> tosky: I appreciate your help with CI
15:13:06 <amotoki> e0ne: yes, I cleanedup all legacy jobs in the early stage of zuulv3 migration.
15:13:45 <e0ne> oops, we've got some bionic-based jobs https://github.com/openstack/horizon/search?q=bionic&unscoped_q=bionic
15:13:53 <e0ne> I'll propose a patch after the meeting
15:14:33 <vishalmanchanda> e0ne: +1.
15:16:21 <tosky> are those nodeset different from the default ones?
15:16:25 <tosky> nodesets*
15:16:34 <tosky> well, just one, ubuntu-bionic
15:16:43 <amotoki> nodejs10 is available in focal, so it would be simpler.
15:17:01 <e0ne> tosky: they should not be. need to check if there are no issues with nodejs
15:17:07 <amotoki> the nodeset definition was introduced when we used trusty
15:17:30 <amotoki> it may be defined only for explicitly. I am not sure.
15:17:37 <e0ne> TBH, I didn't use nodejs from ubuntu packages
15:18:37 <amotoki> tosky: do you know where is the default node defined?
15:19:53 <tosky> amotoki: iirc in openstack-zuul-jobs
15:20:12 <tosky> https://opendev.org/openstack/openstack-zuul-jobs/src/branch/master/zuul.d/nodesets.yaml
15:20:55 <amotoki> nodejs jobs inherit jobs definitions from zuul-jobs (not from openstack-zuul-jobs)
15:20:56 <amotoki> https://opendev.org/openstack/horizon/src/branch/master/.zuul.d/nodejs-jobs.yaml#L3
15:21:01 <tosky> but I guess it depends on what nodejs-run-lint use
15:21:31 <amotoki> so perhaps explicit nodeset might make sense
15:21:52 <tosky> yeah, I guess so
15:22:04 <tosky> it's a less common case than the usual devstack jobs
15:22:15 <tosky> where the default can just be inherited
15:25:59 <amotoki> as far as I checked, other jobs inherit from openstack-zuul-jobs. nodejs jobs look the only exceptions.
15:26:14 <amotoki> *look like*
15:28:54 <e0ne> let's move on the next topic
15:29:20 <e0ne> next OpenStack Summit will be virtual again
15:29:23 <e0ne> #link https://www.openstack.org/summit
15:29:46 <e0ne> I'm sorry, Open Infrastructure Summit
15:29:48 <e0ne> Oct 19-23, 2020
15:30:18 <e0ne> it will be less complicated than virtual PTG
15:30:45 <e0ne> and it sounds absolutely reasonable with the current situation
15:31:16 <e0ne> and one more announcement from me
15:31:36 <e0ne> I created a poll for Victoria virtual mid-cycle poll as we discussed at the PTG
15:31:41 <e0ne> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-July/016040.html
15:32:11 <e0ne> I don't expect a lot of discussion, so 1 hour should be enouph
15:32:27 <e0ne> otherwise, we can schedule one more session
15:32:50 <vishalmanchanda> e0ne: cool. already voted!
15:33:00 <amotoki> candidate dates are July 27-31, but you said please response by Aug 4....
15:33:10 <e0ne> I tried to select timezone to be suitable both for US and Asia
15:33:58 <e0ne> amotoki: my bad. I meant Aug  5-7
15:34:04 <e0ne> will send an update
15:34:17 <amotoki> e0ne: thanks
15:34:31 <e0ne> it's a crazy day for me :(
15:34:45 <amotoki> the week of Aug 5 is a summer vacation week in my company :(
15:35:14 <e0ne> oh... we can schedule a week later I guess
15:35:49 <e0ne> I'm sorry, I have to run away in 10 minutes:(
15:36:05 <amotoki> If it is better to have it that week, I can coordinate my schedule but it is my schedule at the moment.
15:36:38 <amotoki> due to the current situation I have no specific plan during that off week
15:37:05 <e0ne> amotoki: please, drop a note to the thread what dates are good for you
15:37:30 <amotoki> e0ne: any week is okay except that.
15:38:03 <amotoki> e0ne: I just wonder scheduling it later leads to less days till FF
15:38:28 <e0ne> that's the issue
15:39:09 <e0ne> the week of Sep 07 - Sep 11 is Feature Freeze
15:40:28 <amotoki> vishalmanchanda: rdopiera: what about you?
15:41:03 <amotoki> I am okay to move my off week if the week of Aug 5 is fine to you all.
15:41:17 <vishalmanchanda> amotoki: I can be available on any day except 3rd August.
15:41:40 * e0ne is afk now
15:43:16 <vishalmanchanda> rdopiera: what about you?
15:43:50 <vishalmanchanda> I mean Aug 5 week works for you?
15:44:16 <rdopiera> vishalmanchanda: it does
15:44:42 <vishalmanchanda> rdopiera: cool.
15:46:05 <vishalmanchanda> then we can plan mid-cycle in August 5 week except Monday.
15:47:04 <vishalmanchanda> e0ne: around?
15:47:39 <amotoki> okay, I will coordinate my schedule internally next week. (next two days are holidays in Japan)
15:48:46 <vishalmanchanda> amotoki: cool.
15:49:04 <vishalmanchanda> e0ne: I think Ivan is not around.
15:50:48 <vishalmanchanda> Guys please vote to Ivan's poll for mid-cycle timing link http://lists.openstack.org/pipermail/openstack-discuss/2020-July/016040.html
15:51:03 <vishalmanchanda> moving on to next topic.
15:51:17 <vishalmanchanda> #open-discussion
15:51:30 <amotoki> vishalmanchanda: you need '#topic' :p
15:51:38 <vishalmanchanda> oops.
15:52:00 <vishalmanchanda> #topic open-discussion
15:52:50 <vishalmanchanda> amotoki: I have fixed your comments on this patch https://review.opendev.org/#/c/708069/.
15:53:12 <vishalmanchanda> Please take a look once you have time.
15:53:20 <vishalmanchanda> rdopiera: you too.
15:54:27 <amotoki> do we have a consensus on whether we should add 'details' to all exceptions.handle() or automatically add details to error messages?
15:56:14 <amotoki> as long as in the horizon repo it looks better to add details automatically because you changes all occurrences of exceptions.handle()
15:57:12 <vishalmanchanda> adding details to all exceptions.handle looks fine to me.
15:57:16 <amotoki> I am not sure about horizon plugins, but if we plan to make similar changes for all plugins an explicit 'details' argument would not make sense.
15:57:39 <vishalmanchanda> rdopiera: Do you want to add something here?
15:59:04 <vishalmanchanda> amotoki: what is the issue in adding a additional parameter i.e 'details'.
15:59:46 <rdopiera> nothing
16:00:00 <amotoki> vishalmanchanda: if all callers specify details=str(ex) it is just redundant.
16:00:16 <rdopiera> just the fact that details don't always have to come from the exception
16:00:33 <vishalmanchanda> ok we can continue on #horizon channel.
16:00:38 <vishalmanchanda> #endmeeting