15:01:14 <e0ne> #startmeeting horizon
15:01:15 <openstack> Meeting started Wed Sep  9 15:01:14 2020 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:18 <openstack> The meeting name has been set to 'horizon'
15:01:32 <vishalmanchanda> hi
15:01:35 <tmazur> o/
15:01:46 <rdopiera> o/
15:01:52 <jadonn> 0/
15:04:04 <e0ne> ok, let's start
15:04:12 <e0ne> I hope amotoki will join us later
15:04:25 <e0ne> #topic Notices
15:04:47 <amotoki> hi, just working on a document :)
15:04:55 <e0ne> :)
15:05:21 <e0ne> so, we're reaching victoria-3 milestone this week
15:05:24 <e0ne> #link https://releases.openstack.org/victoria/schedule.html
15:05:46 <e0ne> it's also Soft StringFreeze
15:05:56 <e0ne> "You are no longer allowed to accept proposed changes containing modifications in user-facing strings. Such changes should be rejected by the review team and postponed until the next series development opens (which should happen when RC1 is published)."
15:06:28 <e0ne> please, be careful with approval any changes with user-facing strings
15:08:34 <e0ne> some usual reminders about PTG and Summit
15:08:52 <e0ne> Horizon Virtual PTG planning etherpad
15:08:54 <e0ne> #link https://etherpad.opendev.org/p/horizon-w-ptg
15:09:11 <e0ne> feel free to add topics you would like to discuss
15:09:43 <e0ne> general PTG details and registration information could be found  here:
15:09:45 <e0ne> #link https://www.openstack.org/ptg
15:10:17 <e0ne> Virtual Open Infrastructure summit details are available:
15:10:21 <e0ne> #link https://www.openstack.org/summit
15:10:47 <e0ne> please, don't forget to register for PTG and Summit if you're going to attend them
15:11:34 <e0ne> that's all updates from me
15:11:54 <e0ne> #topic victoria-3 milestone (feature freeze)
15:12:15 <e0ne> amotoki: thanks for work on policy-in-code
15:12:21 <e0ne> #link https://review.opendev.org/#/c/750134/
15:12:44 <e0ne> amotoki: I agree with you that it's better to have it in early in Wallaby release
15:13:29 <amotoki> related to this, I checked if the existing policy rules in horizon match back-end services.
15:13:30 <amotoki> https://etherpad.opendev.org/p/horizon-victoria-policy-check
15:13:48 <e0ne> I'm feeling OK to merge such changes just before FF except cases when we really need such patches
15:13:56 <amotoki> the check is based on policy-in-code patch, so I don't know the check is based on the current horizon codebase.
15:14:28 <amotoki> the current horizon codebase == the current policy.json files in horizon
15:16:50 <e0ne> technically, the patch contains pretty small code changes but it could break anything
15:17:11 <amotoki> e0ne: yeah, that's true
15:17:16 <e0ne> amotoki: did you check that it doesn't break horizon upgrades?
15:17:28 * e0ne just notices that there is no release note
15:17:50 <amotoki> e0ne: I haven't checked the upgrade.
15:18:42 <amotoki> at least I confirmed it works even when the current policy.json files exist
15:18:46 <e0ne> I propose to test this patch before putting +1/+2 on it and merge it once Wallaby cycle starts
15:19:16 <amotoki> agree. sounds fair and steady
15:19:59 <e0ne> :)
15:20:20 <e0ne> #agreed to move policy-in-code to the next cycle
15:20:57 <e0ne> #topic victoria-3 milestone (feature freeze): Error messages refactoring
15:21:11 <e0ne> #link https://review.opendev.org/#/q/topic:bp/refactor-error-messages+(status:open+OR+status:merged)
15:21:29 <e0ne> there is only one patch left for horizon:
15:21:30 <e0ne> #link https://review.opendev.org/#/c/749739/
15:21:43 <e0ne> and some clean up patches to plugins
15:22:27 <e0ne> amotoki, rdopiera: please, review this patch ^^
15:22:42 <e0ne> I forgot to mention that Feature Freeze is tomorrow
15:23:29 <e0ne> vishalmanchanda: you did a great  job with this feature during this release
15:23:43 <amotoki> e0ne: I thought this follow-up is a bug fix while it is nice to land it earilier.
15:24:10 <vishalmanchanda> e0ne: thanks for helping me with JS Hack:)
15:24:56 <e0ne> amotoki: technically, you're right
15:25:46 <e0ne> amotoki: but since it contains "Partially-Implements blueprint" text in the commit message I would like to treat it as a minor feature and force to merge it before FF
15:26:20 <e0ne> amotoki: of course, you can disagree with me :)
15:26:38 <amotoki> e0ne: one question on the patch is whether .....fadeIn(100) is assigned to "this_alert" and you call .find() method on it.
15:27:30 <amotoki> e0ne: I will add my comment after the meeting. I haven't checked the detail code behind this but you may know more.
15:28:06 <e0ne> amotoki: sorry, could you please point me into the code with 'fadeIn(100)' call
15:28:08 <e0ne> ?
15:28:14 <amotoki> https://review.opendev.org/#/c/749739/3/horizon/static/horizon/js/horizon.messages.js
15:28:35 <amotoki> L.50 and L.56
15:28:45 <amotoki> I will add my comment anyway
15:29:45 <e0ne> oh.. I've got what do you mean
15:30:05 <e0ne> fadeIn returns jQuery instance
15:30:09 <e0ne> amotoki: https://api.jquery.com/fadeIn/
15:30:51 <amotoki> e0ne: thanks
15:31:00 <e0ne> in our case, it will be some html element
15:31:11 <e0ne> amotoki: np
15:32:36 <e0ne> let's move on
15:32:49 <e0ne> #topic victoria-3 milestone (feature freeze): Cinder user messages
15:32:56 <e0ne> #link https://review.opendev.org/#/c/734161/
15:33:52 <vishalmanchanda> I have to add some U.T test for this patch.
15:34:15 <amotoki> I made several clean up comments yesterday and most of them were minor and fixed.
15:34:36 <amotoki> the remaining thing is the new code has no test coverage.
15:34:45 <e0ne> I didn't look on the lates patch-set. will do it after the meeting
15:34:50 <vishalmanchanda> I will try to push it by tomorrow. Let's see if we also get this feature in this cycle.
15:35:16 <amotoki> I am okay with either. UT in this patch or in a follow-up patch
15:35:34 <e0ne> vishalmanchanda: is the only reason to not merge it is test coverage, you can ask for FFE tomorrow
15:35:43 <vishalmanchanda> amotoki: It have some test to check "message-list" at least.
15:36:04 <vishalmanchanda> amotoki: ok I will add U.T in follow-up patch.
15:36:13 <vishalmanchanda> will update the patch after the meeting.
15:36:17 <amotoki> vishalmanchanda: precisely speaking, the API code has coverage. no coverage for panel implementation.
15:36:53 <vishalmanchanda> amotoki: yeah as there is no url I have added in this change so I didn't able to do much thing with res.
15:37:28 <vishalmanchanda> amotoki: I tried to do something like this  https://review.opendev.org/#/c/734161/10/openstack_dashboard/dashboards/project/volumes/tests.py@1506 but it didn't work out
15:40:20 <amotoki> vishalmanchanda: I don't have a good answer right now in the meeting.
15:41:14 <vishalmanchanda> amotoki: e0ne : If it's fine for both of you I can add these U.T in a follow-up patch.
15:42:36 <e0ne> I'm OK with it
15:42:58 <amotoki> as mentioned above, I am okay
15:43:50 <vishalmanchanda> e0ne: amotoki thanks. then I will update it after the meeting.
15:44:37 <e0ne> #topic victoria-3 milestone (feature freeze): Add flatten_volume_from_snapshot config option
15:44:47 <e0ne> #link https://review.opendev.org/#/c/741990/5
15:45:07 <e0ne> vishalmanchanda, amotoki: thanks for your reviews
15:45:22 <e0ne> I'll ask Oleksiy  to update this patch tomorrow
15:45:42 <amotoki> e0ne: is "flatten" a common word in cinder?
15:45:51 <e0ne> he used cinder-specific tems which are not obvious for everybody
15:46:32 <e0ne> amotoki: yes, in case of RBD and maybe few other drivers
15:46:38 <vishalmanchanda> e0ne: yeah first I am also confused then I refer this document https://docs.openstack.org/cinder/ussuri/drivers.html#rbddriver
15:47:03 <e0ne> we'll try to find a better name for this
15:47:15 <amotoki> I see. I am okay to use "flatten" if we have a good description.
15:47:27 <amotoki> the other thing from me is about the test name.
15:47:36 <e0ne> my main question is: shoud we treat this patch as a feature or as a test fix?
15:47:56 <e0ne> it adds a new config option but only for integration tests config
15:47:57 <amotoki> I think it is a fix or a workaround in tests
15:48:00 <amotoki> not a feature
15:48:42 <e0ne> amotoki: ok, so we can merge it after FF and before RC
15:48:43 <amotoki> we don't touch any feature in our main code. it touches only the test codes, so I think it is not a target of FF.
15:48:56 <amotoki> e0ne: exactly. that's my thought.
15:49:14 <e0ne> amotoki: got it. it was not clear to my, so I added it for today's discussion
15:49:22 <amotoki> e0ne: thanks
15:49:27 <e0ne> amotoki: np
15:49:49 <e0ne> that's all I've found in gerrit as a horizon feature proposal
15:51:33 <e0ne> if you know about any other feature in progress, just let us know
15:51:59 <e0ne> #topic victoria-3 milestone: horizon beta-1 release
15:52:16 <amotoki> e0ne: I have a topic around https://review.opendev.org/#/c/743600/ in on-demand agenda.
15:52:26 <amotoki> go ahead this topic first
15:52:32 <e0ne> it's not mandatory anymore but
15:53:24 <e0ne> I prefer to get this release to make sure that plugins are not broken
15:53:40 <e0ne> but I'm OK if we decide to skip beta release
15:54:07 <amotoki> it is a good idea to cut a release.
15:54:29 <amotoki> our last release was shipped about three months ago now
15:54:56 <amotoki> precisely speaking, it is not a beta release though. we adopt the intermediary release model.
15:54:57 <e0ne> ok, let's do it tomorrow once vishalmanchanda's patches will be merged
15:55:10 <e0ne> amotoki: you're right
15:55:44 <e0ne> my point is: it's not a release candidate and not a final release for victoria
15:56:08 <amotoki> e0ne: yeah, i know it too
15:56:48 <e0ne> amotoki: ok, let's move to your topic
15:56:53 <e0ne> #topic Open Discussion
15:57:14 <amotoki> https://review.opendev.org/#/c/743600/ proposed a revert ot OPENSTACK_NOVA_EXTENSIONS_BLACKLIST deprecation
15:57:18 <e0ne> we've got 5 minutes left but we can continue in #openstack-horizon channel
15:57:41 <amotoki> the discussion turns out what we want is just SimpleTenantUsage in the setting.
15:57:57 <amotoki> so I think it is better to introduce a new setting
15:58:12 <amotoki> I just pushed a draft of the document to clarify it https://review.opendev.org/#/c/750693/1/doc/source/configuration/settings.rst
15:58:23 <amotoki> we have two ways now
15:58:45 <amotoki> the one is to clarify OPENSTACK_NOVA_EXTENSIONS_BLACKLIST will not be dropped until a new setting is implemented
15:58:54 <amotoki> the other is to add a new setting in this release
15:59:03 <amotoki> both would be simple
15:59:16 <amotoki> I would like to know your opinions
15:59:34 <amotoki> we run out of time, so please give me feedback in #-horizon channel.
15:59:59 <e0ne> let's continue in #openstack-horizon
16:00:04 <e0ne> #endmeeting