15:02:17 <e0ne> #startmeeting horizon
15:02:18 <openstack> Meeting started Wed Mar 17 15:02:17 2021 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:21 <openstack> The meeting name has been set to 'horizon'
15:04:53 <vishalmanchanda> hi.
15:06:23 <tmazur> o/
15:07:51 <e0ne> let's start
15:07:57 <e0ne> it seems to be a short meeting
15:08:05 <e0ne> #link https://etherpad.opendev.org/p/horizon-release-priorities
15:08:21 <e0ne> #topic Notices
15:08:58 <e0ne> we're about one month before Wallaby release
15:09:02 <e0ne> #link https://releases.openstack.org/wallaby/schedule.html
15:10:06 <e0ne> we reached a soft string freeze and feature freeze milestones, so please be helpful during reviews
15:12:34 <e0ne> a kindly reminder to not forget to register for a PTG: https://www.openstack.org/ptg #link
15:13:06 <e0ne> that's all updates for this week
15:14:44 <e0ne> vishalmanchanda: will you create a poll with PTG timeslots?
15:15:00 <e0ne> IMO, we can use the same as we'd got before
15:15:19 <vishalmanchanda> e0ne: ok I will do that.
15:15:48 <vishalmanchanda> e0ne: yeah I think last ptg time slots work for all of us.
15:15:54 <e0ne> +1
15:16:19 <vishalmanchanda> e0ne: Should I have to send a mail on open-discuss about time-slot poll?
15:16:31 <vishalmanchanda> e0ne: or you will do that?
15:17:01 <e0ne> I can do it
15:17:15 <vishalmanchanda> e0ne: ok thanks.
15:17:16 <e0ne> #action e0ne to send timeslots proposal for PTG to the ML
15:18:10 <vishalmanchanda> e0ne: you also forgot to send tmazur core reviewer announcement mail on open-discuss.
15:18:22 <e0ne> vishalmanchanda: I did:(
15:18:25 <vishalmanchanda> e0ne: just a reminder from last weekly meeting
15:18:33 <e0ne> that's why I sent a mail just before the meeting
15:18:54 <vishalmanchanda> e0ne: ok just checked nice:)
15:19:22 <e0ne> anyway, I added tmazur to the gerrit and launchpad groups last week :)
15:19:57 <vishalmanchanda> nice
15:20:30 <e0ne> #topic Open Discussion
15:20:53 <e0ne> do we have anything to discuss?>
15:21:24 <vishalmanchanda> I was just looking at our launchpad bugs.
15:21:33 <vishalmanchanda> small update on that.
15:22:00 <vishalmanchanda> We have 4 high priority and 1 critical bug.
15:22:20 <e0ne> it means somebody uses horizon :)
15:22:21 <vishalmanchanda> I have pushed a patch for https://bugs.launchpad.net/horizon/+bug/1869222
15:22:22 <openstack> Launchpad bug 1869222 in OpenStack Dashboard (Horizon) "In Resize Instance interface Advanced Options -> Server Group option does not do anything" [High,In progress] - Assigned to Vishal Manchanda (vishalmanchanda)
15:22:31 <vishalmanchanda> e0ne: hehe..
15:22:49 <vishalmanchanda> #link https://review.opendev.org/c/openstack/horizon/+/781086
15:23:17 <vishalmanchanda> Please review it carefully as i have done too many changes in the Unit test cases
15:24:00 <vishalmanchanda> I have also looked into https://bugs.launchpad.net/horizon/+bug/1894801 but didn't find any solution yet.
15:24:01 <openstack> Launchpad bug 1894801 in OpenStack Dashboard (Horizon) "django encoding issue in password setting" [High,Confirmed] - Assigned to Vishal Manchanda (vishalmanchanda)
15:25:00 <vishalmanchanda> I was just checking that above bug automatically resolved if we move to django 3.0
15:25:41 <vishalmanchanda> but my env. stop working due to pyscss issues🙂)
15:25:41 <e0ne> :)
15:26:02 <e0ne> vishalmanchanda: did you see amotoki's comment?
15:27:02 <vishalmanchanda> e0ne: yes his comment is very helpful but I didn't able to find where I should encode and decode the translated string.
15:28:16 <e0ne> vishalmanchanda: I see, ping me tomorrow If I don't send you update on it. I'll take a look on it tomorrow morning
15:28:44 <e0ne> there should be some easy way to do it in django
15:28:52 <vishalmanchanda> e0ne: thanks
15:30:59 <vishalmanchanda> e0ne: Also I was thinking to push a Test patch in requirements so we can reproduce XStatic-JQuery-Migrate bug
15:31:08 <vishalmanchanda> #link https://bugs.launchpad.net/horizon/+bug/1914782
15:31:09 <openstack> Launchpad bug 1914782 in OpenStack Dashboard (Horizon) "Horizon Integration tests Fails with XStatic-JQuery-Migrate 3.3.2.1 Version" [Critical,Confirmed]
15:31:46 <vishalmanchanda> rdopiera also pushed a patch in horizon to fix it and we can check if that's work or not
15:32:00 <vishalmanchanda> and how can we further proceed.
15:32:14 <e0ne> +1
15:32:20 <vishalmanchanda> https://review.opendev.org/c/openstack/horizon/+/773996
15:32:30 <e0ne> it's good to have a fix early in the next release cycle
15:32:41 <rdopiera> that patch doesn't really fix it, it just makes the error less confusing
15:33:10 <vishalmanchanda> rdopiera: yeah I know that.
15:34:51 <rdopiera> I suspect that to fix the failuers we will need to first fix all the warnings
15:36:11 <vishalmanchanda> rdopiera: If I want see those warning how should I check.
15:36:36 <vishalmanchanda> Can I see those warning in our zuul CI/CD.
15:36:57 <rdopiera> basically pip install XStatic-JQuery-Migrate in your venv and then you will see them in the js console
15:37:31 <rdopiera> you can't see it in our CI, because we use firefox, and it doesn't let selenium retrieve the js console contents
15:37:59 <rdopiera> there is a 6 year old bug for this in firefox bugtracker
15:39:12 <vishalmanchanda> Ok I will also try to reproduce those warning in my local env.
15:43:12 <vishalmanchanda> e0ne: Do we have any other topic to discuss?
15:44:41 <e0ne> nothing from me
15:45:48 <e0ne> let's wrap up the meeting
15:47:02 <e0ne> thanks everybody for your contributions! see you next week
15:47:03 <vishalmanchanda> Thanks everyone!
15:47:56 <tmazur> Thanks all!
15:49:52 <e0ne> #endmeeting