12:01:25 <david-lyle> #startmeeting horizondrivers
12:01:26 <openstack> Meeting started Wed Aug 26 12:01:25 2015 UTC and is due to finish in 60 minutes. The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:30 <openstack> The meeting name has been set to 'horizondrivers'
12:01:37 <robcresswell> o/
12:02:37 <rdopiera> o/
12:03:01 <robcresswell> Agenda: https://wiki.openstack.org/wiki/Meetings/HorizonDrivers
12:03:11 <tsufiev> o/
12:03:14 <david-lyle> #link https://wiki.openstack.org/wiki/Meetings/HorizonDrivers
12:03:25 <robcresswell> Travis has suggested that we defer Angular reviews until next week, which I am inclined to agree with.
12:03:35 <robcresswell> bah sorry, always forget the link.
12:04:12 <david-lyle> I would agree with that, but I will argue replacing the can't with won't
12:04:42 <robcresswell> Haha, yeah I agree.
12:05:08 <david-lyle> but I digress
12:05:32 <robcresswell> With that in mind, I'll update the agenda for next week, and we should look at tsufiev bp
12:05:33 <david-lyle> tsufiev: added one, we can start with
12:05:41 <david-lyle> #link https://blueprints.launchpad.net/horizon/+spec/integration-tests-hardening
12:05:49 <tsufiev> david-lyle, yep, I'm here
12:06:06 <tsufiev> 3 of total 5 commits addressing the BP are already landed
12:06:46 <tsufiev> oh, 3 of 4
12:07:09 <tsufiev> and I think there will be more 2-4 commits addressing different points of the BP
12:07:47 <tsufiev> david-lyle, should we discuss the remaining steps for hardening tests?
12:08:03 <david-lyle> so for #3 in the bp spec, is that just adding more id HTML attributes to use ?
12:08:12 * david-lyle was reading
12:09:04 <tsufiev> david-lyle, yes, it is. The most controversial one for now (although it was merged because it _fixes_ tests)
12:09:18 <tsufiev> the same idea as in #4
12:11:02 <robcresswell> IIRC, #2 was the one I wasn't too happy about either...
12:11:24 <david-lyle> I need to look through that one again, we added an attribute just for testing.
12:11:29 <robcresswell> As for the bp itself, this is a really key one IMO. Should be marked High.
12:11:38 <robcresswell> and targeted for M I suppose.
12:12:03 <tsufiev> robcresswell, what's wrong with #2? Btw it hasn't been implemented yet
12:12:16 <robcresswell> Yeah, it was a workaround for truncated data.
12:12:22 <robcresswell> tsufiev: Sorry, I meant patch 2
12:12:59 <tsufiev> robcresswell, better to post the link )
12:13:07 <david-lyle> instead of that why not add an 'name' attribute
12:13:53 <tsufiev> david-lyle, the idea here is to mark this attribute as pertaining to selenium tests, so other people would easily recognize it
12:14:35 <david-lyle> but most entity detection in HTML is done by name
12:14:47 <david-lyle> curious why we need a new one
12:14:56 <david-lyle> as name would be more generally useful
12:15:18 <david-lyle> but aside from that, I'm always in favor of improving integration testing
12:15:18 <tsufiev> david-lyle, just changing 'selenium-data' -> 'name'?
12:16:00 <david-lyle> tsufiev: yes, I think so, but I need to evaluate what you're putting in selenium-data now
12:16:07 <tsufiev> okay
12:16:34 <tsufiev> david-lyle, here it is https://review.openstack.org/#/c/214671/
12:16:42 <robcresswell> Yeah, its useful to fix the tests, just not sure about adding attributes specifically to hold data for tests. That feels wrong IMO. Then you're just testing test data, rather than actual data, right?
12:17:34 <david-lyle> well name would be wrong
12:17:49 <david-lyle> in that case, hadn't dug into the change enough
12:18:05 <tsufiev> robcresswell, kind of. We may decide that every time some text is being truncated in horizon, it's necessary to provide an original value as some attribute
12:18:21 <david-lyle> tsufiev: I think that's true
12:18:34 <tsufiev> and choose some naming pattern, that tests can rely on
12:18:37 <david-lyle> because I would expect a tooltip to provide the full value
12:18:52 <david-lyle> if truncated
12:19:05 <robcresswell> Should the test not account for that? Or even, just use the tooltip.
12:19:40 <tsufiev> robcresswell, the thing is that in future tooltip representation may change
12:19:45 <tsufiev> and that would break tests
12:19:47 <robcresswell> I don't have any solid reasoning here, which is why I didn't -1. It just seems a little inconsistent to have data for tests in the item being tested.
12:19:55 <mrunge> I wouldn't try to get the test calculating, if screen width is wide enough to truncate or not truncate
12:20:01 <david-lyle> that's what I would think, but that's a feature I don't feel is implemented yet
12:20:31 <david-lyle> I suppose this is a reasonable stop-gap
12:20:36 <mrunge> and screen size would be in some kind of virtal frame buffer
12:20:49 <david-lyle> but I would prefer a not and followon item to fix more elegantly
12:21:03 <robcresswell> Agreed, it's a good stop-gap. Not a huge issue, but not a pattern I'd like to see repeated :)
12:21:04 <tsufiev> robcresswell, but, if we had some convention on how the data being truncated should be preserved, then we could use that in tests
12:21:43 <robcresswell> tsufiev: Agreed, then the truncation is the issue and a pattern should be made, and if people don't follow it, then their tests will fail.
12:21:54 <david-lyle> tsufiev: is there more outstanding than just the field ordering patch? more in the works?
12:22:02 <tsufiev> anyways, I'm happy to fix it more elegantly - as soon as we agree on what kind of elegantness we want :)
12:22:11 <david-lyle> or should I slate for L
12:22:42 <david-lyle> tsufiev: understood there needs to be a concrete description of said elegance
12:22:44 <tsufiev> david-lyle, I'm also going to address #2 and #4 of the BP in a separate patches
12:23:11 <tsufiev> #2 implementation is easy and quite probable to be ready before L3
12:23:25 <david-lyle> ok I will leave un-targeted for now and if it makes L-3 all the better
12:23:38 <tsufiev> about #4 I'm not so sure.... I think it's discussable whether we should implement #4 at all
12:23:54 <tsufiev> it was hurgleburger's idea
12:24:37 <david-lyle> I think unique element naming could help
12:24:41 <tsufiev> (well, I don't mean I don't like it, yet haven't thought about this enough)
12:25:04 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/integration-tests-hardening approved High
12:26:02 <robcresswell> I've got a short list of bps that can be made obsolete I think.
12:26:03 <david-lyle> I'd say even if we get 4/5 we're in much better shape
12:26:17 <david-lyle> robcresswell: let's have at them
12:26:37 <robcresswell> #link https://blueprints.launchpad.net/horizon/+spec/ceilometer-hosts-measurement
12:26:49 * david-lyle puts away his #link
12:26:56 <robcresswell> :D
12:27:10 <robcresswell> That one first. 2 years old, no code
12:28:05 * tsufiev is wondering how well Tuskar is...
12:28:36 <mrunge> rdopiera, should have an answer there...
12:28:37 <david-lyle> tsufiev: patches still get merged, but is has slowed considerably, at least the ui part
12:29:29 <robcresswell> Thoughts on removing it?
12:29:35 <robcresswell> the bp, not tuskar :p
12:29:41 <david-lyle> actually IPMI data is available now in Horizon from ceilometer
12:29:54 <mrunge> yeah, remove the bp
12:29:54 <david-lyle> I don't think SNMP is
12:30:05 <mrunge> it is partly implemented
12:30:08 <david-lyle> so this one is at least partially superceded
12:30:21 <mrunge> I feel it's not really fitting in horizon anyways
12:31:52 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/ceilometer-hosts-measurement marked superseded
12:31:57 <robcresswell> #link https://blueprints.launchpad.net/horizon/+spec/horizon-improved-security-group-and-rule-creation
12:32:06 <robcresswell> Next one. Over a year old, very small, no code.
12:33:17 <tsufiev> perhaps Angular guys have some ideas about improving Groups & Rules creation?
12:33:27 <david-lyle> I think that's no longer correct either. toshi added code to ease in creating security groups
12:33:32 <mrunge> that's still true. but let's drop it for now
12:33:53 <mrunge> I mean, drop the bp
12:33:58 <robcresswell> The bp itself doesn't really hold any useful info or code, so could be dropped imo.
12:34:14 <david-lyle> ok, dropping
12:35:00 <robcresswell> #link https://blueprints.launchpad.net/horizon/+spec/uploading-auto-segmented-large-images
12:35:14 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/horizon-improved-security-group-and-rule-creation marked obsolete
12:35:17 <robcresswell> Next up. Same story, old, no info, no code.
12:35:46 <rdopiera> mrunge: I didn't keep track of it
12:36:02 <mrunge> rdopiera, no worries
12:36:53 <tsufiev> david-lyle, hm, this one sounds interesting
12:37:21 <david-lyle> I thought there was some work recently on this problem but not using websockets
12:37:37 <tsufiev> david-lyle, the problem itself is still actual and I've been trying to solve it as part of the bug at https://review.openstack.org/#/c/166969/
12:37:43 <mrunge> oh, interesting
12:37:53 <david-lyle> I'm also unsure why the image has to bounce through the horizon server
12:38:00 <mrunge> try to upload a 15 gigs windows file to glance
12:38:02 <tsufiev> yet, the solution is too complicated and Frode Nordahl suggested reusing work on CORS
12:38:11 <mrunge> while upload, keystone token will time out
12:38:17 <tsufiev> I know not much about CORS support in horizon
12:38:32 <david-lyle> tsufiev: well the CORS would be with glance actually
12:38:42 <david-lyle> which likely does not support it yet
12:38:54 <tsufiev> david-lyle, we don't need CORS in Horizon to feed the image to Glance?
12:39:41 <david-lyle> CORS is cross origin scripting, the JS in the client would send directly to the glance server, not proxying through horizon server
12:39:48 <david-lyle> that's what CORS provides
12:40:35 <david-lyle> *cross origin resource sharing
12:41:15 <robcresswell> In terms of the actual bp... is it worth keeping, or removing and let another be uploaded if we pursue this method?
12:41:21 <david-lyle> although that's the wrong direction for CORS
12:42:09 <david-lyle> anyway, I'm inclined to stick with the bug in progress than the bp without any meat
12:42:09 <tsufiev> meaning it (large image upload) should be done in some other way?
12:42:56 <tsufiev> I can create a BP for long-living uploads, possible w/ CORS support and link it to the above CR
12:43:21 <tsufiev> there is a lot of issues with this bug, it overweighs some BPs )
12:43:33 <david-lyle> tsufiev: sure that sounds reasonable
12:43:43 <tsufiev> by issues I mean at least some UX implications
12:44:06 * tsufiev adds an action item for himself
12:44:48 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/uploading-auto-segmented-large-images marked superseded
12:44:56 <tsufiev> btw, I remember a lot of file upload related BPs that seem stale
12:45:02 <tsufiev> and long forgotten
12:45:03 <robcresswell> #link https://blueprints.launchpad.net/horizon/+spec/soft-reboot-on-vnc-console
12:45:06 <david-lyle> #action tsufiev to add bp for current work on large image upload
12:46:21 <robcresswell> Same with this bp, old, no "meat"
12:46:52 <david-lyle> my only hesitation is that this was operator feedback
12:47:07 <mrunge> uhm, are we sure we can do that?
12:47:17 <robcresswell> True. Perhaps we should pass that on to Piet?
12:47:24 <david-lyle> mrunge: don't know
12:47:32 <mrunge> I mean, it's novnc
12:49:21 <mrunge> this is valuable feedback, but we can't do much about it, right?
12:49:39 <david-lyle> mrunge: very quick google, seems like it may be possible, but may also be outside our scope
12:50:23 <mrunge> david-lyle, I remember some bugs with the console in horizon
12:50:33 <mrunge> it all came back to: different component
12:50:46 <david-lyle> I'll mark obsolete, someone with a real desire and greater knowledge of novnc can look into it
12:52:45 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/soft-reboot-on-vnc-console marked obsolete
12:52:52 <robcresswell> #link https://blueprints.launchpad.net/horizon/+spec/stats-on-splash
12:53:08 <robcresswell> (This is a pretty good process we got here)
12:53:45 <robcresswell> Seems like a suggestion for a feature, but again there's no real code or ideas behind it.
12:54:21 <tsufiev> I'd handle it directly to Piet to evaluate usefullness
12:54:55 <david-lyle> The identity model here is not really supported upstream. The final feedback on items like this would be add a customization hook into the splash screen to populate with your custom methods. But this as a general feature in horizon doesn't really work.
12:55:04 <david-lyle> was my feedback
12:55:11 <david-lyle> I remember the original push
12:55:21 <david-lyle> those individuals have moved on as well
12:55:42 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/stats-on-splash marked obsolete
12:55:46 <mrunge> so, drop it
12:56:04 <robcresswell> #link https://blueprints.launchpad.net/horizon/+spec/instance-zone-info
12:56:09 <robcresswell> Last one for this meeting probably
12:56:37 <david-lyle> if we don't already provide this, we should
12:57:11 <david-lyle> as long as it's part of the nova response
12:57:29 <robcresswell> https://github.com/openstack/horizon/blob/master/openstack_dashboard/dashboards/project/instances/templates/instances/_detail_overview.html
12:57:52 <robcresswell> L17, isn't that it?
12:58:06 <david-lyle> yu
12:58:08 <david-lyle> p
12:58:15 <robcresswell> bp achieved.
12:58:32 <tsufiev> he wished also for showing it in instance list
12:58:38 <tsufiev> (optionally)
12:58:39 <tsufiev> :)
12:58:56 <david-lyle> too many colums
12:59:00 <david-lyle> *columns
12:59:34 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/instance-zone-info superseded complete
13:00:07 <robcresswell> Cool. I think that wraps up nicely.
13:00:10 <tsufiev> things are lighting fast when no angular is being discussed :)
13:00:22 <david-lyle> well current issues vs past issues
13:00:27 <david-lyle> to be expected
13:00:42 <tsufiev> yes, that's more correct
13:01:02 <david-lyle> thanks everyone, great progress. I appreciate everyone's input and feedback
13:01:07 <david-lyle> #endmeeting