20:00:19 <david-lyle> #startmeeting horizondrivers
20:00:19 <openstack> Meeting started Wed Sep 30 20:00:19 2015 UTC and is due to finish in 60 minutes.  The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:22 <openstack> The meeting name has been set to 'horizondrivers'
20:00:51 <david-lyle> any one like driving horizons around?
20:01:25 <mrunge> o/
20:03:27 <david-lyle> well mrunge, we have a packed house today
20:03:38 <mrunge> *yay!*
20:04:05 <david-lyle> time to reject all open bps \o/
20:04:21 <mrunge> exactly
20:04:43 <tsufiev> (+_+)
20:04:57 <TravT> o/
20:05:11 <mrunge> btw, we had one question about adding a ironic dashboard
20:05:20 <mrunge> but nothing written yet
20:05:56 <mrunge> I *think* we could use a table/whatever in Tokyo to collect ideas
20:06:56 <tqtran> [=_=]/
20:07:46 <mrunge> I must admit, I'm badly prepared and relied on robcresswell to provide a list of blueprints to discuss
20:08:00 <mrunge> do we have such a list (just in case?)
20:08:07 <tqtran> i admit the same thing lol
20:08:12 <tqtran> https://wiki.openstack.org/wiki/Horizon/WeeklyBugReport#Blueprints
20:08:17 <tqtran> yeah he had a list posted earlier
20:08:31 <david-lyle> I'm having terrible network issues today
20:08:37 <david-lyle> no, I just usually sort the launchpad page
20:08:44 <TravT> i've noticed you dropping in and out
20:08:58 <mrunge> ah, ok. there are 3 new blueprints proposed
20:09:00 <TravT> so, what is the status on rc2?  what is the current criteria for a bug?
20:09:03 <david-lyle> TravT: you looked to enjoy it so much
20:09:12 <david-lyle> I thought I'd emulate :)
20:09:18 <TravT> yeah, i think they finally fixed my network issues...
20:09:21 <tsufiev> tqtran, that's a list for notifying people to look already exsiting/approved bps
20:09:39 <tqtran> oh... well then, ignore my link earlier lmao
20:09:49 <tqtran> thanks for pointing that out tsufiev
20:09:52 <david-lyle> rc2 has some bugs that could potentially be included
20:10:03 <david-lyle> but nothing overly terrible
20:10:23 <david-lyle> the d-o-a bug is a separate release
20:10:36 <tsufiev> tqtran, well, at least I know it about integration tests bp, 2 others are about angular stuff - still terra incognita for me :/
20:10:46 <david-lyle> https://bugs.launchpad.net/horizon/+bugs?field.tag=liberty-rc2-potential is the list for RC-2
20:11:47 <david-lyle> #chair mrunge
20:11:48 <openstack> Current chairs: david-lyle mrunge
20:12:06 <david-lyle> if my internet dies, mrunge can close
20:12:08 <david-lyle> :)
20:12:18 <mrunge> will do david-lyle
20:12:41 <david-lyle> #link https://blueprints.launchpad.net/horizon/+spec/volumes-tagging
20:12:45 <TravT> maybe not important enough to be included, but we've got a couple more magic search widget fixes that i'd ask to be considered to be added to the list... for reasons i can explain.
20:13:16 <mrunge> TravT do you have links to bugs?
20:13:18 <david-lyle> I suppose we should talk through RC-2 first
20:13:44 <david-lyle> if the bug is not high or critical I'm against including it
20:13:58 <TravT> ok, i don't think we can call it high or critical at this point
20:15:13 <david-lyle> #link https://bugs.launchpad.net/horizon/+bug/1415712
20:15:13 <openstack> Launchpad bug 1415712 in OpenStack Dashboard (Horizon) ""Volumes" tab doesn't show up if cinder v1 isn't registered" [High,In progress] - Assigned to Akihiro Motoki (amotoki)
20:15:21 <david-lyle> would be good to get in if we can clean it up
20:15:44 <mrunge> that is true for kilo as well, imho
20:15:48 <david-lyle> v2 is purported to be stable in liberty, so it's conceivable folks would stop using v1
20:16:05 <mrunge> I mean the bug is in kilo, too
20:16:26 <david-lyle> but I think the patch needs a revisit IIRC
20:16:59 <david-lyle> the two subnetpool bugs would be nice since that's new functionality in Liberty
20:17:20 <david-lyle> #link https://bugs.launchpad.net/horizon/+bug/1498926
20:17:20 <openstack> Launchpad bug 1498926 in OpenStack Dashboard (Horizon) "Unable to create subnet from IPv6 subnetpool" [High,In progress] - Assigned to Frode Nordahl (fnordahl)
20:17:21 <david-lyle> and
20:17:31 <david-lyle> #link https://bugs.launchpad.net/horizon/+bug/1495191
20:17:31 <openstack> Launchpad bug 1495191 in OpenStack Dashboard (Horizon) "Create subnet from subnetpool fails in stable/liberty" [Medium,Fix committed] - Assigned to Frode Nordahl (fnordahl)
20:18:56 <mrunge> this is a backport to liberty?
20:19:39 <david-lyle> the functionality was added in late liberty, and should be backported yes
20:20:48 <mrunge> unfortunately, this fix is not covered by a test
20:23:19 <mrunge> I don't feel like we have the time to ask the contributor to provide a test case for this, squashing both commits in one for the backport
20:23:48 <david-lyle> RC-2 will happen next week
20:23:55 <david-lyle> so yeah, not a lot of time
20:24:07 <david-lyle> but some new functionality is just broken at this point
20:24:22 <tsufiev> I'd like to suggest another bugfix for rc2: https://bugs.launchpad.net/horizon/+bug/1286099
20:24:22 <openstack> Launchpad bug 1286099 in OpenStack Dashboard (Horizon) "UpdateProjectQuotas doesn't pay attention on disabled_quotas" [Low,In progress] - Assigned to Timur Sufiev (tsufiev-x)
20:25:13 <mrunge> Timur, I thought we'll only add high or critical bugs to rc2
20:25:41 <tsufiev> mrunge, yes, Matthias, right
20:26:01 <david-lyle> let's get that cleaned up in M
20:26:13 <david-lyle> agree would be nice, but
20:26:20 <tsufiev> okay, shall wait for M, procedures should be done as usual...
20:26:35 <mrunge> disabled quotas are still more or less broken
20:27:11 <david-lyle> any other issues people have come across that we haven't discussed that would be worth holding up a release for?
20:27:27 <david-lyle> personally I think the db is the only one that really qualifies
20:27:29 <mrunge> david-lyle, do we have a bug for translations?
20:27:46 <mrunge> or do we need a bug for translations?
20:27:51 <david-lyle> mrunge: not that I'm aware of
20:27:59 <david-lyle> but would be good for tracking
20:28:32 <mrunge> translations will be proposed automatically without adding the tracker bug though
20:29:06 <david-lyle> either way, and since the only factor for RC-2 is really translation, they likely won't get overlooked
20:29:13 <david-lyle> we can skip for now
20:29:39 <david-lyle> should we clean up some old bps in the remaining time ?
20:29:49 <mrunge> yes please!
20:30:15 <david-lyle> #topic https://blueprints.launchpad.net/horizon/+spec/volumes-tagging
20:31:05 <david-lyle> that one looks like it didn't even make it through the cinder side
20:31:46 <mrunge> scrap it
20:31:46 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/volumes-tagging marked obsolete
20:31:56 <mrunge> tightly connected: https://blueprints.launchpad.net/cinder/+spec/tag-volume
20:32:05 <mrunge> code is abandoned
20:32:10 <david-lyle> yes
20:32:16 <mrunge> and it's a blocker for the other bp
20:32:56 <mrunge> If anyone comes up with a new proposal, let's discuss that.
20:33:26 <david-lyle> #topic https://blueprints.launchpad.net/horizon/+spec/trove-vertica-cluster-support
20:33:44 <mrunge> tagging is obsolete david-lyle ?
20:33:55 <mrunge> just for reference...
20:34:13 <david-lyle> I marked the bp obsolete
20:34:23 <mrunge> ok, thanks.
20:34:37 <mrunge> #info https://blueprints.launchpad.net/cinder/+spec/tag-volume marked obsolete
20:34:56 <david-lyle> mrunge: I don't know about the cinder one
20:35:08 <tsufiev> Cluster and topology view - love these words
20:35:23 <mrunge> david-lyle, oh, I misunderstood you
20:35:43 <mrunge> david-lyle, I would mark that one as obsolete as well, if nobody objects
20:36:01 <david-lyle> well I typically don't mark cinder bps
20:36:05 <david-lyle> nor do I think I can
20:36:19 <david-lyle> permissions wise
20:36:22 <tsufiev> Unfortunately, don't understand what other things are about )
20:36:27 <mrunge> errr. my mistake
20:36:39 <david-lyle> vertica is a proprietary db
20:37:00 <david-lyle> I don't think we need to support a particular db backend in tree
20:37:00 <mrunge> #info https://blueprints.launchpad.net/cinder/+spec/tag-volume undecided.
20:37:10 <mrunge> we should not
20:37:27 <david-lyle> that should be plugin content
20:37:40 <mrunge> it's the same as adding vendor specific driver support
20:38:01 <TravT> i guess the question is, do we have proper support to enable that then?
20:38:38 <mrunge> uhm, isn't trove just moved to contrib to be removed in mitaka cycle?
20:38:56 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/trove-vertica-cluster-support marked obsolete
20:39:02 <david-lyle> I left a note in the bo
20:39:04 <david-lyle> *bp
20:39:11 <mrunge> but TravT s question is valid.
20:39:17 <david-lyle> mrunge: most likely, need to discuss with Trove team
20:39:28 <doug-fish> I'd say if we don't have the needed support, adding it is a fair request
20:39:35 <mrunge> do we have enough support for plugins...
20:39:37 <david-lyle> TravT: I don't see how we don't
20:39:48 <TravT> me neither, but i just don't know
20:39:56 <mrunge> doug-fish, or we need to fix that first
20:40:02 <lhcheng_> TravT: interesting question, for the vertica backend, they need to inject fields and logic to existing forms.
20:40:06 <TravT> i guess if all of trove is in its own repo, then there shouldn't be a problem
20:40:12 <tsufiev> TravT: reimplementing d3 topology graph in every plugin would be a shame
20:40:31 <david-lyle> I think these are unique views
20:40:56 <david-lyle> d3 is the tool, topology considerations are unique to the content
20:41:23 <tsufiev> Challenge accepted )
20:41:44 <TravT> i suppose that if there are specific things they need in the horizon framework, that should be a separate bug or blueprint.
20:41:59 <david-lyle> TravT: I agree
20:42:01 <lhcheng_> TravT: making sure we have the plugin support for that use case would be useful for other deployments
20:42:04 <lhcheng_> ++
20:42:42 <TravT> i'll add that as comment on the BP
20:42:56 <david-lyle> but again I'm not sure how much more commonality there is than at the d3 level
20:43:41 <david-lyle> but I suppose abstract call-outs etc, could be generalized
20:43:58 <david-lyle> #topic https://blueprints.launchpad.net/horizon/+spec/trove-support-cluster-grow-shrink
20:44:12 <tsufiev> david-lyle: I was meaning angular topology graph https://review.openstack.org/#/c/199063/
20:44:33 <tsufiev> But agree, their use cases may be very different
20:45:05 <david-lyle> tsufiev: I won't argue there's potential, but I wouldn't over invest unless we're pretty sure there's value
20:45:33 <tsufiev> Sure
20:45:37 <david-lyle> I think the trove one is a yes, as long as trove support is in horizon
20:45:46 <david-lyle> grow/shrink that is
20:46:10 <david-lyle> any argument?
20:46:34 <mrunge> I would say: yes. accept
20:46:47 <mrunge> as long as trove support is in
20:47:21 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/trove-support-cluster-grow-shrink approved
20:47:34 <mrunge> I've had the request of redis support in horizon
20:47:50 <mrunge> and that's a dependent patch
20:48:53 <david-lyle> so stepping back a sec
20:49:33 <david-lyle> I think I want to have the conversation with trove first
20:49:43 <david-lyle> before reviewing the list of trove bps
20:49:51 <mrunge> makes sense
20:49:55 <TravT> +1
20:50:01 <david-lyle> because I think the vertica one makes perfect sense for them
20:50:04 <david-lyle> just not us
20:50:26 <TravT> hey all just FYI that I have to leave for an appointment right now.  thanks!
20:50:36 <mrunge> thanks TravT
20:50:45 <david-lyle> #action david-lyle talk to Trove about in-tree vs plugin
20:51:10 <david-lyle> thanks TravT
20:51:25 <david-lyle> #topic https://blueprints.launchpad.net/horizon/+spec/show-all-floating-ips
20:51:51 <mrunge> ugh.
20:51:55 <david-lyle> :)
20:51:59 <mrunge> not much content here
20:52:25 <david-lyle> so list all active floating IPs in the cloud?
20:52:25 <mrunge> I've heard this as an operator feedback more than once
20:52:43 <mrunge> yes, in best case, include connected vms
20:53:19 <david-lyle> how big is the list before unusable?
20:53:20 <lhcheng_> related to Floating IP,  Cern/Yahoo had to manually hide Sec Group and Floating IP in horizon through manual patches.
20:53:40 <david-lyle> because of nova net?
20:54:24 <mrunge> those patches should be avoidable with the finer granular plugin system
20:54:28 <david-lyle> well I think it's certainly a neutron only issue for listing all floating IPs
20:54:37 <mrunge> yes, probably
20:54:40 <lhcheng_> Isn't Floating IP more used for public cloud consumer?
20:55:06 <mrunge> uhm, and if you want HA?
20:55:34 <mrunge> not sure, if HA is possible with nova net
20:55:40 <david-lyle> it's not
20:56:19 * david-lyle says authoritatively, but is only fairly sure
20:56:45 <mrunge> the question remains, how many fips to show here, before it becomes unusable
20:57:01 <tsufiev> mrunge: pagination?
20:57:03 <lhcheng_> david-lyle: could be because of nova net, but we have a different system for managing networks
20:57:29 <mrunge> tsufiev, not sure if that's supported here
20:57:50 <david-lyle> lhcheng_: are FIPs a configuration option in neutron, or always on?
20:58:10 <tsufiev> mrunge: I think it' supported by neutron, not by nova-net
20:58:35 <david-lyle> I'd like to see this fleshed out more before moving forward
20:58:37 <mrunge> I think we could restrict this to neutron
20:59:25 <mrunge> ok, thanks
20:59:31 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/show-all-floating-ips marked discussion
20:59:34 * tsufiev curious how long nova-net should be supported by horizon
20:59:46 <david-lyle> tsufiev: as long as it is in nova
20:59:49 <lhcheng_> mrunge: yeah, finer grained plugin system should help.
21:00:05 <mrunge> tsufiev, as long as the used api is the same?
21:00:16 <lhcheng_> mrunge: have to go back to drawing board what more extension point we need to have.
21:00:36 <mrunge> lhcheng_, extension point for what?
21:00:58 <tsufiev> We did a study regarding pagination support, neutron looks much better
21:01:06 <mrunge> lhcheng_, disabling fips panel?
21:01:51 <lhcheng_> mrunge: not just disabling fips panel, some fips/sec group code are embedded in other panels
21:02:18 <mrunge> right
21:02:53 <mrunge> lhcheng_, adding checks around those codes should help
21:03:07 <mrunge> time's up?
21:03:31 <lhcheng_> mrunge: yeah, could work. worth trying out.
21:03:47 <lhcheng_> mrunge: you can end the meeting :P
21:03:52 <mrunge> #char david-ly_
21:04:00 <mrunge> #endmeeting