20:02:26 <david-lyle_> #startmeeting horizondrivers
20:02:27 <openstack> Meeting started Wed Oct 14 20:02:26 2015 UTC and is due to finish in 60 minutes.  The chair is david-lyle_. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:32 <openstack> The meeting name has been set to 'horizondrivers'
20:02:36 <robcresswell> o/
20:02:41 <david-lyle_> #chair david-lyle
20:02:42 <openstack> Current chairs: david-lyle david-lyle_
20:02:46 <david-lyle_> #chair robcresswell
20:02:47 <mrunge> o/
20:02:48 <openstack> Current chairs: david-lyle david-lyle_ robcresswell
20:02:57 <robcresswell> In case of internet?
20:03:03 <david-lyle_> yeah
20:03:19 <david-lyle_> coming from two computers now, hopefully it won't be necessary
20:03:33 <robcresswell> haha
20:03:40 <mrunge> two handed chatting?
20:03:42 <TravT> o/
20:03:49 <robcresswell> seems he spoke too soon
20:03:52 <david-lyle_> trying to find someone to agree with me
20:03:52 <TravT> david-lyle_: i feel your pain!
20:03:59 <david-lyle_> :)
20:04:12 <david-lyle_> General things, briefly
20:04:28 <david-lyle_> RC-2 is our final RC and will be the release for Liberty tomorrow
20:04:41 <TravT> |o?
20:04:55 <tqtran> [=_=]/3
20:04:59 <david-lyle_> Summit sessions are finalizing for Horizon
20:05:06 <TravT> i think i just accidentally invented a new emoticon
20:05:16 <TravT> (I have a question)
20:05:21 <david-lyle_> I like the hook
20:05:27 <david-lyle_> TravT, shoot
20:05:57 <TravT> oh sorry, no i don't have any question... was a pure accidental type
20:06:15 <david-lyle_> then yes
20:06:19 * TravT too many energy drinks, getting a little twitchy
20:06:38 <mrunge> you have a keyboard shortcut for: I have a question?
20:06:45 <robcresswell> haha
20:06:52 <robcresswell> The most uncertain person ever
20:07:00 * mrunge shuts up now.
20:07:35 <david-lyle> #link https://etherpad.openstack.org/p/horizon-mitaka-summit
20:07:39 <david-lyle> voice any concerns about the proposed schedule at the bottom by tomorrow
20:07:42 <david-lyle> as I will be publishing those
20:08:29 <david-lyle> those are the general items
20:08:36 <TravT> The angular fight club one will be tough for me to make at the 5:30 proposed time
20:08:38 <TravT> on Wed
20:09:11 <david-lyle> also fishbowl with ceilometer on Wed at 12:05 re: sorry state of ceilometer support in Horizon and what both teams can do about it
20:09:21 <mrunge> great
20:09:40 <david-lyle> TravT: other more pressing concerns at that time?
20:10:00 <TravT> Just that the main conference searchlight presentation I have ends at 5:20
20:10:19 <david-lyle> run ?
20:10:21 <david-lyle> jk
20:10:34 <TravT> and might be hard to rush over depending on if there are people who want to ask questions / talk after it
20:10:47 <TravT> i think it is in a separate building
20:10:51 <david-lyle> is hurgleburgler coming to Tokyo?
20:10:54 <TravT> yes
20:10:57 <TravT> :)
20:11:02 <david-lyle> ok cool
20:11:12 <david-lyle> theming wouldn't make much sense otherwise
20:11:29 <robcresswell> The one person in Horizon who understands out CSS right now.
20:11:32 <robcresswell> our*
20:11:33 <mrunge> will the fight club cover, why angular is so sloow?
20:11:37 <david-lyle> could swap theming/UX and 5:30 session
20:11:49 <david-lyle> mrunge: yes
20:11:53 <david-lyle> it better
20:11:54 <mrunge> awesome
20:12:16 <david-lyle> it's about adding more bottlenecks
20:12:38 <mrunge> do we have a list of bottlenecks to add?
20:12:56 <david-lyle> that's the slow down reason
20:12:59 <TravT> mrunge: that'd be great to bring information on "slow" with perf tests and analysis to a fight club
20:13:17 <mrunge> TravT, I added measurements to reviews
20:13:33 <TravT> oh cool. i hadn't seen them...
20:13:41 <TravT> but still bring them!
20:13:45 <david-lyle> we've gone from one set of API calls to services and added on top a large series of API requests to horizon over an even slower network
20:13:48 <mrunge> will do
20:14:20 <mrunge> even on a single machine with fast interconnection, it is slower
20:14:21 <david-lyle> anyway session fodder
20:14:25 <mrunge> yupp
20:14:38 <david-lyle> still over 2x the API requests
20:14:43 <david-lyle> ok, moving on
20:14:53 <david-lyle> or back to scheduling
20:15:52 <david-lyle> will move either theming or keystone into Wed 5:30 and shuffle the other working sessions down a slot
20:16:00 <TravT> thanks, david-lyle
20:16:06 <david-lyle> preferences on which?
20:16:30 <TravT> mine would be keystone...
20:16:38 <TravT> to go to wed
20:16:52 <TravT> but you, lhcheng, schedules for that would be key.
20:16:57 <david-lyle> doug-fish, lhcheng, ok with that?
20:17:12 <david-lyle> I have the master schedule here somewhere
20:18:00 <david-lyle> keystone PTL talk at that time, no keystone session
20:18:05 <david-lyle> lhcheng: is that an issue
20:18:06 <david-lyle> ?
20:18:35 <david-lyle> will track down later
20:18:42 <lhcheng> david-lyle: wed 5:30?
20:18:45 <david-lyle> yeah
20:19:17 <david-lyle> there seems to be a main summit keystone talk at that time, not keystone design session
20:19:39 <david-lyle> ok to talk keystone in horizon at that time?
20:20:16 <lhcheng> yeah, there is keystone fed and OSC design session at that time
20:20:29 <TravT> sounds like theming is better then
20:20:34 <david-lyle> ok theming it is
20:20:48 <lhcheng> yup, thanks for asking
20:20:54 <mrunge> yes, makes sense
20:21:04 <mrunge> but both topics are interesting...
20:22:12 <david-lyle> hurgleburgler: ok?
20:22:25 <david-lyle> going twice?
20:22:32 <hurgleburgler> will TravT not be able to make it?
20:22:48 <TravT> will probably at least be a bit late.
20:23:01 <hurgleburgler> k, then its alright with me
20:23:44 <r1chardj0n3s> o/
20:23:52 <david-lyle> ok moved
20:23:53 <tsufiev> o/
20:23:54 <TravT> r1chardj0n3s: o/
20:23:56 <david-lyle> re-review
20:24:19 <david-lyle> now onto bps
20:24:26 <david-lyle> unless other concerns?
20:24:58 <robcresswell> I put a possible item on the agenda. Wondered if there was interest in discussing feature branching before the summit.
20:25:10 <TravT> robcresswell: agenda link?
20:25:28 <david-lyle> #link https://wiki.openstack.org/wiki/Meetings/HorizonDrivers#Agenda_for_October_14_2000_UTC
20:25:42 <david-lyle> a lot of that looks like summit topics
20:25:49 <robcresswell> heh, beat me to it. Thanks david-lyle
20:26:16 <robcresswell> The bps themselves are just angular bps as more of those folk around now
20:26:26 <david-lyle> but I'm open to starting the conversation now
20:26:42 <robcresswell> Cool!
20:27:10 <robcresswell> So the idea floated around was having a feature branch with more relaxed approval for a couple of the angular panels to get patterns and work together quicker.
20:27:27 <robcresswell> There are quite a number of people in HP/ Thoughtworks/ IBM being bottlenecked by our current process.
20:27:40 <robcresswell> And I'm worried by the idea of a repo split that has been mentioned as well.
20:27:59 <tqtran> I think we should also start the process for creating a feature branch, whether we end up using it or not. Streamline the process so that people arent waiting around an additional week or two until we can get their work onto the feature branch
20:28:09 <robcresswell> IMO, if community demands faster pace, we should meet that in a manageable way, which in my mind means feature branch.
20:28:45 <TravT> #link https://openstack.nimeyo.com/61606/openstack-horizon-suggestions-handling-refactors-future?qa_q=Suggestions+for+handling+new+panels&show=61606#q61606
20:28:53 <david-lyle> my concern is we're being inundated by changes that are very low priority if desirable at all
20:29:21 <david-lyle> while we're still trying to figure out a pattern
20:29:46 <david-lyle> feature branch is fine to try and arrive at that pattern
20:29:49 <robcresswell> david-lyle: Yes. The scope needs to be contained to 2/3 panels, not dozens.
20:30:07 <david-lyle> but things like system info holds no real value
20:30:23 <robcresswell> I would like us to have a feature branch for say, Users and Images to sort themselves out, then merge back later in M.
20:30:35 <david-lyle> it's a very seldom used page, duplicating in angular is not really necessary, especially at this point
20:30:49 <david-lyle> and provides no real advantage
20:31:12 <david-lyle> angular should be used to do the things it does well that django does not
20:31:31 <david-lyle> a static list of services is not dynamic, why treat it as such
20:32:04 * david-lyle try's to veer back from this tangent
20:32:34 <david-lyle> I'm fine with a feature branch for those items
20:32:38 <tqtran> the idea is, lets focus on 2-3 panels, have a feature branch for it, and have metrics that we can measure and a definitive date that we merge back into master
20:32:51 <robcresswell> Excellent.
20:32:53 <tqtran> whether it i perfect or not
20:33:30 <david-lyle> nothing's going to be perfect
20:33:43 <robcresswell> Right
20:33:44 <TravT> yeah, if we can't reach a milestone point for merging it back as "good enough", then we'll have to go to the new repo idea.
20:33:48 <tqtran> right, so for me, im all for the feature branch if those two conditions are met
20:33:49 <r1chardj0n3s> so the feature branch will have "more relaxed approval" does that mean we have to approve the merge back to master, ie. one ginormeous patch?
20:34:15 <TravT> r1chardj0n3s: i would think we would cherry pick some patches out
20:34:21 <david-lyle> by more relaxed, it means not a full replacement
20:34:21 <r1chardj0n3s> ok
20:34:26 <david-lyle> it's addititive
20:34:27 <TravT> maybe not "technicallly" cherry-pick
20:34:34 <TravT> more figuratively
20:35:00 <david-lyle> yes, new patches based on feature branch work
20:35:29 <david-lyle> but the idea is that those reviewing on the feature branch are comfortable with that code going into master
20:36:01 <TravT> a little clarification on that point... perhaps...
20:36:09 <david-lyle> for pure exploration, I suggest other options
20:36:15 <TravT> it can go onto feature branch to enable better collaboration
20:36:33 <TravT> but before going to master, it would be vetted with full tests, etc.
20:36:51 <david-lyle> those tests should be in the feature branch by the end
20:36:56 <TravT> agreed...
20:37:08 <robcresswell> I think you're defensively agreeing here guys :)
20:37:16 <TravT> david-lyle: other options?
20:37:23 <mrunge> should we squash patches then before merging back?
20:37:27 <tsufiev> TravT: and integration tests :)
20:37:32 <david-lyle> github?
20:37:43 <david-lyle> private repo?
20:38:16 <r1chardj0n3s> feature branches like http://docs.openstack.org/infra/manual/drivers.html ?
20:38:41 <david-lyle> r1chardj0n3s: yes
20:39:08 <david-lyle> although some projects have said it's easier to construct new patches from the content on the feature branch than doing a merge commit
20:39:18 <david-lyle> I think both methods have been used
20:39:18 <TravT> what do you mean by private repo?
20:39:19 <r1chardj0n3s> yep
20:39:39 <david-lyle> gerrit is not the only git
20:40:06 <david-lyle> why have all the check jobs run and fail on something you're not ready to propose?
20:40:42 <david-lyle> if you're looking for feedback, then fine
20:41:09 <david-lyle> I just think our signal to noise ratio is out of whack right now
20:41:25 <TravT> so private repo, do you mean a fork on github?
20:41:39 <tqtran> i think you guys are talking pass each other
20:41:43 <david-lyle> well that's more public
20:41:47 <mrunge> maybe gerrithub setup?
20:42:04 <mrunge> that would integrate a gerrit and a github repository
20:42:18 <mrunge> ... i.e a more upstream-like setup
20:42:25 <mrunge> instead of pull request
20:42:34 <david-lyle> I was thinking git init
20:42:36 <david-lyle> locally
20:43:07 <robcresswell> I don't think we need an external repo for the work we're suggesting. It's 2/3 panels in a feature branch, with slightly relaxed reviewing, so those being bottlenecked can collab better.
20:43:18 <david-lyle> robcresswell: not for that no
20:43:32 <robcresswell> Cool, the off-topic had me worried
20:43:50 <david-lyle> I just think we're getting a lot of half-thought through patches up
20:44:15 <david-lyle> it's ok to think them through further then propose, is all I'm suggesting
20:44:27 <david-lyle> if you're wanting to collaborate, then by all means
20:44:50 <robcresswell> awesome. So what's the next step for creating the branch?
20:44:53 * david-lyle hasn't checked the depth in pages of our reviews in a while and is scared to do so
20:45:07 <david-lyle> talking to relmgmt
20:45:19 <tqtran> we should start the process imo
20:45:29 <tqtran> doesnt hurt to have one ready when we decide to go with feature branch
20:45:36 <david-lyle> ok, will start the conversation
20:45:50 <david-lyle> #action david-lyle get that branch
20:45:50 <robcresswell> I agree, would be best to start that process sooner than later
20:45:59 <robcresswell> Woop, thanks david-lyle
20:46:27 <TravT> that will be a good process item out of the way.
20:46:51 <TravT> I'm quite certain david's point on the number of patchsets going through zuul was missed...
20:47:12 <TravT> i don't think feature branch changes that, but it should reduce rebases at least.
20:47:31 <david-lyle> sure, and if we're working collaboratively, it's ok
20:47:46 <david-lyle> zuul scales, most of the time
20:48:04 <tqtran> until end od release cycle lol
20:48:17 <david-lyle> exactly, most of the time
20:48:37 <robcresswell> Its mainly just that you often see people pushing test patches etc, using gerrit as a backup tool, which is just extra zuul load. People should be a little mindful of infra, thats all.
20:48:56 <TravT> so, next we have to agree on actual panels and a milestone targeting merge back...
20:49:08 <r1chardj0n3s> fight club!
20:49:09 <TravT> feature branch can't just be the new purgatory...
20:49:40 <tsufiev> robcresswell: people would be happy to be able to tell Zuul just relax
20:49:41 <tqtran> and a date as well....
20:49:41 <david-lyle> no it's not, but a deadline is a guideline
20:50:46 <TravT> i wish we could have a wip on patches that stayed persistent and could also have one to say (don't test)...
20:50:46 <robcresswell> The panels is down to what angular devs are prepared to work on. Something like Users and Images, targeted for OpenStack M-3 (End of Fed/ Early March)
20:51:28 <TravT> m3 is too late.
20:51:31 <robcresswell> Release schedule if you're interested https://wiki.openstack.org/wiki/Mitaka_Release_Schedule
20:51:33 <david-lyle> I think common elements and API changes can come out when they are ready too
20:51:58 <tsufiev> btw, is anybody interested in writing integration tests for angular panels?
20:52:03 <robcresswell> TravT: It was just an arbitrary selection
20:52:19 <TravT> i'd like to consider searchlight in the mix... although i'm not sure that is better or not for me at this point.
20:52:19 <robcresswell> M-2 is mid January
20:52:42 <TravT> it probably is...
20:52:46 <robcresswell> TravT: That panel was awesome. If there is available devs, a third panel should be doable. But I would not go beyond that.
20:52:53 <robcresswell> Otherwise scope is unmanageable.
20:53:09 <TravT> the reason i'd like to consider it
20:53:28 <TravT> is i want to be able to inject searchlight search service into angular panels
20:53:36 <TravT> and for it to be able to inject actions from other panels into it
20:53:44 <tqtran> tsufiev: i would be, but im hung up on the users work atm. i want to get around to it though
20:54:32 <TravT> this probably won't make sense until i show people at the summit
20:55:03 <tqtran> gosh, after the summit people are going to go on vacations and holidays, it might be difficult
20:55:21 <tsufiev> tqtran: it'd be really good if someone volunteered, I'm a bit worried about integration coverage decline when we switch to angular panels from legacy ones
20:55:21 <TravT> i'm planning on sleeping
20:55:32 <robcresswell> TravT: No time for that
20:55:40 * david-lyle doesn't believe TravT
20:55:58 <tqtran> tsufiev: i agree fully, we should sit down and talk at the summit. im sure sqchen would be interested as well
20:56:01 * TravT david-lyle seems to know me
20:56:13 <tsufiev> tqtran: sure, will do
20:56:18 <TravT> matt-borland will be there...
20:56:30 <TravT> and the thoughtworks lead
20:56:30 <tqtran> and matt-borland, and anyone else hahaha
20:56:44 <TravT> maybe we can get some effort directed on that
20:56:49 <tqtran> just a brainstorm talk and then we will bring it up to the table and share
20:56:50 <r1chardj0n3s> tqtran: actually, I'm moving house the day after I get back from the summit; I clearly do vacation wrong ;)
20:57:05 <tqtran> r1chardj0n3s: omg lol yes definitely
20:57:20 <robcresswell> I'm taking the week off to wander round Japan :D
20:57:25 <tqtran> me too!
20:57:27 <robcresswell> post-summit
20:57:27 <TravT> so, should one of the working sessions be dedicated to testing?
20:57:43 <david-lyle> maybe part of the collab meetup
20:57:43 <TravT> maybe even r1chardj0n3s and tsufiev giving a talk on it?
20:57:58 <hurgleburgler> +1
20:57:59 <TravT> educational kinda thing?
20:57:59 <tsufiev> Hmmm
20:58:02 <david-lyle> we don't have topics work items penciled in
20:58:36 <r1chardj0n3s> I guess that could be done. What's the missing info in people's testing knowledge?
20:58:47 <tqtran> try everything lol jk
20:58:49 <david-lyle> moar tests
20:59:13 <tsufiev> TravT: I could prepare some integration tests how to
20:59:13 <TravT> r1chardj0n3s: how do you describe what you don't know?
20:59:14 <david-lyle> an integration testing strategy around angular content?
20:59:18 <tqtran> those mocks sean mentioned are starting to sound real nice :P
20:59:24 <TravT> i mean, i don't know what i don't know
20:59:35 <david-lyle> more than you know
20:59:43 <robcresswell> tqtran: Both of the mock bps are on the agenda for this meeting lol :p
20:59:49 <tqtran> not that you know
20:59:58 <TravT> what are we talking about again?
21:00:01 <tsufiev> david-lyle: I'm definitely not in the angular party :/
21:00:12 * TravT trying to make jokes, not sure if they are coming across in irc
21:00:15 <david-lyle> party?
21:00:22 <tqtran> tsufiev: i have prepared an invitation for you already, its coming....
21:00:31 <robcresswell> This is getting very surreal
21:00:51 <tsufiev> Haha, it' say bad English
21:00:59 <david-lyle> well I'm glad we had this time together
21:01:02 <david-lyle> :-D
21:01:04 <tsufiev> I meant 'a group of people'
21:01:11 <TravT> tsufiev: what are you saying?
21:01:16 <david-lyle> I thought political party
21:01:20 <tsufiev> Yep
21:01:26 <robcresswell> I have no idea what's going on
21:01:30 <david-lyle> time's up
21:01:35 <david-lyle> thanks everyone
21:01:38 <david-lyle> #nedmeeting
21:01:43 <robcresswell> loool
21:01:43 <david-lyle> #endmeeting