20:00:20 <david-lyle> #startmeeting HorizonDrivers
20:00:21 <openstack> Meeting started Wed Nov 25 20:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:25 <openstack> The meeting name has been set to 'horizondrivers'
20:00:54 <mrunge> o/
20:01:32 <tsufiev> o/
20:02:03 <tsufiev> Is it already thanksgiving day in us?
20:02:21 <david-lyle> looking at the rest of the meeting rooms seems like everyone cancelled meetings today
20:02:28 <david-lyle> maybe I should have done that too
20:02:43 <tsufiev> :) shortest meeting ever
20:02:43 <mrunge> maybe yeah
20:03:10 <david-lyle> do either of you have anything to discuss that we didn't hit this morning?
20:03:25 <mrunge> maybe quite quickly: did we decide about mid-cycle yet?
20:03:48 <david-lyle> I don't have it pinned down
20:03:55 <mrunge> ok
20:04:05 <david-lyle> I can post a poll an narrow down dates
20:04:18 <mrunge> that'd be helpful, yes
20:04:30 <david-lyle> alright
20:04:33 <mrunge> or if we could narrow locations down?
20:04:44 <david-lyle> #action david-lyle post midcycle poll
20:05:00 <mrunge> that'd be helpful for getting esta done
20:05:12 <tsufiev> +1
20:05:44 <david-lyle> ok dates and locations in the poll
20:05:56 <mrunge> right, thank you
20:06:21 <mrunge> well, if we don't have a location outside US, I'll have to do ESTA anyways
20:08:30 <david-lyle> any thing else to discuss?
20:08:43 <tsufiev> nope
20:09:34 <david-lyle> ok, I'll call it. Sorry for the false alarm
20:09:57 <david-lyle> next week we won't have drivers meeting, only horizon meeting at 2000
20:10:11 <david-lyle> will send email to list about that too
20:10:14 <robcresswell> Oh okay
20:10:23 <robcresswell> Will drivers meating cease?
20:10:26 <robcresswell> meeting*
20:10:29 <mrunge> ok, thank you david-lyle
20:10:35 <david-lyle> isn't that what we decided last time?
20:10:37 <tsufiev> Are we going to cancel 12:00 times lot?
20:10:49 <david-lyle> only drivers at 2000 alternating weeks?
20:11:10 <robcresswell> Ah cool sorry I misunderstood
20:11:18 <david-lyle> or is my lack of short/mid/long term memory showing
20:11:28 <robcresswell> No, I remember that
20:11:38 <robcresswell> I'm fine with that
20:11:48 <david-lyle> ok
20:11:49 <mrunge> yeah
20:11:58 <david-lyle> thanks again robcresswell for organizing the bug day
20:12:13 <mrunge> yes! robcresswell that was really helpful
20:12:15 <robcresswell> No problem. I'm thinking about another post-christmas.
20:12:26 <mrunge> yes please!
20:12:36 <tsufiev> robcresswell: let's do it once a month
20:12:39 <david-lyle> robcresswell: that would be great
20:13:00 <robcresswell> tsufiev: Something around that time scale would be nice
20:13:12 <robcresswell> every 4-6 weeks, working around holidays, summits etc.
20:13:15 <mrunge> oh, btw, when setting a bug invalid, please remove assignee as well
20:13:26 <mrunge> otherwise tickets won't get removed
20:13:28 <robcresswell> Oh, sure thing.
20:13:35 <david-lyle> oh, didn't know that
20:13:48 <david-lyle> other thing, I forgot tags for a while
20:13:51 <david-lyle> :P
20:14:01 <robcresswell> I added i18n and low-hanging-fruit to a few
20:14:16 <robcresswell> low-hanging-fruit bugs get picked up in minutes, two of them already have patches up.
20:14:18 <david-lyle> there is a topology-view tag
20:14:22 <mrunge> when a bug will get removed, you'll see a note on the top: "This bug will be removed in 60 days (see why)"
20:14:26 <david-lyle> which I assigned a couple to
20:14:31 <robcresswell> david-lyle: Thats useful. I'll look into those.
20:14:47 * david-lyle didn't realize we had so many tags
20:14:59 <robcresswell> Whats the horizon-core tag for?
20:15:18 <tsufiev> robcresswell: horizon library?
20:15:19 <david-lyle> core table dashboard tabs panel action code
20:15:25 <robcresswell> We have a few tags that could be dropped, like icehouse/juno backport
20:15:27 <mrunge> I think that was used to tag something for horizon part
20:15:31 <robcresswell> Ah, I see
20:15:32 <mrunge> unlike dashboard part
20:15:50 <david-lyle> yes what the other said
20:15:56 <david-lyle> *others
20:16:09 <mrunge> ah yes, I think we can drop those version tags, no?
20:16:17 <robcresswell> I think we should rename this meeting to EU-and-david, too.
20:16:18 <robcresswell> :p
20:16:28 <david-lyle> want to clean those up now?
20:16:31 <tsufiev> Do you that there is a special UI in launchpad for managing tags?
20:16:39 <david-lyle> accessibility 2 tag?
20:16:42 <tsufiev> *know
20:16:46 <mrunge> angular tag?
20:17:03 <robcresswell> tsufiev: Yes, there's an "edit official tags" button
20:17:05 <mrunge> django tag
20:17:11 <david-lyle> ah the 2 is number
20:17:17 * tsufiev found it week ago
20:17:29 <david-lyle> django 1.7 is going
20:17:48 <robcresswell> liberty-rc-potential can go
20:18:14 <robcresswell> swift... just assign those all to r1chardj0n3s and neillc
20:18:32 <tsufiev> Haha
20:18:40 <david-lyle> ok purged a couple tags
20:18:57 <tsufiev> Not convenient, others may want to filter just swift bugs
20:19:18 <tsufiev> And only richard's
20:19:29 <tsufiev> *not
20:20:17 <robcresswell> So... blueprints?
20:20:36 <david-lyle> I guess we have quorum if people are interested
20:20:49 <david-lyle> robcresswell: without you we were going to quit :P
20:21:04 <mrunge> yupp
20:21:07 <robcresswell> Quit? Pfft
20:21:24 <mrunge> or move to somewhere else?
20:22:32 <robcresswell> Heh, I feel bad now since its mainly EU folk and must be 9pm+ for mrunge anf tsufiev
20:22:42 <robcresswell> Perhaps we should call it :)
20:23:11 <mrunge> hahaha
20:23:42 <mrunge> let's drop at least one blueprint
20:23:56 <david-lyle> all 5 of the latest bps are prioritized
20:23:58 <tsufiev> robcresswell: do you suggest end the meeting? I agree that it'd be better to postpone bp stuff until US folks join
20:24:09 <robcresswell> tsufiev: Well, this is their tz
20:24:21 <robcresswell> Cant' force them to join the meeting, but they should be here.
20:24:39 <david-lyle> likely travel day in the UX
20:24:41 <david-lyle> *US
20:24:49 <robcresswell> Ohhh
20:24:54 <david-lyle> I forget because I don't travel for holidays
20:25:03 <robcresswell> Makes sense
20:25:07 <tsufiev> Btw, we're making good progress so far with keystone ldap users and horizon
20:25:25 <mrunge> you mean, with pagination?
20:25:28 <robcresswell> Orly? I had thought that effort had died
20:25:29 <david-lyle> filtering?
20:25:32 <tsufiev> Hehe
20:25:43 <tsufiev> david-lyle: filtering + limits
20:25:53 <david-lyle> excellent
20:25:58 <mrunge> great, yes!
20:25:59 <robcresswell> Was this the suggestion with a blank table, that requires a filter? and that for results over 500 (?) we ask for a better filter
20:26:11 <robcresswell> and less than 500 we can just show them all anyway, or something.
20:26:16 <david-lyle> I think I killed a bug semi-related that you may have been tied to tsufiev
20:26:45 <tsufiev> My colleague is working on that internally, he says that Keystone seems to work fine with leap limits, now it's time to fix horizon
20:26:59 <tsufiev> LDAP limits
20:27:19 <mrunge> interesting
20:27:25 <tsufiev> This autoreplacement is killing me
20:27:57 <tsufiev> david-lyle: what is the bug?
20:28:12 * david-lyle was afraid you'd ask
20:28:17 <robcresswell> haha
20:28:19 <tsufiev> :)
20:28:35 <david-lyle> will have to dig
20:29:15 <tsufiev> Ok, if I haven't noticed so far, it must have been unimportant :)
20:29:36 <mrunge> users will report again
20:30:03 <robcresswell> Btw, at the summit we discussed removing admin overview, and changing how admin panels show data
20:30:23 <david-lyle> tsufiev: https://bugs.launchpad.net/horizon/+bug/1496045
20:30:23 <openstack> Launchpad bug 1496045 in OpenStack Dashboard (Horizon) "Horizon cannot display >1.5K users from LDAP" [Undecided,Won't fix]
20:30:50 <david-lyle> I'm not sure the bug is invalid, but the targeted approach was wrong
20:31:09 <david-lyle> which is what I put in my comment
20:31:17 <tsufiev> david-lyle: no worries, I would do the same
20:31:58 <tsufiev> We still have a bp, it's unapproved though... Should check the the details again
20:32:06 <david-lyle> link that
20:32:20 <david-lyle> if it's ready for review
20:32:36 <tsufiev> No, I think it' snot
20:32:48 <david-lyle> ok
20:32:49 <tsufiev> Will do it at next meeting
20:34:17 <david-lyle> killed two lbaas v2 bps
20:34:31 <david-lyle> #link https://blueprints.launchpad.net/horizon/+spec/lbaas-v2-panel marked obsolete
20:34:55 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/lbaas-v2-api marked obsolete
20:35:06 <david-lyle> all in a plugin now
20:35:34 <mrunge> did we remove trove now?
20:35:42 <david-lyle> mrunge: not yet
20:35:52 <david-lyle> I have patches for sahara started, trove would go next
20:35:56 <mrunge> there are lots of trove related blueprints
20:36:00 <david-lyle> once the pattern is better established
20:36:04 <mrunge> agreed
20:36:13 <david-lyle> I have a few things to work out on sahara
20:36:32 <david-lyle> even more involved than I thought
20:37:05 <david-lyle> a plugin tutorial is going to be huge if we document all the pieces
20:37:38 <david-lyle> which is why I'm having difficulty churning such a thing out
20:38:21 <robcresswell> Doc all the pieces? As in, setting up a plugin? Or writing the content?
20:38:50 <david-lyle> writing about testing and apis and integration testing and localization and structure
20:38:52 <mrunge> ugh, reminds me to document how to package a plugin
20:39:22 <tsufiev> I could take the integration testing docs part
20:39:24 <robcresswell> Is a lot of that not covered by existing docs?
20:39:34 <robcresswell> Or *should* be covered
20:39:49 <david-lyle> I think
20:39:51 <robcresswell> A lot of that doesnt seem like it would be horizon-plugin-specific
20:39:56 <david-lyle> that the basics should be covered
20:40:05 <tsufiev> Since I'm going to sort it out for Sahara
20:40:10 <david-lyle> the rest is going to be by example in existing plugins
20:41:28 * tsufiev suggest to delegate different parts to different people
20:41:41 <david-lyle> yeah, I think basics first
20:41:45 <david-lyle> fill in more later
20:41:51 <mrunge> spread the load, yes
20:42:13 <david-lyle> updating thai's patch some, then we can build off that
20:42:16 <mrunge> but, my experience with packaging docs was: spreading to much doesn't work well
20:42:19 <robcresswell> At some point we'll have to think about properly organising all the doc content thats been added in the past ~6 months
20:43:10 <david-lyle> robcresswell: yes, there are a bunch of bits and no flow now
20:43:16 <mrunge> robcresswell, I'd say: organize/rework all docs
20:43:29 <david-lyle> could use a major overhaul
20:43:34 <robcresswell> Yeah, I've been more concerned with having content written first, then move it around later.
20:43:48 <david-lyle> yes, something is better than none
20:43:56 <david-lyle> coherent is better than some
20:43:57 <robcresswell> At least now, Horizon folk can drop a link for people. Ideally, they'd find the links themselves :)
20:44:12 <robcresswell> david-lyle: agreed
20:45:20 <mrunge> what about this bp: https://blueprints.launchpad.net/horizon/+spec/widget-based-views
20:45:31 <mrunge> I think that's obsolete now
20:45:33 <david-lyle> robcresswell: this is done no? https://blueprints.launchpad.net/horizon/+spec/drop-dj17
20:45:51 <robcresswell> david-lyle: Not entirely. Still got deprecation messages
20:46:32 <tsufiev> mrunge: I'd say superseded with ng work
20:47:00 <mrunge> yupp, and with david-lyle s plugins config for panels
20:47:03 <david-lyle> I think that was a request for the overview pages
20:47:49 <mrunge> nevertheless, there's not much new in
20:48:12 <tsufiev> david-lyle: I remember there was UX discussion about customizable overview, with tiled widgets
20:48:12 <david-lyle> I think more concrete bps should be used than this one
20:48:20 <robcresswell> My internet went a little odd there.
20:48:32 <david-lyle> this is really just a place holder in the older style of bp
20:48:49 <mrunge> yes
20:48:52 <david-lyle> I'd vote for culling this particular bp
20:48:59 <mrunge> +1
20:49:08 <robcresswell> +1
20:49:22 <tsufiev> +
20:50:15 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/widget-based-views marked superseded
20:51:43 <mrunge> another superseded: https://blueprints.launchpad.net/horizon/+spec/faceted-search
20:52:04 <mrunge> in the light of searchlight
20:52:12 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/horizon-designate marked superseded
20:52:38 <david-lyle> mrunge: or magic search
20:52:50 <mrunge> yupp, both
20:53:02 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/faceted-search marked superseded
20:54:26 <david-lyle> #link https://blueprints.launchpad.net/horizon/+spec/horizon-mobile-design
20:54:53 <david-lyle> I think that's superseded by hurgleburgler's work
20:55:01 <mrunge> yes
20:55:11 <mrunge> or even not applicable
20:55:40 <mrunge> ah, reading again, just superseded
20:56:03 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/horizon-mobile-design marked superseded
20:56:10 <robcresswell> woop
20:56:37 <david-lyle> #link https://blueprints.launchpad.net/horizon/+spec/improve-session-timout
20:56:59 <david-lyle> seems obsolete since we removed that check
20:57:07 <david-lyle> ergo, improved :)
20:57:43 <david-lyle> well the bp is different I guess reading
20:58:09 <david-lyle> that is something we won't fix
20:58:32 <tsufiev> I think horizon shouldn't actively logout
20:58:56 <tsufiev> It's bad for a web app to be too smart :)
20:59:00 <david-lyle> nope, if it's a concern, your OS will auto lock screens
20:59:10 <david-lyle> that's not the web apps job
20:59:14 <tsufiev> +1
20:59:27 <mrunge> +1
20:59:33 <r1chardj0n3s> +1
20:59:44 <robcresswell> r1chardj0n3s: Good meeting contribution
20:59:46 <robcresswell> :p
20:59:51 <r1chardj0n3s> :-P
20:59:54 <tsufiev> lol)
20:59:55 <r1chardj0n3s> just woke up :-P
20:59:58 <mrunge> another obsolete bp: https://blueprints.launchpad.net/horizon/+spec/show-all-floating-ips
21:00:10 <mrunge> there seem to be at least 3 bps with the same scope
21:00:45 <mrunge> #link https://blueprints.launchpad.net/horizon/+spec/show-all-floating-ips obsolete
21:00:52 <david-lyle> #info https://blueprints.launchpad.net/horizon/+spec/improve-session-timout marked obsolete
21:01:16 <mrunge> the other one was opened by me, I won't complain here
21:01:32 <tsufiev> mrunge: do you think that floatings need to be moved to network panel?
21:02:02 <mrunge> tsufiev, the story with that is a bit different
21:02:13 <mrunge> but let's move to horizon channel
21:02:18 <mrunge> or discuss tomorrow
21:02:25 <mrunge> I mean, time is up here
21:02:42 <tsufiev> mrunge: ok, better leave this for tomorrow
21:03:13 <tsufiev> end meeting?
21:03:16 <david-lyle> Thanks everyone.  208 bps
21:03:24 <david-lyle> getting better
21:03:26 <mrunge> thank you all
21:03:30 <david-lyle> #endmeeting