15:59:10 <primeministerp> #startmeeting hyper-v
15:59:11 <openstack> Meeting started Tue Nov 20 15:59:10 2012 UTC. The chair is primeministerp. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:13 <openstack> The meeting name has been set to 'hyper_v'
15:59:17 <primeministerp> HI all
15:59:36 <primeministerp> we'll give a couple more minutes before we get started
16:01:57 <Hitesh> primeministerp: Hi,
16:02:34 <Hitesh> alexpilotti: Hello
16:02:47 <primeministerp> Hitesh: hello
16:02:52 <primeministerp> Hitesh: starting in a couple minutes
16:03:02 <Hitesh> primeministerp: Ok.
16:04:39 <pnavarro> hi all
16:04:53 <primeministerp> pnavarro: perfect
16:05:03 <primeministerp> pnavarro: i was mainly waiting for you
16:05:09 <primeministerp> let's begin everyone
16:05:18 <pnavarro> sorry and thanks primeministerp
16:05:24 <primeministerp> pnavarro: no worries
16:05:29 <alexpilotti> hi guys!
16:05:33 <zykes-> hola!
16:05:38 <primeministerp> zykes-: hey now
16:05:55 <EmilienM_> hola
16:06:01 <Hitesh> Hello guys
16:06:02 <primeministerp> EmilienM_: how's it going
16:06:05 <primeministerp> alexpilotti: you around?
16:06:12 <primeministerp> ociuhandu: ?
16:06:14 <alexpilotti> primeministerp: yep
16:06:19 <primeministerp> great
16:06:29 <primeministerp> #topic blueprints
16:06:34 <alexpilotti> pnavarro: this is the repo with the cinder bits?
16:06:35 <EmilienM_> primeministerp: fine thx
16:06:47 <primeministerp> so first item to discuss is blueprints
16:07:04 <primeministerp> alessandro has been adding/adjust blueprints for work that is being done
16:07:19 <primeministerp> vish had requested that we break the blueprints up by implemented veature
16:07:21 <primeministerp> er feature
16:07:40 <pnavarro> alexpilotti: what do you mean by this?
16:07:57 <pnavarro> alexpilotti: did you point to a link? I missed it
16:07:58 <alexpilotti> pnavarro: I forgot the link sorry :-D
16:08:05 <alexpilotti> pnavarro: https://github.com/pnavarro/nova/blob/master/nova/virt/hyperv/volumeops.py
16:08:17 <pnavarro> yeah, alexpilotti
16:08:20 <primeministerp> #link https://github.com/pnavarro/nova/blob/master/nova/virt/hyperv/volumeops.py
16:08:45 <primeministerp> pnavarro: alexpilotti added a bluepint for the wmi v2 cinder work as well
16:08:49 <primeministerp> pnavarro: i believe
16:08:55 <primeministerp> alexpilotti: am i correct?
16:08:58 <alexpilotti> pnavarro: I see that you are using a CONF.hyperv_os_version to get the OS version
16:09:10 <alexpilotti> pnavarro: why don't you query the OS directly?
16:09:13 <pnavarro> well, in fact, volumeops have no changed that much, the true changes are in : https://github.com/pnavarro/nova/blob/master/nova/virt/hyperv/volumeutilsV2.py
16:09:29 <primeministerp> #link https://github.com/pnavarro/nova/blob/master/nova/virt/hyperv/volumeutilsV2.py
16:10:00 <pnavarro> alexpilotti: err... good point, I didn't know I could get this granurality through os
16:10:20 <primeministerp> pnavarro: how long before the cinder pieces are complete?
16:10:23 <alexpilotti> pnavarro: def _get_hypervisor_version(self):
16:10:24 <alexpilotti> """Get hypervisor version.
16:10:25 <alexpilotti> :returns: hypervisor version (ex. 12003)
16:10:27 <alexpilotti> """
16:10:28 <alexpilotti> version = self._conn_cimv2.Win32_OperatingSystem()[0]\
16:10:29 <alexpilotti> .Version.replace('.', '')
16:10:31 <alexpilotti> LOG.info(_('Windows version: %s ') % version)
16:10:31 <alexpilotti> return version
16:10:42 <pnavarro> ok !
16:11:11 <pnavarro> primeministerp: well, it's 99% complete, just was missing some pieces like alexpilotti was pointing
16:11:23 <primeministerp> pnavarro: will it be in for g1?
16:11:36 <pnavarro> sure
16:11:47 <primeministerp> pnavarro: that's by week end I believe..
16:11:52 <primeministerp> or is it next
16:12:02 <primeministerp> pnavarro: it's close
16:12:04 <alexpilotti> pnavarro: the storage WMI namespace is supported on Windows 8?
16:12:22 <pnavarro> alexpilotti: yes, the doc says so
16:12:52 <alexpilotti> pnavarro: in that case we can just check for the OS version >= 6.2 :-)
16:13:31 <alexpilotti> pnavarro: what about adding a FLAG (aka CONF) for forcing the usage of the old one in case of issues?
16:13:35 <pnavarro> primeministerp: I'd need some help from alexpilotti to launch live migration tests
16:14:03 <alexpilotti> pnavarro: like: CONF.force_vmutils_v1
16:14:05 <primeministerp> pnavarro: I'm still a week off from that
16:14:19 <primeministerp> pnavarro: any way we can get help from the ibm folks on that?
16:14:54 <primeministerp> EmilienM_: can you help test the livemigration side of things?
16:15:06 <EmilienM_> primeministerp: yep
16:15:18 <primeministerp> pnavarro: EmilienM_ can assist too
16:15:43 <primeministerp> #action EmilienM_ help w/ volume/live-migration testing
16:15:46 <pnavarro> alexpilotti: in that case, I can transform the conf _hyperv_os_version for that
16:16:17 <alexpilotti> primeministerp: pnavarro needs only to generate the test stubs for passing Jenkins tests
16:16:18 <primeministerp> alexpilotti: great
16:16:25 <alexpilotti> pnavarro: sure! :-)
16:16:27 <primeministerp> and that can be done by just generating the moc?
16:16:39 <primeministerp> or additional coding prior to the moc?
16:16:50 <alexpilotti> primeministerp: yep, by simply running the tests
16:16:58 <primeministerp> ok
16:17:09 <primeministerp> which is why he needs the live migration bits
16:17:14 <primeministerp> got it
16:17:17 <alexpilotti> primeministerp: correct!
16:17:28 <primeministerp> pnavarro: are you capible of working w/ EmilienM_ to do that?
16:17:48 <EmilienM_> pnavarro: I think that's ok :)
16:17:56 <pnavarro> I don't know how EmilienM_ can help...
16:18:09 <primeministerp> pnavarro: you don't have a live migration setup
16:18:16 <primeministerp> pnavarro: if EmilienM_ does
16:18:26 <primeministerp> pnavarro: he can generate the moc bits by running the test
16:18:35 <EmilienM_> pnavarro: I have I think
16:18:36 <primeministerp> alexpilotti: correct in my understanding?
16:18:47 <alexpilotti> primeministerp: yep
16:19:00 <primeministerp> pnavarro: you understand?
16:19:00 <pnavarro> primeministerp: I started yesterday a VM Domain controller... but if EmilienM_ has this setup, yes definetely can be helpful
16:19:17 <primeministerp> EmilienM_: you have a 2 hyper-v setup correct?
16:19:22 <EmilienM_> primeministerp: right
16:19:29 <EmilienM_> primeministerp: but never test live migration
16:19:56 <primeministerp> EmilienM_: if you're in a domain, and have used the cloudbase installer
16:20:01 <primeministerp> EmilienM_: it should work
16:20:05 <EmilienM_> primeministerp: that's fine
16:20:15 <primeministerp> EmilienM_: i can help debug today in a hour or so
16:20:17 <primeministerp> if you need help
16:20:25 <EmilienM_> primeministerp: which kind of test
16:20:35 <EmilienM_> live migration or python tests ?
16:20:55 <primeministerp> EmilienM_: live migration
16:20:59 <EmilienM_> primeministerp: fine
16:21:16 <EmilienM_> primeministerp: can't do it before 8pm CEST
16:21:16 <primeministerp> pnavarro: so you can help him get those running w/ your code?
16:21:26 * EmilienM_ in classroom ATM :-)
16:21:29 <primeministerp> EmilienM_: coordinate w/ pnavarro
16:21:32 <primeministerp> EmilienM_: but that's ok
16:21:37 <pnavarro> I'll call EmilienM_ later
16:21:45 <primeministerp> pnavarro: great, thanks for working together
16:21:49 <EmilienM_> primeministerp: yep, we have scheduled a conf call tonight
16:21:53 <primeministerp> EmilienM_: thanks for helping out
16:22:06 <EmilienM_> primeministerp: I'll do my best
16:22:11 <primeministerp> ok
16:22:14 <primeministerp> moving on then
16:22:18 <primeministerp> #status updates
16:22:26 <primeministerp> alexpilotti: you want to give a quick rundown?
16:22:42 * alexpilotti is cloning pnavarro's repo
16:22:50 <alexpilotti> primeministerp: sure
16:22:57 <primeministerp> cloudinit work was completed and made it through jenkins last friday
16:23:00 <alexpilotti> Nova:
16:23:12 <primeministerp> alexpilotti:thx
16:23:13 <alexpilotti> CloudInit / ConfigDriveV2 is in
16:23:29 <alexpilotti> and the Grizzly installer has been updated
16:23:36 <EmilienM_> I need to leave IRC guys
16:23:39 <primeministerp> Good feature to have for G1
16:23:44 <EmilienM_> bye all
16:23:47 <primeministerp> EmilienM_: thx again, include me on threads
16:23:50 <primeministerp> pls
16:23:52 <alexpilotti> we are using a couple extra tools: mkisofs and qemu-img
16:23:56 <EmilienM_> pnavarro: see you later ;)
16:24:08 <pnavarro> bye EmilienM_
16:24:11 <alexpilotti> to generate the ISO and VHD to attach
16:24:29 <alexpilotti> cloud-init had a few bugs, we helped the mainteiners to fix them
16:24:39 <primeministerp> alexpilotti: great work
16:25:08 <primeministerp> any updates on RDP?
16:25:17 <alexpilotti> we have precompiled deb and rpm packaes with cloudinit if you need them
16:25:32 <primeministerp> alexpilotti: o nice, do you have urls?
16:25:36 <primeministerp> we'll post them for the minutes
16:26:00 <alexpilotti> and on our blog there's a full VHD w Ubuntu 12.04 ready for Glance
16:26:28 <primeministerp> alexpilotti: great let's post those url's too if you got them
16:26:37 <alexpilotti> a full blog post will follow up on cloud init / config drive
16:26:57 <primeministerp> awesome!
16:27:01 <alexpilotti> http://www.cloudbase.it/downloads/UbuntuServer1204_cloudinit.zip
16:27:18 <primeministerp> #link http://www.cloudbase.it/downloads/UbuntuServer1204_cloudinit.zip
16:27:20 <alexpilotti> I'm going to fetch the .deb and .rpm asap
16:27:33 <alexpilotti> ok, back to the updates
16:27:33 <primeministerp> use "#link" when posting
16:27:41 <primeministerp> pls
16:27:45 <primeministerp> ok
16:27:48 <primeministerp> updates...
16:27:50 <alexpilotti> cloud-init for Windows. We have a bomb:
16:28:00 <primeministerp> anything i can help w/?
16:28:03 <alexpilotti> publik key authentication on RDP
16:28:07 <primeministerp> yes
16:28:13 <primeministerp> we discussed briefly
16:28:33 <primeministerp> did you finish the work for ssh key auth?
16:28:37 <alexpilotti> briefly, auth on Windows will use the same SSH keys
16:28:48 <alexpilotti> primeministerp: working on it
16:28:56 <luis_fdez> alexpilotti: that sounds interesting...
16:29:04 <primeministerp> alexpilotti: well from a end user perspective it's great news
16:29:13 <primeministerp> great feature alexpilotti
16:29:20 <primeministerp> alexpilotti: even if it's from a bomb
16:29:28 <alexpilotti> once that is done we'll port cloud-init to Windows, using the same authorized_keys deployed for SSH
16:29:38 <alexpilotti> and the sae keypairs udes by openstack
16:29:45 <primeministerp> awesome
16:29:57 <alexpilotti> in short this means that there will be no more issue for password distribution
16:30:12 <alexpilotti> I'd expect also Amazon & company to pick up such a feature
16:30:25 <primeministerp> that should make it interesting
16:30:49 <alexpilotti> ok, that's it for cloud-init so far
16:30:58 <primeministerp> alexpilotti: and i'm assuming quantum status is the same due to work on cloudinit?
16:30:58 <alexpilotti> nova: fixed a few bugs
16:31:14 <pnavarro> Quantum: from my side wvs_quantum_plugin (Windows Virtual Switch) advances slowly, but it advances
16:31:17 <alexpilotti> including today a very annoying one on VM status
16:31:37 <primeministerp> alexpilotti: yes i saw that
16:31:54 <alexpilotti> Quantum: we are also advancing slowly, due to teh time we had to spend w the reviews
16:32:01 <primeministerp> yes I know
16:32:06 <alexpilotti> Quantum target is definitely G2
16:32:09 <primeministerp> hopefully we can find a way to speed up that process
16:32:34 <alexpilotti> other stuff: RDP console, ociuhandu is working on it
16:33:00 <alexpilotti> we got aslo a great help from sagar, which is doing some great testing work
16:33:12 <primeministerp> ok
16:33:26 <primeministerp> good
16:33:38 <primeministerp> I don't think sagar's on today
16:33:40 <alexpilotti> ok, those were the updates for this week :-)
16:33:47 <primeministerp> alexpilotti: thanks for info
16:33:58 <primeministerp> luis_fdez: any thing to add from the CERN front?
16:34:08 <Hitesh> Thanks for great info :)
16:34:18 <primeministerp> luis_fdez: sorry i couldn't get more movement on the SCOM discussion
16:34:23 <Hitesh> specially alexpilotti :)
16:34:41 <alexpilotti> Hitesh: tx
16:34:47 <luis_fdez> nothing new... I was out of the office since thursday...
16:34:52 <alexpilotti> luis_fdez: tx for your get_stats patch!
16:34:58 <primeministerp> luis_fdez: yes thank you
16:35:05 <primeministerp> alexpilotti: thanks for reminding me
16:35:05 <luis_fdez> no problem primeministerp, let's see if we can make some development on that...
16:35:09 <Hitesh> alexpilotti: sorry I couldn't contribute more, however, I am doing setup..
16:35:14 <alexpilotti> luis_fdez: I'd like to get your CPU patch in this week. Do you have some time to get it done?
16:35:18 <Hitesh> alexpilotti: stucked with office work..
16:35:30 <primeministerp> luis_fdez: well if you start let me know, and I'll try to get you at least the information sources when needed
16:35:53 <Hitesh> alexpilotti: building quantum source from scratch on RedHat
16:35:54 <luis_fdez> alexpilotti: ok, I think I'll be able
16:36:10 <luis_fdez> but... alexpilotti , I can't wait cloud-init for win and ssh key auth!!!!
16:36:30 <primeministerp> luis_fdez: talk it up...
16:36:34 <luis_fdez> :)
16:36:40 <primeministerp> luis_fdez: make sure jan knows
16:36:43 <primeministerp> luis_fdez: ;)
16:36:51 <alexpilotti> luis_fdez: should be a quick thing. I'd like to validate the json stuff w the nova guys as there's no documentation on it and you did a great job in reverse engineer it from KVM etc
16:37:36 <pnavarro> Hitesh: why don't you use devstack?
16:37:40 <alexpilotti> luis_fdez: ssh jey auth is very close. As a side effect, I have a tool that dumps clear text passwords on login :-D
16:37:46 <luis_fdez> ok
16:37:55 <primeministerp> hehe
16:38:02 <primeministerp> alexpilotti: we all need one of those tools
16:38:06 <Hitesh> pnavarro: you are right, but we are developing custom plugin
16:38:28 <Hitesh> pnavarro: and supporting different DB
16:38:37 <pnavarro> primeministerp: so G1 it's for 22-11-2012.
16:38:38 <alexpilotti> I have a question on the Nova side
16:38:42 <Hitesh> pnavarro: so we will have to run only quantum :)
16:38:52 <primeministerp> pnavarro: so thinking G2?
16:39:12 <Hitesh> pnavarro: so let's think to target our quantum stuff for G2 :)
16:39:21 <alexpilotti> do you guys have any feature you'd like in Nova-Grizzly, beside what we already have and Resize?
16:39:23 <primeministerp> pnavarro: or will you be able to get done what you need w/ EmileM before?
16:39:27 <Hitesh> pnavarro: hope I will finish office stuff this weekend
16:39:52 <Hitesh> pnavarro: I will get back to you on wvs_quantum_plugin
16:40:09 <primeministerp> alexpilotti: you mean for G1?
16:40:14 <primeministerp> alexpilotti: or in general?
16:40:24 <pnavarro> primeministerp: well we'll try
16:40:25 <alexpilotti> primeministerp: Grizzly in ge
16:40:47 <alexpilotti> primeministerp: just to check if there are more plugins to write
16:41:01 <alexpilotti> sorry, meant blueprints, lapsus :-)
16:41:13 <primeministerp> pnavarro: o yes
16:41:29 <primeministerp> pnavarro: make sure you have appropriate blueprints prior to submitting
16:41:44 <primeministerp> Hitesh: anything to add?
16:41:45 <pnavarro> ok primeministerp
16:41:58 <Hitesh> primeministerp: Nops from my side
16:42:01 <alexpilotti> pnavarro: we need to add a blueprint for your new Cinder bits
16:42:34 <Hitesh> primeministerp: I didn;t get a chance to work more on our stuff...so nothing to add this time...:(
16:42:46 <pnavarro> I'll sync with you this night alexpilotti
16:43:20 <alexpilotti> pnavarro: ok!
16:43:35 <primeministerp> greate
16:44:03 <primeministerp> guess general ci update from my end
16:44:21 <alexpilotti> primeministerp: cool!
16:44:24 <primeministerp> working like a mad man preping for the visit from alexpilotti and ociuhandu
16:44:45 <primeministerp> implemeneted the production puppet infra on friday and base pxe node
16:44:48 <primeministerp> all puppetized
16:44:59 <alexpilotti> primeministerp: cool! Should we also set up a meeting with the OpenStack CI guys for inputs?
16:45:00 <primeministerp> core switch is puppetized
16:45:09 <primeministerp> alexpilotti: i'll work on that for next week
16:45:18 <alexpilotti> primeministerp: great tx!
16:45:41 <primeministerp> #action pp setup meeting w/ mtaylor and other for ci discussion
16:45:54 <pnavarro> I have to go, missing my bus... see you later
16:45:57 <pnavarro> bye
16:45:59 <primeministerp> pnavarro: thanks again
16:46:12 <alexpilotti> pnavarro: bye!
16:46:25 <Hitesh> same here..I will to catch my bus
16:46:28 <primeministerp> I should be done w/ the switch automation and trunking of all available ports between switches
16:46:28 <Hitesh> bye guys
16:46:36 <primeministerp> bye Hitesh
16:46:38 <Hitesh> I will synch with alexpilotti and pnavarro
16:46:45 <Hitesh> bye
16:47:05 <primeministerp> alexpilotti: we'll deal w/ things like logging etc later, i'm trying to get the basics in place for when you come to to be able to roll the setups as quickly as possible
16:47:11 <primeministerp> and have contol w/ jenkins
16:47:39 <alexpilotti> primeministerp: ok!
16:47:52 <primeministerp> alexpilotti: the rest i fugure we integrate what is already there
16:47:58 <primeministerp> alexpilotti: in terms of the jenkins jobs etc
16:48:38 <primeministerp> alexpilotti: we'll discuss that w/ monty
16:48:59 <primeministerp> ok I'll talk w/ him and schedule something for next week
16:49:04 <primeministerp> we have a holiday on thurs
16:49:09 <primeministerp> i'll be working on friday as well
16:49:22 <primeministerp> just out thur
16:49:34 <primeministerp> on that note
16:49:41 <primeministerp> I'll end it and send out the notes
16:49:45 <primeministerp> we can touch base later
16:49:48 <primeministerp> if needed
16:49:51 <primeministerp> alexpilotti: ^
16:49:56 <primeministerp> #endmeeting