13:00:09 <claudiub> #startmeeting hyper-v
13:00:10 <openstack> Meeting started Wed Jul 13 13:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is claudiub. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:14 <openstack> The meeting name has been set to 'hyper_v'
13:00:20 <atuvenie_> Hi all
13:00:24 <claudiub> hello
13:00:36 <abalutoiu> hi
13:00:57 <claudiub> such a lovely day today
13:01:04 <ypen> Hi
13:01:37 <c64cosmin> o/
13:02:05 <claudiub> ok, I think we've waited enough for people to join
13:02:17 <sagar_nikam> Hi
13:02:28 <claudiub> #topic nova feature freeze
13:02:53 <claudiub> soo, typically nova feature freeze happens in the milestone N-2.
13:03:02 <claudiub> which is in 2 days.
13:03:40 <claudiub> there is only one more patch that was deemed worthy of a feature freeze exception, which is the hyper-v device tagging.
13:03:52 <claudiub> #link hyper-v device tagging: https://review.openstack.org/#/c/331889/
13:04:11 <claudiub> so, I'm expecting it to merge in the following days.
13:04:35 <claudiub> other than that, everything is pretty much frozen.
13:05:00 <sagar_nikam> cluster driver and FC in O release now ?
13:05:04 <sagar_nikam> correct
13:05:18 <claudiub> it seems that the hyper-v ovs vif plug driver would be considered an "os-vif" priority, so we can still hope on merging that.
13:05:49 <claudiub> sagar_nikam: indeed. for the cluster driver it seems that we'll have to have a conversation with nova core about it next week at the midcycle.
13:07:16 <claudiub> anyways. IMO, there were quite a few patches merged in the hyper-v driver in newton, so I'd say it was a productive cycle in this regard.
13:07:28 <claudiub> \o/
13:07:44 <lpetrut> Hi guys
13:08:07 <sagar_nikam> claudiub: agree.. quite a bit of hyperv patches merged
13:08:54 <claudiub> we'll probably have to submit new blueprints and features for O, otherwise that "nova  hyper-v priority list" might get too empty. :)
13:08:57 <claudiub> moving on.
13:09:13 <claudiub> #topic networking-hyperv status
13:09:42 <claudiub> #action lpetrut atuvenie_ to review: https://review.openstack.org/#/c/328210/
13:10:19 <claudiub> other than that, there are no other outstanding commits.
13:10:53 <claudiub> #topic designate status
13:11:29 <claudiub> there has been some reviews on the patch, but mostly os-win 1.1.0 had to be released.
13:11:32 <claudiub> still have to.
13:11:57 <claudiub> os-win 1.1.0 wasn't released yet as there was a bug that we had to take care of it first.
13:12:29 <claudiub> that has been dealt with, will request release again. thus, the designate patch won't be blocked on this.
13:12:50 <claudiub> abalutoiu: anything else to add?
13:13:03 <sagar_nikam> claudiub: designate is planned for newton ?
13:13:15 <claudiub> sagar_nikam: yep.
13:13:25 <sagar_nikam> ok ... nice
13:13:34 <claudiub> sagar_nikam: only nova and cinder have the feature freeze in the milestone N-2.
13:13:36 <abalutoiu> claudiub not really, I'm fixing the comments now, and I'm going to do some tests with python 3.4 as well
13:13:52 <claudiub> sagar_nikam: the rest of the projects have feature freeze somewhere close to N-3
13:14:11 <claudiub> abalutoiu: cool, thanks. :)
13:14:34 <claudiub> moving on.
13:14:42 <claudiub> #topic os-brick status
13:14:55 <claudiub> seems we are blocked here.
13:15:18 <claudiub> the cinder core want to have a voting ci before they merge any more patches, it seems.
13:15:46 <claudiub> sooo, getting the ci up and running will be a must.
13:16:45 <sagar_nikam> we have the CI setup
13:16:51 <sagar_nikam> already at microsoft
13:16:57 <sagar_nikam> where 3par is available
13:17:09 <sagar_nikam> is that not in use for the os-brick  ci ?
13:17:45 <claudiub> but that might take some time. seems that some infra upgrades will be necessary for it
13:18:12 <sagar_nikam> ok
13:18:25 <sagar_nikam> so till that time, we cant get os-brick merged ?
13:18:35 <claudiub> sagar_nikam: from what I've talked with the ci team, setting up a new ci for a new project isn't that easy.
13:18:40 <claudiub> sagar_nikam: yep.
13:18:48 <sagar_nikam> ok
13:19:18 <sagar_nikam> so this will also move to O
13:19:19 <sagar_nikam> now
13:19:28 <sagar_nikam> hopefully we have the CI by that time
13:19:34 <claudiub> not necessarely. still hoping for N.
13:20:03 <claudiub> but this is something I have little control over.
13:20:09 <sagar_nikam> that would be good .. if it is N
13:20:14 <claudiub> I'll help however I can though.
13:20:26 <sagar_nikam> claudiub: thank you
13:20:30 <claudiub> np. :)
13:20:56 <claudiub> #topic open discussion
13:21:01 <sagar_nikam> monasac
13:21:13 <sagar_nikam> wanted some discussion on monasca
13:21:37 <sagar_nikam> how is it going ?
13:21:44 <sagar_nikam> are the patches reviewed and merged ?
13:22:10 <claudiub> sagar_nikam: yeah. no updates there I'm afraid. I was the person responsible for that project, didn't have the time to keep working on it, since I've allocated all my time to nova, getting things merged.
13:22:40 <claudiub> sagar_nikam: will have to resume, now that nova is frozen. :)
13:23:16 <sagar_nikam> claudiub: no problem....
13:23:23 <sagar_nikam> let us know when it is ready
13:23:27 <sagar_nikam> we will pick and check it
13:23:34 <claudiub> also, another note.
13:23:58 <claudiub> #note claudiub won't attend next week's meeting, due to the nova midcycle event
13:24:41 <sagar_nikam> are we having the meeting next week ?
13:24:59 <sagar_nikam> also one more question on monasca ... is it planned for N ?
13:25:17 <claudiub> so, someone else will have to chair the meeting next week.
13:25:30 <claudiub> sagar_nikam: if there are people attending, yes.
13:25:42 <claudiub> sagar_nikam: yes, still planned for N. :)
13:26:11 <sagar_nikam> if required... we can not have it next week... if lot of your team members will attend the mid-cycle...
13:26:20 <sagar_nikam> i can attend the meeting, if it is there
13:26:51 <sagar_nikam> ok... monasca planned for N... nice, we will pick up as soon as it is available
13:27:28 <claudiub> well, we can post-pone next week's meeting to the next-next one.
13:28:01 <claudiub> anyways, any more topics for today? :)
13:28:27 <ypen_> anybody has information of the cassandra database development?
13:29:25 <sagar_nikam> yes... 2 more topics from me...
13:29:55 <claudiub> ypen_: well, we don't have anything related to cassandra. or at least, not directly.
13:29:58 <sagar_nikam> cluster driver ... iscsi supprt, any more discussion since we last chatted on this
13:30:53 <atuvenie> sagar_nikam: not really
13:31:11 <atuvenie> sagar_nikam: I've talked with alessandro, but this is something we need to put some thought into
13:31:26 <ypen_> What I mean is the plugin metric database
13:31:30 <sagar_nikam> atunenie: sure... thanks for the update
13:31:38 <atuvenie> sagar_nikam: for the moment I'm working on containers, and haven't focused that much on the cluster part
13:31:59 <sagar_nikam> atuvenie: ok .... is iscsi support for cluster planned in N ?
13:32:12 <sagar_nikam> atleast in compute-hyperv ?
13:32:19 <claudiub> ypen_: you mean like, cassandra database metrics?
13:32:25 <atuvenie> sagar_nikam: I think at this point that having a custom cluster provider will be the way to go, but we have to analyse the full impact of that
13:32:28 <ypen_> yes
13:32:54 <ypen_> we can help if nobody is responsible for that
13:33:08 <sagar_nikam> atuvenie: custom cluster provider .... some more info please... this is new to me
13:33:13 <claudiub> ypen_: that sounds like something that should be brought up to the monasca meeting. This is the hyper-v meeting. :)
13:33:38 <claudiub> ypen_: the monasca meeting is in 90 minutes, if I'm not mistaken.
13:33:46 <atuvenie> sagar_nikam: we talked about it at the last meeting
13:33:55 <ypen_> Deutsche telekom
13:34:22 <sagar_nikam> ok... the same... i will check it again
13:34:22 <ypen_> Sorry about this. this is our first time
13:34:31 <atuvenie> sagar_nikam: we said we considered writing a custom provider for MSFT cluster that will take care of loging targets when a failover is triggered
13:34:32 <claudiub> ypen_: no problem. :)
13:37:12 <sagar_nikam> atuvenie: thanks... keep us posted on how things progress, we can check and let you know
13:37:46 <claudiub> anything else for today?
13:38:36 <claudiub> just fyi, the dealine for the openstack summit talks and presentations is pretty close. if you have any presentations you want to submit, you'll have to hurry. :)
13:40:24 <sagar_nikam> yes
13:40:45 <claudiub> well, if there's nothing else, will close this meeting soon. :)
13:41:06 <sagar_nikam> one final topic.... freerdp... as of now it is on hold... correct ?
13:41:17 <sagar_nikam> the bug we raised
13:41:23 <claudiub> c64cosmin: hello. it is your time to shine. :)
13:41:25 <sagar_nikam> it will be worked later
13:42:22 <c64cosmin_> sagar: Yes, I haven't forgot about you guys
13:42:35 <sagar_nikam> c64cosmin: thanks ...
13:42:41 <c64cosmin_> unfortunately work on FreeRDP-WebCOnnect is delayed a bit
13:43:01 <c64cosmin_> but will  come back right to it, when I can, no worries
13:43:02 <sagar_nikam> the reason i asked... since this is postponed, we will also start on other things
13:43:19 <c64cosmin_> sounds reasonable
13:43:24 <sagar_nikam> will let my QA team member know about it.. so that he can test other features
13:43:31 <sagar_nikam> just for our planning
13:43:35 <c64cosmin_> I will write to you to skype when I have news
13:44:19 <sagar_nikam> c64cosmin: sure... thanks... so we will stop freerdp till you get back to us... and we focus on other hyperv checks
13:45:35 <claudiub> well, if there's nothing else, we can end it soon. :)
13:45:51 <sagar_nikam> claudiub: have you seen this https://github.com/python-beaver/python-beaver ?
13:46:40 <sagar_nikam> this is for sending any logs to logstash
13:46:48 <sagar_nikam> nova-compute logs etc
13:46:55 <claudiub> no, I haven't, but it certainly has a funny description. :D
13:47:10 <sagar_nikam> can be sent to logstash using rabbitmq or kafka
13:47:11 <claudiub> sagar_nikam: kinda' sounds like what monasca-logging does
13:47:37 <sagar_nikam> claudiub: you may be right
13:47:59 <sagar_nikam> we started checking how nova-compute logs on hyperv can be sent using beaver
13:48:19 <claudiub> it seems that it has been quite actuve, having 46 releases, but it hasn't been updated for 3 months.
13:48:25 <sagar_nikam> but ... no windows support
13:48:26 <claudiub> Wondering if it's still alive.
13:48:47 <sagar_nikam> just wanted to check if claudbase has seen this...
13:49:00 <claudiub> sagar_nikam: seems there is a pull request to port to Windows: https://github.com/python-beaver/python-beaver/pull/293
13:49:31 <sagar_nikam> yes... that is the patch submitted by my team mate
13:50:09 <sagar_nikam> we submitted the patch to supprt windows
13:50:21 <claudiub> sagar_nikam: no, we haven't, but I'd prefer making monasca-logging work on Windows. it probably has more synnergy with other openstack components.
13:51:02 <claudiub> sagar_nikam: I see. it seems that the ci fails on that pull request though.
13:51:04 <sagar_nikam> ok... let me check with some monasca experts here.... need to understand monasca-logging
13:51:25 <sagar_nikam> claudiub: that patch was submitted when beaver used rabbitmq
13:51:29 <sagar_nikam> now it used kafka
13:51:52 <sagar_nikam> we could not get the patch merged then.. since not many people in beaver understood windows
13:52:28 <claudiub> sagar_nikam: yeah, understandable. Windows is not a common specimen in the Ops community. :)
13:52:52 <sagar_nikam> claudiub: agree....
13:53:57 <claudiub> sagar_nikam: well, let us know how the discussion about monasca-logging goes. :)
13:54:15 <claudiub> until then, we can close the meeting. :)
13:54:16 <sagar_nikam> claudiub: sure
13:54:29 <claudiub> thanks folks for joining, see you next-next week!
13:54:35 <sagar_nikam> if monasca-logging is useful.. we should use it
13:54:48 <sagar_nikam> thanks... so no meeting next week ?
13:54:49 <claudiub> sagar_nikam: yep. :)
13:55:21 <sagar_nikam> ok .... meet you all 2 weeks from now
13:55:45 <claudiub> sagar_nikam: yeah, there won't be a lot of people attending next week, and there won't be any updates, since the preparation ofr the midcycle takes time.
13:55:48 <sagar_nikam> claudiub: and hopefully you have a nice meeting at mid-cycle meetup
13:56:07 <sagar_nikam> especially on cluster driver
13:56:32 <claudiub> sagar_nikam: yeah, I really hope so. they tend to over-analyze everything. :)
13:57:14 <claudiub> well, bye folks!
13:57:17 <sagar_nikam> i am done with topics..
13:57:19 <sagar_nikam> bye..
13:57:23 <itoader> bye
13:57:28 <claudiub> #endmeeting