14:01:48 <rosmaita> #startmeeting image import sync
14:01:48 <openstack> Meeting started Tue Oct  4 14:01:48 2016 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:49 <Jokke_> o/
14:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:52 <openstack> The meeting name has been set to 'image_import_sync'
14:02:02 <rosmaita> I didn't know that would work!
14:02:15 <rosmaita> hi Jokke_
14:02:19 <Jokke_> hello
14:02:21 <croelandt> hey
14:02:31 <rosmaita> hi cyril
14:02:45 <rosmaita> ok, let's use an etherpad for some notes
14:02:48 <rosmaita> #link https://etherpad.openstack.org/p/glance-ocata-image-import-sync
14:02:58 <rosmaita> (nothing on it yet except a link to the spec)
14:03:26 <rosmaita> i was working on a proposed OSSN, so don't really have much atm
14:03:35 <croelandt> do we want to implement it?
14:03:42 <croelandt> iirc some people did not agree with the spec
14:03:53 <croelandt> which explains why there has not been much progress on this
14:04:03 <rosmaita> no, the lack of progress was consensus building
14:04:06 <rosmaita> that's been built
14:04:21 <rosmaita> so defcore is on board
14:04:24 <rosmaita> the api-wg is on board
14:04:29 <rosmaita> we are on board
14:04:48 <rosmaita> the key thing is all the discoverabilty aspects must be implemented
14:04:49 <croelandt> https://bugs.launchpad.net/glance/+bugs?field.tag=mitaka-new-import-process is this still OK then?
14:04:58 <croelandt> are these tasks still relevant?
14:05:31 <rosmaita> yeah, the titles all look good
14:05:43 <rosmaita> plus, stuart had a patch up for an "mvp" for this
14:05:56 <Jokke_> I still just don't like using bugs for tracking them
14:06:00 <Jokke_> but the items are there
14:06:22 <croelandt> About the discovery thing, I wrote that https://review.openstack.org/#/c/270980/
14:06:28 <croelandt> and Nikhil took it over a while ago
14:06:43 <croelandt> but it seems stalled, so I could probably send an updated version if need be
14:08:00 <rosmaita> yeah, we shoudl probably get something up
14:08:09 <rosmaita> i think the schema may change a bit, though
14:08:17 <rosmaita> but we can iterate
14:08:29 <croelandt> So you'd say this patch is the first one that should be merged?
14:08:34 <croelandt> And then we can implement the rest?
14:08:42 <rosmaita> no, i think the headers
14:08:49 <rosmaita> but acutaully, it doesn't matter
14:09:00 <rosmaita> none of this stuff will be useful not matter what we do first
14:09:22 <Jokke_> indeed
14:09:34 <rosmaita> croelandt: i am worried about our json-schema support
14:09:34 <croelandt> hhhe
14:09:40 <Jokke_> before we have it all in it won't work as designed anyways
14:09:44 <croelandt> just trying to figure out what we should code first
14:10:08 <rosmaita> so maybe this is a good place to start
14:10:20 <Jokke_> I'd leave the API changes last so we can actually build up the bits and test them on each phase we iterate
14:10:20 <rosmaita> to find out if we need better json schema support
14:10:46 <croelandt> Jokke_: good idea
14:10:58 <rosmaita> i agree
14:11:04 <Jokke_> the API endpoints are after all pointless if we have no code behind 'em
14:11:06 <rosmaita> so let's start with the internals
14:11:15 <rosmaita> gimme a sec to find stuart's patch and notes
14:11:53 <croelandt> kk
14:13:13 <rosmaita> here's stuart's notes:
14:13:17 <rosmaita> #link https://etherpad.openstack.org/p/glance-image-import-implementation-tactics
14:15:22 <rosmaita> and i think these are the patches:
14:15:36 <rosmaita> #link https://review.openstack.org/308386
14:15:47 <rosmaita> #link https://review.openstack.org/312653
14:15:55 <rosmaita> https://review.openstack.org/312972
14:16:04 <rosmaita> oops
14:16:08 <rosmaita> #link https://review.openstack.org/312972
14:16:33 <croelandt> and
14:16:37 <croelandt> #link https://review.openstack.org/#/c/270980/
14:17:05 <rosmaita> ok, thanks
14:17:18 <rosmaita> there's also a "headers" patch from sabari
14:17:47 <rosmaita> afaik, sabari and stuart don't have time to work on this now, but i think we can ask them for reviews
14:18:53 <croelandt> hum
14:18:53 <rosmaita> what i'd like to propose is that we each look through the mvp etherpad and the stuart's patches
14:19:02 <croelandt> ok
14:19:08 <croelandt> I added all these patches to our Etherpad
14:19:18 <rosmaita> i don't want to necessarily wait a week to hook back up
14:19:20 <croelandt> I might try to resubmit the one about the discovery
14:19:21 <Jokke_> that sounds like a decent plan for now
14:19:25 <rosmaita> how about friday?
14:19:32 <croelandt> same time?
14:19:35 <rosmaita> or thursday after glance meeting?
14:19:48 <rosmaita> i should be realistic, friday
14:19:50 <Jokke_> Fri looks fine
14:19:56 <rosmaita> (checking time)
14:19:57 <Jokke_> Thu is starting to get crowded
14:20:14 <rosmaita> friday at this time works for me, too
14:20:24 <Jokke_> I have 1200UTC 30min and 14:30 30min block on Fri
14:20:33 <rosmaita> #action look over mvp etherpad and patches
14:20:50 <rosmaita> so could you do 14:00 or do you want to do 14:30 ?
14:21:00 <croelandt> 14:30 is OK with me
14:21:01 <Jokke_> so if we want to have Fri more than 30min, I'd say lets do bit earlier than now if ok
14:21:18 <croelandt> 13:30UTC ?
14:21:24 <Jokke_> I mean those 2 blocks are reserved currently
14:21:41 <rosmaita> i am getting confused!
14:21:44 <Jokke_> Fri 13:30 UTC would suite me
14:21:51 <rosmaita> i can do that
14:21:55 <rosmaita> croelandt: ?
14:22:08 <croelandt> ok
14:22:08 <Jokke_> so I'm booked Friday  1200-1230 and 1430-1500
14:22:30 <Jokke_> other than that I have friday flexible
14:22:41 <croelandt> no, Friday 13:30 is OK
14:22:41 <rosmaita> #action follow up meeting in #openstack-glance 13:30 UTC friday 7 oct
14:22:48 <rosmaita> ok cool
14:22:55 <rosmaita> thanks!
14:23:00 <croelandt> Thanks, see you on Friday
14:23:08 <rosmaita> #endmeeting image import sync