12:29:01 <ttx> #startmeeting incub_sync
12:29:02 <openstack> Meeting started Thu Jul  3 12:29:01 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:29:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:29:05 <openstack> The meeting name has been set to 'incub_sync'
12:29:06 <ttx> #topic Designate
12:29:11 <ttx> Kiall: hi!
12:29:33 <Kiall> Heya :) So, first time doing one of these. Could you give me an intro? :)
12:30:08 <ttx> Well, it's more to ensure you have time to ask questions, and so that we sync on juno status
12:30:28 <ttx> the latter becomes more important as you start to have your mielstones published by release management rather than yourself
12:30:57 <ttx> basically, we gradually make sure you handle releases and the release cycle in the common way
12:31:14 <ttx> and have opportunity to learn and ask questions while doing so
12:31:34 <ttx> At this point, designate always did its own release work
12:31:47 <Kiall> Okay - sure.. I guess that leads to my first question then :) When do we start having you handle releases? I'm guessing it's not "now" - but sometime soon?
12:31:49 <ttx> although it's already aligned with the release series
12:32:05 <Kiall> Yea, our process is 99% identical. Although, we did miss/skip j1
12:32:29 <ttx> what do you want to do with j1 ? Should we mark is done/inactive?
12:32:37 <ttx> it*
12:33:28 <Kiall> I was considering simply cutting a j1 release sometime in the next few days - But, not sure it's worth it. We have very little user facing changes so far - it's all been core work.
12:33:53 <ttx> alternatively we can move everything to j2 and "cancel" j1
12:34:09 <ttx> your call
12:34:26 <Kiall> Okay - That sounds like as good a plan, we'll migrate all the bugs/bps and close j1 on launchpad.
12:34:51 <ttx> we can switch to release-management managed releases for j2
12:35:03 <ttx> if you think you can hit the deadline
12:35:13 <ttx> the tooling should be mostly ready
12:35:33 <ttx> we'll just have to adjust a few permissions in LP
12:35:42 <Kiall> Okay, that depends on what you need from us :) We should be following the process pretty closely already, but there may be a few small things.
12:35:55 <ttx> if we do that now I can use scripts to move everything to j2 and cancel j1 for you
12:35:58 <Kiall> I actually believe you should already have access - the designate LP projects are marked as part of openstack
12:36:23 <ttx> that's unfortunately not enough ;) You need to set openstack-admins as maintainer of https://launchpad.net/designate
12:36:25 <Kiall> So - you should inherit perms via that, correct?
12:36:37 <ttx> and then add the openstack-release group in the designate-drivers group
12:36:48 <Kiall> Okay. I'll do that straight after our meet.
12:37:28 <Kiall> So - Is there anything else we might need to change before j2 for you to be able to handle the releases?
12:37:34 <ttx> you'll keep rights over the project via the designate-drivers group still being the "drivers" of the project
12:37:46 <ttx> I don't think so
12:38:03 <ttx> I shall inherit everything needed from "all projects" in gerrit
12:38:09 <Kiall> Okay - Excellent.
12:38:28 <ttx> could you set the Lp perms now ? Then i can use my scripts to move bugs around
12:38:31 <Kiall> Sure
12:38:42 <ttx> that way you won't have to manually do it and we can agree o nthe result
12:39:08 <Kiall> Done on both designate and python-designateclient
12:39:22 <ttx> then it's just a question of you letting me know of a master SHA you'd like to tag as juno-2, ideally during the juno-2 common week
12:39:39 <ttx> and i'll run the script to make it happen
12:39:51 <Kiall> Okay - That's no problem
12:40:28 <ttx> ok, let me try the defer bug script
12:40:33 <Kiall> So, another question. We have a in-tree DevStack plugin, and HP has a (currently not open source) Horizon plugin. We'd like to get these merged to devstack/horizon - is that something we can do yet?
12:41:24 <ttx> it's a bit of a chicken-and-egg, and the TC resolved that it's something you shall do during your first integrated cycle (between the time you graduated to integrated and the first release as integrated)
12:41:38 <ttx> so for example sahara is doing it during the Juno cycle
12:41:49 * SergeyLukjanov lurking
12:41:56 <ttx> but then you need to opensource it first ;)
12:41:56 <Kiall> Okay, so that's a "not yet" then?
12:42:15 <ttx> yes, not yet, but I'd work (1) on opensourcing it and (2) in getting horizon devs feedback on it
12:42:23 <ttx> SergeyLukjanov can let you know how he did it
12:42:23 <Kiall> Yea - our Horizon team are not wanting to maintain it in two places, so really want to push it into horizon rather than another repo.
12:42:44 <ttx> Kiall: at this point you should probably publish it in a git repo under the designate program
12:42:55 <ttx> and maintain it there until horizon can take it
12:43:11 <ttx> like sahara did with openstack/sahara-dashboard
12:43:31 <SergeyLukjanov> yup, and then you could ask horizon devs to take a look on it
12:43:32 <Kiall> Yea, that's plan B :) I have Endre extracting it from our internal horizon fork at the moment, then we'll need to pass it through our open source process.
12:43:47 <SergeyLukjanov> and when you'll be integrated you'll start merging hell
12:43:57 <Kiall> :)
12:45:04 <SergeyLukjanov> Kiall, the super huge pros of such approach - ability to easy hack your dashboard code
12:45:14 <SergeyLukjanov> it'll be impossible after merging into horizon
12:45:24 <Kiall> Okay - So, another question, beyond looking after the project itself, are they any other expectations for PTLs?
12:45:37 <ttx> Kiall: small note, you should not be using "Juno" series in your bugs, like in https://bugs.launchpad.net/designate/+bug/1271493
12:45:39 <Kiall> (+ beyond this weekly sync up :))
12:45:41 <ttx> just use the default series
12:45:49 <ttx> otherwise most scripts are confused
12:46:04 <Kiall> Oh. Okay, I think all our bugs are like that
12:46:25 <ttx> no only 3 of them were
12:46:34 <ttx> (from the j-1 targeted things at least)
12:46:46 <ttx> the default series means 'the series under development"
12:46:50 <Kiall> Ah - Yea, there is piles more which aren't on j1.
12:47:00 <ttx> juno series is a bit of a corner case in Lp
12:47:08 <ttx> https://launchpad.net/designate/+milestone/juno-1 is now empty
12:47:14 <ttx> shal I just delete it now ?
12:47:22 <Kiall> Sur
12:47:23 <Kiall> Sure*
12:47:43 <ttx> OK, so we are good
12:48:00 <Kiall> Should we fix any bugs targeted to Juno BTW?
12:48:15 <ttx> bah don't bother
12:48:25 <ttx> we'll catch them when the scripts fail
12:48:25 <Kiall> Okay
12:48:46 <ttx> fwiw development milestoes are just point in time
12:49:09 <ttx> a common time reference, handy for rough targeting estimates
12:49:20 <ttx> it's not supposed to be a lot better or worse than any point in master
12:49:29 <ttx> although we try to avoid tagging when it's utterly broken
12:49:58 <Kiall> Makes sense.
12:50:15 <Kiall> So, another question, beyond looking after the project itself, are they any other expectations for PTLs?
12:50:19 <ttx> OK, that's all i had for today. like I said, next week we'll have a look at the j-2 targeted content and try to see if it makes any sense
12:50:40 <ttx> Kill: did you read https://wiki.openstack.org/wiki/PTLguide ?
12:50:52 <ttx> Kiall: ^
12:51:00 <ttx> Hmm, looks like I need to update it a bit
12:51:15 <ttx> the whole milestone-proposed thing is a bit outdated now
12:51:16 <Kiall> ttx: Aha - I was looking for a page like that, and missed it.
12:51:36 <ttx> I will update it, but I suspect most of it will still be current
12:51:50 <ttx> I'll have it updated before next week sync point
12:51:56 <Kiall> Okay - I've watched the page, once you have updated I'll review it
12:51:58 <ttx> #action ttx to update https://wiki.openstack.org/wiki/PTLguide
12:52:15 <ttx> Ok, that's enough for a first contact :)
12:52:21 <ttx> talk to you next week!
12:52:28 <Kiall> Thanks ttx - cya :)
12:52:30 <ttx> (unelss you have another question)
12:52:41 <Kiall> No, that's it for now :)
12:52:53 <ttx> OK! have a good day!
12:53:18 <Kiall> same to you :)
15:20:53 <flaper87> bu28
15:20:55 <flaper87> ops
15:31:03 <ttx> jraim: around?
15:39:50 <ttx> devananda: ready when you are
15:40:01 <devananda> ttx: hi!
15:40:16 <ttx> looks like you're the only one around again :)
15:40:21 <devananda> huh
15:40:23 <ttx> #topic Ironic
15:40:28 <ttx> well, I had kiall this morning
15:40:46 <devananda> only real news from last week is http://lists.openstack.org/pipermail/openstack-dev/2014-June/039031.html
15:41:04 * flaper87 is around for Marconi
15:41:15 <devananda> ironic core team did a hangout, looked at our notes from the summit, and tried to evaluate where we are on accomplishing them
15:41:18 <devananda> that email summarizes it
15:41:39 <devananda> oh, and one other news
15:42:09 <devananda> Nova approved the spec for an ironic virt driver
15:42:16 <ttx> devananda: cool
15:42:23 <devananda> so I'm quickly prepping the code for landing it there.
15:42:38 <ttx> devananda: is https://launchpad.net/ironic/+milestone/juno-2 up to date with the plan described in the Google spreadsheet ?
15:42:49 <devananda> no
15:42:50 <ttx> Looks a bit thin
15:42:51 <ttx> ok
15:43:02 <ttx> You use specs iirc
15:43:11 <devananda> yes, however many of them haven't landed
15:43:42 <ttx> You can use http://git.openstack.org/cgit/openstack-infra/release-tools/tree/spec2bp.py to keep spec in line with spec state
15:43:48 <devananda> I'm hoping to corralle the spec review team into landing them by next week, then i'll target. it seems a bit rushed
15:44:22 <devananda> fwiw, we've also got 33 open specs right now
15:44:24 <ttx> as long as the spec and the blueprint have the same name, you can run the script when the spec is approved
15:44:50 <ttx> as long as you're incubated it's not a big deal if the bleuprint plan lags a bit
15:45:22 <ttx> since it's not published as part of http://status.openstack.org/release/
15:45:22 <devananda> ack
15:45:54 <devananda> it's a bit awkward to be incubated and also juggling not just early adopters but a few companies' product plans :)
15:46:03 <ttx> but as you get closer to j-2 it's good to bring the blueprint landscape in sync
15:46:29 <devananda> will do
15:46:29 <ttx> incubated is not really about stability or maturity, it's really about integration
15:46:40 <ttx> and process convergence
15:46:42 <devananda> yes
15:46:50 <ttx> the name is a bit of a misnomer
15:46:58 <devananda> i'm well aware of that
15:47:12 <ttx> learning-integration is a mouthful though
15:47:47 <ttx> planning to tag j-2 on the common j2 week?
15:48:28 <devananda> that's the current plan
15:48:30 <ttx> #info Ironic planning to do j2 on integrated j2 week
15:48:45 <ttx> #info j2 plans will be refined as we get closer to j2 date
15:48:59 <ttx> OK, that's all I had, anything else you wanted to mention ?
15:49:05 <devananda> nope - thanks!
15:49:11 <ttx> #info Nova approved the spec for an ironic virt driver
15:49:27 <ttx> devananda: many thanks!
15:50:08 <ttx> jraim: last call
15:50:17 <jraim> ttx: I'm here
15:50:20 <jraim> sorry about that
15:50:21 <ttx> hah!
15:50:26 <jraim> IRC client didn't notify me for some reason
15:50:26 <ttx> no pb, deva was early
15:50:33 <ttx> #topic Barbican
15:51:47 <jraim> are you waiting on me? Or is my IRC client being weird again?
15:51:54 <ttx> no, thinking
15:52:07 <ttx> jraim: how do you want to handle juno-2 ? Should I take over the release management ?
15:52:51 <jraim> I think I would be fine with that. Our plan was to just do the release like we've done previously
15:52:54 <ttx> (mostly means you would just confirm a SHA to tag, ideally during the common juno-2 week, and I would do the rest)
15:53:11 <jraim> That seems good to me
15:53:18 <ttx> well, except i'm not around at juno-� so proobably someone else would do it, but that's the plan
15:53:22 <ttx> juno-2*
15:53:59 <ttx> jraim: let me check the launchpad rights
15:54:35 <ttx> jraim: to align with other projects, you should rename https://launchpad.net/~barbican-core to barbican-drivers
15:54:40 <ttx> and add openstack-release in it
15:54:49 <ttx> so that we can change bug status at release time
15:55:22 <jraim> barbican drivers? that's the normal name for the core reviewers?
15:55:22 <ttx> that way we can handle the Launchpad end of things
15:55:38 <ttx> those are actually two different groups
15:55:45 <ttx> COre reviewers are defined in gerrit
15:56:04 <ttx> the launchpad driver group is for blueprint targeting and such
15:56:14 <jraim> ahh okay, we can change that stuff
15:56:17 <ttx> currently you have two things named barbican-core
15:56:21 <ttx> and probably out of sync
15:56:28 <ttx> https://launchpad.net/~barbican-core
15:56:29 <ttx> and
15:56:44 <ttx> https://review.openstack.org/#/admin/groups/178,members
15:56:48 <ttx> those are not synced
15:56:55 <ttx> so keeping the same name is a bit confusing
15:57:08 <jraim> fair enough
15:57:11 <jraim> we'll get that cleaned up
15:57:22 <ttx> that's why the Launchpad driver group is usually called $PROJECT-drivers
15:57:32 <jraim> makes sense
15:57:43 <ttx> and in order for us to set milestones on fixed bugs etc. openstack-release has to be added to it
15:58:02 <jraim> okay, we'll get that group added
15:58:09 <ttx> well, rrenamed
15:58:25 <jraim> yeah, rename the main group and add -release
15:58:29 <ttx> you don't need a new group, just rename the Launchpad "barbican-core"
15:58:36 <ttx> will avoid further confusionb
15:58:39 <ttx> -b
15:58:54 <ttx> ok, once that's done we should be able to do releasing
15:58:59 <jraim> great
15:59:04 <jraim> I'll get that done today
15:59:19 <ttx> Is https://launchpad.net/barbican/+milestone/juno-2 representative of your j-2 goals ?
15:59:26 <ttx> or astill a bit incomplete ?
15:59:47 <jraim> my guess is that it is still incomplete
15:59:52 <jraim> I'll run through it today to get caught up
16:00:08 <ttx> #action jraim to rename ~barbican-core in LP to ~barbican-drivers and add ~openstack-release to it
16:00:17 <jraim> We have our mid-cycle next week, so we'll get that cleaned up with everyone there
16:00:26 <ttx> jraim: no hurry, just needs to be more..; accurate as we get closer to the milestone
16:00:50 <ttx> but then, communicating what's likely to be landed is a good exercise
16:00:55 <jraim> cool. should be easy with everyone in the same room to get it all cleaned up
16:00:56 <jraim> yeah
16:01:05 <ttx> we use the launchpad blueprint page as a tool for communicating likely-landing features
16:01:27 <ttx> once integrated, your input is aggregated to http://status.openstack.org/release/
16:01:44 <ttx> which presents the whole integrated picture
16:01:51 <jraim> right.
16:02:03 <ttx> jraim: ok, that's all I had for today -- anything you wanted to mention, any question ?
16:02:34 <jraim> not too much, we've been getting ready for the mid-cycle next week
16:03:10 <ttx> rigth
16:03:32 <ttx> if you have a wikipage fr that event, you can add it to
16:03:36 <ttx> https://wiki.openstack.org/wiki/Sprints
16:03:43 <ttx> currently points to a TBD
16:03:50 <jraim> we have an eitherpad set up so I'll go link it
16:03:54 <ttx> cool
16:04:08 <ttx> well, have a great July 4 weekend
16:04:14 <jraim> you too, thanks!
16:04:21 * ttx works tomorrow
16:04:43 * ttx realizes he works on French and US holidays
16:04:51 <ttx> something needs to be fixed here
16:05:09 <ttx> anyway, that concludes our 1:1s for today
16:05:13 <ttx> Thanks everyone!
16:05:19 <ttx> #endmeeting