11:53:26 <ttx> #startmeeting incub_sync
11:53:27 <openstack> Meeting started Thu Aug 21 11:53:26 2014 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:53:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
11:53:30 <openstack> The meeting name has been set to 'incub_sync'
11:53:35 <ttx> #topic Zaqar
11:53:59 <ttx> #link https://launchpad.net/marconi/+milestone/juno-3
11:54:16 <flaper87> #info launchpad project is being renamed now
11:54:44 <flaper87> anyway, there are quite some blueprints in "Needs Code Review" state
11:54:54 <ttx> flaper87: I see the rename blueprint is implemented, is LP the last step?
11:55:03 <flaper87> ttx: yeah
11:55:07 <ttx> ok, cool
11:55:12 <flaper87> devstack, client and everything else is handled
11:55:27 <ttx> agree, a lot still in review
11:55:35 <flaper87> there are quite some blueprints in "NEeds code review", we are all over them
11:55:49 <flaper87> Most of them will likely land this/next week
11:56:10 <flaper87> As for the 4 bugs in Triaged, the asignees are working on them. Some already have patches under review
11:56:20 <ttx> https://blueprints.launchpad.net/marconi/+spec/document-config-options --> that can probably be finished by RC1
11:56:30 <flaper87> As of now, most of the pending work we have is related to docs and reviews
11:56:33 <ttx> if need be
11:56:40 <flaper87> ttx: +1
11:56:50 <ttx> doc (and adding tests) is not really considered a feature
11:57:06 <ttx> as in, nothing bad can come out of adding some
11:57:12 <flaper87> Right but we still have the graduation thing :P
11:57:22 <flaper87> which will be before RC1, IIRC
11:57:33 <ttx> yes, it's currently scheduled for...
11:57:48 <flaper87> We'd like to go for it, still need to do the go/no-go voting
11:57:50 <ttx> Sep2 and Sep 9 meetings
11:57:56 <flaper87> right
11:59:19 <ttx> OK, that looks good, just a lot of ground still to cover
11:59:33 <ttx> you might want to defer stuff that obviously won't make it at the earliest
11:59:49 <ttx> like that "not started" thread-model
12:00:06 <ttx> doesn't sound like something you can do on the back of a towek over lunch
12:00:10 <ttx> towel
12:00:13 <flaper87> yeah, there are 2 blueprints that I'll likely defer if I don't see anything by mid next week
12:00:28 <flaper87> yeah, the thread-model is one of them
12:00:47 <ttx> do you have any question ?
12:00:55 <flaper87> Kurt mentioned he would work on it starting tomorrow/next week. If nothing happens by then, I'll push it to K
12:00:57 <flaper87> not from me
12:00:59 <ttx> Like on PTL duties vs. milestone release?
12:01:01 <ttx> ok
12:01:26 <ttx> consider yourself synced. Talk to you next week!
12:01:34 <flaper87> awesome, thanks!
12:01:42 * flaper87 feels synced
12:50:29 <ttx> Kiall: around? Missed our time again
12:50:35 <Kiall> Heya :)
12:50:45 <ttx> don't hesitate to ping me :)
12:50:49 <ttx> #topic Designate
12:50:59 <Kiall> I figured you were still on holidays :)
12:51:10 <ttx> if only
12:51:11 <ttx> #link https://launchpad.net/designate/+milestone/juno-3
12:51:36 <ttx> https://blueprints.launchpad.net/designate/+spec/mdns-designate-mdns-tsig has unknown state ? Or is it just not started?
12:51:42 <Kiall> So, you're going to ask about those 2 BPs assigned to me :)
12:51:55 <Kiall> That should be "Not started" - Not sure how it ended up "Unknown"
12:52:00 <ttx> willfix
12:52:19 <Kiall> Both are still planned for j3, both are mine, and I'll have them in the next 5-6 days
12:52:21 <ttx> Kiall: those definitely look like the most in jeopardy as far as J3 is concerned, yes :)
12:53:14 <ttx> Otherwise the plan looks good, just a bit late
12:53:38 <Kiall> Anyway, the next two, Expose SOA and NS Records and Migrate a Zone Between Tenants With No Interruption of Resolution are both going though code review / tweak cycles
12:54:37 <ttx> ok, that works
12:54:47 <ttx> Did you have any question on juno-", feature freeze, or anything?
12:54:51 <ttx> juno-3 I mean
12:55:59 <Kiall> 1 :) for j3, will you be performing the release, and any way to test in advance? There was trouble doing it last time
12:56:45 <Kiall> (Gerrit ACLs hadn't applied by the time the release was done, and haven't been tested)
12:56:55 <ttx> Kiall: I'll do it yes.
12:57:06 <ttx> Not sure how we can test that
12:57:12 <ttx> I can check them out
12:57:25 <Kiall> Excellent :)
12:57:41 <ttx> #action ttx to check that Designate gerrit ACLs would not block J3 publication
12:58:13 <ttx> Kiall: ok then, talk to you later!
12:58:23 <Kiall> yes, nice and quick :) Thanks!
15:33:47 <ttx> jraim: around?
15:33:57 <jraim> ttx: yes
15:33:59 <ttx> #topic Barbican
15:34:14 <ttx> #link https://launchpad.net/barbican/+milestone/juno-3
15:35:06 <ttx> This looks a bit behind with only 2 weeks to go
15:35:31 <jraim> Yes. We've been tracking some of the big things
15:35:32 <ttx> Is https://blueprints.launchpad.net/barbican/+spec/restructure-pkcs11-plugin doable in that timeframe?
15:35:39 <jraim> I don't think all of them are going to land
15:35:52 <jraim> I need to talk to Paul. I think he's actually done work on that, so Not Started may not be right
15:35:59 <jraim> but if he isn't anywhere, it'll get pushed
15:36:20 <ttx> OK, the idea is to remove stuff that will be deferred as soon as possible, so that we don't communicate wrong expectations
15:36:53 <jraim> Sounds good to me. I'll reach out to those folks today / tomorrow and see if we can push a few things
15:37:06 <ttx> Also you should expect a peak in gate activity in the next two weeks, so get what you can in early :)
15:37:24 <jraim> Ha, I forgot about that :). Will do.
15:37:41 <ttx> That's all I had for today, do you have any question ? Re juno-3 or feature freeze or...
15:38:00 <jraim> Nope. I was happy with the way the review went.
15:38:09 <jraim> Do we need to have another? I think we were all in consensus?
15:38:21 <ttx> jraim: no I think we don't need a part 2
15:38:32 <ttx> which is usually a good sign we are on the same line
15:38:50 <jraim> Okay. That's all I had. We're in the process of getting specs and stuff set us for all the integration work, but they are all Kilo targeted
15:39:14 <ttx> ok then, talk to you later
15:39:25 <jraim> Talk to you later
15:39:34 <ttx> lucasagomes: ready when you are
15:39:40 <lucasagomes> hey
15:39:46 <ttx> #topic Ironic
15:39:56 <lucasagomes> #link https://launchpad.net/ironic/+milestone/juno-3
15:40:05 <lucasagomes> Compared with last week we have 3 more blueprints implemeted this week
15:40:11 <ttx> Nice
15:40:13 <lucasagomes> https://blueprints.launchpad.net/ironic/+spec/cleanup-all-imagecaches, https://blueprints.launchpad.net/ironic/+spec/drac-power-driver and https://blueprints.launchpad.net/ironic/+spec/enabling-ipmi-double-bridge-support
15:40:23 <lucasagomes> In the High priority list all the bps are already started and have code waiting for review.
15:40:31 <lucasagomes> Two of them 'Management Inteface' and 'iPXE' has the code already merged in Ironic and are just waiting for tempest and devstack changes, respectively. (I've pinged people on the -qa channel to try to speed up the reviews so I can mark them as Implemented)
15:40:40 <ttx> everything feel on track to you ? Or are there things you already know will miss?
15:41:05 <lucasagomes> so there's only one Low priority that I'm not sure it will make it
15:41:10 <ttx> ok
15:41:16 <lucasagomes> which is the SNMP one
15:41:20 <ttx> what about the tow "unknown" status ones ? Are they just not started?
15:41:26 <ttx> s/tow/two
15:41:28 <lucasagomes> there's no code up for review yet, and I've emailed the author
15:41:40 <lucasagomes> yeah, the DRAC one I know the author and I know he's working on it
15:41:53 <ttx> shall we mark both "started" ?
15:42:11 <lucasagomes> there's no code for them yet
15:42:32 <ttx> that's fine. If the dev started working on it, we use "started"
15:42:45 <lucasagomes> alright, I will do it
15:42:49 <ttx> I'm on it
15:42:56 <lucasagomes> so about the SNMP one the author said that
15:43:19 <lucasagomes> it's written and in use on their site but they need more time to refine and improve unit testing, also, he have not been through the company procedures for external code release yet
15:43:22 <ttx> (reference: see https://wiki.openstack.org/wiki/Blueprints#Implementation for status codes)
15:43:34 <lucasagomes> ttx, thanks I will check that out
15:44:10 <ttx> ok, did you have any question?
15:44:39 <lucasagomes> but J3 is looking good in general, me and other cores in ironic will do a hangout every tuesday to try to speed up the review process for the bps we already have approved
15:44:52 <lucasagomes> ttx, hmm nothing specific
15:44:54 <ttx> ok
15:45:02 <ttx> lucasagomes: talk to you later then!
15:45:06 <lucasagomes> ttx, thanks
15:45:09 <ttx> #endmeeting