16:00:33 <ttx> #startmeeting incub_sync
16:00:37 <openstack> Meeting started Thu Dec 4 16:00:33 2014 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:38 <ttx> #topic Barbican
16:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:41 <openstack> The meeting name has been set to 'incub_sync'
16:00:45 <ttx> We finally manage to meet :)
16:01:00 <ttx> A few checks on the project first
16:01:06 <ttx> https://launchpad.net/barbican/
16:01:11 <ttx> Teams are set up fine
16:01:17 <redrobot> Indeed! Sorry I missed you last Thursday, slept in because of Thanksgiving. :)
16:01:25 <ttx> Missingf the next kilo milestones
16:01:38 <ttx> Should I create them for you ? You plan to align with the common ones, right ?
16:01:52 <redrobot> yes, we plan to stick to the Kilo Schedule
16:01:57 <ttx> ok, let me create them
16:02:50 <ttx> ok set
16:03:20 <ttx> As far as artifacts go, is there anything else to "release" at milestones apart from barbican itself ?
16:03:59 <redrobot> thanks. no, the barbican tarball should be all that is needed
16:04:17 <ttx> OK, I checked the tarball jobs earlier and we should be all set on that side
16:04:21 <ttx> https://launchpad.net/barbican/+milestone/kilo-1
16:04:29 <ttx> Let's have a quick look at the k1 plans
16:04:54 <ttx> As a reminder, we use the LP milestone pages to communicate what is coming
16:05:18 <redrobot> Yes, I spent some time the last few days cleaning up the blueprints
16:05:22 <ttx> Are those 2 blueprints the only things that will land in k1 ?
16:05:27 <ttx> or do you expect more ?
16:05:53 <ttx> (if more has already landed, feel free to retroactively add implemented blueprints :)
16:05:53 <redrobot> No, I don't expect any more BPs to land for k1. We're still reviewing BPs that came out of the summit.
16:06:02 <ttx> alright, sounds good
16:06:18 <redrobot> I do want to drum up bugfixes in the next couple of weeks, so I'm hoping some bugs will land.
16:06:27 <ttx> No more questions from me. Any question on your side ?
16:07:05 <redrobot> I was curious about where to direct TC questions? is it the openstack-tc dev list?
16:07:22 <ttx> redrobot: depends.
16:07:25 <redrobot> There's been questions about the integration requriements/dates etc
16:07:57 <ttx> redrobot: if you're proposing a governance change, it can be directly proposed as code change to openstack/governance
16:08:14 <ttx> redrobot: If you're proposing a landslide change, better sent it to -dev ML
16:08:37 <ttx> redrobot: if it's just a simple question to TC members, you can use the -tc ML or the Open Discussion section of the TC meeting
16:08:54 <redrobot> I see.
16:09:16 <redrobot> I think that's all I have for today.
16:09:31 <ttx> redrobot: Answer is likely to be dependent on the fate of https://review.openstack.org/#/c/138504/ though
16:09:59 <redrobot> Yeah, I saw that discussion during the last TC meeting.
16:10:10 <ttx> redrobot: alright then, have a good week!
16:10:14 <redrobot> thanks you too!
16:10:37 <ttx> bswartz: around?
16:10:48 <bswartz> ttx: hi
16:10:50 <ttx> #topic Manila
16:11:01 <bswartz> you have a nice office here, ttx
16:11:04 <bswartz> lol
16:11:04 <ttx> So first let's do a bit of sanity check on Launchpad permissions
16:11:32 <ttx> To match what we have for other projects you should change a few things on https://launchpad.net/manila/
16:11:49 <ttx> The manila-core team should be renamed manila-drivers
16:12:20 <bswartz> wait I thought drivers and core team were 2 different groups
16:12:26 <ttx> And you should add openstack-release to it
16:12:44 <ttx> Yes they are. But we don't define -core in Launchpad
16:12:49 <bswartz> ah
16:12:57 <ttx> since -core is used for reviews, it's defined on Gerrit
16:12:57 <bswartz> okay that makes sense
16:13:18 <ttx> basically manila-drivers are the people allowed to play with Launchpad Manila blueprints
16:13:24 <bswartz> so who should be in the drivers group, other than me and openstack-release?
16:13:31 <ttx> and create stuff on those pages.
16:13:45 <ttx> bswartz: whoever you want to delegate that not-so-funny task to, if any
16:14:24 <ttx> for erference, manila-core is defined there: https://review.openstack.org/#/admin/groups/213,members
16:14:56 <ttx> So the simpler is to rename the manila-core group in LP to manila-drivers and clean it up
16:15:14 <ttx> Then you can set manila-drivers both as "Driver" and "Maintainer" of the project
16:15:26 <ttx> otherwise we'll miss part of the necessary permissions to run the release scripts
16:15:29 <bswartz> does openstack-infra need to be a driver?
16:15:49 <ttx> no. But they may want to "own" that team to be able to take over
16:16:12 <ttx> i.e. you can change the "Owner" of manila-drivers to be openstack-admins
16:16:20 <ttx> and then you remove openstack-admins from the group itself
16:16:26 <bswartz> openstack-infra was added to manila-core so the proposal bot could propose things
16:16:36 <ttx> that lets them explicitely add themselves to fix things, but with an audit trail
16:17:02 <ttx> Hmm, not sure that's needed anymore
16:17:18 * ttx checks other projects
16:17:49 <ttx> yeah, other projects don't have the infra bot in "drivers"
16:18:29 <ttx> Once you added openstack-release to the -drivers team I'll be able to fix your milestones
16:18:37 <bswartz> okay
16:18:48 <bswartz> I have created the drivers group and assigned it power
16:18:49 <ttx> bswartz: you're using different dates currently, is that on purpose ? or should I fix them to align them ?
16:18:55 <bswartz> please fix them
16:19:06 <ttx> ok, will do once you enable me
16:19:15 <bswartz> I set up the milestones before the official dates were announced
16:19:23 <ttx> ok, quick check on k1
16:19:24 <bswartz> you should be enabled now
16:19:35 <bswartz> let me know if it's not working
16:20:00 <ttx> should be good once I accept invite
16:20:08 <ttx> done
16:20:24 <ttx> yep, looks good.
16:20:29 <ttx> so.. k1
16:20:33 <ttx> https://launchpad.net/manila/+milestone/kilo-1
16:20:47 <bswartz> yes
16:20:59 <bswartz> the list of BPs needs cleaning up
16:21:00 <ttx> Like I said to Douglas, the idea is to maintain this page to describe what's likely to come up, to the best of your prediction abilities
16:21:03 <bswartz> we discussed that in the previous hour
16:21:10 <ttx> It's never exact science obviously
16:21:28 <ttx> ideally all BPs should have an assignee, a priority and an implementation status
16:21:33 <bswartz> I have an AI to remove BPs that definitely won't happen
16:21:51 <ttx> OK, we can review the list next week once you clean it up
16:21:56 <bswartz> and then to track down the assignees of the remaining ones and make sure they're on track
16:22:03 <ttx> We'll have just one week left to milestone, so that's a good moment to do that
16:22:12 <bswartz> one week?
16:22:16 <bswartz> I thought 2
16:22:26 <ttx> next week, we'll have only one week left
16:22:37 <bswartz> https://wiki.openstack.org/wiki/Kilo_Release_Schedule
16:22:46 <bswartz> this says 18 December
16:22:56 <bswartz> which is 2 weeks
16:23:05 <ttx> yes, so next week (Dec 11) we'll be one week away
16:23:12 <bswartz> oh okay
16:23:19 <ttx> sorry that was confusing :)
16:23:34 <bswartz> I'm just glad I didn't tell a lie in the previous meeting
16:23:34 <ttx> basically, reviewing the list this week to have a good list next week is good timing
16:23:43 <bswartz> since I told everyone 2 weeks
16:23:45 <ttx> the Wiki is always Right.
16:24:02 <ttx> OK, that's all for today. Questions on your side ?
16:24:09 <bswartz> nope I'm alright
16:24:15 <ttx> alright then, have a great week!
16:24:18 <ttx> flaper87: around?
16:24:20 <bswartz> I still haven't dealt with the tarball thing, it's not urgent though
16:24:30 <ttx> I think it should be working now
16:24:40 <ttx> I checkjed and the job is definitely defined
16:24:45 <bswartz> manila tarball should be working?
16:24:46 <ttx> so we'll tag and pray
16:24:54 <bswartz> okay I will follow up on that
16:25:18 <ttx> bswartz: you already have a manila-branch-tarball building per-commit tarballs at
16:25:20 <ttx> http://tarballs.openstack.org/manila/
16:25:36 <ttx> the manila-tarball job is triggered when a tag is pushed. Like around milestones
16:25:51 <bswartz> nothing special other than making a tag?
16:26:08 <ttx> I'll ask infra to doublecheck, but the job is defined, so should work
16:26:16 <ttx> #action ttx to ask infra about manila-tarball
16:26:17 <bswartz> thanks
16:26:25 <ttx> #action ttx to fix kilo milestones for manila
16:26:28 <ttx> np :)
16:26:36 <ttx> flaper87: around now ?
16:26:52 <ttx> Kiall: maybe you can go now
16:26:58 <Kiall> Heya
16:26:59 <ttx> #topic Designate
16:27:00 <Kiall> I'm here..
16:27:14 <ttx> ok, so sanity check on the Launchpad project
16:27:24 <Kiall> Sure - https://launchpad.net/designate/+milestone/kilo-1
16:27:47 <ttx> Perms set correctly. I will add the missing kilo milestones unless you tell me not to
16:28:00 <ttx> #action ttx to create Designate kilo milestones
16:28:17 <Kiall> Sure, go ahead :)
16:28:26 <ttx> For release artifacts, is there anything else to "release" than designate itself ?
16:28:31 <ttx> (around milestones)
16:28:46 <Kiall> No, Just the designate tarball
16:28:55 <ttx> sounds good
16:28:59 <ttx> https://launchpad.net/designate/+milestone/kilo-1
16:29:33 <ttx> Looks good anyone assigned to https://blueprints.launchpad.net/designate/+spec/add-reload-config-files and https://bugs.launchpad.net/designate/+bug/1387662 yet ?
16:30:24 <Kiall> No, no assignee for either yet - the BP is Wishlist if someone happens to do it, the bug I'll need to get someone on it
16:30:33 <ttx> ok, makes sense
16:30:52 <ttx> Well, this looks very much under control. Questions on your side ?
16:31:29 <Kiall> Yep (sorry - it's long ;))
16:31:41 * ttx braces himself
16:32:30 <Kiall> - We're working through some big enough changes, the core pieces have landed, but we're struggling to get the new stuff totally integrated, while keeping compatibility for the old stuff.. We're mostly agreed within the team that if we broke the old stuff for K1, and fixed in K2, we're happy.. Not sure what the general policy around this though
16:33:21 <ttx> Well, I'd say that as long as you're just incubated, we don't really set expectations there
16:33:53 <ttx> so that is fine (as long as you realize it's not something to do on "released" software)
16:33:57 <Kiall> Okay - I'm guessing the answer is different for integrated projects then?
16:34:12 <ttx> Well, those are "released" and are supposed to be always usable
16:34:24 <ttx> and have drastic deprecation policies
16:34:32 <Kiall> Ah, yes- I get you now :)
16:34:59 <ttx> You might still want to communicate that on -dev though
16:35:08 <ttx> to warn devs and early adopters
16:35:16 <Kiall> Will do
16:35:26 <ttx> Kiall: anything else ?
16:35:34 <Kiall> Okay, that was the only Q I had for you anyway, we'll know at out next meet if we'll go the break in K1 fix in K2 or if we can find another way...
16:35:51 <ttx> Kiall: ok
16:36:01 <ttx> Kiall: have a great busy week then :)
16:36:09 <ttx> flaper87: last call
16:36:10 <Kiall> I'll try ;)
16:36:48 <ttx> flaper87: ok, we'll sync next week... ping me if you have urgent concerns.
16:36:57 <ttx> #endmeeting