19:01:31 <jeblair> #startmeeting infra
19:01:32 <openstack> Meeting started Tue Jun 25 19:01:31 2013 UTC.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:35 <openstack> The meeting name has been set to 'infra'
19:01:43 <jeblair> agenda:
19:01:45 <jeblair> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
19:01:51 <jeblair> last meeting:
19:01:52 <jeblair> #link http://eavesdrop.openstack.org/meetings/infra/2013/infra.2013-06-18-19.02.html
19:02:01 <jeblair> #topic Actions from last meeting
19:02:14 <jeblair> jeblair start a ml thread about asterisk
19:02:22 <jeblair> i have failed to do that, which is ridiculous.
19:02:24 * ttx lurks for the Neutron rename part
19:02:43 <jeblair> #action jeblair start a ml thread about asterisk
19:03:04 <jeblair> pleia2, jlk make git.openstack.org exist
19:03:11 <pleia2> after fighting with selinux, I have a test instance up here with some basic projects in it, http://15.185.88.233/cgit/ now just working on infrastructure bits
19:03:31 <pleia2> right now on a script to parse projects.yaml to generate the git repo configuration
19:03:51 <jeblair> pleia2: awesome; what kind of selinux changes are needed?
19:04:19 <pleia2> jeblair: sadly simple, I just need to apply the right selinux permissions to the /var/lib/git directory after creating it
19:04:33 <jeblair> pleia2: cool, does our version of puppet make that easy?
19:05:01 <pleia2> jeblair: should be fine, even if we make puppet run the bash command
19:05:19 <clarkb> I think puppet may have native support for it. I would check in their type reference
19:05:27 <pleia2> it's just "restorecon -R -v /var/lib/git/"
19:05:33 <pleia2> clarkb: cool, I'll have a look
19:06:00 <fungi> or there might be a boot-time something parsing a run-parts directory where we can stash an selinux config stub for that setting?
19:06:08 <clarkb> pleia2: yup there appear to be sel* parameters to the file type
19:06:15 <fungi> oh, perfect
19:06:18 <pleia2> great
19:06:18 * mordred loves the new cgit
19:06:33 <jeblair> fungi: it looks like it's not a config setting, but rather the directory needs the appropriate label set
19:06:42 <fungi> got it
19:06:45 <pleia2> it just needs the defaults set
19:06:52 <jeblair> fungi: more like making sure the directory gets created with the correct perms, or fixing them if not.
19:06:56 <pleia2> (not sure why that's not automatic, but selinux)
19:07:20 <fungi> yeah, so built-in puppet groking it on the file object is ideal
19:07:39 <mordred> pleia2: the URL loses the containing directory - so doing links might be weird
19:07:55 <pleia2> mordred: ah, like the top level "openstack-infra" etc?
19:08:02 <mordred> yah. e.g: http://15.185.88.233/cgit/ceilometer/
19:08:22 <mordred> but in general, it looks quite nice
19:08:31 <pleia2> *may* actually be able to alter the url based on section, I'll keep that in mind
19:08:40 <jeblair> pleia2: if possible, i think that would be ideal
19:08:47 <clarkb> ++
19:09:16 <jeblair> (we should see what gerrit does with that when we tell it to make cgit urls)
19:09:53 <mordred> I was just looking at the gitweb link with https://review.openstack.org/gitweb?p=openstack%2Fheat.git;a=commitdiff;h=f63e5ef6db25d23ac8c77425481071ca5b209591
19:10:01 <mordred> which has the full openstack/heat embedded in it
19:10:03 <pleia2> fungi: and I'll probably grab you when it comes to the actual replication work (getting the git repos over to git.o.o and keeping populated) since you have some experience there :)
19:10:18 <pleia2> yeah
19:10:21 <fungi> pleia2: sure, it's pretty straightforward
19:10:32 <fungi> happy to help
19:10:38 <jeblair> mordred: yeah, i _assume_ that it will do the same thing, but maybe not.
19:10:43 <mordred> jeblair: :)
19:10:54 <mordred> assuming anything with gerrit is dangerous
19:11:04 <clarkb> s/with gerrit//
19:11:05 <jeblair> #topic neutron rename
19:11:31 <jeblair> "markmcclain will come back to us when the code-level rename is done and we're ready to move forward with repo+devstack+devstack-gate rename"
19:11:35 <jeblair> i assume that hasn't happened yet
19:11:50 <mordred> I have heard no updates on that topic
19:12:10 <jeblair> so unless anyone jumps in, i assume we're in a holding pattern.
19:12:22 <markmcclain> yep.. no big updates
19:12:27 <ttx> jeblair: objections to us asking LPadmins to rename the project in LP ?
19:12:47 <markmcclain> I do have 1 question on timing
19:12:49 <fungi> ttx: if it happens ahead of time, bug updates will need patching
19:13:23 <ttx> fungi: I think that's better than continuing to use "Quantum" there
19:13:36 <jeblair> ttx, fungi: yeah, i think we can live with patching the bug update script.
19:13:36 <clarkb> its a small patch too
19:13:48 <jeblair> markmcclain: ?
19:13:49 <fungi> yep, just wanting to make sure we remember to do that
19:13:56 <ttx> changing the project name in LP takes care of a large "attention getting use" of QUantum
19:14:22 <jeblair> ttx: do you want to put in that request?
19:14:47 <markmcclain> jeblair: with H2 in coming up.. what is the ideal day/time to the have outage to rename?  (this will kind of dictate our schedule of changes)
19:14:57 <ttx> jeblair: I can do it, if you don't beat me to it... will do tomorrow though
19:15:06 * ttx is a bit struggling with time tonight
19:15:21 <jeblair> #action ttx request lp admins rename quantum to neutron (and patch bug script)
19:15:47 <ttx> ack
19:16:08 <jeblair> markmcclain: i think we should do the rename outage between a us friday afternoon and sunday evening.
19:16:28 <jeblair> markmcclain: it's a short outage, but because it's part of the gate, is likely to impact everything for a while
19:17:43 <markmcclain> right.. and I'm guessing the post 4th weekend is out or would that be ideal?
19:18:19 <clarkb> I will be in another state, but won't be camping or anything so that should work for me
19:18:36 <clarkb> but other peopel may be enjoying the holiday properly :)
19:18:46 <jeblair> i think we want to try to get as many core reviewers from other projects around
19:19:16 <markmcclain> we should be able to run changes for the other projects through before the cut over
19:19:19 <fungi> i too will be in another state. need to check when my flights are
19:19:20 <ttx> markmcclain: July 13 is late, June 29 is short, July 6 is a bit after July 4th
19:19:49 <jeblair> i would be okay with that weekend
19:20:07 <fungi> as long as i'm not in the air, i should be able to pitch in
19:20:24 <ttx> I'd rather avoid July 13 and I doubt June 29 is an option... so July 6 sounds good
19:20:26 <markmcclain> I'll be around the 6th and thought the timing gives plenty of warning to everyone
19:20:55 <markmcclain> the 29th would be a bit too disruptive given short notice
19:21:02 <jeblair> okay, that sounds good.
19:21:08 <ttx> the 13th would affect h2 and be risky
19:21:16 <markmcclain> ttx:  agreed
19:21:45 * mordred adjacent to a wedding on the 6th, fyi, but can help out if we do earlier in the day
19:22:07 <jeblair> 7th is a possibility too.
19:22:15 <fungi> yeah my flight home is late on the 7th, so i can likely arrange to be in the vicinity of internets for a while on the 6th
19:22:16 * markmcclain good any day that weekend
19:22:27 <jeblair> mordred: how early?
19:22:33 <ttx> good any day too
19:22:57 <mordred> jeblair: don't know - don't have schedule for the weekend yet - just assuming that earlier == less on my plate
19:23:27 <fungi> anything after 1600z on the 7th is likely to catch me in and out of airports and planes
19:23:32 <jeblair> k.  well, let's try for the 6th then
19:24:07 <jeblair> mordred: oh, and you're in PDT then right?
19:24:16 <mordred> jeblair: nope. NYC
19:24:30 <mordred> jeblair: friends here are getting married on the 7th- I'm lighting it
19:26:11 <jeblair> what time on the 6th then?  1500 1600 utc?
19:27:00 <clarkb> 1600 is better for me but I can probably do 1500 if that helps mordred and fungi
19:27:00 <mordred> I think those both work for me
19:27:08 <jeblair> i can send the gerrit outage notice...
19:27:12 <mordred> I thinkn 1600 would be fine
19:27:29 <jeblair> is someone keeping track of changes that need to get merged in other projects?
19:27:40 <markmcclain> jeblair: yes
19:27:49 <markmcclain> I'll publish a wiki with that info
19:27:52 <ttx> jeblair: if you need me I can hop around 1600 and then do 1900+ if necessary
19:27:59 <jeblair> #action jeblair announce gerrit outage for quantum->neutron rename july 6th 1600 utc
19:28:35 <jeblair> ttx: awesome, the more the merrier.  anything could break.  :)
19:28:53 <ttx> jeblair: if it's LP don't count on me to patch it
19:29:13 <jeblair> #action markmcclain publish wiki page with view of changes that need to be merged in other projects
19:29:29 <jeblair> anything else on this topic?
19:30:02 <ttx> we'll raise it again at the release meeting later today.
19:30:39 <jeblair> ttx: yeah, and we should start letting people there know we'd like to have core reviewers on hand
19:30:59 <jeblair> #topic Progress on clouddocs-maven-plugin internalization (needs: working jenkins jobs to do releases to maven)
19:31:16 <jeblair> someone added that? ^
19:31:32 * ttx afks for a bit
19:31:39 <jeblair> annegentle: did!
19:31:52 <jeblair> annegentle: you around?
19:31:58 <jeblair> zaro: ping
19:32:16 <clarkb> jeblair: I think zaro is on a plane
19:32:31 <jeblair> oh, i will try my best to summarize
19:32:38 <clarkb> but, https://review.openstack.org/#/c/34023/ should give us the ability to publish to maven repos
19:32:44 <jeblair> annegentle: zaro has changes in review ...
19:32:50 <jeblair> yeah that.  :)
19:33:11 <jeblair> annegentle: so i think we're really close to being able to publish some things we already do in gerrit
19:33:16 <fungi> #link https://review.openstack.org/34023
19:33:29 <jeblair> annegentle: and then it should not be difficult to add the docs plugin after that.
19:33:55 <mordred> ++
19:34:00 <jeblair> annegentle: so we're pretty close, and i personally really like the system -- it will work much like how we release python client libraries
19:34:10 <jeblair> which i think just about everyone who has used loves
19:34:30 <mordred> jeblair: when that's in place, should we move the scp plugin in to gerrit too?
19:34:31 <annegentle> jeblair: oh good.
19:34:38 <annegentle> zaro: thank you also
19:34:56 <jeblair> mordred: i want to keep that at arms length.  i don't think it's really ours.
19:35:00 <mordred> ok
19:35:17 <jeblair> #topic open discussion
19:35:36 <jeblair> it is hot in nyc.
19:35:41 <mordred> it is hot in nyc
19:35:50 <fungi> it is pleasant in nc
19:35:53 <mordred> also, I have arranged for dinner at a place thursday that probably requires pants
19:35:55 <mordred> sorry about that
19:36:22 <clarkb> mordred: their website says the dress code is casual. but I think nyc casual is different than seattle casual
19:36:27 <annegentle> heh
19:36:35 <mordred> honestly, I don't think it'll b ea problem
19:36:42 <mordred> we're in a private-ish room
19:36:43 <annegentle> hey so I'm looking at zaro's patch
19:37:41 <mordred> I also got a good suggestion for a wine place to go after dinner for folks who are in to that - and there's also a bar near my apartment with a moose head on the wall. so I think eveningtime is covered
19:37:58 <annegentle> and isn't maven-properties.sh used to inject enviro variables for building? We have that already, right? I was looking for progress on building the plugin itself?
19:38:08 <annegentle> not doc building, doc tools building? Or am I just lost?
19:38:16 <mordred> annegentle: for doc tools
19:38:22 <jeblair> annegentle: no that's a new, but similarly named script
19:38:36 <annegentle> jeblair: ok, whew
19:38:37 <jeblair> annegentle: you're thinking of maven-docbook-properties.sh or something like that
19:38:44 <annegentle> jeblair: too similar for my feeble brain :)
19:39:03 * mordred thinks annegentle's feeble brain holds more information about openstack than his own
19:39:08 <jeblair> annegentle: that patch (and those jobs), and the maven-properties.sh script are all about making jenkins jobs that build a war file and then upload it to maven central
19:39:20 <annegentle> jeblair: woo that was the goal
19:39:27 <annegentle> jeblair: what's after that patch lands?
19:39:38 <jeblair> annegentle: yep.  zaro has been able to do a little more that what we thought we could do at the summit
19:40:13 <clarkb> next step is slurping the project into gerrit and configurign jenkins and zuul
19:40:32 <annegentle> clarkb: okay, cool. I'll let David Cramer know.
19:40:39 <jeblair> annegentle: his system will build the war file with the correct version ir response to a tag, so the workflow should just be to tag the repo with the version, and you don't have to do the complicated commit, tag, commit dance we were talking about.
19:41:15 <mordred> some people think the tag-based-commit system is crazy. then they use it. then they stop thinking it's crazy.
19:41:24 <mordred> tag-based-version
19:41:48 <jeblair> mordred tags repos when he wants a cup of coffee.
19:41:54 <mordred> if only
19:42:07 <mordred> tagging is so much less work than getting a cup of coffee
19:42:52 <clarkb> you do have to remember the passphrase for your key
19:42:59 <fungi> so, we're up to 21 attendees registered for the bootcamp, eh?
19:43:00 <clarkb> and type it in
19:43:13 <fungi> (deduping clarkb and olaph)
19:43:24 <clarkb> that is a good number
19:43:33 <annegentle> wow that's great guys
19:43:42 <annegentle> I meant to ask, are they all flying in on their company's dollar/dime?
19:44:19 <jeblair> annegentle: yes, and only a few of them work for mordred!
19:44:30 <fungi> i think sdague's just driving in for the day? but in general yes
19:44:42 <olaph> i know i am
19:44:48 <jeblair> fungi: train i believe
19:44:51 <mordred> annegentle: we have at least one person paying their own way
19:44:56 <fungi> ahh, train waaaay better
19:45:14 <annegentle> train would be awesome!
19:45:28 <clarkb> we have a little bit of time here at the end I might as well talk more logstash/elasticsearch
19:45:38 <jeblair> clarkb: +1
19:45:38 <jlk> I would have gone on RAX dime, but I'm set to go camping that weekend, and my wife would be angry :)
19:45:41 <sdague> fungi: actually, it will be on the train
19:45:42 <clarkb> we now have a three node elasticsearch cluster. performance is much much much better with that
19:45:54 <mordred> clarkb: ++
19:46:02 <clarkb> I have also added 2 logstash gearman workers so we are up to 5 workers shoving logs into elasticsearch
19:46:39 <clarkb> I have also opened things in the reverse proxy on logstash.o.o to allow elasticsearch queries against http://logstash.openstack.org/elasticsearch
19:46:53 <fungi> so that's 9 total virtual machines dedicated to logstash now, right?
19:47:11 <clarkb> and finally I have proposed a change to retain 2 weeks instead of 1 week of indexes
19:47:15 <clarkb> fungi: yup
19:47:36 <fungi> that's some awesome scaling
19:47:38 <clarkb> I think I can go up to 3 weeks on the current hardware, but I figure I will gradually increase the backlog so that it doesn't fall over
19:48:00 <sdague> clarkb: I think 2 weeks should be enough to keep track of gate bugs at least
19:48:08 <sdague> it's a good starting point for sure
19:48:52 <sdague> logstash has already been invaluable for figuring out if flakey bugs in the gate have gone away
19:48:54 <clarkb> I am now looking forward to other people breaking it so that I can make it even better :)
19:49:07 <jeblair> clarkb: are the individual machines sized appropriatly?  or are they still at your initial best guess for ram size?
19:49:47 <clarkb> jeblair: looking at cacti I think the sizes are appropriate. Particularly for the elasticsearch nodes. We want those to be as big as possible beacuse it is a CPU, Memory, and Disk hog
19:49:48 <mordred> clarkb: have you sent any messages to the -dev list telling people about the system?
19:49:52 <clarkb> oh and network
19:50:14 <clarkb> mordred: not yet, I am really hoping that sdague can hit it first
19:50:45 <clarkb> his input has already been valuable and I want to avoid a the flood of "please fix this and that and can haz feature xyz
19:51:04 <clarkb> it is going to happen anyways but getting important ones out of the way first should help
19:51:33 <clarkb> jeblair: the worker nodes chew up 2 cpus when busy and can use the 4GB of ram if it is there
19:51:51 <jeblair> clarkb: cool
19:51:58 <mordred> clarkb: kk. cool
19:52:29 <mordred> clarkb: point mikal at it too. he's great at breaking things
19:52:44 <clarkb> will do :)
19:54:20 <clarkb> but yeah feel free to use it
19:54:25 <clarkb> it should be completely open
19:54:31 <clarkb> and feedback is good
19:55:57 <fungi> i have absolutely used it to great effect in helping devs hunt down issues with tests
19:56:07 <fungi> several times already
19:56:09 <fungi> kudos
19:58:14 <jeblair> we seem to have wound down, so thanks everyone!
19:58:28 <jeblair> i hope to see many of you in a couple of days!
19:58:30 <pleia2> thanks jeblair
19:58:37 <jeblair> #endmeeting