19:01:02 <jeblair> #startmeeting infra
19:01:02 <openstack> Meeting started Tue Oct  8 19:01:02 2013 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:05 <mordred> o/
19:01:05 <openstack> The meeting name has been set to 'infra'
19:01:12 <jeblair> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
19:01:17 <jeblair> #link http://eavesdrop.openstack.org/meetings/infra/2013/infra.2013-10-01-19.01.html
19:01:28 <jeblair> #topic Actions from last meeting
19:01:37 <jeblair> #action jeblair move tarballs.o.o and include 50gb space for heat/trove images
19:01:58 <jeblair> i have not done that.  i'll to get to that this week
19:02:29 <jeblair> i did, however, announce the maintenance
19:02:41 <mordred> I have understood the mysterious caching issue - which is that there is apparently no mysterious caching issue
19:02:42 <jeblair> which clarkb and fungi and i performed
19:02:53 <jeblair> mordred: excellent!
19:03:05 <mordred> the base image for an image build can be set via an environment variable to point to a pre-existing image
19:03:11 <mordred> which is what we'd want
19:03:18 <jeblair> mordred: then lets move onto...
19:03:22 <mordred> lifeless indicated that dib may need to grow a flag...
19:03:27 <jeblair> #topic Trove testing (mordred, hub_cap)
19:03:29 <mordred> to disable the checksum testing
19:03:45 <mordred> to disable attempting to download a new version of the base image from the internet
19:05:33 <jeblair> mordred: so what do we need to do to proceed?
19:05:33 <mordred> jeblair: I believe we just need to start writing jobs
19:05:33 <mordred> or, rather
19:05:33 <hub_cap> hilo
19:05:33 <mordred> we need to make sure that the base images that tripleo/trove/heat may need are listed in such a way that the nodepool image prep pre-downloading of things pre-downloads thenm
19:05:34 <mordred> and then we need to start writing jobs which do the image building the trove/heat/tripleo need with those pre-downloaded images as input
19:05:46 <mordred> the first one sounds like us, the second one sounds lke hub_cap
19:06:07 <hub_cap> sounds good to me. do we do them in parallel or do i have some more time to finish up the client? :)
19:07:03 <mordred> finish up the client. do we know how to tell what base images you will need?
19:07:11 <mordred> right now, we scan devstack for image urls
19:07:14 <mordred> and we pre-download those
19:07:41 <mordred> how does one tell which base images dib builds are going to want? (I think there are only two, right, but are they listed somewhere?)
19:08:03 <hub_cap> well rhel/ubuntu for each trove & heat
19:09:00 <mordred> but the base images are the same
19:09:06 <mordred> the things we download from the interwebs
19:09:15 <hub_cap> ohhh base image sry
19:10:20 <hub_cap> dib is in charge of that for us (until now hehe)
19:10:27 <jeblair> mordred: it may not be terrible to special case those in the nodepool setup scripts?
19:10:47 <mordred> jeblair: maybe we do that until we it grows past two?
19:11:07 * ttx lurks
19:11:15 <jeblair> mordred: or if dib is doing it, is there a place in dib we can consult to find the list?
19:11:33 <jeblair> mordred: as what we do now with devstack is to clone devstack and read that file...
19:12:02 <hub_cap> https://github.com/openstack/diskimage-builder/search?q=DIB_CLOUD_IMAGES&type=Code
19:12:04 <jeblair> mordred: at any rate, that actually does sound like a lot of work just to get those 2 images, so i'm still okay with hardcoding that in the nodepool scripts for now.
19:12:14 <clarkb> dib is just running shell scripts in a chroot (basically) if it isn't possible today I think it should be possible to list things in a file that is sourced by dib
19:12:48 <jeblair> clarkb: oh, that's a little easier then...
19:13:15 <mordred> yup. I think reading the files should not be terrible
19:13:20 <jeblair> mordred: you want to take a stab at that?
19:13:28 <mordred> however- that gets us into an interesting question
19:13:52 <mordred> which is that currently the plan was for heat/trove to simply consume released version of dib rather than master version
19:14:26 <stevebaker> hi
19:14:35 <mordred> I'll take a stab at pulling things from dib though - I could probably also install it with pip and then source a couple of files from well-known locations
19:15:29 <hub_cap> mordred: u can likely then run the 10-cache-*-tarball to do the dl work too
19:15:55 <stevebaker> it would be nice if you could just run dib and get it to quit before the preinstall phase
19:15:56 <mordred> hub_cap: nah. that does too much work
19:16:34 <mordred> I believe we'd like to avoid running a bunch of root-based qemu-nbd stuff on the nodes as we're prepping them for the devstack pool
19:16:38 <mordred> too many moving pieces there
19:16:53 <mordred> BUT - I think we can work with what's there
19:16:54 <stevebaker> it won't just cache the base image, also all the invoked source-repositories
19:17:12 <stevebaker> ..but, baby steps
19:17:21 <mordred> yes. I think baby steps are important
19:17:38 <hub_cap> otherwise that baby wont start walkin
19:18:13 <jeblair> cool, it sounds like we're set to proceed; anything else?
19:18:42 <jeblair> thanks!
19:18:45 <jeblair> #topic  Tripleo testing (mordred, clarkb, lifeless, pleia2)
19:18:52 <pleia2> ok, this is very exciting!
19:19:02 <pleia2> we've been fleshing out this https://etherpad.openstack.org/tripleo-test-cluster
19:19:21 <jeblair> #link https://etherpad.openstack.org/tripleo-test-cluster
19:19:25 <pleia2> if you scroll down to iteration 1, I have a review here to get that done: https://review.openstack.org/#/c/49454/
19:19:40 <pleia2> so if we could get that in soon so I can make sure it works, that would be awesome :)
19:19:54 <pleia2> I just had a call with lifeless last night to hash out the plan for iteration 2
19:20:06 <pleia2> so I have a lot of work to do, but we're on track
19:20:55 <clarkb> jeblair: will merging 49454 conflict with your gearman nodepool work?
19:21:00 <mordred> I like seeing patches! (it's now in my browser to review and stuff)
19:21:02 <jeblair> there are a lot of words there... :)
19:21:10 <clarkb> jeblair: if not I can go ahead and rereview 49454 and approve if it looks good
19:21:30 <clarkb> (or maybe if it does we make the gearman changes deal with it)
19:22:04 <lifeless> please land it, we wants the experimental queue ;)
19:22:47 <jeblair> clarkb: 49454 already uses the new syntax and is based on master, so it won't conflict
19:22:53 <pleia2> yeah, I rebased
19:23:04 <clarkb> perfect, it is at the top of my review queue now
19:23:08 <pleia2> thank you!
19:23:19 <jeblair> clarkb: we'll just want to put the gearman changes back in place so that puppet will actually apply it
19:23:52 <jeblair> (and restart puppet, i forgot to say ^)
19:25:08 <jeblair> this seems to be going smoothly.  :)  anything else on this topic?
19:25:45 <jeblair> #topic  New etherpad.o.o server and migration (clarkb)
19:25:53 <jeblair> clarkb: thank you!
19:26:16 <clarkb> a new etherpad.o.o has been spun up as well as a new etherpad-dev.o.o.
19:26:29 <clarkb> they are both running on 2GB nodes (down from 4GB) and use clouddbs for the backend database
19:26:33 <mordred> neat
19:26:59 <clarkb> I intend on fully switching out the -dev server today (DNS etc and delete the old node), but we need to plan a time to switch the etherpad.o.o hosts
19:27:23 <clarkb> process is simple. stop etherpad service on both servers, dump database, copy database to new database server, start etherpad on new server, flip DNS
19:27:47 <clarkb> I think doing that soon is better than waiting. I was thinking Sunday morning PST
19:28:28 <fungi> i'll be around if you end up needing help
19:28:33 <clarkb> it would be awesome if there was one other set of eyes making sure I don't completely derp stuff
19:28:53 * fungi is happy to lend eyeballs and fingers
19:28:56 <clarkb> fungi: awesome. Should we plan for 1600UTC Sunday? I will send an announcement to the -dev list if that works
19:29:05 <fungi> sounds great
19:29:24 <fungi> i doubt it will take long at all
19:29:40 <mordred> I'll also be around
19:29:47 <jeblair> #action clarkb announce 1600UTC Sunday etherpad outage
19:29:53 <clarkb> it shouldn't, I will also lower the TTL on the current DNS records earlier in the week so that DNS doesn't take its time
19:30:02 <fungi> k
19:30:04 <fungi> sounds great
19:30:23 <mordred> I for one welcome our new etherpad server overlords
19:30:29 <jeblair> clarkb: let us know when you move etherpad-dev, and we can all bang on it
19:30:35 <clarkb> ++ will do
19:30:51 <jeblair> clarkb, sdague: do you happen to know of a load testing tool for ep?
19:30:57 <clarkb> I don't
19:31:05 <sdague> jeblair: nope
19:31:17 <sdague> it would require something that did js well, as it's all client side rendering
19:31:24 <clarkb> #link https://github.com/ether/etherpad-lite/tree/master/bin/loadTesting
19:32:00 <clarkb> I will look at getting that load tester going
19:32:03 <sdague> clarkb: also, the folks in the #etherpad channel (or maybe it's #eplite) are super responsive
19:32:06 <jeblair> clarkb: that would be awesome
19:32:07 <sdague> so I'd just ask them
19:32:53 <jeblair> clarkb: it would be nice to be armed with information like we can definitely support a couple hundred people using it at once during the summit
19:33:01 <fungi> if it works out well, a quick blurb in the etherpad.rst about load-testing updates.changes on etherpad-dev would be awesome too
19:33:10 <pleia2> ++
19:33:27 <clarkb> jeblair: yup, I will look into the in tree load test scripts and ping them on IRC
19:33:37 <clarkb> fungi: good idea
19:34:00 <jeblair> #topic Open discussion
19:34:35 <jeblair> i'm working on a test pootle server so the translation tema can play around with it a bit before the summit
19:35:05 <pleia2> I'm off to a conference on thursday (ACM Projections | Reflections in Illinois), so will be in and out then through sunday
19:35:08 <annegentle_> jeblair: cool, thinking of it as a resplacement for transifex or is it a necessary inbewteen?
19:35:13 * annegentle_ cant' spell
19:35:18 <mordred> jeblair: excellent
19:35:37 <annegentle_> jeblair: mordred: docs does have a translation session at the summit where we can talk about tooling
19:35:40 <jeblair> annegentle_: replacement
19:35:49 <annegentle_> jeblair: got it
19:35:53 <mordred> annegentle_: yeah. you know about the transifex issue, yeah?
19:36:12 * anteaya is traveling to a conference tomorrow and then in Toronto the following week
19:36:14 <annegentle_> jeblair: I talked to Mozilla folks about the proprietary direction Transifex was taking and the woman I talked to wasn't too concerned
19:36:32 <jeblair> annegentle_: don't they use pootle?
19:36:35 <annegentle_> jeblair: but, I sorta talked her into a bit of concern I think (not really meaning to, but asking more questions that made her think)
19:36:45 <annegentle_> jeblair: they use transifex for the phone os stuff apparently
19:36:46 <mordred> annegentle_: excellent. good job
19:36:50 <annegentle_> mordred: lol
19:37:00 <annegentle_> honestly I just want to hear what the translators like best
19:37:01 <mordred> annegentle_: too many people in open source have been too complacent on the use of non-open source things, tbh
19:37:20 <jeblair> annegentle_: if you check the i18n list, you'll see recent messages like "oh, we can't use the stats api because that's a premium feature"
19:37:27 <jeblair> (the openstack-i18n list)
19:37:29 <annegentle_> I use a proprietary authoring tool because it just makes me more efficient
19:37:33 <annegentle_> but it's not required
19:37:34 <annegentle_> so yeah
19:37:38 <fungi> in the past, there weren't necessarily great free software answers to all this supporting infrastructure, but now there's a lot more itches scratched
19:37:39 <annegentle_> not cool
19:37:44 <mordred> annegentle_: I'm fine with people using proprietary things to work on openstack
19:37:49 <mordred> I'm not fine with them being required to
19:37:59 <annegentle_> mordred: yeah totally agree
19:38:01 <jeblair> so the good news is that, on paper at least, pootle has caught up in terms of what it was lacking compared to transifex
19:38:06 <mordred> jeblair: awesome
19:38:14 <anteaya> how much longer can design summit sessions be proposed?
19:38:14 <jeblair> (part of spinning this up is to examine some of that for ourselves)
19:38:33 <fungi> and also, i feel like with the resources we as a project have at our disposal, it's our duty to a great extent to provide the tools we can use to run out project if such tools don't already exist
19:38:52 <fungi> s/out/our/
19:38:53 <mordred> anteaya: not sure - it's pretty open ended
19:38:59 <mordred> anteaya: since it's run by the ptls
19:38:59 <anteaya> mordred: okay
19:39:02 <anteaya> ah
19:39:14 <annegentle_> ok then the only other open discussion thing from me was about invites, are there more going out (to ensure savanna gets invites)?
19:39:14 <mordred> anteaya: the longer you wait though, the more chance you  may have of no slots being left
19:39:15 <clarkb> fungi: ++
19:39:18 <jeblair> mordred: it has real git integration too...
19:39:20 <jeblair> A typical commit message when committing from Pootle will look something like this:
19:39:24 <anteaya> true
19:39:24 <jeblair> Commit from GNOME Pootle by user Sipho.  80 of 100 messages translated (7
19:39:25 <jeblair> fuzzy).
19:39:32 <mordred> neat
19:39:33 <jeblair> that's from http://docs.translatehouse.org/projects/pootle/en/latest/features/version_control.html
19:39:34 <annegentle_> anteaya: ttx once said a handwavy mid october :)
19:39:36 <mordred> that's exciting
19:39:48 <mordred> jeblair: any chance it has openid consumption support?
19:39:51 <annegentle_> jeblair: that's quite cool
19:39:52 <anteaya> annegentle_: okay thanks, love the specificity of the handwave
19:40:03 <fungi> that also suggests we're much closer to making translators atcs if we want, at least from a technical hurdle standpoint
19:40:18 <fungi> (assuming we use pootle)
19:40:20 <ttx> annegentle_: starting October 17 you're free to start making your schedule :)
19:40:23 <mordred> nod
19:40:46 <jeblair> mordred: i'm pretty sure it will at least work with apache mod_auth_openid
19:40:58 <mordred> jeblair: excellent
19:41:04 <ttx> annegentle_: so it's "you have at least until October 17" thing. Then each topic lead is free to have their own rules
19:41:12 * anteaya notes ttx's handwave means the 17th
19:41:38 <clarkb> I haven't submitted anything for this summit. I can't tell if that is a good thing or not
19:41:48 <clarkb> everyone else has been submitting good things :)
19:41:48 <ttx> The 17th is when *I* can start spending time looking into the issue :)
19:42:01 * anteaya wonders how the remaining calendar days translate to gestures
19:42:08 <anteaya> like baseball signals
19:42:30 <anteaya> what does it mean when you touch the peak of your cap, ttx
19:42:42 <anteaya> or rub the side of your nose?
19:42:46 <ttx> "curved RC"
19:42:50 <anteaya> ha ha ha
19:42:52 <anteaya> punt
19:42:59 <mordred> what if we all started giving dates in terms of ttx hand signals
19:43:09 <anteaya> better than utc
19:43:15 <mordred> "I'll meet you on ttx-nods-head of october"
19:43:26 <ttx> rub the side of my nose = royal flush
19:43:49 <jeblair> and i think that may signal the end of the meeting... :)
19:43:59 <clarkb> :) nothing else from me
19:44:01 <ttx> starting to derive a bit, yes
19:45:02 <jeblair> thanks everyone!
19:45:07 <jeblair> #endmeeting