19:01:12 <fungi> #startmeeting infra
19:01:13 <openstack> Meeting started Tue May  6 19:01:12 2014 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:17 <openstack> The meeting name has been set to 'infra'
19:01:24 <fungi> this should be fairly short, i think
19:01:26 <mattoliverau> o/
19:02:07 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:20 <fungi> #topic Actions from last meeting
19:02:48 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2014/infra.2014-04-29-18.59.html
19:02:52 <fungi> (none)
19:03:06 <fungi> #topic manage-projects status (mordred)
19:03:15 <fungi> it seems to be working, yes?
19:03:40 <fungi> i've personally merged a couple of things which it grabbed and ran with successfully
19:03:50 <mattoliverau> is mordred back from his 5 min task?
19:03:58 * SergeyLukjanov here
19:03:59 <clarkb> yup the i8ln project was created
19:04:06 <clarkb> seemed happy
19:04:46 <fungi> #link http://git.openstack.org/cgit/openstack/oslo.i18n/
19:04:48 <fungi> that one?
19:05:20 <clarkb> yup
19:05:45 <clarkb> I do know there are issues creating projects without a seed repo
19:05:47 <fungi> ahh, yeah 78 minutes ago and has all its history, so lgtm
19:05:52 <clarkb> mordred has a change up to fix that but it is not tested
19:06:01 <fungi> good to keep in mind
19:07:04 <fungi> "it works" is probably sufficient status, but we can revisit when mordred returns if there's anything more we need to dig into here
19:07:08 <clarkb> or was it projects that needed a seed ACL
19:07:12 <clarkb> fungi: ++
19:07:34 <fungi> as much as i'm sure we'll all miss the drama of "new project fridays"
19:07:46 <fungi> #topic Summit next week (clarkb)
19:08:28 <fungi> jeblair has asked that we work out any reshuffling which needs to happen to resolve schedule conflicts asap so he can go over them in the upcoming project meeting
19:08:30 <mordred> blast. it was 8 minutes
19:08:39 <clarkb> friendly reminder that the summit happens next week. we don't do meetings during that week and anyone that has a session under the infra track should add a link to an etherpad for that session at https://wiki.openstack.org/wiki/Summit/Juno/Etherpads#Infrastructure
19:08:47 <mordred> clarkb: ++
19:08:56 <krotscheck> Here
19:09:12 <fungi> did anyone have any requests to reschedule or rehome a session?
19:09:23 <clarkb> fungi: I basically gave up when I had like 5 triple bookings
19:09:50 <fungi> i suspect we'll just do like we always have and work out on the spot who's going to split to attend what
19:09:52 * clarkb looks at them really quickly
19:09:56 <SergeyLukjanov> it looks ok for me
19:10:53 <mordred> my schedule looked stupid as usual
19:11:04 <mordred> so I didn't think of thinking of suggesting moves
19:11:08 <clarkb> ya basically it is never going to be perfect
19:11:16 <clarkb> so I was ok with dealing with it
19:11:25 <zaro> o/
19:11:25 <fungi> works for me too
19:11:58 <clarkb> though this might be a good time to suggest paper shcedules again
19:12:07 <clarkb> because sched.org hated us in hong kong
19:12:20 <anteaya> o/
19:12:38 <mordred> clarkb: on-demand paper schedules that print out based on my username would be fantastic
19:13:17 <mordred> or monitors that respond to the nfc chip in my phone to show me my personal schedule
19:13:36 * mordred shuts up
19:14:07 * gothicmindfood thinks RFID chips for all to geo-locate each other on an openstack-infra app sounds good
19:14:12 <anteaya> i like paper schedules
19:15:03 <fungi> okay, as i see no objections raised to the current infra and infra-related sessions scheduled, and have none myself, i think this makes things easier for jeblair ;)
19:15:36 <fungi> anybody else have summit/conference-related things to cover?
19:15:49 <clarkb> monday is freeish
19:15:56 <mordred> we should all drink some time
19:15:56 <fungi> "ish"
19:16:06 <anteaya> I was going to spend some time in the ops track on monday
19:16:09 <clarkb> according to gertty zuul has 25 outstanding changes
19:16:19 <anteaya> the thing tom is organizing
19:16:22 <clarkb> I think it would be excellent to do some zuul hacking at some point
19:16:29 <clarkb> anteaya: yup me too
19:16:39 <anteaya> yes a group zuul hack
19:16:41 <fungi> yes, having people attend relevant ops sessions would be good
19:16:42 <anteaya> I would like that
19:16:45 <clarkb> but we can do the zuul thing informally
19:16:53 <clarkb> when there is time (if there is time)
19:16:59 <clarkb> maybe over dinner and beer one evening
19:17:08 <anteaya> sounds good
19:17:10 <clarkb> (lol like jeblair will be free for dinner)
19:17:11 * mordred is considering not bringing his laptop just like hong kong
19:17:28 <anteaya> you only use your phone anyway at these things
19:17:49 <zaro> yes, would like to be on better terms with zuul as well
19:17:58 <clarkb> if that falls through maybe we should consider a mid cycle zuul specific meetup
19:18:10 <anteaya> hey a mid cycle might be nice
19:18:10 <clarkb> since a generic infra one was deemed less useful last cycle
19:18:25 <clarkb> (I am just throwing ideas out there, not particularly sold on any one in particular)
19:18:39 <mordred> clarkb: by mid-cycle - you clearly mean "everyone goes to the beach at fungi's house"
19:18:47 <fungi> works for me
19:18:55 <clarkb> mordred: or hawaii
19:18:59 <clarkb> mordred: hawaii was really nice
19:19:05 <fungi> just be prepared for it to be really crowded there that time of year
19:19:16 <fungi> oh, i would totally go in for hawaii ;)
19:19:26 <anteaya> I'm up for the beach
19:19:29 <mattoliverau> jhesketh is talking about turbo-hipster, on i think monday, tho cant remember at this time of morning. He might go into my nodepool-ify of TH as well. didnt see that on any list.
19:19:32 <krotscheck> I want to grab a bunch of you and show you mockups and ask you questions.
19:19:42 <zaro> fungi ++
19:19:55 <anteaya> so yeah, fungi's house in july
19:20:03 <clarkb> fungi: also hawaii is easy for the australians apparently
19:20:07 <clarkb> so its win win :)
19:20:09 <anteaya> and I'll put zuul in the reason for on the expense report
19:20:28 <anteaya> who is there to organize something in hawaii
19:20:33 <anteaya> we can't just show up
19:20:41 <fungi> mattoliverau: do you recall whether it was a conference session or an ops summit session?
19:20:50 <mattoliverau> yeah its a little closer :)
19:21:10 <clarkb> the future of jenkins session is tuesday iirc
19:21:16 <mattoliverau> giid question, my mind doesn't work to well at 5am :P I'll find it
19:21:20 <clarkb> nope wednesday
19:21:23 <mattoliverau> *good
19:21:28 <mordred> the future of jenkins is unicorns
19:21:47 <fungi> oh, the design summit session on future of jenkins. got it
19:22:01 <clarkb> I think that is jheskeths session
19:22:10 <fungi> i definitely planned on hitting that one
19:23:19 <clarkb> any other summit things?
19:23:31 <fungi> seems like no
19:23:32 <clarkb> you know I should've proposed a future of tox session
19:23:35 <clarkb> oh well
19:23:43 <mordred> clarkb: we can always talk about that over beer
19:23:44 <anteaya> that will be over beer  Ithink
19:23:49 <anteaya> ha
19:24:01 <fungi> #action clarkb fix tox over beer
19:24:11 <jesusaurus> ++
19:24:25 <fungi> #topic Open discussion
19:24:35 <fungi> (which this more or less has been anyway)
19:24:48 <ianw> hi, just wanted to check on https://review.openstack.org/#/c/91728/
19:24:50 <jesusaurus> i would like to talk about my refactoring of the jenkins module
19:24:53 <jesusaurus> https://review.openstack.org/#/c/89708/
19:24:57 <fungi> mordred: you didn't have any additional input on manage-projects besides what we covered already, right?
19:25:05 <krotscheck> So, who’s actually been using storyboard, and what kind of feedback do you have?
19:25:24 <mattoliverau> Monday at 2pm: http://is.gd/M6V2yW
19:25:31 <mattoliverau> jhesketh ^^
19:25:39 <clarkb> jesusaurus: oh ya, that is on my list of things to review this week hopefully. But what little I saw of it is good
19:25:44 <clarkb> jesusaurus: I think the new terminology is much more clear
19:25:59 <clarkb> mattoliverau: oh at the conference proper
19:26:05 <jesusaurus> ive chatted with people in -infra on a couple occassions about it, but i still don't have any reviews
19:26:29 <mordred> fungi: nope. it should be working
19:27:04 <mordred> krotscheck: I have been using it lightly - but thusfar don't have specific feedback - I haven't used it in anger yet
19:27:10 <mordred> krotscheck: I blame my life as a PHB
19:27:25 <clarkb> jesusaurus: your change has been starred, bug me about it if I don't get around to it tomorrow
19:27:28 <zaro> krotscheck: what projects are in storyboard so far?
19:27:36 <jesusaurus> mordred: phb?
19:27:51 <krotscheck> zaro: Storyboard, storyboard webclient, zuul, gertty, nodepool
19:27:58 <fungi> jesusaurus: dilbert reference. pointy-haired boss
19:27:58 <mordred> jesusaurus: "pointy haired boss"
19:28:01 <clarkb> jesusaurus: players handbook or pointy haired boss depending on the type of nerd you are
19:28:02 <jesusaurus> ahhh
19:28:16 <jesusaurus> clarkb++ thats where my mind was
19:28:23 <mordred> clarkb: I probably would not have been saying "I blame my life as a player's handbook"
19:28:27 <zaro> jesusaurus: that's a wopper!
19:28:44 <zaro> krotscheck: are you open to adding others?
19:28:46 * mordred should have been saying that
19:29:34 <krotscheck> zaro: Absolutely, especially since you sit close enough to throw things at me when it’s annoying.
19:29:44 <zaro> jesusaurus: like the idea. will take a look
19:29:47 <anteaya> your hair is not pointy enough yet, I hope you are working on that
19:31:54 <clarkb> anything else?
19:31:56 <jesusaurus> id also like to talk a bit about the larger picture of where i want to go with refactoring jenkins
19:32:02 <clarkb> jesusaurus: go for it
19:32:24 <fungi> ianw: commented on 91728, i more or less agree with derekh_ but otherwise the change lgtm
19:32:26 <jesusaurus> i would like to see some of the modules broken out into their own repos to make them more easily used by others
19:33:00 <clarkb> ++, but first step in that is figuring out r10k and/or publishing to puppet forge automagically
19:33:21 <clarkb> which I hthink has been the biggest holdup for us. We can consume the monolithic lib easily
19:33:27 <clarkb> hard to consume when broken into pieces
19:33:29 <fungi> jesusaurus: yeah, i started reviewing 89708 but it's hugeish. i really wish we had a way to test it not-in-production
19:33:30 <jesusaurus> yes, as well as figuring out automagic upgrading on the puppetmaster
19:34:05 <jesusaurus> which implies functional testing of multiple puppet modules together
19:34:07 <zaro> should we bother with suppoting the new 'draft-published' event zuul?
19:34:14 <fungi> jesusaurus: i definitely agree with the overall concept however, and the terminology changes are great
19:34:26 <zaro> i mean 'in zuul'
19:34:29 <mordred> clarkb, fungi, jesusaurus: we have a "install modules" script already - why don't we just have it iterate over a set of git repos
19:34:30 <clarkb> zaro: I don't think so
19:34:34 <clarkb> zaro: I really want drafts to just die
19:34:39 <mordred> I mean, it's great that puppet modules exist and all
19:34:47 <mordred> and it's great that there are complex ruby ways to do that
19:34:50 <clarkb> mordred: we really wnt r10k for that
19:34:52 <ianw> fungi: ok, so i should just move it to devstack-gate.yaml?  or there's "misc"
19:34:53 <mordred> but we ALREADY have a compelx shell script
19:34:55 <clarkb> mordred: because the shell script sucks enough
19:35:13 <fungi> ianw: misc is more builder and publisher macros. devstack-gate.yaml is probably the best home for it
19:35:13 <mordred> but r10k is super excessive and fancy and probably won't work for puppet apply
19:35:17 <zaro> clarkb: there's an oustanding bug that wants zuul to build on draft publish event.
19:35:28 <mordred> where as a simple script that's just a for loop of git clones is probably all we need
19:35:30 <mordred> no?
19:35:34 <jesusaurus> mordred: the shell script is currently meant to pin all of the modules, and theres no way to say 'we trust master for some modules'
19:35:42 <clarkb> mordred: I think it will work for puppet apply, you just have ot install it first and run it
19:35:43 <mordred> jesusaurus: havea  ref for each thing
19:35:46 <clarkb> mordred: just like we do with the shell script
19:36:01 <mordred> so - each thing either lists master or the name of some tag
19:36:10 <jesusaurus> that would work
19:36:23 <mordred> I mean, I get what you're saying with r10k - but this has been a todo list item for like 1.5 years, so maybe we're making it too hard
19:36:36 <mordred> we've already got an associative bash array
19:36:44 <mordred> which lists versions and module names
19:36:52 <fungi> zaro: clarkb: i think having zuul support running jobs when it gets a draft-published event is already supportable in configuration, right (so other deployers of gerrit/zuul can make use of that)? however i agree that if we can disable drafts for review.openstack.org we should
19:37:15 <clarkb> fungi: yes I think hashar added it when gerrit added the event
19:37:22 <sdague> fungi: so how big of a stretch would it be to make the puppet code live testable?
19:37:23 <clarkb> fungi: so a layout.yaml update is all that is necessary
19:37:28 <zaro> fungi: option to disable isn't available until 29
19:37:32 <zaro> 2.9
19:37:41 <sdague> like having it spin up dev-infra-stack? and see that it works
19:37:57 <zaro> fungi: i do not believe zuul even knows about drafts events
19:38:17 <clarkb> zaro: I am pretty sure it does. hashar added it iirc
19:38:22 <mordred> sdague: at the moment, I think we're still not automatic enough in several of our components
19:38:23 <zaro> actually i know that for sure.  i have already gone down path to add it.
19:38:29 <mordred> sdague: I think it's an AWESOME idea though
19:38:35 <mordred> and would love for it to be a thing
19:38:37 <clarkb> zaro: yup it does
19:38:43 <clarkb> zaro: git grep draft
19:38:55 <zaro> clarkb: did that merge?
19:38:59 <clarkb> zaro: yes forever ago
19:39:01 <fungi> zaro: https://review.openstack.org/22690
19:39:10 <jesusaurus> mordred: what bits arent automatic enough?
19:39:21 <mordred> installing jenkins. installing errit
19:39:23 <fungi> zaro: merged more than a year ago
19:39:24 <mordred> gerrit
19:39:28 <jesusaurus> sdague: ive been playing with some lxc's that mimic infra and i run test.sh there
19:39:34 <mordred> both have manual steps. several.
19:39:38 <ttx> o/
19:39:51 <mordred> jesusaurus: if you can make it work, I'll buy you a unicorn
19:39:54 <sdague> jesusaurus: how hard would that be to convert into d-g jobs?
19:40:07 <fungi> ttx: got anything good for the infra meeting?
19:40:11 <jesusaurus> sdague: im not sure, im not very familiar with d-g yet
19:40:24 <ttx> fungi: nothing special
19:40:26 <mordred> jesusaurus: also - finishing the puppeting of jenkins master would be welcome
19:40:34 <jesusaurus> mordred: noted
19:40:36 <mordred> jesusaurus: since you were already working on jenkins puppet
19:40:52 <mordred> biggest challenge there is taht the main config.xml gets polluted with slave config
19:40:59 <mordred> which means that $fancy will have to happen
19:41:00 <sdague> jesusaurus: we should sit down at summit at some point then and look. Because if we could auto test more of this, it would be huge.
19:41:05 <mordred> sdague: ++
19:41:20 <jesusaurus> sdague: sure thing
19:42:00 <zaro> fungi, clarkb : i don't think that change is enough.  need to add the draft event to layout as well so zuul can recognize it.  https://review.openstack.org/#/c/92268/1
19:42:10 <clarkb> zaro: yes you need to update the layout.yaml
19:42:15 <clarkb> zaro: but zuul itself doesn't need any changes
19:42:29 <clarkb> zaro: what fungi was saying is that openstack doesn't need to do anything with drafts, but others can if they wish
19:43:15 <fungi> clarkb: zaro: right. for openstack's zuul deployment, it may just make sense to wait for gerrit 2.9, disable drafts, and mark that bug invalid/wontfix at that point
19:43:31 <zaro> clarkb: when draft is uploaded gerrit must send a patchset-created event as well?
19:43:58 <clarkb> zaro: its does but only for people that can see the draft which doesn't include zuul
19:44:02 <fungi> zaro: it doesn't, because then people watching the event stream would know there was a super secret draft
19:44:07 <zaro> ok, i see where this is leading.  gonna abandon my efforts.
19:44:39 <fungi> er, doesn't unless the account watching teh event stream is a reviewer on the draft
19:44:49 <clarkb> ya that
19:44:52 <zaro> i had a difficult time with zuul tests anyways.
19:45:42 <zaro> clarkb: i think you are mistaken, zuul would need changes to understand the draft-published event.
19:46:13 <clarkb> zaro: it already has that change
19:46:24 <clarkb> zaro: `git grep draft` in the zuul repo
19:46:31 <zaro> clarkb: i can tell because this doesn't work, https://review.openstack.org/#/c/92158/
19:47:20 <clarkb> zaro: it should work. I am pretty sure hashar is using it
19:47:37 <zaro> clarkb: tests don't seem to pass.
19:48:14 <marekd> 6/n
19:48:27 <clarkb> zaro: voluptuus is complaining about something
19:48:27 <zaro> clarkb: i thought it's because zuul doesn't undertand that new event. so that's why my attempt at updating zuul.
19:48:33 <clarkb> zaro: but I think draft-published is sound
19:49:04 <zaro> clarkb: hmm.  i'll ask hasher for input on it then.
19:49:16 <fungi> yeah, i think it's just not in the validation mapping
19:49:36 <fungi> probably needs a very minor testing fix to add that
19:49:38 <zaro> good news then :)
19:52:11 <fungi> krotscheck: i've used storyboard very minimally, and want to say you've done some awesome work, but unfortunately i don't have any particular requests outside of the current roadmap
19:52:23 <krotscheck> fungi: Thanks!
19:52:29 <fungi> though i definitely plan to be in the summit session for it
19:52:32 <krotscheck> fungi: I feel like I could go a bit faster though :/
19:52:43 <fungi> krotscheck: we'll bolt some wheels on you
19:52:49 <krotscheck> …. ow.
19:52:59 <krotscheck> Just get me drunk first.
19:53:15 <fungi> krotscheck: that's a nightly agenda item during the summit, i think
19:53:22 <fungi> did anybody else have anything for open discussion?
19:53:35 <clarkb> none here
19:54:16 <SergeyLukjanov> nope
19:54:32 <fungi> guess i'll button this one up. thanks everyone! hope to see you all at the summit. travel safely
19:54:43 <fungi> #endmeeting