19:00:56 <fungi> #startmeeting infra
19:00:57 <openstack> Meeting started Tue Nov 11 19:00:56 2014 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:00 <openstack> The meeting name has been set to 'infra'
19:01:09 <krtaylor> o/
19:01:44 <fungi> mordred: jeblair: SergeyLukjanov: jhesketh: clarkb: assuming you're not around... i'll defer what needs to be deferred
19:02:03 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:12 <fungi> #topic Actions from last meeting
19:02:27 <fungi> #action clarkb figure out gerrit per project third party voting ACLs and third party accounts via openid
19:02:42 <fungi> #action fungi draft initial third-party liaisons description, to later be amended as needed before publication
19:02:50 <fungi> (pretty sure we haven't done those yet)
19:03:05 <fungi> #topic Priority Efforts
19:03:30 <fungi> i'm assuming no new developments on Swift logs
19:03:54 <AJaeger_> Now I'm here as well...
19:04:12 <anteaya> for third party liaisons, we have jogo for nova and asselin for cinder with DuncanT for mailing lists, and mestery and edgar for neutron
19:04:26 <fungi> thanks anteaya
19:04:29 <anteaya> np
19:04:34 <fungi> asselin: were you wanting to discuss "Puppet module split" wrt the Jenkins module? if not, we can push it off to next week
19:05:02 <asselin> I was hoping to get it 'done'
19:05:10 <asselin> and move on to the next
19:05:38 <fungi> okay... so at this point we just need to get the migration change and deletion change merged?
19:05:49 <fungi> asselin: have links to those?
19:05:50 <asselin> yes
19:06:01 <asselin> one sec...didn't realize meeting time changed!
19:06:15 <fungi> asselin: that's the funny part... the meeting time didn't change ;)
19:06:35 <bswartz> the meeting time didn't change -- silly americans changed their clocks
19:06:56 <fungi> (people simply changed their clocks)
19:07:01 <asselin> https://review.openstack.org/#/c/131305/
19:07:12 <asselin> https://review.openstack.org/#/c/131302/
19:07:19 <fungi> #link https://review.openstack.org/131305
19:07:29 <asselin> (many americans wished they didn't have to change clocks)
19:07:29 <fungi> #link https://review.openstack.org/131302
19:07:59 <fungi> asselin: set all your clocks to utc and join the movement... i'm recruiting
19:08:07 <asselin> #link https://review.openstack.org/#/q/status:open+topic:module-split,n,z
19:08:30 <asselin> that link also has the spec updates that are ready for merge
19:08:35 <anteaya> movement... hehehe
19:08:51 <fungi> okay, great. i'm making a note to review those myself--thanks asselin!
19:09:04 <fungi> we should just get them in and fix whatever they break, if anything
19:09:19 <fungi> general discussion on splitting out modules, if we didn't sufficiently cover it before the summit, should probably be saved to next meeting
19:09:41 <anteaya> we have asked an infra-core to shepherd modules splits, asselin do you have a shepherd?
19:09:53 <asselin> anteaya, no, not yet
19:09:54 <fungi> if you don't, you do now
19:09:59 <anteaya> yay
19:10:02 <asselin> thanks fungi
19:10:03 <anteaya> thanks fungi
19:10:05 * fungi will wield the shepherd's crook
19:10:09 <anteaya> :D
19:10:14 <fungi> ianw: you're probably the only one around who has a chance of having updates on "Nodepool DIB"
19:10:15 <AJaeger_> thanks, shepherd!
19:10:37 <fungi> if not, then we'll move on
19:10:39 <ianw> fungi: nothing really, we need a upgrade of the hosts to get anything rpm-based going
19:10:48 <fungi> right, that matches my recollection
19:10:54 <fungi> "Docs publishing"
19:11:02 <fungi> says it's in a holding pattern, so i'm going with that
19:11:20 <anteaya> waiting on swift logs if I recall correctly
19:11:29 <fungi> i vaguely recall through the drunken haze that we discussed it some at the summit, but we can go into details next week as needed
19:11:47 <fungi> "Jobs on trusty"
19:11:54 <fungi> #link https://etherpad.openstack.org/p/py34-transition
19:12:28 <fungi> still in progress. glanceclient has ponied up patches that work, so we're down to waiting for that to merge plus python 3.4 updates in trusty
19:12:43 <fungi> #topic puppet-apache (ianw)
19:12:57 <fungi> #link https://review.openstack.org/129496
19:13:01 <fungi> ianw: you have the floor
19:14:04 <ianw> well, did we come to any agreement on the name?
19:14:20 <pleia2> I'm still inclined to agree with the httpd fork name (I was lurking around when nibalizer and anteaya were talking about it)
19:14:25 <anteaya> nibalizer and I both like puppet-httpd
19:14:30 <fungi> wfm
19:14:43 <ianw> ok, i'll change it, that's all for that then
19:14:47 <pleia2> thanks ianw
19:14:47 <anteaya> thanks
19:15:02 <fungi> #agreed puppet-httpd
19:15:03 <anteaya> yay no hyphen and underscore
19:15:09 <pleia2> hehe
19:15:12 <AJaeger_> ;)
19:15:19 <fungi> #topic log download (ianw)
19:15:27 <fungi> #link https://review.openstack.org/122615
19:15:38 <fungi> ianw: the floor remains yours ;)
19:16:00 <ianw> not much really, if anyone who could possibly +2 this is interested in looking at it, that's would be great
19:16:18 <fungi> got it. so an osla patch
19:16:20 <ianw> otherwise it's just kind of stuck
19:16:24 <ianw> that's all for that
19:16:29 <fungi> i am a fan of the idea. i'll have a look
19:16:33 <AJaeger_> sdague gave a -1 to it
19:17:07 <anteaya> ianw: I'd suggest going back to sdague and seeing what you can agree on
19:17:09 <fungi> i also do think sdague's suggestion has merit. whether in thta change or a follow-on, it's a good idea
19:17:10 <AJaeger_> sdague: could you read ianw's comment and followup on the patch?
19:18:12 <fungi> so anyway, seems like it's something we'll likely get movement on as people reawaken from their post-summit slumber
19:18:34 <fungi> #topic Fedora 21 (ianw)
19:18:46 <fungi> #link https://review.openstack.org/131921
19:18:50 <ianw> fyi i have been looking at f21 bring-up
19:18:58 <fungi> #link https://review.openstack.org/132757
19:19:04 <fungi> #link https://review.openstack.org/132923
19:19:11 <fungi> #link https://review.openstack.org/132925
19:19:20 <fungi> exciting. the wheel of progress turns
19:19:25 <ianw> 131921 i think is actually a nodepool one for centos7 -- per the description i think that's the place to set the path
19:19:31 <fungi> any interesting developments/gotchas there?
19:19:45 <ianw> 757 / 923 were the only little issues i found
19:19:59 <ianw> i have made good images with diskimage-builder locally
19:20:18 <ianw> 925 can't really work until we have upgraded the nodepool hosts, similar to centos7
19:20:25 <fungi> those look at first glance like good and reasonably trivial fixes
19:20:52 <ianw> yeah, the only query on the java one was if we want other hosts using java 1.8
19:21:01 <ianw> openjdk-1.8
19:21:13 <fungi> zaro: as our resident java maven (pun intended)... ^ ?
19:21:39 <fungi> i don't feel well-informed enough to have an opinion presently
19:21:53 <ianw> IMO i think it's best done outside that change anyway
19:21:59 <fungi> likely so
19:22:59 <ianw> anyway, so i feel like we've got a decent head-start on f21, building nodepool images from the beta .qcow2's would be awesome and have us in a position to test from day-1, which is what i'm hoping for
19:23:11 <ianw> that's all
19:23:15 <fungi> neat
19:23:18 <pleia2> thanks ianw
19:23:32 <fungi> #topic Upcoming Project Renames
19:23:45 <fungi> looks like we have stackforge/heat-translator -> openstack/heat-translator
19:23:59 <fungi> #link https://review.openstack.org/131558
19:24:08 <fungi> deferring scheduling discussion to next week
19:24:17 <AJaeger_> yep, seems the only one.
19:24:19 <fungi> since i'm pretty sure we're nowhere near core quorum ;)
19:24:31 <fungi> #topic Open discussion
19:24:37 <fungi> knock yourselves out
19:24:59 <fungi> productive summit, yeah?
19:25:05 <AJaeger_> great summit...
19:25:23 <fungi> i feel like i got a bunch done, without getting anything done
19:25:35 <AJaeger_> Some review love would be great, our queue in project-config is rather long...
19:25:35 <pleia2> I'm so happy to have the translations stuff planned out now
19:25:40 <krtaylor> still processing everything
19:25:45 <pleia2> and it was great to meet AJaeger_ and krtaylor
19:25:54 <krtaylor> absolutely
19:25:57 * AJaeger_ has plans for tonight to go through his Action items
19:26:19 <krtaylor> me too, lots of summary email to do
19:26:21 * pleia2 has plans for tonight to sleep :)
19:26:26 <fungi> yep, the translations decision-making is awesome to have out of the way. pleia2: when you get to the point where you need help with anything, let me know
19:27:01 <pleia2> fungi: thanks, AJaeger_ and I are currently going through the spec I tossed up on Friday, you're welcome to have a look (my first spec, so may be a bit wobbly): https://www.youtube.com/watch?v=wFk-bxRHS7M
19:27:05 <pleia2> haha
19:27:06 <pleia2> https://review.openstack.org/#/c/133222/
19:27:15 <pleia2> that is the proper link :) the other is notre dame bells
19:27:16 <anteaya> I just showed up not to block stuff on me, still offically off
19:27:28 <pleia2> anteaya: thanks, enjoy
19:27:30 <krtaylor> I had one question for infra docs - there is also a third-party docs group forming, should we merge the rfforts, seems like the right thing to do
19:27:38 <anteaya> kk
19:27:45 <AJaeger_> pleia2: I like the spec, just remembered a few things that we missed ;)
19:27:56 <anteaya> krtaylor: lets let the third party docs team find each other
19:28:06 <anteaya> let's keep the groups separate
19:28:27 <anteaya> since part of the p0oint is for third party to work with each other
19:28:42 <anteaya> they can fix up the thridparty.rst file
19:28:55 <anteaya> for starters
19:28:59 <krtaylor> anteaya, well, I plan on writing third-party info, but I was planning on that being in the infra doc sprint
19:29:07 <krtaylor> ok, yes I remember that discussion now
19:29:14 <pleia2> it would be helpful to specifically note what third party docs should be landing where, in infra we have http://docs.openstack.org/infra/manual/third-party.html and http://ci.openstack.org/third_party.html right now (plus the jaypipes blog posts to convert)
19:29:22 <pleia2> it's not fully clear to me what goes where
19:29:28 <fungi> agreed. that's the official location for that to be documented at the moment, so updating it to be more useful seems like the next relevant step
19:29:38 <krtaylor> agreed, we can format and merge that later as needed
19:29:39 <anteaya> let's focus on the dev docs and core guide at the infra manual sprint
19:29:49 <anteaya> krtaylor: we need to get that populated
19:29:54 <fungi> by "that" i mean http://ci.openstack.org/third_party.html
19:30:02 <fungi> #link http://ci.openstack.org/third_party.html
19:30:03 <anteaya> before we are pulled off course by special interests
19:30:22 <krtaylor> yes, we'll focus on fixing that first, but I'll still also help with infra doc
19:30:37 <anteaya> krtaylor: you are welcome to help with infra doc
19:30:48 <AJaeger_> krtaylor: great!
19:30:56 <anteaya> but please don't try to turn it into third party
19:31:08 <krtaylor> I would never!  :)
19:31:08 <anteaya> we need to focus first
19:31:11 <fungi> and yes, the hope is that the third-party group first collaborates among themselves on updating the existing document, before we start a larger discussion on expanding/relocating it
19:31:11 <anteaya> thanks
19:31:20 <anteaya> fungi: exactly
19:31:35 <krtaylor> thanks
19:31:47 <anteaya> krtaylor: stay small and focused and get work done first
19:32:02 <anteaya> once you have a body of work, then we can discuss further
19:32:22 <fungi> any other exciting news? anyone? if not, you can have a half hour of your lives back
19:32:39 <anteaya> amsterdam has a purse museum?
19:32:46 <fungi> that's a frightening thought
19:32:53 <anteaya> for you
19:32:55 <AJaeger_> anteaya: lost ones?
19:32:58 <anteaya> I enjoyed it
19:32:59 <pleia2> thanks for chairing, fungi :)
19:32:59 <krtaylor> wow, not sure how to respond to that
19:33:08 <anteaya> AJaeger_: historical
19:33:15 <anteaya> we quite educational
19:33:23 <anteaya> fungi: you do a great job chairing
19:33:34 * fungi takes a gracious bow
19:33:36 <krtaylor> yes, thanks fungi
19:33:46 * AJaeger_ applauds fungi
19:33:48 <pleia2> oh, I'm on vacation starting friday, will be back next friday
19:33:54 <fungi> congrats pleia2
19:33:55 <anteaya> pleia2: yay vacation
19:34:04 <anteaya> pleia2: hope you do it better than I do
19:34:06 <fungi> we should all be so diligent in our vacationing
19:34:11 * AJaeger_ is travelling the next week - it's SUSECon. Don't expect much from me
19:34:18 <pleia2> AJaeger_: ooh, enjoy!
19:34:26 <fungi> AJaeger_: thanks for the heads up, and happy conferencing
19:34:31 <anteaya> AJaeger_: tee up the reviews and I will go through them next week
19:34:50 <anteaya> AJaeger_: add good comments so if we get resolution while you are away we can proceed
19:35:00 <AJaeger_> btw. my photos from Paris: http://ajaeger.smugmug.com/Events/OpenStack-Summit-2014-Paris
19:35:08 <AJaeger_> anteaya: I'll try
19:35:30 <anteaya> AJaeger_: thanks, you do awesome things :D
19:36:33 <krtaylor> AJaeger_, great pics!
19:36:54 <pleia2> I wrote 3 blog posts about the summit over at princessleia.com/journal/ incl. qa+infra session notes
19:36:54 <AJaeger_> pleia2: thanks for your blogs, helps me go through what I missed ;)
19:36:57 <fungi> heh, found myself in the last photo ;)
19:37:00 <pleia2> AJaeger_: hooray!
19:37:21 <pleia2> my photos are coming together here: https://www.flickr.com/photos/pleia2/sets/72157649238029542/
19:37:27 <pleia2> (should have more uploaded this afternoon)
19:39:31 <fungi> seems we've finally hit a conversational lull, so i'll call it
19:39:34 <fungi> thanks everyone!
19:39:37 <anteaya> I also am in the last photo
19:39:41 <anteaya> thanks fungi
19:39:49 <fungi> #endmeeting