19:01:10 <jeblair> #startmeeting infra
19:01:11 <openstack> Meeting started Tue Mar 3 19:01:10 2015 UTC and is due to finish in 60 minutes. The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:14 <openstack> The meeting name has been set to 'infra'
19:01:20 <jeblair> i'm listening to mordred speak at the board meeting right now, so i expect limited input from him...
19:01:25 <anteaya> o/
19:01:25 * jeblair turns down the volume
19:01:32 <timrc> o/
19:01:33 <greghaynes> O/
19:01:41 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:01:47 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/infra/2015/infra.2015-02-24-19.01.html
19:01:51 <jeblair> #topic Actions from last meeting
19:01:55 <jeblair> mordred create openstackinfra account on puppetforge
19:02:07 <jeblair> so, anyone know if that happened? :)
19:02:12 <anteaya> I do not
19:02:55 <jesusaurus> o/
19:03:17 <jeblair> yes it has!
19:03:23 <anteaya> yay
19:03:29 <jeblair> the password is recorded in hiera
19:03:48 <nibalizer> woot
19:03:49 <jeblair> so we can proceed with publishing our puppet modules via that account
19:04:01 <jeblair> nibalizer: i think that means a bunch of little patches to each of the puppet repos, right?
19:04:11 <nibalizer> couple things
19:04:38 <krtaylor> o/
19:04:39 <nibalizer> we need to manually create the module on the forge web app, and we need to enable the publishing job on each of the modules
19:05:05 <nibalizer> I think the metadata.json in each of our modules is good enough that we don't have to make changes there
19:05:08 <nibalizer> we shall see
19:05:22 <anteaya> can we decide on a module to test this workflow?
19:05:23 <jeblair> nibalizer: okay, how about we work through one of the modules first, then go from there
19:05:32 <nibalizer> sounds good
19:05:34 <jesusaurus> ++
19:05:38 <jeblair> http?
19:05:38 <nibalizer> i nominate openstackinfra-httpd
19:05:49 <jeblair> nibalizer: excellent ;)
19:05:58 <nibalizer> oh, yes, if we're changing to openstackinfra then we need a small change to each module
19:06:04 <jeblair> #action jeblair nibalizer work through openstackinfra-httpd publishing
19:06:30 <jeblair> #topic Priority Efforts
19:07:01 <jeblair> so one thing i was thinking we should do to streamline the priority efforts part of this is to nominate a gerrit topic for each effort and use that for all related changes
19:07:11 <jeblair> we've been doing this partially and ad-hoc recently....
19:07:14 <anteaya> oh I like that
19:07:22 <jeblair> and asselin actually put that in some of his specs
19:07:31 <jeblair> which i also think is a good idea
19:07:39 <jesusaurus> that makes a lot of sense
19:07:52 <jeblair> so maybe as we go through these today, let's pick a topic, and i'll make sure it's in the wiki for reference
19:07:53 <asselin> cool. I can add that to the spec template then
19:07:58 <jeblair> asselin: ++ thanks
19:08:05 <jeblair> #topic Priority Efforts (Swift logs)
19:09:23 <jeblair> it looks like "enable_swift" is being used as a topic for this
19:09:31 <clarkb> I got the concurrent swift uploads change merged and onto our images. d-g log uploads take ~2 minutes now which is much better than before
19:09:36 <jeblair> #info Gerrit topic: enable_swift
19:09:52 <jeblair> clarkb: how does that compare to scp?
19:10:13 <jeblair> #link https://review.openstack.org/#/q/status:open+topic:enable_swift,n,z
19:10:15 <clarkb> jeblair: they are about equal now. I think scp may take a bit longer actually
19:10:29 <clarkb> though scp is doing all the uploads serially so could be made faster if necesary
19:11:10 <jeblair> so it seems like there should be no reason to hold off on approving those changes to start rolling this out more widely
19:11:12 <jeblair> yeah?
19:12:06 <anteaya> I don't have a reason to hold off
19:12:29 <AJaeger_> go for it!
19:12:38 <clarkb> ya I think we can start making it more widely available
19:12:54 <clarkb> there is a change to support globbing though we will need that for some of the jobs iirc
19:13:17 <jeblair> #link https://review.openstack.org/#/c/158514/
19:13:25 <jeblair> cool, so let's land that, then continue
19:13:31 <jeblair> #topic Priority Efforts (Nodepool DIB)
19:13:59 <jeblair> looks like 'dib-nodepool' is being used here, at least partially
19:14:11 <jeblair> #info Gerrit topic: dib-nodepool
19:14:30 <jeblair> #link https://review.openstack.org/#/q/status:open+topic:dib-nodepool,n,z
19:14:36 <jeblair> though nothing there atm
19:15:03 <clarkb> next steps are fungi's bindep change to condense the number of images we need and the move of nodepool to using shade
19:15:20 <clarkb> both are in progress but not quite ready aiui
19:15:30 <jeblair> ah, and we should also see about adopting bindep into infra
19:15:39 <anteaya> I asked about that
19:15:48 <jeblair> how was the reception?
19:15:50 <anteaya> neither fungi or lifeless wanted to move forward on that
19:15:57 <anteaya> the reception was a decided meh
19:15:59 <anteaya> so I left it
19:16:18 <jeblair> oh, i thought lifeless was okay with it?
19:16:22 <anteaya> if you want it, I can write the patch
19:16:27 <anteaya> oh no obstacle
19:16:39 <tchaypo> does “wanted to move forward” mean they didn’t want to spend the effort personally
19:16:40 <anteaya> they jsut weren't going to do the work or support me if I did
19:16:45 <tchaypo> or did they think it was a bad idea?
19:16:54 <anteaya> neight thought it was a bad idea
19:16:57 <anteaya> or a good one
19:17:23 <anteaya> since it wasn't mine to decide I walked away at that point
19:17:31 <anteaya> if you want it jeblair I can write the patch
19:17:44 <jeblair> i think it's a good one since right now, there is only one core reviewer (who is not particularly engaged), and we're talking about making this a fairly important piece
19:17:57 <jeblair> so i think we can give it a good home :)
19:17:57 <anteaya> that was my thinking
19:18:10 <anteaya> with your support, I will compose the patch
19:18:25 <anteaya> feel free to toss me an action item to that effect
19:18:27 <jeblair> sounds good
19:18:33 <anteaya> or shall I?
19:19:06 <jeblair> #action anteaya write patch to have infra adopt bindep; lifeless would remain in bindep-core, infra-core would be added; ask lifeless to review
19:19:16 <anteaya> will do, thanks
19:19:38 <jeblair> any other nodepool-dib things to discuss?
19:20:11 <jeblair> #topic Priority Efforts (Migration to Zanata)
19:20:53 <pleia2> so, we made some progress this week on the module
19:20:59 <jeblair> #info Gerrit topic: zanata
19:21:01 <mrmartin> I had a quick review on the new patch
19:21:09 <jeblair> #link https://review.openstack.org/#/q/status:open+topic:zanata,n,z
19:21:22 <mrmartin> so it has better dependencies now, but I still need to allocate some time for testing
19:21:25 <pleia2> and I realized I needed more help, so I'm meeting with cinerama tomorrow in person to get her up to speed with it (she's got a vagrant VM with the puppet stuff to test so far, woo)
19:21:38 <anteaya> congrats pleia2 on having a unique one work gerrit topic
19:21:48 <jeblair> pleia2, mrmartin: that's excellent news!
19:21:48 <pleia2> StevenK has also signed up to get the zanata client packaged
19:21:54 <mrmartin> pleai2: would you like to share this vagrant somewhere?
19:22:05 <pleia2> mrmartin: you'll want to talk to cinerama
19:22:09 <mrmartin> I also have some vagrant scripts under the hood
19:22:12 <pleia2> I don't have it :)
19:22:33 <mrmartin> pleia2: I can put this out somewhere (github) and later we can merge it into the puppet module
19:22:46 <pleia2> mrmartin: I think that would be helpful
19:22:49 <mrmartin> because actually it is not nice, but works some way :)
19:22:59 <jeblair> that's our motto!
19:23:10 <pleia2> I have been working with cloud VMs, but since there's now two people using vagrant to test it makes more sense to share
19:23:11 <anteaya> that's our motto?
19:23:16 * anteaya takes notes
19:23:47 <pleia2> so with the client packaging we're now trying to push forward on more fronts than just the puppet+server thing, which is good
19:24:02 <pleia2> that's all :)
19:24:06 <jeblair> that's great!
19:24:16 <jeblair> #topic Priority Efforts (Downstream Puppet)
19:24:17 <mrmartin> you can use vagrant with cloud vm
19:24:30 <jeblair> there were two specs for this, both approved now
19:24:38 <pleia2> great
19:24:55 <jeblair> #link https://review.openstack.org/#/c/137471/
19:25:01 <jeblair> #link https://review.openstack.org/#/c/139745/
19:25:24 <jeblair> how about 'downstream-puppet' for a topic?
19:25:39 <jeblair> or openstackinfra-puppet?
19:26:00 <jeblair> or perhaps openstackci-puppet?
19:26:13 <anteaya> I vote for downstream-puppet
19:26:19 <jeblair> #info Gerrit topic: downstream-puppet
19:26:22 <nibalizer> cool
19:26:46 <nibalizer> oh cool these have merged
19:27:04 <nibalizer> ill spin up an example implementation of 137471 this week
19:27:37 <jeblair> oh
19:27:44 <jeblair> actually the spec said "openstackci" as a topic
19:28:09 <nibalizer> hardly specific, taht
19:28:23 <anteaya> jeblair: okay
19:28:28 <anteaya> what the spec said
19:28:31 * asselin pays attention
19:28:45 <jeblair> maybe let's change the spec
19:29:03 <jesusaurus> i like downstream-puppet as a topic
19:29:04 <jeblair> i'll do that
19:29:06 <asselin> there are 2 specs. same topcic for both?
19:29:48 <anteaya> asselin: yeah, so we can address them in the same meeting topic
19:29:56 <jeblair> asselin: i think so -- i think they are related enough that i'd like to treat them as one effort and try to get the same people reviewing them at the same time
19:30:05 <asselin> ok, no objection. just to be clear.
19:30:14 <jeblair> i could be wrong about that, and if so, we can split it up later, but i think it's worth trying :)
19:30:31 <asselin> +1
19:31:01 <jeblair> asselin: so is step 1 to create the new repo?
19:31:11 <asselin> yes
19:31:44 <jeblair> sounds good. anything else to help get these started?
19:32:11 <anteaya> jeblair: write the govenance patch?
19:32:31 <asselin> I think we can start with that
19:32:47 <jeblair> anteaya: yeah, all part of 'create the repo' now :)
19:32:50 <jeblair> #topic Priority Efforts (Askbot migration)
19:32:54 <anteaya> okay
19:33:19 <mrmartin> for askbot, I assigned the tasks for storyboard to track progress: https://storyboard.openstack.org/#!/story/2000158
19:33:25 <jeblair> #info Gerrit topic: askbot-site
19:33:40 <jeblair> mrmartin: yay! thanks! :)
19:33:50 <mrmartin> and and wrote some additional info to spec required for migration: https://review.openstack.org/160693
19:34:14 <mrmartin> and that's all, if https://review.openstack.org/140043 gets an approval, than
19:34:15 <jeblair> #link https://review.openstack.org/#/q/status:open+topic:askbot-site,n,z
19:34:37 <mrmartin> some involvment required from a core member, because most of the tasks requires some manual work
19:34:40 <jeblair> that has a +2 from me, needs another infra-core to aprv
19:34:55 <mrmartin> like instance launch, hiera setup, backup / recovery etc.
19:35:11 <jeblair> mrmartin: yeah, once that lands, we'll find an infra-root to help with that
19:35:31 <mrmartin> ok, so shortly this is the status
19:35:36 <mrmartin> can I do anything to move forward things?
19:35:39 <clarkb> I will try to do spec review after cleaning up new gerrit server
19:36:03 <jeblair> fyi https://review.openstack.org/140043 is a system-config change to actually add the server
19:37:01 <mrmartin> ok, so just a review of hiera variables required before approval
19:37:15 <jeblair> mrmartin: if another infra-core hasn't reviewed it by the end of the week, let me know
19:37:21 <mrmartin> ok, thnx
19:37:31 <jeblair> #topic Priority Efforts (Upgrading Gerrit)
19:37:57 <jeblair> pleia2: did you set up the netcat?
19:38:26 <clarkb> no, pleia2 doesn't have a user on the system yet do to a puppet race during user creation that led to groups being wrong and overlapping for some users in bad ways
19:38:35 <clarkb> I am going to fix that after the meeting
19:38:36 <pleia2> thanks clarkb :)
19:38:40 <jeblair> oh ok. so real soon now. :)
19:38:45 <pleia2> yep
19:38:50 <jeblair> #action pleia2 set up netcat hello-world on new gerrit port 29418
19:39:02 <jeblair> we should probably defer discussion of the upgrade date until next week
19:39:20 <jeblair> #info april 11 and may 9 suggested as gerrit upgrade dates
19:39:26 <jeblair> (just continuing that from last time)
19:39:28 <anteaya> agreed would be nice to pick a time fungi can participate
19:39:43 <clarkb> jeblair: you don't have a user either :P
19:39:57 <jeblair> zaro: anything else?
19:40:04 <jeblair> clarkb: you don't know what a relief that is
19:40:09 <pleia2> haha
19:40:51 <jeblair> #topic Governance changes (jeblair)
19:41:08 <jeblair> #link https://review.openstack.org/#/c/159936/ Remove py26 add py34 to PTI
19:41:08 <jeblair> #link https://review.openstack.org/#/c/159935/ Remove reference to Jenkins
19:41:08 <jeblair> #link https://review.openstack.org/#/c/159930/ IRC channel policies
19:41:36 <jeblair> these are all probably worth a look and of some interest to infra folks
19:41:43 <jeblair> the first two are quite trivial
19:42:09 <jeblair> the third i wrote at the request of the tc in response to the recent community thread...
19:42:22 <nibalizer> jeblair: are you going so far as to set the 'on join' message in chanserv?
19:42:26 <jeblair> i think a lot of folks think that it would be simplest/best if all the irc channels are logged
19:42:38 <jeblair> so that's a resolution to have the tc say that they think it should be the case
19:42:42 <anteaya> I agree with the patches as written
19:42:52 <jeblair> and i've written somewhat vaguely so that we have some discretion about how to implement it
19:43:04 <anteaya> I'm for vague at this point
19:43:25 <jeblair> i think at a minimum we should enforce logging in project-config (could probably make it a gate check, but at least a human check for now)
19:43:27 <anteaya> since more detail just means more policing/follow up for us
19:43:28 <jeblair> and yes..
19:43:49 <jeblair> nibalizer: i think we should also do on join messages, and possibly figure out a way to get the log location into all the topics automatically
19:43:59 <AJaeger_> jeblair: in project-config? Logging is configured in system-config
19:44:12 <anteaya> yeah that statement lost me as well
19:44:19 <jeblair> AJaeger_: ha, indeed. :)
19:44:26 <anteaya> I thought we were discussing logging of irc channels
19:44:48 * AJaeger_ cleaned up recently channels so that all channels in gerritbot get accessbot as well - that's one part of the story
19:45:00 <anteaya> AJaeger_: nice job
19:45:08 <AJaeger_> there're a couple of review - and I've learned from clarkb to check this during reviews ;)
19:45:28 <jeblair> i'm hoping to fix the fact that logging is not in project-config, but i don't have a plan written up yet, sorry.
19:45:42 <anteaya> ah now I can follow that statement
19:45:55 <jeblair> so yeah, we may need to do some cross-checking for a while
19:45:57 <AJaeger_> jeblair: once we move it over, we could gate that a channel is configured in all three places
19:46:10 <anteaya> do we care about channels that use openstack- but aren't represented in project-config in any way?
19:46:11 <jeblair> AJaeger_: yeah. i'm hoping to make one config file
19:46:23 <AJaeger_> jeblair: What's the order? Merge in project-config only if change has been proposed for system-config?
19:46:50 <anteaya> or system-config either
19:47:59 <jeblair> AJaeger_: that sounds like a good starting point
19:48:15 <jeblair> and we'll work on making it simpler
19:48:43 * AJaeger_ reviews proposed changes again...
19:49:10 <jeblair> AJaeger_: heh, we could wait until the governance change lands before we start enforcing it
19:49:26 <jeblair> #topic Infra-cloud (jeblair)
19:49:39 <jeblair> so i briefly linked to the artifacts from this last week, but we ran out of time
19:50:06 <jeblair> #link summary email https://etherpad.openstack.org/p/kBPiVfTsAP
19:50:06 <jeblair> #link story https://storyboard.openstack.org/#!/story/2000175
19:50:06 <jeblair> #link etherpad https://etherpad.openstack.org/p/InfraCloudBootcamp
19:50:35 <jeblair> this is just getting started, but i think the next step here is to write up the design documentation based on what we talked about in person
19:50:41 <jeblair> and get that up for review
19:51:08 <jeblair> is anyone interested in doing that?
19:51:32 <anteaya> you would need someone from the in person meeting to do that, yeah?
19:51:57 <jeblair> anteaya: it would make the most sense. there's a lot of detail captured on the etherpad, but they would have more context to tie it together and fill in blanks
19:52:12 <tchaypo> Interested, but wouldn’t be able to start on it until about the 16th, which is going to be almost a month after the midcycle
19:52:15 <AJaeger_> will that cloud be accessable for translators and documentation as reference?
19:52:24 <pleia2> re: Bikeshedding about ansible and puppet <-- did we actually decide?
19:52:37 <pleia2> installing and maintaining openstack is hard :)
19:52:52 <greghaynes> heh, you dont have to tell the tripleoers that
19:52:54 <tchaypo> pleia2: from memory, that wasn’t a “which should we use?” discussion, it was a “how do they mesh?” discussion
19:52:56 <jeblair> pleia2: i think the consensus was strongly in favor of using the openstack puppet modules from stackforge
19:53:02 <pleia2> greghaynes: yep, that's where I got my experience
19:53:06 <tchaypo> with perhaps a bit of ansible to kick off puppet runs
19:53:16 <tchaypo> and orchestrate things
19:53:18 <jeblair> tchaypo: right
19:53:28 <jeblair> which is the general direction we're already heading
19:53:35 <pleia2> jeblair: so I spoke with crinkle about the puppet modules over the weekend (unrelated) and puppet-openstack isn't really a thing anymore, you sort of cobble together your own central openstack module and pull in the nova, neutron, etc
19:53:36 <jeblair> AJaeger_: not sure i understand the question
19:53:56 <crinkle> I don't recall in-depth discussion on puppet vs ansible, would like to see that hashed out a bit
19:53:57 <zaro> o/
19:54:04 <pleia2> crinkle: ++
19:54:18 <AJaeger_> jeblair: the translation team has setup a "reference server" so that translators can look at horizon and figure out where and how strings are used and then write the proper translation
19:54:34 <AJaeger_> Suchc a reference would be usefull for documentation sometimes as well.
19:54:52 <greghaynes> crinkle: ++ - I think we also had some false assumptions about the state of ansible openstack deploy tooling (which I discovered after playing with them this week). Maybe an ML thread is in order
19:54:58 <jeblair> pleia2: makes sense; i imagine we will have machines that use the nova module, others that use glance, etc...
19:55:00 <annegent_> AJaeger_: ++
19:55:01 <pleia2> anyway, I'd like to be involved with this
19:55:05 <AJaeger_> So, my question is whether translators and documentation writers will be able to access the cloud - or whether that's something totally different?
19:55:10 <pleia2> but I wasn't at the in person meeting, so maybe someone else leads here
19:55:34 <jeblair> AJaeger_: it's not our primary goal, but if we get it up and running, perhaps we can figure out a way to do that later on. it's a good idea.
19:56:03 <annegent_> AJaeger_: jeblair: I often use Trystack and saw a similar possibility here.
19:56:14 <jeblair> pleia2: i want you to be as well :)
19:56:15 <tchaypo> What would translators and doc writers want to do in the cloud?
19:56:41 <tchaypo> (I’m not questioning why they’d get access, I’m wanting to make sure we’re clear about how it would be useful so we can keep that in mind as we design)
19:56:50 <mrmartin> tchaypo: testing use cases?
19:57:05 <pleia2> tchaypo: checking the state of translations in the horizon interface, how complete they are from a UI perspective
19:57:08 <AJaeger_> tchaypo: see http://docs.openstack.org/user-guide/ - that guide has a horizon section
19:57:17 <AJaeger_> Documentation editors need to verify that
19:57:33 <jeblair> greghaynes: i'd like to get a proposal written up first before we start a list thread on something like that
19:57:33 <AJaeger_> And translators see a random string in horizon and need to figure out how to translate it
19:57:54 <jeblair> greghaynes: let's have a think we can specifically point to and change
19:57:54 <annegent_> tchaypo: for checking if horizon changed release-to-release
19:57:56 <AJaeger_> tchaypo: best to reach out to the openstack-i18n list
19:57:57 <tchaypo> would they be wanting “go build a horizon for me with this new patchset” access, or just “let me see a recent horizon"
19:58:06 <annegent_> tchaypo: six month releases only
19:58:18 <AJaeger_> tchaypo: current horizon
19:58:21 <annegent_> tchaypo: otherwise I have to run a devstack on stable/release branches
19:58:23 <tchaypo> okay
19:58:26 <greghaynes> jeblair: Agreed, theres also a lot of things to do before we get to a point where we need to decide too
19:58:33 <annegent_> tchaypo: just to see the dashboard
19:58:37 <tchaypo> thanks :)
19:58:46 <AJaeger_> tchaypo: the i18n team just deploys head daily AFAIK
19:58:47 <annegent_> tchaypo: thanks for asking about the use case :)
19:59:06 <pleia2> jeblair: design documentation == spec?
19:59:40 <jeblair> pleia2: normally i would say yes, however, in this case i think we could actually just write the documentation patch for system-config...
20:00:07 <jeblair> i think that will save some effort in the long run
20:00:32 <jeblair> we can treat it like a spec in that we don't have to approve it until we agree that the documentation matches what we want :)
20:00:43 <pleia2> makes sense
20:00:51 <tchaypo> I’ve added a note to the bottom of https://etherpad.openstack.org/p/kBPiVfTsAP summarsing what I understand of what we just said
20:01:14 <tchaypo> feel free to make what I wrote match reality if it’s wrong
20:01:31 <jeblair> anyway, we have failed to get a volunteer for this. i will move on to alternate means unless someone pings me in channel. :)
20:01:36 <jeblair> time's up, thanks all
20:01:38 <jeblair> #endmeeting