19:01:12 <jeblair> #startmeeting infra
19:01:13 <openstack> Meeting started Tue Jun  2 19:01:12 2015 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:17 <openstack> The meeting name has been set to 'infra'
19:01:22 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:01:23 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/infra/2015/infra.2015-05-26-19.02.html
19:01:29 <pabelanger> o/
19:01:32 <crinkle> o/
19:01:34 <nibalizer> o/
19:01:36 <krtaylor> o/
19:01:39 <ianw> o/
19:01:40 <jhesketh> o/
19:01:40 <docaedo> o/
19:01:42 <AJaeger> +1
19:01:45 <rbradfor> o/
19:01:49 <zaro> o/
19:02:02 <jeblair> everybody gets a 'line said' in the meeting today! :)
19:02:05 <anteaya> I find myself going to the meetings wikipage to get the history to find links to meeting agendas
19:02:16 <yolanda> o/
19:02:17 <anteaya> just as a data point to file for later
19:02:24 <anteaya> jeblair: one for everybody
19:02:27 <pleia2> o/
19:02:30 <asselin_> o/
19:02:32 <jeblair> #topic Announcements
19:02:33 <mrmartin> o/
19:02:36 <jhesketh> yep, job done, back to bed ;-)
19:02:42 <anteaya> jhesketh: ha ha ha
19:02:45 <jeblair> #link http://docs.openstack.org/infra/system-config/project.html#teams
19:02:53 <jeblair> the process changes we talked about last week are in place, so this meeting structure has changed accordingly
19:03:00 <jeblair> we'll have a new section where we announce specs that are ready for the council to vote on
19:03:06 <jeblair> also, to many of you, welcome to the infrastructure council!  i'm not sure anyone but gerrit knows who you are :)
19:03:32 <fungi> i have scripts that know ;)
19:03:56 * AJaeger would be suprised if fungi wouldn't have ;)
19:04:07 <jeblair> any questions or comments on this? or shall we go try it out?
19:04:23 <fungi> let's get this party started
19:04:23 <AJaeger> yes, let's give it a try...
19:04:32 <pabelanger> trial by fire!
19:04:37 <jhesketh> jeblair: might be we worth linking who is on the council if that's around somewhere?
19:05:02 <fungi> jhesketh: i'll get a link together in a bit. i think i can do it with a single gerrit api call
19:05:10 <jeblair> ooh, neat
19:05:14 <jhesketh> shiny
19:05:27 <jeblair> it's implemented as a gerrit group with about 100 member-groups (some of which have their own groups)
19:05:41 <AJaeger> jeblair: yeah https://review.openstack.org/#/admin/groups/925,members looks impressive
19:06:06 <jeblair> i had to write a script (which is in review; failing pep8 i think) to create it
19:06:23 <jeblair> #topic Actions from last meeting
19:06:29 <jeblair> mordred write a spec to move infra bugs to maniphest
19:06:46 <jeblair> mordred said he might not make the meeting today, but this is in progress
19:07:04 <jeblair> he did push up the shade spec which is great
19:07:17 <jeblair> hopefully that one will make the agenda next week
19:07:23 <jeblair> #action mordred write a spec to move infra bugs to maniphest
19:07:27 <jeblair> jeblair write infra-cloud spec with SpamapS
19:07:29 <jeblair> is done
19:07:41 <jeblair> and there's one more action item we'll talk about later in the meeting
19:07:46 <jeblair> #topic Specs approval
19:07:56 <jeblair> when specs are ready for final voting by the infra council, add them to the agenda in this section and we will announce them here
19:08:02 <jeblair> we can discuss them a little as needed, but mostly this is to serve as notice that people should vote on them
19:08:07 <jeblair> i was thinking we would start with a ~48 hour voting period
19:08:12 <jeblair> how does that sound?
19:08:15 <nibalizer> i like that
19:08:20 <pleia2> sounds good
19:08:27 <anteaya> what are you looking for in terms of votes?
19:08:34 <anteaya> how many to move ahead?
19:09:08 <jeblair> anteaya: simple majority?
19:09:12 <jeblair> and if we think it's not working out, we'll change it
19:09:19 <anteaya> how big is the council?
19:09:32 <jeblair> unknown :)
19:09:36 <anteaya> is majority 51% or better
19:09:56 <jeblair> let's go with "more positive than negative votes"
19:10:10 <anteaya> so 2 positive and 1 negative is a merge?
19:10:16 <anteaya> or mergable?
19:10:26 <jeblair> if that's all that can be bothered to vote within 48 hours, sure
19:10:52 <jhesketh> votes can be added before the 48 hours is open yeah?
19:11:02 <jeblair> jhesketh: i don't see why not
19:11:07 <anteaya> so window for voting set in the meeting, more positive than negative and the spec merges
19:11:08 <nibalizer> jeblair: if someone wants to abstain from voting on a partictulr spec, how do you want them to do that, +0?
19:11:11 <jhesketh> ie, we've reviewed it earlier or saw it was in the agenda ahead of time and added a vote
19:11:24 <anteaya> nibalizer: yes I 0 vote is abstain
19:11:33 <anteaya> a 0 vote
19:11:37 <pleia2> yeah, it's noted in the interface
19:11:43 <pleia2> webui anyway :)
19:12:08 <nibalizer> cool
19:12:17 <jeblair> you can also leave a differing code-review vote.  i'm not entirely sure what that means in all circumstances, but we might find it useful.  you might -1 and +0 for some really good reason.
19:13:24 <jeblair> #topic Specs approval: Infra-cloud (jeblair, SpamapS)
19:13:28 <zaro> pleia2: does it really say '0 abstain'?
19:13:31 <jeblair> #link infra cloud spec https://review.openstack.org/186960
19:13:37 <pleia2> zaro: yes
19:13:37 <jeblair> #info voting on https://review.openstack.org/186960 open until 2015-06-04 19:00 UTC
19:14:31 <jeblair> we've talked about this for a while, and it's worth noting that the technical decisions will be made over in system-config, so be sure to participate there if you have opinions on openstack deployment choices
19:14:36 <mordred> o/
19:14:38 <jeblair> but this covers the process and overall effort
19:14:45 <asselin_> can we add this one too? https://review.openstack.org/#/c/135170/
19:15:00 <jeblair> asselin_: let's do it next week
19:15:20 <AJaeger> asselin_: please add to the agenda for next week
19:15:36 <asselin_> will do, thanks
19:15:38 <krtaylor> thanks asselin_
19:16:22 <jeblair> #topic Specs approval: Host OpenStack Apps Catalog Service (docaedo, fungi)
19:16:31 <jeblair> #link apps.o.o spec https://review.openstack.org/187646
19:16:32 <fungi> yep
19:16:37 <jeblair> #link apps.o.o topic https://review.openstack.org/#/q/status:open+topic:apps-site,n,z
19:16:41 <fungi> there's this apps site
19:16:44 <fungi> and we should host it
19:16:52 * fungi wins at tl;dr
19:16:55 * pleia2 nods
19:17:00 <jeblair> ayup
19:17:07 <fungi> any... questions?
19:17:19 <AJaeger> fungi: if the specs is as easy to understand, you have my +1 vote ;)
19:17:21 <jeblair> and i think this is already in progress
19:17:25 <fungi> it is
19:17:40 <fungi> the review topic already has associated changes awaiting review
19:17:41 <jhesketh> noting that the spec was uploaded today, should there be a minimum review time before it is voted on?
19:18:20 <jhesketh> since it also (unless I missed it) wasn't in the agenda for very long as a heads up
19:18:29 <fungi> perhaps, yes. i suggest a minimum review time of at least 0 seconds
19:18:34 <fungi> we're not deciding on it in this meeting
19:18:43 <fungi> just announcing that it's ready for review/council vote
19:19:01 <jeblair> yeah, i think we'll want to get to the point where things are on the agenda longer than "immediately before the meeting", but we're also sort of catching up current efforts to the new process
19:19:03 <jhesketh> isn't announcing it is ready for vote putting it in a 48 hour window
19:19:45 <jeblair> and in this case, i think with the summit discussion and key participants agreeing on the current spec, it's okay for this one
19:19:55 <fungi> also it's sort of a rush job
19:19:57 <jeblair> jhesketh: yes
19:20:07 <jhesketh> yep, sure, I don't think this is an issue, just pointing out that if somebody were away for 2 days it'd be easy to miss a spec like this
19:20:38 <jeblair> yeah, we'll get better in the future; if there isn't an objection for this particular instance, i'd say we should go ahead with the vote
19:20:42 <fungi> some decisions were made, for better or for worse, and this is a "bug" we need to correct as soon as possible, before it becomes a major pr issue
19:20:44 <jhesketh> but that's not going to be common and objections can be given after it is merged
19:21:40 <jeblair> well, ideally we'd get objections before it's merged
19:22:04 <jhesketh> I meant worst case
19:23:41 <jeblair> yeah, if something looks like it's going to go off the rails, let's bring it up in this meeting (we can choose to defer voting), or -1 council vote it with a suggestion for more revising, or infra-cores can veto it on that basis too, and we'll get the process back on track
19:24:07 <jeblair> the goal is to get all the participants on the same page, so we should work toward that :)
19:24:35 <jeblair> i'm glad i rushed something on the agenda, that's useful :)
19:24:35 <jhesketh> sounds good :-)
19:24:42 <jeblair> #info voting on https://review.openstack.org/187646 open until 2015-06-04 19:00 UTC
19:24:55 <jeblair> #topic Priority Efforts
19:25:25 <jeblair> reminder that this section is by prior request on the agenda only, so i'll skip efforts that didn't have something in the agenda
19:25:30 <jeblair> #topic Priority Efforts (Downstream Puppet)
19:25:44 <asselin_> Hi, I would like to propose a virtual sprint
19:25:52 <jeblair> #link https://wiki.openstack.org/wiki/VirtualSprints#Schedule_of_Upcoming_OpenStack_Virtual_Sprints
19:26:17 <asselin_> that was very effective last time, and I think the initiative would benefit from doing this
19:26:52 <asselin_> I'd like to schedule this after L1 is done...so early L2 if there's enough people avaiable / not on vacation
19:27:00 <fungi> asselin_: what goal do you have in mind for the common ci solution sprint?
19:27:24 <fungi> just work toward implementation of teh spec and any oassociated work items?
19:27:32 <asselin_> fungi, yes
19:27:45 <yolanda> asselin, ++
19:27:46 <jeblair> maybe we could identify one or more modules to complete?  possibly identify one that we might be able to move openstack-infra to using?
19:28:17 <jeblair> s/modules/classes/ you know what i mean... maybe 'compenents'.
19:28:22 <asselin_> I'd like to get nodepool, zuul, and jenkins done
19:28:36 <nibalizer> ya moving -infra to consuming openstackci would be huge
19:28:57 <anteaya> asselin_: setting priorties would help
19:28:59 <fungi> i like having achievable or measurable goals for a sprint. if completion of the entire spec is doable within the sprint, then seems fine as a goal. otherwise would be great to see it scoped more clearly
19:29:01 <asselin_> the alternative is to keep doing as we are
19:29:11 <nibalizer> I'm in for this, though i think the parallelism here is much lower than the modules split sprint
19:29:20 <anteaya> asselin_: so folks can focus on one and then move to the next
19:29:59 <asselin_> anteaya, that's another good approach. We can target e.g. 1 module per week and focus on that
19:30:11 <anteaya> asselin_: sorry no I meant for the sprint
19:30:17 <anteaya> I support the sprint
19:30:27 <nibalizer> for i in ls system-config/modules/openstack_project/*; do (move stuff into either the correct module or to openstackci; move infra to consume that); done
19:30:34 <anteaya> but people need you to make a decision, however arbitrary it may feel
19:31:01 <anteaya> asselin_: so select a time and select 3 modules (you did already) and prioritize them
19:31:07 <anteaya> asselin_: then people can take action
19:31:33 <anteaya> asselin_: until you make a decision, people will just keep giving you suggestions
19:32:01 <asselin_> anteaya, I am asking for peoples opinions
19:32:09 <nibalizer> sprinting is good i think
19:32:18 <yolanda> asselin, i think that these modules are the ones that need attention
19:32:20 <anteaya> asselin_: so far I'm hearing when you decide on dates for a sprint, people will show up
19:32:26 <yolanda> i'm ok to have an sprint for that
19:32:37 <nibalizer> a sprint like atmosphere is the best way to accomplish the 'pivot' needed to get infra using openstackci I think
19:32:42 <pabelanger> I would think nodepool would be the first to break out of the list, limited dependencies
19:32:48 <nibalizer> the slow way of doing that will take eons and introduce risk
19:32:52 <asselin_> ok, so yolanda and nibalizer are in for sprint. What about infra cores?
19:32:58 <yolanda> pabelanger, i started work on nodepool
19:32:59 * zaro has no opinion just willing to help
19:33:20 <yolanda> i'm trying to find gaps during the week to continue with that
19:33:35 <anteaya> asselin_: I support the sprint, my attendance depends on dates selected, and don't optimize for me
19:33:44 <fungi> we have it designated as a priority effort, so i'm in favor of getting it done however we can to free up bandwidth for other priorities
19:33:44 <jeblair> i'm happy to help
19:33:47 <pleia2> I can participate
19:33:48 <asselin_> fungi I think is in as long as there is clear measurable scope. We can do that.
19:34:04 <pabelanger> yolanda, Ya, seen your review.  Was going to comment on it about allow a template or content to just be passed, over individual elements.  But, I'm not against what you started
19:34:08 <nibalizer> our testing is still 'in progress' so we should make sure that we leave ample time between now and the date of the sprint to get our framework for pupept testing locked in
19:34:16 <nibalizer> locked down? set up? established?
19:34:20 <jeblair> nibalizer: that will help tremendously
19:34:24 <yolanda> pabelanger, i got some feedback from jeblair, asselin, so i'm going to refactor that a bit
19:34:50 <asselin_> nibalizer, you think you can get that done by L1?
19:35:24 <asselin_> Libery schedule is her: https://wiki.openstack.org/wiki/Liberty_Release_Schedule
19:35:25 <nibalizer> asselin_: i dont know when L1 is
19:35:27 <asselin_> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
19:35:33 <jeblair> (i don't normally thing much about milestone dates, they don't really affect us too much)
19:35:35 <asselin_> June 25th
19:36:16 <yolanda> i'm on holiday since 29th june, i hope it's scheduled before that...
19:36:16 <asselin_> jeblair, I'm avoiding the sprint bfore L1 b/c I assume many people are busy then
19:36:20 <crinkle> is puppet functional testing included as part of downstream-puppet? clarkb's spec doesn't have a decision yet so I don't know if it's appropriate to try to lock down testing https://review.openstack.org/#/c/178887
19:36:40 <nibalizer> crinkle: thats fair...
19:36:49 <fungi> milestone dates are only a concern insofar as if they indicate a huge uptick in dev activity for openstack projects on the whole then we want to strive to keep things more stable during those windowsa
19:37:09 <asselin_> fungi, +1
19:37:11 <nibalizer> clarks spec was sortof subsumed by the discussion at the design summit, as i understand it
19:37:35 <nibalizer> so we didn't resolve or land clarks spec, but we did make a decision on a path forward
19:37:43 <asselin_> ihmo we can do this in parallel
19:37:51 <jeblair> i think we decided to head towards beaker-rspec, we should update clark's spec to reflect that
19:37:53 <nibalizer> then when we sprinted at the summit we (or I and some others) focused on testing using teh decision we made
19:38:03 <crinkle> jeblair: ++
19:38:13 <nibalizer> cool
19:38:41 <asselin_> so how about June 29 and 30?
19:38:43 <nibalizer> but I do think we can get beaker-rspec in place before the 'late june' sprint that asselin_ is suggesting
19:39:00 <jeblair> tuesdays are bad for me :)
19:39:01 <pabelanger> asselin, Close to Canada and USA holidays
19:39:01 <nibalizer> i also think testing is one of the ways virtual sprints prevent us from hurting ourselves
19:39:06 <pabelanger> Canada day is July 1st
19:39:20 <yolanda> 29 and 30 don't work for me, but i'll leave my work prepared for you to take it
19:39:28 <fungi> i'm closing on a house on june 30 so will likely not be around for that timeframe, but don't plan around me
19:39:29 <asselin_> ok July 8 & 9?
19:39:36 <yolanda> ++
19:39:38 <jeblair> wfm
19:39:41 <nibalizer> wfm
19:39:43 <pabelanger> ya, better here
19:39:52 <asselin_> I will create a vote in the etherpad and send to the e-mail list.
19:39:53 <fungi> i can probably do july 8-9, yes
19:39:55 <pleia2> I might be out of town then, but I have to confirm
19:40:05 <anteaya> asselin_: I also may be out of town
19:40:19 <anteaya> but july 8 and 9 seem to be popular with others
19:40:26 <zaro> wfm
19:40:37 <jeblair> #action asselin_ propose july 8,9 for openstackci sprint to mailing list
19:40:49 <zaro> reminder would be excellent
19:40:51 <asselin_> ok thanks
19:40:55 <jeblair> asselin_: cool, thanks
19:40:59 <asselin_> zaro, will do. thanks
19:41:03 <jeblair> anything else?
19:41:07 <asselin_> that's it
19:41:13 <jeblair> #topic Priority Efforts (Upgrading Gerrit)
19:41:20 <zaro> https://gerrit-review.googlesource.com/#/c/68149/
19:41:33 <zaro> i tested the proposed fix, but it didn't fix.
19:41:48 <pleia2> :\
19:42:13 <jeblair> zaro: uh oh
19:42:27 <anteaya> did you post your results to anywhere google can read?
19:42:44 <fungi> he commented on the review
19:42:45 <zaro> yes, on mailing list + on the review
19:43:25 <fungi> #link https://groups.google.com/forum/#!msg/repo-discuss/ZeGWPyyJlrM/mQsZIsy2740J
19:43:40 <zaro> not sure what to do besides wait for real jgit fix. other option is to increase timeout like the sony guys did
19:44:05 <jeblair> what did they set their timeout to?
19:44:27 <zaro> not sure, but can ask sven.
19:44:50 <zaro> he said he increased in the mailing list and that made error go away. i will ask him
19:45:11 <jeblair> i'm a little concerned about that, because occasionally we have some _really huge_ changes; we either set ourselves up to a dos by letting gerrit perform all that computation, or a dos by killing repositories
19:45:33 <jeblair> on the plus side, it's really cool this is possible to test now :)
19:46:06 <zaro> yeah, not ideal but i think that's what sony is doing now
19:46:22 <zaro> just an option wanted to throw out.
19:46:35 <jeblair> zaro: can you keep testing their proposed fixes
19:46:49 <jeblair> and let's see if they can resolve this soon-ish
19:46:49 <zaro> yes, i plan to.
19:46:58 <anteaya> is moving to 2.9 an option?
19:47:13 <jeblair> and if they give up, we'll work something else out :)
19:47:41 <jeblair> anteaya: i don't feel like we're under significant pressure to upgrade to 2.9
19:47:46 <anteaya> okay
19:47:53 <anteaya> I would like close connection
19:48:01 <anteaya> which works with 2.9 but not 2.8
19:48:07 <anteaya> but that's just me
19:48:15 <anteaya> 2.9+
19:48:40 <jeblair> anything else?
19:48:54 <zaro> i'm not sure that's true, i think i had to add it to our 2.10 branch
19:49:03 <zaro> anteaya: ^
19:49:18 <zaro> http://git.openstack.org/cgit/openstack-infra/gerrit/commit/?h=openstack/2.10.2&id=5b6d0cd846ed2389584a0559866aeff3c1fff20a
19:49:29 <anteaya> close connection works with 2.9+, it is a feature in 2.11 but you backported successfully to 2.10 and 2.9
19:49:33 <zaro> which means it's only in 2.11
19:49:34 <anteaya> it doesn't work with 2.8
19:49:56 <anteaya> at least that is what I recall you told me
19:49:59 <zaro> ohh, i see what you mean
19:50:16 <zaro> nothing else from me on this topic
19:50:18 <anteaya> so staying on 2.8 means no close connection feature, which I would like
19:50:20 <jeblair> okay, let's see where the gerrit folks get to on this
19:50:22 <anteaya> I'm done too
19:50:25 <jeblair> #topic puppet-stackalytics (pabelanger)
19:50:33 <pabelanger> ohai
19:50:45 <nibalizer> hello
19:50:55 <nibalizer> we cooking this up again, then?
19:51:06 <pabelanger> So, mostly helping mordred with the effort to get stackalytics under infra.
19:51:23 <pabelanger> jeblair asked to get a spec up, so I did that today: https://review.openstack.org/#/c/187715/
19:51:37 <jeblair> we had a nice work session at the summit where a lot of folks generally thought that stackalytics was the way to go
19:51:44 <jeblair> pabelanger: oh cool, that was fast :)
19:51:54 <mrmartin> so it means we will drop activity.o.o ?
19:51:57 <pabelanger> I also have a base puppet-stackalytics modules already created and ready for governance.  https://review.openstack.org/#/c/187645/ and https://review.openstack.org/#/c/187269/
19:52:20 <fungi> the direction forward we determined from the infra analytics tools discussion at the summit was to try and get stackalytics hosted/managed within the openstack community and supplement it with anything we were originally relying on other analytics tools for
19:53:05 <fungi> so that includes probably activity.o.o reports, things ptls want from reviewstats, et cetera
19:53:13 <jeblair> mrmartin: i don't think reed has plans to do that any time soon, it has a lot of things he still needs
19:53:13 <mrmartin> ok.
19:53:14 <nibalizer> cool
19:53:21 <pabelanger> I'm not sure who at mirantis to talk to about the move, I know mordred knows some peeps.  But would be good to get them involved with the spec if possible
19:53:33 <jeblair> pabelanger: SergeyLukjanov and docaedo offered to help on that front
19:53:38 <fungi> SergeyLukjanov volunteered to assist'
19:53:41 <fungi> er, that
19:53:41 <pabelanger> roger
19:54:19 <pabelanger> Ya, so once the puppet-stackalytics is created, I'll port over the work mordred did a few months ago and polish it up
19:54:34 <pabelanger> Should be a straightforward move
19:54:34 <jeblair> cool, so people should go review that spec, and we'll certainly want some mirantis folks signing off on that too
19:54:38 <jeblair> pabelanger: sounds good
19:55:01 <jeblair> reed: ^ you'll probably want to look at that
19:55:06 <jeblair> #link https://review.openstack.org/#/c/187715/
19:55:25 <jeblair> anything else on this?
19:55:37 <pabelanger> nothing from me
19:55:48 <jeblair> #topic Schedule next project renames
19:55:55 <docaedo> please add me as a reviewer for the stackalytics stuff :)
19:55:59 <jeblair> (technically not on agenda)
19:56:07 <jeblair> but we have a boatload of these
19:56:13 <jeblair> many of which actually have changes ready now
19:56:35 <jeblair> did we decide on an interval for this?  like once every N- weeks/months?
19:56:55 <fungi> not that i recall
19:56:56 <nibalizer> I also heard chatter about an ansible playbook to streamline it
19:56:57 <anteaya> I didn't know we were trying to decide on an interval
19:57:11 <jeblair> okay, we might want to at some point...
19:57:15 <jeblair> anyone seen the playbook?
19:57:17 <fungi> yeah, mordred wanted to test-drive his rename playbook this time
19:57:30 <anteaya> where does it live?
19:57:48 <jeblair> anteaya: that's the question :)
19:58:07 <fungi> #link https://review.openstack.org/105057
19:58:09 <fungi> i think
19:58:14 <pabelanger> fungi, yes
19:58:24 <jeblair> we should probably go ahead and schedule, and if the playbook shows up, cool
19:58:30 <anteaya> 3 -1's
19:58:38 <anteaya> jeblair: yeah I agree with that
19:58:45 <jeblair> this friday?  next friday?
19:59:05 <anteaya> either is fine with me
19:59:14 <anteaya> we have quite a load do we want to split them up?
19:59:33 <jeblair> anteaya: they won't take much longer
19:59:39 <anteaya> okay
19:59:44 <jeblair> anteaya: it's easier on us to have bigger batches
19:59:57 <anteaya> ah okay then I'm for next friday then
20:00:07 <fungi> agreed, big batches are fine
20:00:20 <anteaya> to ensure all the patches are ready
20:00:32 <jeblair> deferred until next meeting then
20:00:34 <jeblair> #endmeeting