19:02:14 <jeblair> #startmeeting infra
19:02:15 <Shrews> hey hey
19:02:15 <openstack> Meeting started Tue Jul 7 19:02:14 2015 UTC and is due to finish in 60 minutes. The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:16 <pabelanger> o/
19:02:16 <yolanda> o/
19:02:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:19 <openstack> The meeting name has been set to 'infra'
19:02:21 <mordred> o/
19:02:23 <jhesketh> Morning
19:02:25 <SotK> o/
19:02:26 <nibalizer> heyo
19:02:26 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:32 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/infra/2015/infra.2015-06-30-19.01.html
19:02:44 <SpamapS> o/
19:03:11 <jeblair> #topic Specs approval
19:03:16 <zaro> o/
19:03:16 <jeblair> #topic Specs approval: Refstack hosting
19:03:21 <jeblair> #link refstack hosting spec http://specs.openstack.org/openstack-infra/infra-specs/specs/refstack_dot_org.html
19:03:24 <jeblair> #info refstack hosting spec approved
19:03:44 <jeblair> so that landed!
19:03:48 <pleia2> o/
19:03:55 <pleia2> yay refstack spec
19:04:07 <fungi> i have a change proposed to create that server now
19:04:13 <fungi> though it needs some puppet help
19:04:25 <jeblair> light the puppet signal
19:04:30 * crinkle hides
19:04:38 <fungi> #link https://review.openstack.org/198869
19:04:40 <nibalizer> heh
19:04:45 <fungi> i started digging into the failure log there
19:04:52 <fungi> haven't gotten very far
19:04:57 <fungi> hogepodge: ^ when you get time
19:05:28 <fungi> anyway, we can move on with specs news
19:05:47 <jeblair> yay progress, and it's nice for puppet folks to have outed themselves :)
19:05:55 <mordred> yay puppet people
19:05:56 <jeblair> #topic Specs approval: Centralize release tagging
19:06:03 <jeblair> #link centralize release tagging spec https://review.openstack.org/191193
19:06:10 <pabelanger> fungi, incoming reviews
19:06:17 <jeblair> this has gone through several revisions
19:06:36 <jeblair> with some really good back and forth on the different options, most of which is actually captured in the alternatives section
19:06:42 <Rockyg> o/
19:06:42 <fungi> yep, was in the middle of rereading it when the meeting snuck up on me
19:06:45 <jeblair> so you probably don't even need to look at the old review comments :)
19:07:12 <dhellmann> jeblair: should I fix that typo in the current patch, or submit a cleanup patch?
19:07:23 <jeblair> dhellmann: i'd go with cleanup
19:07:32 <dhellmann> jeblair: ack
19:08:07 <fungi> i have at least one additional rendering error i'm seeing
19:08:18 <fungi> which can also go to cleanup
19:09:04 <dhellmann> fungi: ok, I'll watch for a comment (I didn't see any issues scanning quickly just now)
19:09:23 <dhellmann> oh, in the list, I see it
19:09:34 <fungi> dhellmann: i went ahead and added it now while i'm finishing reading through it
19:09:52 <fungi> i mean, while i'm paying attention in this meeting!
19:09:58 <jeblair> anyway, i think a good set of affected/interested folks have examined this; anyone think it needs more time or should we open voting?
19:09:58 <fungi> ;)
19:10:44 <dhellmann> cleanups: https://review.openstack.org/199226
19:11:07 <fungi> go ahead and open voting. if i discover i'm concerned by anything it it while finishing skimming we can always adjust the spec down the road
19:11:23 <ttx> o/
19:11:40 <dhellmann> yeah, I expect to tweak the file format details as we start implementing the tools to read it, but I think this is what we want in broad strokes
19:11:58 <jeblair> sounds good
19:12:01 <jeblair> #info centralize release tagging spec voting open until 2015-07-09 19:00 UTC
19:12:14 <fungi> it looks like it embodies enough of what we discussed early on that we've got latitude to shift direction with tooling down the road since it's starting out mostly manual
19:12:54 <jeblair> dhellmann: thanks!
19:13:06 <jeblair> #topic Schedule Project Renames
19:13:24 <dhellmann> jeblair: thanks for all the feedback along the way
19:13:42 <jeblair> anyone want to do some renames, or should we wait a few more weeks?
19:14:06 <jeblair> (as an aside, i got good feedback from the tc last week on the stackforge resolution, and hope to have a revised version ready for next week's meeting)
19:14:16 <fungi> looks like we have a dozen lined up so far
19:14:26 <anteaya> sprint is this friday
19:14:40 <fungi> this weekend is out for me since i'm closing on a house at the end of the week
19:14:45 <jeblair> anteaya: wed/thurs i think
19:14:48 <anteaya> I'm at keystone midcycle next friday
19:14:57 <anteaya> so it is
19:15:01 <pleia2> I'm around all week (though participating in puppet sprint friday)
19:15:08 <fungi> weekend after next is oscon travel i think
19:15:09 <anteaya> I had in my head thursday friday
19:15:20 <anteaya> I prefer small bites
19:15:28 <anteaya> rather than huge platters of rename
19:15:32 <pleia2> fungi: yeah, I fly out on that friday
19:15:34 <anteaya> the last round was tiring
19:15:47 <fungi> i could probably do friday the 18th since i don't fly until the weekend
19:15:53 <pabelanger> I'll assist if needed
19:16:06 <anteaya> july 18th is a saturday
19:16:14 <fungi> er, 17th ;)
19:16:14 <nibz> ya, is there a way for people like me to help with these operations?
19:16:25 <jeblair> pabelanger: cool, thanks; there ended up being a lot of project-config changes that needed wrangling last time (that was actually most of the work)
19:16:28 <jeblair> nibz: ^
19:16:29 <anteaya> nibz: review the patches
19:16:47 <jeblair> and rebase/fix/resolve conflicts
19:16:49 <fungi> and also review the maintenance plan for mismatches/discrepancies
19:17:05 <fungi> and also help test things out afterward
19:17:09 <nibz> ok
19:17:15 <pabelanger> roger
19:17:22 <AJaeger> during review we should check that the changes are really renames and no new jobs added - let's keep the changes simple
19:17:24 <nibz> im free july 18th to help
19:17:39 <fungi> mordred: any interest in having your rename playbook in shape for that?
19:17:46 <jeblair> nibz: how about july 17?
19:17:48 <mordred> fungi: yes
19:17:56 <jeblair> pleia2: are you flying on 17th?
19:18:00 <anteaya> july 17th is keystone midcycle for me
19:18:09 <anteaya> but the week after is nova midcycle
19:18:13 <fungi> mordred: are you around on the 17th? (metaphysical question i know)
19:18:29 <anteaya> so planning around me isn't really useful
19:19:00 <nibz> jeblair: ya I can july 17
19:19:01 <mordred> I get on a plane at 2pm Eastern
19:19:11 <mordred> so - I may not be actually available at a useful time
19:19:44 <pleia2> jeblair: yes, need to be there in time for friday evening events
19:19:46 <jeblair> #startvote are you available for renames on these dates? july10, july17, both
19:19:47 <openstack> Begin voting on: are you available for renames on these dates? Valid vote options are july10, july17, both.
19:19:48 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:20:01 <pleia2> #vote july10
19:20:02 <jeblair> i'm abusing the poll option here to survey our availability ^
19:20:04 <jeblair> #vote both
19:20:14 <anteaya> #vote july10
19:20:17 <zaro> #vote july10
19:20:24 <pabelanger> #vote july10
19:20:26 <fungi> july17
19:20:30 <fungi> #vote july17
19:20:38 * zaro on vacation in coming weeks.
19:20:45 <nibz> #vote both
19:21:07 <jeblair> mordred: ?
19:21:11 <mordred> #vote july10
19:21:37 <jeblair> i think that's everyone who expressed an interest
19:21:42 <jeblair> #endvote
19:21:42 <openstack> Voted on "are you available for renames on these dates?" Results are
19:21:43 <openstack> july17 (1): fungi
19:21:45 <openstack> both (2): jeblair, nibz
19:21:46 <openstack> july10 (5): mordred, pleia2, anteaya, zaro, pabelanger
19:22:05 <jeblair> pleia2: have you done one of these?
19:22:08 <fungi> i'm fine skipping one. i think i've been around for the last 10+
19:22:28 <anteaya> jeblair: any way I can get permissions on the github rename part?
19:22:41 <anteaya> jeblair: that seems like a tough slog and something I could figure out how to do
19:22:46 <pleia2> jeblair: I pitched in a couple times ago, and have watched several, I'm ready to take a stronger role this time around
19:22:54 <jeblair> anteaya: fraid not; the perms to do that are terrifyingly broad. i don't like that i have them.
19:23:08 <anteaya> jeblair: okay, I'm trying to find ways to help
19:23:30 <jeblair> pleia2: woot, then i think we should do it on july 10
19:23:41 <pleia2> \o/
19:23:48 <jeblair> give fungi a break and you an opportunity
19:23:53 <fungi> heh
19:23:55 <pleia2> sounds good
19:23:57 <jeblair> pleia2: want to start by sending the announcement? :)
19:24:03 <pleia2> jeblair: will do
19:24:08 <pleia2> what time?
19:24:27 <pleia2> US pacific afternoon on friday seems best
19:24:43 <jeblair> 20:00 or 21:00 utc?
19:24:56 <jeblair> er, wait not those
19:25:18 <jeblair> 21 or 22?
19:25:20 <jeblair> perhaps 22?
19:25:21 <pleia2> 2200
19:25:34 <anteaya> I think last one was 2200
19:25:51 <nibz> 2200 sgtm
19:25:57 <jeblair> #agreed next project renames at 2200 utc july 10
19:26:12 <jeblair> #action pleia2 send announcement of next project renames at 2200 utc july 10
19:26:29 <anteaya> who will set up the etherpad for the event?
19:26:36 <anteaya> fungi usually does that
19:26:49 <fungi> i am happy to provide tips
19:26:50 <jeblair> fungi: want to help pleia2 with that?
19:26:51 <pleia2> I can take a stab at that too
19:26:55 * pleia2 thumbs up
19:27:07 <jeblair> and mordred will hopefully throw some code at you soon :)
19:27:09 <pleia2> I'll look at the past ones and fungi can error check
19:27:19 * mordred slings code like a ...
19:27:23 <jeblair> #topic Priority Efforts (Downstream Puppet)
19:27:25 * mordred can't finish that sentence in any useful way
19:27:33 <jeblair> finished it for you
19:27:46 <fungi> pleia2: best not to directly copy old ones--at least start with a copy of the steps from our documented instructions every time in case they change
19:27:50 <yolanda> there are a few patches pending for review or approval from my side
19:27:53 <nibz> this week has been cool for downstream puppet because puppet-zuul/openstackci/system-config are now linked
19:28:10 <pleia2> fungi: noted
19:28:14 <jeblair> awesome!
19:28:14 <mordred> nibz: dude
19:28:28 * mordred notes nibz new nick approvingly
19:28:42 <yolanda> nibalizer, puppet-os-cloud-config project change was landed
19:29:02 <nibz> sweet, so that opens the door for us to write that module, then patch the nodepool puppet module
19:29:07 <asselin> o/
19:29:08 <mordred> \o/
19:29:15 <nibz> I'd like to ask for reviews on the stack starting here https://review.openstack.org/#/c/184891/
19:29:26 <nibz> Its the beaker tests for openstackci
19:29:32 <yolanda> yes, i have the changes ready for nodepool and secure.config, so that bit is missing, and well be good for openstack-ci for nodepool
19:29:37 <jeblair> oh yes, i should look at those
19:29:44 <nibz> very close to what they're doing in openstack/puppet-*
19:30:10 <nibz> we've even gotten a bit silly and we zuul-clone the system-config so changes to e.g. modules.env can get picked up
19:30:23 <nibz> thanks to crinkle for doing most of the work there
19:30:28 <jeblair> that sounds like a good idea to me, but then, i'm silly
19:30:35 <crinkle> zuulception
19:30:54 <pleia2> yay crinkle
19:31:12 <jeblair> #info Sign-up if interested in virtual sprint: July 8-9, 2015 15:00 UTC https://etherpad.openstack.org/p/common-ci-sprint
19:31:23 <jeblair> #link https://etherpad.openstack.org/p/common-ci-sprint
19:31:35 <nibz> thats all I have from puppet-space
19:31:36 <pleia2> never a dull moment around here
19:31:38 <fungi> sorry all, i need to duck out. bank/lawyer last minute stuff. ping me if you need anything and i'll read the log when i get back later today
19:31:54 <jeblair> fungi: np, thanks
19:32:42 <asselin> also, please add your name to a specific are of interest on the etherpad so we can have mini-groups of people divide and conquer
19:32:54 <jeblair> any more downstream puppet stuff? (though, i mean, we'll be talking about it a lot tomorrow)
19:33:33 <yolanda> there were some problems today with several projects, due to removal of puppet-system acl
19:33:54 <yolanda> i sent a change for puppet-refstack fix, there were a pair of failures also for beaker projects, not sure about it
19:34:09 <jeblair> yolanda: i'm not sure what you mean
19:34:16 <AJaeger> jeblair, yolanda: https://review.openstack.org/198938
19:34:28 <yolanda> jeblair, in project-config, 3 projects where pointing to a non-existing acl
19:34:38 <zaro> asselin: i don't see juame in the sprint. is he gonna complete the jjb portion?
19:34:44 <anteaya> some patches were merged that pointed to a non-existant acl
19:34:51 <asselin> there's one task I added to create a sample site.pp to put it all together. If anyone's interested to do that, let me know.
19:35:15 <yolanda> AJaeger, thx, +1
19:35:20 <nibz> asselin: i've added my name to that
19:35:25 <asselin> zaro, I haven't heard from him. I've reviewed some of his patches and may just push up some fixes
19:35:33 <nibz> I figure thats where I can be the most help, other than going off in a corner to poke testing
19:35:34 <asselin> nibz, thanks
19:36:03 <yolanda> nibz, will you be able to take some time tomorrow in the os-cloud-config stuff? i can help there as well, so we get all the bits ready for nodepool
19:36:05 <asselin> nibz == nibalizer ?
19:36:11 <anteaya> asselin: yes
19:36:26 <nibz> yes this is nibalizer, I am unfortunately not with ssh keys right now
19:36:32 <nibz> so the normal irc session is locked off
19:36:33 <zaro> asselin: i think there was another change required to plumb the new jjb manifest. i can do if you like
19:36:44 <anteaya> keyless nibalizer
19:36:51 <nibz> yolanda: we can just do it after this meeting if you want
19:36:53 <asselin> zaro, ok sure...go ahead. i'll test and review
19:36:54 <jeblair> probably ought to get a +1 from the infra ptl before adding new infra projects
19:37:03 <nibz> jeblair: heh
19:37:16 <yolanda> nibz, i won't be staying after the meeting, too late for me, but i can review and pick up tomorrow
19:37:22 <nibz> okay sure
19:37:28 <nibz> ill stay up until you get on probably so can handoff
19:37:43 <yolanda> ah yes, you never sleep, we can talk in my morning :)
19:37:52 <nibz> so anything else on poopit?
19:38:02 * nibz out of things
19:38:04 <yolanda> not from my side
19:38:07 <mordred> nibz: that makes me want to say so many things ... none of them useful
19:38:19 * Clint coughs.
19:38:20 <jeblair> #topic Phabricator analysis (ttx)
19:38:24 <ttx> ohai
19:38:25 <asselin> it would be good to put in your timezone on the etherpad..
19:38:26 <mordred> look it's a ttx
19:38:51 <jeblair> #link https://review.openstack.org/#/c/194119/
19:38:51 <jeblair> #link http://lists.openstack.org/pipermail/openstack-infra/2015-July/002885.html
19:38:51 <jeblair> #link https://wiki.openstack.org/wiki/Phabricator
19:38:59 <jeblair> i prepared some #links for you :)
19:39:34 <ttx> right, so I proposed a step on that phabricator spoec where we would do some investigation on how we could solve some of the complex openstack use cases with Phabricator
19:39:44 <ttx> That's https://review.openstack.org/#/c/194119/
19:40:00 <ttx> I didn't wait for that to be approved and did that analysis last week and Monday
19:40:05 <jeblair> (which i think we can merge now that mordred has seen it)
19:40:20 <ttx> posted progress on infra list, and summary on https://wiki.openstack.org/wiki/Phabricator*
19:40:22 <pleia2> ttx: thank you for your thorough emails, they were great
19:40:28 * mordred has been enjoying them
19:40:39 <ttx> It's not every day that I dive into some PHP
19:40:50 <ttx> been cleaning myself up three times today to wash the dye
19:41:14 <pleia2> hehe
19:41:25 <anteaya> salt baths
19:41:29 <anteaya> I recommend them
19:41:42 <ttx> So I guess the next step is to push at least some of that wishlist to Phabricator itself
19:41:53 <ttx> see how likely they are to include it
19:42:23 <ttx> some of it is clearly off-product from how they usually react
19:42:50 <ttx> they could be amenable in supporting a hook point though, if we contract Phacility to do it
19:42:53 <mordred> yah
19:42:57 <jeblair> yeah, i'm not super keen on supporting a fork
19:43:02 <jeblair> (that is an understatement ^)
19:43:07 <mordred> I kind of think we're at the point of being able to articulate the desire in a conversation with them
19:43:08 <anteaya> what is Phacility?
19:43:21 <mordred> and potentially have enlist their help in coming up with solutinos
19:43:23 <ttx> anteaya: a company selling support on Phabricator
19:43:25 <jeblair> but maintaining plugins for well-defined extension points is more palatable
19:43:39 <ttx> they happen to control upstream pretty tightly
19:43:43 <anteaya> ttx we need to get a contractor to get code upstream?
19:43:54 <zaro> have we talked to any of our friends @ wikimedia whether would want to do the same things?
19:43:56 <mordred> anteaya: nope, we can write the code if we want
19:44:04 <pleia2> (but we don't want to write php)
19:44:09 <pleia2> :D
19:44:21 <ttx> mordred: but they have to the right to refuse it if it's not part of their vision for Phab
19:44:22 <mordred> there is that - but also, we could probably have a non-contract discussion with them first
19:44:30 <pleia2> mordred: nods
19:44:38 <ttx> Yes, we should start contacting them
19:44:51 <mordred> and then figure out if it would be helpful to have a contract with them for them to accelerate things
19:44:56 <mordred> might or might now
19:44:57 <ttx> I've seen them react ... more gracefully to requests from wikimedia than from John Doe
19:44:58 <mordred> not
19:45:00 <anteaya> them being wikimedia or them being phabricator?
19:45:13 <mordred> them being phacility
19:45:18 <mordred> I mean, right now we
19:45:21 <ttx> so maybe they could be receptive to our requests
19:45:21 <mordred> yah
19:45:44 <ttx> Do we know anyone on that group, beyond the people at Wikimedia ?
19:45:51 <mordred> I do not
19:46:19 <ttx> and who should lead that contact with them ? I guess I can do it those days, but startign Sept I'll be more busy
19:46:42 <mordred> ttx: if you can start it off and get the ball rolling, I can pick it up when you get busy
19:46:50 <ttx> ok, deal
19:47:22 <ttx> General comment, the code is pretty solid
19:47:29 <mordred> yah. I agree with that
19:47:33 <mordred> I thin kthey've done a good job
19:47:42 <ttx> but they seem to have expanded scope much faster than they tied loose ends. Reminds me of another project
19:47:51 <mordred> bah
19:47:54 <ttx> for example their API is a big mess
19:48:20 <mordred> their API is clearly not the thing they find the most important
19:48:25 <ttx> Reading https://secure.phabricator.com/T5873 made me a sad panda
19:49:03 <ttx> that is all. I'll take the action of turning that wiki page into a set of Phabricator bugs and lead the charge from there
19:49:07 <mordred> cool
19:49:11 <mordred> and I'll help
19:49:14 <mordred> while we're on the topic ...
19:49:26 <mordred> is there anyone around who wants to poke at making cauth speak openid?
19:49:48 <mordred> that's on my TDL and I have not made it far enough to working on it
19:50:17 <jeblair> mordred: link to cauth?
19:51:30 <jeblair> EmilienM: ^ know anyone who might be interested in that?
19:51:41 <EmilienM> o/
19:51:56 <mordred> jeblair: looking
19:52:07 <zaro> i don't think i'm the best person for this job, but if there are no takers then i am willing to give it a try. will need help though.
19:52:08 <mordred> #link https://github.com/enovance/cauth
19:52:22 <EmilienM> jeblair: yes, mhu
19:52:36 <EmilienM> https://github.com/mhuin
19:52:51 <EmilienM> jeblair: we should contact him and see
19:53:00 <jeblair> cool, let's do that
19:53:04 <mordred> it's written in pecan/wsme - and we have openid consumer support in pecan/wsme in storyboard - so there should be directly leveragable code
19:53:39 * mordred will hand him a very plump chicken in exchange for openid support that works against launchpad
19:53:43 <jeblair> this is the perfect transition to...
19:53:44 <jeblair> #topic Storyboard Development
19:54:07 <EmilienM> mordred: he likes chicken.
19:54:15 <jeblair> persia: ^ i think you added this to the agenda?
19:54:19 <persia> I have been working with a firm that uses Storyboard in production, and with the changes in upstream maintenance, I have convinced them to assign a couple people to work on things.
19:54:26 <persia> jeblair: Yes, sorry, I fail at wiki editing
19:54:30 <pleia2> persia: wow, nice
19:54:38 <tchaypo> someone uses storyboard in production?
19:54:40 <persia> What I don't know is the best way for them to be productive WRT reviews, etc.
19:54:42 <yolanda> persia, i'm glad to hear that
19:54:49 <anteaya> persia: are they on irc?
19:54:54 <persia> Note that this is *entirely separate* from any discussion about whether OpenStack uses Storyboard.
19:54:57 <ttx> anteaya: yes
19:54:59 <persia> anteaya: yes.
19:54:59 <yolanda> i saw some new changes, i'm happy for that
19:55:01 <tchaypo> this is exciting
19:55:02 <greghaynes> tchaypo: technically I think we do too :)
19:55:04 <anteaya> yay
19:55:25 <ttx> I wonder if we should not spin it out of Infra and back to stackforge (only half kidding) and reset core there
19:55:43 <ttx> unless it's still a contender
19:55:58 <jeblair> http://lists.openstack.org/pipermail/openstack-infra/2015-June/002880.html
19:56:01 <persia> I don't care where it lives, but I'd prefer to be able to use gerrit, etc.
19:56:19 <jeblair> i wrote that message recently about the future of jjb, which, if we proceed with my zuulv3 proposal, we would no longer use in openstack-infra
19:56:32 <jeblair> i think a lot of the ideas about how to handle that transition could apply here too
19:57:01 <ttx> jeblair: rigth, I just want to not block them. jjb still has some infra people caring for it
19:57:27 <jeblair> in general, i think openstack's primary interest in storyboard at this point in maintenance of our production system, and when we switch to maniphest, we won't care that much, but still would be happy to help it succeed
19:58:11 <ttx> ok. I expect them to fork it if it becomes too painful anyway
19:58:22 <jeblair> indeed, always an option :)
19:58:25 <fungi> back just in time for the end of the meeting!
19:58:27 <ttx> I just think we should adjust cores
19:58:42 <ttx> because the current set is pretty limited
19:58:56 <jeblair> yeah, i think we can onboard new cores, and if needed, create a development branch, etc
19:59:06 <ttx> especially if you factor in my ability to review JS
19:59:10 <ttx> https://review.openstack.org/#/admin/groups/187,members
19:59:45 <jeblair> so if folks have suggestions for new cores, run them by me and i can look at adding them
20:00:10 <jeblair> and it's time, thanks all!
20:00:11 <jeblair> #endmeeting