19:01:30 <jeblair> #startmeeting infra
19:01:30 <openstack> Meeting started Tue Sep 8 19:01:30 2015 UTC and is due to finish in 60 minutes. The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:34 <openstack> The meeting name has been set to 'infra'
19:01:41 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:01:41 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/infra/2015/infra.2015-09-01-19.01.html
19:01:58 <jeblair> #topic Specs approval: Artifact Signing Toolchain (fungi)
19:02:04 <jeblair> #link Artifact Signing Toolchain https://review.openstack.org/213295
19:02:23 <mordred> o/
19:02:24 <jhesketh> o/
19:02:25 <jeblair> fungi warned us this would be coming up this week :)
19:02:34 <fungi> i've addressed everyone's comments so far, so assumed it was time to punt it to a vote
19:02:38 <mordred> I, for one, welcome our Artifact Signing overlords
19:03:16 <fungi> just a reminder, this is only securing one piece of the publication chain, but i'm trying to leave it open to flexible solutions for the other parts later
19:03:35 <jeblair> ++
19:03:46 <fungi> primarily this should make post-publication tampering obvious
19:03:46 <anteaya> you are so accomodating that way
19:04:29 <jasondotstar> o/
19:04:30 * jhesketh has had it on his review radar but hasn't had a chance yet. I'll do that today (more than happy to see it go to vote)
19:04:36 <fungi> anyway, i have nothing really to say which isn't already said in that change
19:04:54 <jeblair> no one is screaming, so let's put it to a vote!
19:04:56 <mmmpork> o/
19:04:59 <jeblair> #info Artifact Signing Toolchain voting open until 2015-09-10 19:00 UTC
19:05:02 <fungi> thanks!
19:05:08 <anteaya> thank you
19:05:08 <jeblair> fungi: thank you!
19:05:11 <jeblair> #topic Schedule Project Renames
19:05:26 <ociuhandu> o/
19:05:29 <jeblair> we have some renames scheduled for friday
19:05:30 <anteaya> I've created an etherpad to organize the patches for friday
19:05:39 <fungi> thanks anteaya!!!
19:05:41 <pleia2> thanks anteaya
19:05:43 <fungi> link?
19:05:44 <jasondotstar> nice
19:05:46 <anteaya> #link https://etherpad.openstack.org/p/project-renames-Septemeber-2015
19:05:57 <anteaya> who wants to drive the renames
19:06:06 <pleia2> oh good, ansible is on there this time :)
19:06:06 <anteaya> I'll co-ordinate with whoever drives
19:06:23 <anteaya> I can do the legwork and get them into shape
19:06:35 <anteaya> when are we no longer accepting additions to the list
19:06:41 <anteaya> so I can start the rebases
19:06:59 <fungi> it went well the last time i wasn't involved, so i'm happy to see another infra root who isn't me take point, but can if there are no volunteers
19:07:07 <anteaya> fungi: ha ha ha
19:07:22 <anteaya> pleia2: I'm going with you are a bit frazzled with last week and zanata
19:07:25 <mordred> I may be around - or I may be stupid jetlagged and asleep - or I may be stupid jetlagged and AWAKE
19:07:29 <mordred> so consider me a wildcard bonus
19:07:42 * fungi doesn't want to steal maintenance opportunities from new recroots
19:07:48 <mordred> fungi: ++
19:07:48 <anteaya> jhesketh: driven a rename yet?
19:07:54 <anteaya> jhesketh: it's lots of fun
19:07:58 <jasondotstar> does it have to be a root?
19:08:02 <anteaya> and you will get help
19:08:05 <anteaya> jasondotstar: yes
19:08:09 <jeblair> anteaya: we did schedule it for jhesketh's saturday morning
19:08:11 <pleia2> anteaya: yeah, I can help but I probably shouldn't be driver this time
19:08:15 <jasondotstar> anteaya: ack.
19:08:27 <anteaya> jhesketh: what a fun way to spend a saturday
19:08:29 <anteaya> :)
19:08:30 <pleia2> lol
19:08:31 <fungi> go ahead and put me down to coordinate
19:08:35 <pleia2> thanks fungi
19:08:38 <anteaya> fungi: thanks
19:08:46 <anteaya> I'll get it in shape so you can push go
19:08:46 <clarkb> sorry I am here and intend on being there
19:08:58 <clarkb> if fungi wants a break I can drive
19:08:58 <jeblair> i will also be around
19:09:01 <jhesketh> No I haven't yet. But I'll be travelling to the QA sprint from Friday
19:09:04 <anteaya> fungi: I'll will let you do your own etherpad with the db changes and steps and so on
19:09:11 <anteaya> jhesketh: ah that's right
19:09:20 <jhesketh> (everything takes so long to get to from here!)
19:09:22 <anteaya> or clarkb
19:09:27 <anteaya> jhesketh: ha ha ha
19:09:31 <jhesketh> Otherwise would love to help
19:09:53 <anteaya> so the expected renames, two are not in governance
19:10:04 <anteaya> move them to the stackforge wikipage?
19:10:11 <anteaya> other action?
19:10:35 <jeblair> anteaya: sounds good to me
19:10:41 <fungi> i think we decided we don't want to incorporate non-big-tent renames in this maintenance, so yeah
19:10:43 <anteaya> okey dokey I will move them
19:10:58 <anteaya> and try to track down the patch author if possible
19:11:04 <anteaya> no promisies though
19:11:14 <anteaya> that's all from me on this
19:11:45 <jeblair> regarding oct 17; what needs to be done? probably an analysis of how many projects are on the lists....
19:11:58 <jeblair> and then writing some scripts to automate the actual change....
19:12:05 <anteaya> I can start an etherpad on that to co-ordinate
19:12:07 <jeblair> mordred: think we can ansible it?
19:12:08 <fungi> which will become immediately out of date within hours, but is probably at least good for an estimate
19:13:01 <anteaya> #link https://etherpad.openstack.org/p/Stackforge-Namespace-Retirement
19:13:07 <mordred> jeblair: we can ansible it
19:13:30 <jhesketh> We can ansible anything? :-)
19:13:33 <mordred> there is a WIP patch up if anyone want to help me test it
19:13:40 <anteaya> mordred: link?
19:13:41 <jeblair> mordred: should we try it friday?
19:13:42 <mordred> one sec- link coming
19:13:55 <anteaya> I'll add it to the etherpads
19:14:08 <fungi> i would like to see it at least get a test drive before we use it on potentially hundreds of repos at once
19:14:19 * anteaya agrees with fungi
19:14:24 <jhesketh> I like the idea of the trying it
19:14:28 <jasondotstar> fungi: +1
19:14:32 <mordred> https://review.openstack.org/#/c/105057/3/modules/openstack_project/files/ansible/rename.yaml
19:14:35 <jhesketh> +1
19:14:40 <fungi> though that implies more mordred involvement in the maintenance window this week... were you planning to be around?
19:14:49 <mordred> would be great to get other eyes/hands on that _before_ friday
19:14:55 <anteaya> #link https://review.openstack.org/#/c/105057/3
19:15:01 <anteaya> needs a bit of love
19:15:19 <mordred> fungi: _maybe_ - I will have just travelled to europe, so I'm not sure what my level of brain vs. jetlagbrain will be
19:15:34 <mordred> so I'm not comfortable being counted on for important decision making
19:15:58 <fungi> mordred: sounds like your usual shrödinger's brain conundrum
19:16:02 <anteaya> anyone able to spend time on this patch working with mordred before friday?
19:16:12 <mordred> but if someone else is interested in the topic - I'd be thrilled to connect this week before friday on looking at the playbook and stuff
19:16:35 <jeblair> this is a good opportunity for a non-root to pitch in on the rename if they are familiar with ansible and/or can be around friday
19:16:40 <mordred> (also, I tink that playbook needs to be rewritten a little bit)
19:17:04 <mordred> as it should probably have several places where it iterates over a list of dicts - but whoever is interested we can chat about that
19:17:19 <Clint> i'm intrigued by the juxtaposition of -rf and -fr
19:17:21 <anteaya> I will if noone else will but not sure if I can finish it by friday
19:17:25 <clarkb> mordred: its also easy enough to iterate in bash
19:17:36 <clarkb> mordred: in fact I find that is preferable to me based on the d-g work
19:17:39 <fungi> really, the biggest benefit would be github automation
19:17:43 <clarkb> ansible is bad at branching logic
19:18:01 <anteaya> fungi: so focus on getting the github pieces to work first?
19:18:07 <jasondotstar> jeblair: I can help w/ that (the non-root activities)
19:18:11 <fungi> moving directories on the filesystem and updating database tables takes nearly 0 time and effort to custom-automate
19:18:17 <clarkb> fungi: I don't think the current change talks to github
19:18:33 <clarkb> also doesn't talk to the db
19:18:43 <mordred> clarkb: actually no
19:18:48 <anteaya> but github still requires renaming via the gui, yes?
19:18:50 <mordred> I tink you want to iterate in ansible very specifically
19:18:55 <mordred> but we can have that argument later
19:18:56 <jeblair> last i checked the github api didn't expose the transfer function
19:19:00 <fungi> i've actually stopped generating database and filesystem update commands manually anyway
19:19:08 <mordred> (there is no branching logic needed in this playbook)
19:19:20 <clarkb> mordred: there is if its a transfer vs rename
19:19:22 <clarkb> mordred: for github
19:19:33 <mordred> there is no github api support for renames
19:19:34 <clarkb> but I think thats the only place that cares
19:19:36 <mordred> so it doesn't matter
19:19:47 <jeblair> someone should double check that though
19:19:50 <mordred> ++
19:19:57 <anteaya> great, the biggest piece we need automated
19:19:57 <fungi> got it. and yeah that's going to be the time-consuming part for "the big rename"
19:19:58 <clarkb> that really ruins the benefits of automating this imo
19:20:05 <clarkb> right
19:20:07 <clarkb> anyways
19:20:21 <mordred> I feel like I have a much better version of that somewhere too
19:20:47 <jeblair> i have no script to do any of this. i think it's great that fungi has a script to do part of it. but really it would be awesome if as much as possible were automated and checked into system-config.
19:20:55 <pabelanger> sorry, irc proxy died
19:21:01 <mordred> jeblair: ++
19:21:26 <jeblair> and yeah, a lot of it could be done in bash, but we know that there are cross-host coordination issues, so at least orchestrating it should be in ansible (even if it ends up calling bash)
19:21:35 <clarkb> jeblair: I am not suggesting it be done in bash
19:21:46 <anteaya> if folks can add bits to https://etherpad.openstack.org/p/Stackforge-Namespace-Retirement I will do my best to summarize
19:21:55 <clarkb> jeblair: I was merely saying instead of passing in a giant hash of projects that ansible should do in one go we can exec ansible many times for each project
19:22:20 <jeblair> clarkb: sure, as long as we only reindex once.
19:22:40 <mordred> and I'm saying that I believe that's missing the point of ansible and we might as well just use bash and some ssh commands
19:23:13 <mordred> and that this is a bounded enough problem that learning how to actually use the tool would be great
19:23:15 <clarkb> ya we don't need to argue this here, its just a thing I have observed when trying to condense d-g further
19:23:22 <mordred> agree
19:23:23 <clarkb> it becomes almost unreadable as soon as ansible is encoding logic
19:23:24 <fungi> yeah, the cross-host orchestration part does make this tempting
19:23:56 <jeblair> who wants to double check the github api?
19:24:06 <clarkb> jeblair: I can look at that today
19:24:08 <mordred> clarkb: I tnk the d-g mix gets worse as we do more complex playbook things for sure
19:24:20 <jeblair> #action clarkb see if github api supports transfers yet
19:24:36 <jeblair> #action mordred look into better version of https://review.openstack.org/105057 or improve it
19:24:55 <jeblair> #action jasondotstar help mordred with ansibly things
19:25:29 <jeblair> anything else?
19:25:52 <anteaya> just are we having a cut off for adding projects to friday's list
19:26:18 <jeblair> anteaya: is friday morning enough time for you?
19:26:25 <anteaya> it will be
19:26:27 <anteaya> thank you
19:26:35 <anteaya> what utc time is friday morning?
19:26:42 * mordred wishes he could find his better version he already wrote :(
19:26:51 <asselin_> o/
19:27:13 <fungi> anteaya: i would just pick a time before you expect to sit down at your computer
19:27:22 <anteaya> before 1300 utc
19:27:29 <jeblair> #info cutoff for friday renames friday 1300 utc
19:27:35 <anteaya> thank you
19:27:53 <jeblair> #action anteaya prepare rename patches for friday renames
19:27:56 <jeblair> anteaya: thank you
19:28:03 <jeblair> #topic Priority Efforts (Migration to Zanata)
19:28:20 <jeblair> this is, like, imminent, yeah?
19:28:20 <fungi> it's upon us
19:28:30 <anteaya> a few hours from now I think
19:28:46 <jeblair> is there an etherpad or something?
19:28:52 <pleia2> tonight! https://etherpad.openstack.org/p/zanata-deploy
19:28:56 <fungi> it's now imminent and will soon be eminent
19:29:00 <jeblair> #link https://etherpad.openstack.org/p/zanata-deploy
19:29:28 <anteaya> can standers by be of any use?
19:29:36 <anteaya> or should I stand back in awe?
19:29:53 <jeblair> heh, stand by or stand back.
19:30:01 <pleia2> we'll be doing some testing once we complete all the steps in the etherpad
19:30:21 <pleia2> may be useful to have a few folks around to log in and poke at things a little, but not required
19:30:37 <fungi> that's verging into drinkytime for me, so i'll pitch in on anything i am unlikely to be able to break
19:30:50 <anteaya> heh
19:31:05 <jeblair> i have a meatspace commitment so probably can't be around for most of it :(
19:31:07 <pleia2> always fun with time zones for translations things
19:31:08 <anteaya> I can do the poking at things
19:31:15 <anteaya> wooo time zones
19:31:22 <pleia2> I think we're pretty much all set though
19:31:26 <anteaya> yay
19:31:29 <anteaya> good work all
19:31:32 <clarkb> it would likely be good for infra roots to login sometime soon so we can bump their privs
19:31:35 <jeblair> pleia2: cool, thanks!
19:31:40 <clarkb> by soon I mean after it all heppns
19:31:48 <jeblair> oh ok.
19:31:51 <mordred> clarkb: so not soon like right now
19:32:08 * jeblair closes tab
19:32:14 <anteaya> ha ha ha
19:32:16 * mordred backs away from the zanata
19:32:22 <pleia2> mordred: it's ok, you have one :)
19:32:24 <clarkb> well now would be fine too since we are moving the users
19:32:30 <jhesketh> I'll be around if needed
19:32:33 <clarkb> but I don't think it needs to happen yet if you want to do other things
19:32:35 <pleia2> thanks jhesketh
19:32:39 <anteaya> jhesketh: yay
19:33:14 <fungi> huh... so its openid integration is... interesting
19:33:17 <fungi> anyway, done
19:33:24 <jhesketh> I'm hoping I'm not needed though because I'm not that familiar with the work
19:33:44 <jeblair> fungi: ?
19:33:48 <jeblair> fungi: what's interesting about it?
19:34:05 <fungi> it doesn't actually ask the openid server for name, e-mail address, et cetera
19:34:09 <fungi> just re-prompts for them
19:34:31 <fungi> something which can probably be improved later
19:34:32 <jeblair> oh, interesting. and indeed, you said it was interesting.
19:34:48 <pleia2> we were just satisfied with "it actually works" for now
19:34:51 <jeblair> i shoulda just believed you.
19:35:06 <fungi> pleia2: totally
19:35:09 <fungi> i would have been too
19:35:11 <anteaya> pleia2: yay it works
19:35:24 <pleia2> (it did require an openstackid patch to get this far)
19:35:38 <fungi> anyway, i seem to be account 433
19:35:44 <anteaya> lucky you
19:36:10 <fungi> it's prime
19:36:10 <jeblair> sounds like we're set; pleia2: thanks again!
19:36:19 <pleia2> fungi: oh, translate or translate-dev?
19:36:20 <anteaya> ha ha ha
19:36:22 <fungi> and has digits which add up to 10
19:36:28 <jeblair> #topic Priority Efforts (Maniphest)
19:36:38 <fungi> pleia2: oh, good point, i logged into production. i guess that won't do any good
19:36:56 <jeblair> mordred: what's the scoop here?
19:36:57 <pleia2> fungi: right, we're moving stuff from -dev (and dropping all else)
19:37:07 <mordred> so ...
19:37:11 <mordred> I need some help
19:37:12 * fungi just realized that when you asked
19:37:47 <mordred> next step on this is for $someone to stand up a maniphest $somewhere with cauth configured in apache in front of it
19:38:00 <mordred> this will involve $someamount of figuring out exactly what's needed to get that to happen
19:38:04 <Clint> what happened to mhu?
19:38:07 <mordred> but is a pre-req for encoding that in puppet
19:38:27 <jeblair> mordred: have the necessary changes to cauth itself to support openid happened?
19:38:31 <mordred> Clint: mhu wrote the openid support into cauth for us - is he also planning on helping with the puppeting of the cauth interation?
19:38:34 <mordred> jeblair: yes
19:38:40 <Clint> mordred: http://docs-draft.openstack.org/72/219372/5/check/gate-infra-specs-docs/625a32a//doc/build/html/status/maniphest.html
19:38:51 <Clint> unless i halucinated that
19:38:52 <mordred> oh! neat!
19:39:01 <mordred> then maybe I do _not_ need help
19:39:06 <Clint> l
19:39:12 <jeblair> mordred: or more correctly, maybe you already have it!
19:39:16 <mordred> in any case- that is the current thing this is waiting on
19:39:17 <mordred> jeblair: ++
19:39:25 <fungi> you already have that which you seek!
19:39:48 <anteaya> who has contact with mhu?
19:39:50 <jeblair> Clint: what timezone is mhu in? and do they irc?
19:39:56 <anteaya> does he know about infra meetings?
19:40:00 <anteaya> he/she
19:40:21 <Clint> i'm guessing he's in europe, and he's in #openstack-infra
19:40:43 <jeblair> cool, we should ask him to lurk in -meeting
19:40:59 <anteaya> I just pinged in -infra
19:41:53 <jeblair> Clint, mordred: i feel like "hey we linked to a web page that shows someone is working on this" is an outcome second only to "oh this has already been done".
19:42:03 <ttx> mordred: hah, the death of your Phab instance means my mockup for task tracking is no longer up :/
19:42:22 <ttx> The one in case (3) at https://wiki.openstack.org/wiki/Phabricator
19:42:23 <jeblair> Clint, mordred: so... cool. :)
19:42:26 * ruagair is fashionably late
19:42:27 <Clint> jeblair: to be fair, it shows that two other things aren't being worked on
19:42:57 <mordred> ttx: oops
19:43:04 <jeblair> Clint: yah.... #3 looks like it has #1 as a prereq, yeah?
19:43:08 <Clint> presumably
19:43:08 <jeblair> mordred: ^?
19:43:26 <mordred> yes
19:43:31 <mordred> #3 has #1 as a prereq
19:43:36 <jeblair> #2 is ripe for someone to pitch in on though.
19:43:37 <mordred> or might wind up being part of #1 (unsure)
19:43:55 <mordred> #2 is great - it may require rooter collaboration
19:44:09 <jeblair> for what?
19:44:13 <mordred> since it involves someone importing storyboard dbs into a db, then running the migration script
19:44:24 <jeblair> mordred: ah, providing a sb dump?
19:44:27 <mordred> yeah
19:44:46 <jeblair> i would be happy to hand a sb db dump to someone wanting to work on that.
19:45:17 <jeblair> probably just need to omit the auth tokens table.
19:45:21 <Clint> are there success criteria for migration accuracy?
19:45:30 <fungi> yeah, that's the only remotely sensitive bit in there
19:45:38 <mordred> Clint: I'd _love 100% accuracy
19:46:12 <clarkb> and if we can preserve the old bug numbers like we did with lp to sb that would be double awesome
19:46:16 <mordred> so - honestly, this will involve the actor in question setting up a phab instance that they can run on top of the db (not that hard, there is puppet) so that the data in the UI can be verified
19:46:27 <mordred> clarkb: the script currently does that
19:46:31 <clarkb> yay
19:46:51 <fungi> just like ragu... it's in there
19:47:00 <mordred> the script shoudl mostly work
19:47:11 <jeblair> i think it would be swell if one of the new infra folk wanted to jump in on this.
19:47:32 <mordred> however, last time I spot checked the UI, there seemed to be things missing - which might have been because I picked poor data to spot check - or that ther eis a bug in the script
19:47:34 <jeblair> if you do, let me know.
19:47:47 <mordred> things to look at especially are things with mutliple tasks
19:49:04 <jeblair> anything else on this?
19:50:16 <jeblair> #topic Open discussion
19:50:21 <tchaypo> jeblair: If one of the new infra people wants to jump in on this, I’m guessing they should ask in -infra if they need help getting started?
19:50:27 <yolanda> so, i need extra help with reviews of puppet changes
19:50:31 <fungi> tchaypo: yes
19:50:41 <yolanda> several of them waiting with a +2
19:50:56 <yolanda> and the patches i submit, normally only have +1
19:50:56 <clarkb> the git backends are now all centos7
19:51:05 <anteaya> clarkb: yay!
19:51:08 <yolanda> i'd like if more infra cores can give help on it, please
19:51:11 <clarkb> just a general FYI and do mention weirdness if yo usee an
19:51:28 <clarkb> I should probably make a new git.o.o at some point so we can stop centos6ing there too
19:51:37 <mordred> yolanda: sorry - I said i'd do that and then I didn't
19:51:40 <anteaya> clarkb: just what eantshev (?) mentioned on monday after the third-party meeting
19:51:50 <yolanda> mordred, i was thinking about you, yes :)
19:51:52 <clarkb> anteaya: unfortunately there really wasn't any info there and I was weekending
19:51:58 <anteaya> clarkb: but fungi couldn't confirm weirdness in logs
19:52:02 <anteaya> clarkb: /nod
19:52:02 <clarkb> anteaya: the connection failed, but I didn't see any source IPs
19:52:04 <yolanda> so more eyes are needed, so we can move these patches faster
19:52:07 <clarkb> so hard to track down
19:52:15 * ruagair is interested Jeblair, tchaypo, just not fully functional this early.
19:52:18 <anteaya> clarkb: fair enough, that was all I have heard about though
19:52:25 <yolanda> i also normally cannot approve due to the timezones, so i'll need extra help for approval as well
19:52:44 <mmedvede> re f21 job stability, would it be a good idea to ask for the f21 job to be made voting on devstack project? I want to make sure before bringing it up in qa. It has been relatively stable recently.
19:53:00 <jeblair> ruagair, tchaypo: cool, i think mordred or i can help you bootstrap; chat with one of us in -infra when you're ready
19:53:06 <clarkb> mmedvede: I think thats purely a question for qa
19:53:13 <fungi> also etherpad.openstack.org is running on ubuntu trusty with distro node.js packages, latest etherpad develop branch tip and websockets enabled. seems to be performing well now, but please report any strangeness there!
19:53:17 <clarkb> mmedvede: we run the jobs, whether or not qa wants it voting is up to them
19:53:32 <anteaya> fungi jeblair thanks for fixing that this morning
19:53:35 <ruagair> noted jeblair.
19:53:37 <mordred> jeblair, ruagair, tchaypo: ++
19:53:43 <fungi> taron mentioned that there's a change in review which gets us closer to hound
19:53:43 <mmedvede> clarkb: cool. I remember there was discussion in infra about f21 stability, that is why my question, thanks
19:53:44 <fungi> #link https://review.openstack.org/211640
19:53:49 <clarkb> mmedvede: also I think ianw and pabelanger are working to replace f21 with f22 whihc may or may not be a thing to consider
19:54:32 <pabelanger> also, centos7 firewalld is still failing. I think https://review.openstack.org/#/c/219031/ should fix that now
19:54:48 <clarkb> pabelanger: ianw ya I need to test that on hpcloud again
19:55:00 <pabelanger> Ya, some dnf downloadonly issues still with fedora22
19:55:11 <clarkb> pabelanger: ianw I will try that today, but it may take time as I haveto figure ut netowkring there each time I do it
19:55:43 <ianw> i think we can bring up f22 nodes, regardless of caching ATM, and work that out
19:55:59 <pabelanger> Ya, was going to suggest that too
19:56:07 <pabelanger> don't see many things using it right now
19:56:11 <mmedvede> pabelanger: before f22 comes along, is it ok if I ask to make f21 voting (given it is stable)?
19:56:15 <ianw> it would be better for us to be monitoring things like puppet4 compatability than waiting for perfection.
19:56:28 <ianw> mmedvede: on what project?
19:56:35 <mmedvede> ianw: on devstack
19:57:07 <pabelanger> mmedvede: I wasn't tracking devstack specifically. This was for some other reasons, -infra jobs maybe puppet
19:57:55 <mmedvede> ianw: pabelanger: my interest here is that we use f21 for our third-party CI, and making it vote at least on devstack would prevent some regressions
19:58:02 <ianw> so i do not think we want it voting on devstack, because i don't think there are enough people to fix issues. if it breaks, and urgent devstack changes need to get through, we could be in a world of gate-pain
19:58:25 <mmedvede> ianw: :(
19:59:24 <mmedvede> ianw: I might still ask in qa, just in case
19:59:43 <sdague> mmedvede: also, f21 has been 100% fail on devstack for a while, so I'm not sure what your definition of stable is
20:00:09 <ianw> sdague: i believe afazekas has sorted that out
20:00:10 <mmedvede> sdague: it has been good a couple of days #link http://ci-watch.tintri.com/project?project=devstack&time=7+days
20:00:26 <mmedvede> sdague: more time needs to pass though
20:00:28 <jeblair> time is up
20:00:30 <jeblair> thanks all!
20:00:32 <jeblair> #endmeeting